Re: [ovirt-users] Q: Can't connect to oVirt shell / SSL cert issue

2018-03-05 Thread Ondra Machacek



On 03/05/2018 01:28 PM, Andrei Verovski wrote:

On 03/05/2018 12:58 PM, Ondra Machacek wrote:

You should use CA certificate if you use default one it's:

  /etc/pki/ovirt-engine/ca.pem


Executed as root
ovirt-shell -l https://node00.mydomain.com/ovirt-engine/api --cert-file
/etc/pki/ovirt-engine/ca.pem -u "admin@internal"


Right, there should be '--ca-file /etc/pki/ovirt-engine/ca.pem', not
--cert-file /etc/pki/ovirt-engine/ca.pem



=== ERROR ===
server CA certificate file must be specified for SSL secured connection.

ca.pem exists in specified location.



You can find more information about oVirt PKI here:

  https://www.ovirt.org/develop/release-management/features/infra/pki/

On 03/05/2018 11:51 AM, Andrei Verovski wrote:

Hi,

Thanks,  corrected URL accepted.

However, I've run into SSL certificate issue:
ovirt-shell -l https://node00.mydomain.com/ovirt-engine/api
--cert-file /etc/pki/ovirt-engine/certs/engine.cer -u "admin@internal"

 ERROR 
server CA certificate file must be specified for SSL secured connection.

certificate file exists, verified
/etc/pki/ovirt-engine/certs/engine.cer

without specifying SSL cert file its not possible to connect at all
 ERROR 
No response returned from server. If you're using HTTP protocol
against a SSL secured server, then try using HTTPS instead.

Or I should use another certificate from same directory ?

Thanks.


On 03/05/2018 06:46 AM, Karli Sjöberg wrote:



Den 4 mars 2018 23:39 skrev Andrei Verovski :

     Hi !

     I'm trying to connect via Bash from same machine where oVirt engine
     installed
     ovirt-shell --url=http://node00.mydomain.com/api -u admin


Hi!

You've forgotten 'ovirt-engine' before 'api':
http://node00.mydomain.com/ovirt-engine/api

/K

     After entering password I've got:
     === ERROR ===
     [404] - Not Found

     What is wrong here?
     Thanks in advance.
     Andrei
     ___
     Users mailing list
     Users@ovirt.org
     http://lists.ovirt.org/mailman/listinfo/users


Hi !

I'm trying to connect via Bash from same machine where oVirt engine
installed
ovirt-shell --url=http://node00.mydomain.com/api -u admin
After entering password I've got:
=== ERROR ===
[404] - Not Found

What is wrong here?
Thanks in advance.
Andrei
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users





___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users






___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Q: Can't connect to oVirt shell / SSL cert issue

2018-03-05 Thread Andrei Verovski
On 03/05/2018 12:58 PM, Ondra Machacek wrote:
> You should use CA certificate if you use default one it's:
>
>  /etc/pki/ovirt-engine/ca.pem

Executed as root
ovirt-shell -l https://node00.mydomain.com/ovirt-engine/api --cert-file
/etc/pki/ovirt-engine/ca.pem -u "admin@internal"

=== ERROR ===
server CA certificate file must be specified for SSL secured connection.

ca.pem exists in specified location.

>
> You can find more information about oVirt PKI here:
>
>  https://www.ovirt.org/develop/release-management/features/infra/pki/
>
> On 03/05/2018 11:51 AM, Andrei Verovski wrote:
>> Hi,
>>
>> Thanks,  corrected URL accepted.
>>
>> However, I've run into SSL certificate issue:
>> ovirt-shell -l https://node00.mydomain.com/ovirt-engine/api
>> --cert-file /etc/pki/ovirt-engine/certs/engine.cer -u "admin@internal"
>>
>>  ERROR 
>> server CA certificate file must be specified for SSL secured connection.
>>
>> certificate file exists, verified
>> /etc/pki/ovirt-engine/certs/engine.cer
>>
>> without specifying SSL cert file its not possible to connect at all
>>  ERROR 
>> No response returned from server. If you're using HTTP protocol
>> against a SSL secured server, then try using HTTPS instead.
>>
>> Or I should use another certificate from same directory ?
>>
>> Thanks.
>>
>>
>> On 03/05/2018 06:46 AM, Karli Sjöberg wrote:
>>>
>>>
>>> Den 4 mars 2018 23:39 skrev Andrei Verovski :
>>>
>>>     Hi !
>>>
>>>     I'm trying to connect via Bash from same machine where oVirt engine
>>>     installed
>>>     ovirt-shell --url=http://node00.mydomain.com/api -u admin
>>>
>>>
>>> Hi!
>>>
>>> You've forgotten 'ovirt-engine' before 'api':
>>> http://node00.mydomain.com/ovirt-engine/api
>>>
>>> /K
>>>
>>>     After entering password I've got:
>>>     === ERROR ===
>>>     [404] - Not Found
>>>
>>>     What is wrong here?
>>>     Thanks in advance.
>>>     Andrei
>>>     ___
>>>     Users mailing list
>>>     Users@ovirt.org
>>>     http://lists.ovirt.org/mailman/listinfo/users
>>>
>>>
>>> Hi !
>>>
>>> I'm trying to connect via Bash from same machine where oVirt engine
>>> installed
>>> ovirt-shell --url=http://node00.mydomain.com/api -u admin
>>> After entering password I've got:
>>> === ERROR ===
>>> [404] - Not Found
>>>
>>> What is wrong here?
>>> Thanks in advance.
>>> Andrei
>>> ___
>>> Users mailing list
>>> Users@ovirt.org
>>> http://lists.ovirt.org/mailman/listinfo/users
>>
>>
>>
>>
>> ___
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>>
>

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Q: Can't connect to oVirt shell / SSL cert issue

2018-03-05 Thread Ondra Machacek

You should use CA certificate if you use default one it's:

 /etc/pki/ovirt-engine/ca.pem

You can find more information about oVirt PKI here:

 https://www.ovirt.org/develop/release-management/features/infra/pki/

On 03/05/2018 11:51 AM, Andrei Verovski wrote:

Hi,

Thanks,  corrected URL accepted.

However, I've run into SSL certificate issue:
ovirt-shell -l https://node00.mydomain.com/ovirt-engine/api --cert-file 
/etc/pki/ovirt-engine/certs/engine.cer -u "admin@internal"


 ERROR 
server CA certificate file must be specified for SSL secured connection.

certificate file exists, verified
/etc/pki/ovirt-engine/certs/engine.cer

without specifying SSL cert file its not possible to connect at all
 ERROR 
No response returned from server. If you're using HTTP protocol
against a SSL secured server, then try using HTTPS instead.

Or I should use another certificate from same directory ?

Thanks.


On 03/05/2018 06:46 AM, Karli Sjöberg wrote:



Den 4 mars 2018 23:39 skrev Andrei Verovski :

Hi !

I'm trying to connect via Bash from same machine where oVirt engine
installed
ovirt-shell --url=http://node00.mydomain.com/api -u admin


Hi!

You've forgotten 'ovirt-engine' before 'api':
http://node00.mydomain.com/ovirt-engine/api

/K

After entering password I've got:
=== ERROR ===
[404] - Not Found

What is wrong here?
Thanks in advance.
Andrei
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Hi !

I'm trying to connect via Bash from same machine where oVirt engine
installed
ovirt-shell --url=http://node00.mydomain.com/api -u admin
After entering password I've got:
=== ERROR ===
[404] - Not Found

What is wrong here?
Thanks in advance.
Andrei
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users





___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Q: Can't connect to oVirt shell / SSL cert issue

2018-03-05 Thread Andrei Verovski
Hi,

Thanks,  corrected URL accepted.

However, I've run into SSL certificate issue:
ovirt-shell -l https://node00.mydomain.com/ovirt-engine/api --cert-file
/etc/pki/ovirt-engine/certs/engine.cer -u "admin@internal"

 ERROR 
server CA certificate file must be specified for SSL secured connection.

certificate file exists, verified
/etc/pki/ovirt-engine/certs/engine.cer

without specifying SSL cert file its not possible to connect at all
 ERROR 
No response returned from server. If you're using HTTP protocol
against a SSL secured server, then try using HTTPS instead.

Or I should use another certificate from same directory ?

Thanks.


On 03/05/2018 06:46 AM, Karli Sjöberg wrote:
>
>
> Den 4 mars 2018 23:39 skrev Andrei Verovski :
>
> Hi !
>
> I'm trying to connect via Bash from same machine where oVirt engine
> installed
> ovirt-shell --url=http://node00.mydomain.com/api -u admin
>
>
> Hi!
>
> You've forgotten 'ovirt-engine' before 'api':
> http://node00.mydomain.com/ovirt-engine/api
>
> /K
>
> After entering password I've got:
> === ERROR ===
> [404] - Not Found
>
> What is wrong here?
> Thanks in advance.
> Andrei
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
> Hi !
>
> I'm trying to connect via Bash from same machine where oVirt engine
> installed
> ovirt-shell --url=http://node00.mydomain.com/api -u admin
> After entering password I've got:
> === ERROR ===
> [404] - Not Found
>
> What is wrong here?
> Thanks in advance.
> Andrei
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Q: Can't connect to oVirt shell

2018-03-04 Thread Andrei Verovski
Hi !

I'm trying to connect via Bash from same machine where oVirt engine
installed
ovirt-shell --url=http://node00.mydomain.com/api -u admin
After entering password I've got:
=== ERROR ===
[404] - Not Found

What is wrong here?
Thanks in advance.
Andrei
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users