[ovirt-users] Re: Host install failed - cannot set maintenance or remove

2018-05-13 Thread Callum Smith
Sorry this is the existing discussion, duplicated because of the mail list 
migration.

Cheers,

Callum

On 13 May 2018, at 13:06, Michael Burman 
> wrote:

Adding Alona,

On Tue, May 8, 2018 at 12:25 PM, Callum Smith 
> wrote:
Dear All,

There appears to be an issue with the host install on these, there's quite a 
lot of errors being kicked out into the logs as they cycle through attempting 
to activate, failing, and then failing to go into maintenance. I can't remove 
the hosts from the engine to attempt to reinstall them.

Issue presented from having a statically configured network on the ovritmgmt 
network on the hosts before running the host install. There are SQL errors (FK 
missing) and assorted goodness in there.

Any help greatly appreciated, not sure what the next step forward is from here

Engine.log on dropbox:
https://www.dropbox.com/s/82iem0ov869yh32/engine.log-20180508.zip?dl=0

Regards,
Callum

--

Callum Smith
Research Computing Core
Wellcome Trust Centre for Human Genetics
University of Oxford
e. cal...@well.ox.ac.uk


___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to 
users-le...@ovirt.org




--

Michael Burman

Senior Quality engineer - rhv network - redhat israel

Red Hat



mbur...@redhat.comM: 0545355725  
   IM: mburman

[https://www.redhat.com/files/brand/email/sig-redhat.png]
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org


[ovirt-users] Re: Host install failed - cannot set maintenance or remove

2018-05-13 Thread Michael Burman
Adding Alona,

On Tue, May 8, 2018 at 12:25 PM, Callum Smith  wrote:

> Dear All,
>
> There appears to be an issue with the host install on these, there's quite
> a lot of errors being kicked out into the logs as they cycle through
> attempting to activate, failing, and then failing to go into maintenance. I
> can't remove the hosts from the engine to attempt to reinstall them.
>
> Issue presented from having a statically configured network on the
> ovritmgmt network on the hosts before running the host install. There are
> SQL errors (FK missing) and assorted goodness in there.
>
> Any help greatly appreciated, not sure what the next step forward is from
> here
>
> Engine.log on dropbox:
> https://www.dropbox.com/s/82iem0ov869yh32/engine.log-20180508.zip?dl=0
>
> Regards,
> Callum
>
> --
>
> Callum Smith
> Research Computing Core
> Wellcome Trust Centre for Human Genetics
> University of Oxford
> e. cal...@well.ox.ac.uk
>
>
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
>
>


-- 

Michael Burman

Senior Quality engineer - rhv network - redhat israel

Red Hat



mbur...@redhat.comM: 0545355725 IM: mburman

___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org


[ovirt-users] Re: Host install failed - cannot set maintenance or remove

2018-05-09 Thread Alona Kaplan
Hi Callum,

For some reason, when installing the host the management network wasn't
attached to the host.
Since the management network is required, due to
https://bugzilla.redhat.com/1570388
 the host stuck in non
operational <-> activating states.

You have two options -

1. Updating ovirt to ovirt-engine-4.2.3.4 and re-installing the host.

2. Trying to understand why the management network wasn't attached to the
host at the first place.

If you choose option 2 please attach the full engine logs (engine.log,
server.log) and vdsm logs (vdsm.log, supervdsm.log).

Thanks,
Alona.
___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org


[ovirt-users] Re: Host install failed - cannot set maintenance or remove

2018-05-08 Thread Michael Burman
Have you removed the required property?
Do you have other required networks in this cluster except ovirtmgmt?
Do you see event massages complaining that some network/s is missing in the
cluster?
What versions are your engine and vdsm?

Alona, am i missing something?



On Tue, May 8, 2018 at 4:42 PM, Callum Smith  wrote:

> Dear Michael,
>
> No luck, the cycling is still happening. This is with a hard reset of the
> host-engine vm, the host, updating the node versions on everything.
>
> Would it be really bad to just delete the nodes from the DB and clean
> install them?
>
> Regards,
> Callum
>
> --
>
> Callum Smith
> Research Computing Core
> Wellcome Trust Centre for Human Genetics
> University of Oxford
> e. cal...@well.ox.ac.uk
>
> On 8 May 2018, at 13:44, Michael Burman  wrote:
>
> You should only remove the required property from the network, this will
> release the host from the activating cycle in which it's stuck now.
>
> On Tue, May 8, 2018 at 3:39 PM, Callum Smith  wrote:
>
>> Dear Michael,
>>
>> Good to know - didn't know about that path to configure networks.
>>
>> What's the procedure to remove the failing hosts and re-install? I can't
>> get them into maintenance mode to then install them.
>>
>> Regards,
>> Callum
>>
>> --
>>
>> Callum Smith
>> Research Computing Core
>> Wellcome Trust Centre for Human Genetics
>> University of Oxford
>> e. cal...@well.ox.ac.uk
>>
>> On 8 May 2018, at 12:37, Michael Burman  wrote:
>>
>> Hi Callum
>> Looks like you hitting  https://bugzilla.redhat.com/sh
>> ow_bug.cgi?id=1570388
>> Do you have a required network in your env(except ovirtmgmt)? try to
>> uncheck the 'required' from this network, this will solve the issue(via
>> Clusters>network or Networks>Cluster).
>> The bug was fixed in ovirt-engine-4.2.3.4
>>
>> Cheers)
>>
>> On Tue, May 8, 2018 at 12:55 PM, Callum Smith 
>> wrote:
>>
>>> Dear All,
>>>
>>> There appears to be an issue with the host install on these, there's
>>> quite a lot of errors being kicked out into the logs as they cycle through
>>> attempting to activate, failing, and then failing to go into maintenance. I
>>> can't remove the hosts from the engine to attempt to reinstall them.
>>>
>>> Issue presented from having a statically configured network on the
>>> ovritmgmt network on the hosts before running the host install. There are
>>> SQL errors (FK missing) and assorted goodness in there.
>>>
>>> Any help greatly appreciated, not sure what the next step forward is
>>> from here
>>>
>>> Engine.log on dropbox:
>>> https://www.dropbox.com/s/82iem0ov869yh32/engine.log-20180508.zip?dl=0
>>>
>>> PS. Sorry if this comes through a few times, mailing list membership
>>> seems to be having a funny turn this morning.
>>>
>>> Regards,
>>> Callum
>>>
>>> --
>>>
>>> Callum Smith
>>> Research Computing Core
>>> Wellcome Trust Centre for Human Genetics
>>> University of Oxford
>>> e. cal...@well.ox.ac.uk
>>>
>>>
>>> ___
>>> Users mailing list -- users@ovirt.org
>>> To unsubscribe send an email to users-le...@ovirt.org
>>>
>>>
>>
>>
>> --
>> Michael Burman
>>
>> Senior Quality engineer - rhv network - redhat israel
>> Red Hat
>>
>> 
>>
>> mbur...@redhat.comM: 0545355725 IM: mburman
>> 
>>
>>
>>
>
>
> --
> Michael Burman
>
> Senior Quality engineer - rhv network - redhat israel
> Red Hat
>
> 
>
> mbur...@redhat.comM: 0545355725 IM: mburman
> 
>
>
>


-- 

Michael Burman

Senior Quality engineer - rhv network - redhat israel

Red Hat



mbur...@redhat.comM: 0545355725 IM: mburman

___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org


[ovirt-users] Re: Host install failed - cannot set maintenance or remove

2018-05-08 Thread Callum Smith
Dear Michael,

No luck, the cycling is still happening. This is with a hard reset of the 
host-engine vm, the host, updating the node versions on everything.

Would it be really bad to just delete the nodes from the DB and clean install 
them?

Regards,
Callum

--

Callum Smith
Research Computing Core
Wellcome Trust Centre for Human Genetics
University of Oxford
e. cal...@well.ox.ac.uk

On 8 May 2018, at 13:44, Michael Burman 
> wrote:

You should only remove the required property from the network, this will 
release the host from the activating cycle in which it's stuck now.

On Tue, May 8, 2018 at 3:39 PM, Callum Smith 
> wrote:
Dear Michael,

Good to know - didn't know about that path to configure networks.

What's the procedure to remove the failing hosts and re-install? I can't get 
them into maintenance mode to then install them.

Regards,
Callum

--

Callum Smith
Research Computing Core
Wellcome Trust Centre for Human Genetics
University of Oxford
e. cal...@well.ox.ac.uk

On 8 May 2018, at 12:37, Michael Burman 
> wrote:

Hi Callum
Looks like you hitting  https://bugzilla.redhat.com/show_bug.cgi?id=1570388
Do you have a required network in your env(except ovirtmgmt)? try to uncheck 
the 'required' from this network, this will solve the issue(via 
Clusters>network or Networks>Cluster).
The bug was fixed in ovirt-engine-4.2.3.4

Cheers)

On Tue, May 8, 2018 at 12:55 PM, Callum Smith 
> wrote:
Dear All,

There appears to be an issue with the host install on these, there's quite a 
lot of errors being kicked out into the logs as they cycle through attempting 
to activate, failing, and then failing to go into maintenance. I can't remove 
the hosts from the engine to attempt to reinstall them.

Issue presented from having a statically configured network on the ovritmgmt 
network on the hosts before running the host install. There are SQL errors (FK 
missing) and assorted goodness in there.

Any help greatly appreciated, not sure what the next step forward is from here

Engine.log on dropbox:
https://www.dropbox.com/s/82iem0ov869yh32/engine.log-20180508.zip?dl=0

PS. Sorry if this comes through a few times, mailing list membership seems to 
be having a funny turn this morning.

Regards,
Callum

--

Callum Smith
Research Computing Core
Wellcome Trust Centre for Human Genetics
University of Oxford
e. cal...@well.ox.ac.uk


___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to 
users-le...@ovirt.org




--
Michael Burman

Senior Quality engineer - rhv network - redhat israel

Red Hat



mbur...@redhat.comM: 0545355725  
   IM: mburman

[https://www.redhat.com/files/brand/email/sig-redhat.png]




--
Michael Burman

Senior Quality engineer - rhv network - redhat israel

Red Hat



mbur...@redhat.comM: 0545355725  
   IM: mburman

[https://www.redhat.com/files/brand/email/sig-redhat.png]

___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org


[ovirt-users] Re: Host install failed - cannot set maintenance or remove

2018-05-08 Thread Michael Burman
You should only remove the required property from the network, this will
release the host from the activating cycle in which it's stuck now.

On Tue, May 8, 2018 at 3:39 PM, Callum Smith  wrote:

> Dear Michael,
>
> Good to know - didn't know about that path to configure networks.
>
> What's the procedure to remove the failing hosts and re-install? I can't
> get them into maintenance mode to then install them.
>
> Regards,
> Callum
>
> --
>
> Callum Smith
> Research Computing Core
> Wellcome Trust Centre for Human Genetics
> University of Oxford
> e. cal...@well.ox.ac.uk
>
> On 8 May 2018, at 12:37, Michael Burman  wrote:
>
> Hi Callum
> Looks like you hitting  https://bugzilla.redhat.com/
> show_bug.cgi?id=1570388
> Do you have a required network in your env(except ovirtmgmt)? try to
> uncheck the 'required' from this network, this will solve the issue(via
> Clusters>network or Networks>Cluster).
> The bug was fixed in ovirt-engine-4.2.3.4
>
> Cheers)
>
> On Tue, May 8, 2018 at 12:55 PM, Callum Smith 
> wrote:
>
>> Dear All,
>>
>> There appears to be an issue with the host install on these, there's
>> quite a lot of errors being kicked out into the logs as they cycle through
>> attempting to activate, failing, and then failing to go into maintenance. I
>> can't remove the hosts from the engine to attempt to reinstall them.
>>
>> Issue presented from having a statically configured network on the
>> ovritmgmt network on the hosts before running the host install. There are
>> SQL errors (FK missing) and assorted goodness in there.
>>
>> Any help greatly appreciated, not sure what the next step forward is from
>> here
>>
>> Engine.log on dropbox:
>> https://www.dropbox.com/s/82iem0ov869yh32/engine.log-20180508.zip?dl=0
>>
>> PS. Sorry if this comes through a few times, mailing list membership
>> seems to be having a funny turn this morning.
>>
>> Regards,
>> Callum
>>
>> --
>>
>> Callum Smith
>> Research Computing Core
>> Wellcome Trust Centre for Human Genetics
>> University of Oxford
>> e. cal...@well.ox.ac.uk
>>
>>
>> ___
>> Users mailing list -- users@ovirt.org
>> To unsubscribe send an email to users-le...@ovirt.org
>>
>>
>
>
> --
> Michael Burman
>
> Senior Quality engineer - rhv network - redhat israel
> Red Hat
>
> 
>
> mbur...@redhat.comM: 0545355725 IM: mburman
> 
>
>
>


-- 

Michael Burman

Senior Quality engineer - rhv network - redhat israel

Red Hat



mbur...@redhat.comM: 0545355725 IM: mburman

___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org


[ovirt-users] Re: Host install failed - cannot set maintenance or remove

2018-05-08 Thread Callum Smith
Dear Michael,

Good to know - didn't know about that path to configure networks.

What's the procedure to remove the failing hosts and re-install? I can't get 
them into maintenance mode to then install them.

Regards,
Callum

--

Callum Smith
Research Computing Core
Wellcome Trust Centre for Human Genetics
University of Oxford
e. cal...@well.ox.ac.uk

On 8 May 2018, at 12:37, Michael Burman 
> wrote:

Hi Callum
Looks like you hitting  https://bugzilla.redhat.com/show_bug.cgi?id=1570388
Do you have a required network in your env(except ovirtmgmt)? try to uncheck 
the 'required' from this network, this will solve the issue(via 
Clusters>network or Networks>Cluster).
The bug was fixed in ovirt-engine-4.2.3.4

Cheers)

On Tue, May 8, 2018 at 12:55 PM, Callum Smith 
> wrote:
Dear All,

There appears to be an issue with the host install on these, there's quite a 
lot of errors being kicked out into the logs as they cycle through attempting 
to activate, failing, and then failing to go into maintenance. I can't remove 
the hosts from the engine to attempt to reinstall them.

Issue presented from having a statically configured network on the ovritmgmt 
network on the hosts before running the host install. There are SQL errors (FK 
missing) and assorted goodness in there.

Any help greatly appreciated, not sure what the next step forward is from here

Engine.log on dropbox:
https://www.dropbox.com/s/82iem0ov869yh32/engine.log-20180508.zip?dl=0

PS. Sorry if this comes through a few times, mailing list membership seems to 
be having a funny turn this morning.

Regards,
Callum

--

Callum Smith
Research Computing Core
Wellcome Trust Centre for Human Genetics
University of Oxford
e. cal...@well.ox.ac.uk


___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to 
users-le...@ovirt.org




--
Michael Burman

Senior Quality engineer - rhv network - redhat israel

Red Hat



mbur...@redhat.comM: 0545355725  
   IM: mburman

[https://www.redhat.com/files/brand/email/sig-redhat.png]

___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org


[ovirt-users] Re: Host install failed - cannot set maintenance or remove

2018-05-08 Thread Michael Burman
Hi Callum
Looks like you hitting  https://bugzilla.redhat.com/show_bug.cgi?id=1570388
Do you have a required network in your env(except ovirtmgmt)? try to
uncheck the 'required' from this network, this will solve the issue(via
Clusters>network or Networks>Cluster).
The bug was fixed in ovirt-engine-4.2.3.4

Cheers)

On Tue, May 8, 2018 at 12:55 PM, Callum Smith  wrote:

> Dear All,
>
> There appears to be an issue with the host install on these, there's quite
> a lot of errors being kicked out into the logs as they cycle through
> attempting to activate, failing, and then failing to go into maintenance. I
> can't remove the hosts from the engine to attempt to reinstall them.
>
> Issue presented from having a statically configured network on the
> ovritmgmt network on the hosts before running the host install. There are
> SQL errors (FK missing) and assorted goodness in there.
>
> Any help greatly appreciated, not sure what the next step forward is from
> here
>
> Engine.log on dropbox:
> https://www.dropbox.com/s/82iem0ov869yh32/engine.log-20180508.zip?dl=0
>
> PS. Sorry if this comes through a few times, mailing list membership seems
> to be having a funny turn this morning.
>
> Regards,
> Callum
>
> --
>
> Callum Smith
> Research Computing Core
> Wellcome Trust Centre for Human Genetics
> University of Oxford
> e. cal...@well.ox.ac.uk
>
>
> ___
> Users mailing list -- users@ovirt.org
> To unsubscribe send an email to users-le...@ovirt.org
>
>


-- 

Michael Burman

Senior Quality engineer - rhv network - redhat israel

Red Hat



mbur...@redhat.comM: 0545355725 IM: mburman

___
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org