[ovirt-users] Re: dnf update fails with oVirt 4.4 on centos 8 stream due to ansible package conflicts.

2022-03-25 Thread Martin Perina
Hi, oVirt 4.4 requires ansible 2.9, it cannot work with any newer version of ansible because of deep changes in ansible between ansible 2.9 and 2.10. We are preparing upgrade to ansible-core-2.12 in oVirt 4.5, the process is tracked by https://bugzilla.redhat.com/show_bug.cgi?id=2065052 So if

[ovirt-users] Re: dnf update fails with oVirt 4.4 on centos 8 stream due to ansible package conflicts.

2022-03-25 Thread Christoph Timm
Good morning, please note that I have performed some tests and I'm quite sure that oVirt is not compatible with ansible-core-2.12. I run into issues with hosts installation and the check for updates results into a Null pointer exception. So I have reverted back to ansible-2.9 which is also

[ovirt-users] Re: dnf update fails with oVirt 4.4 on centos 8 stream due to ansible package conflicts.

2022-03-25 Thread Christoph Timm
Good morning, please note that I have performed some tests and I'm quite sure that oVirt is not compatible with ansible-core-2.12. I run into issues with hosts installation and the check for updates results into a Null pointer exception. So I have reverted back to ansible-2.9 which is also

[ovirt-users] Re: dnf update fails with oVirt 4.4 on centos 8 stream due to ansible package conflicts.

2022-03-23 Thread Sketch
Just for the record, I fixed this with: # rpm -e ansible --nodeps # dnf install ansible Now dnf update works as expected without errors or removing any packages. I haven't encounted this issue on my hosts because they are running Rocky, not Stream. On Thu, 24 Mar 2022, Sketch wrote: Just a

[ovirt-users] Re: dnf update fails with oVirt 4.4 on centos 8 stream due to ansible package conflicts.

2022-03-23 Thread Sketch
Just a warning, adding --allowerasing on my engine causes ovirt-engine and a bunch of other ovirt-* packages to be removed. So make sure you check the yum output carefully before running the command. On Wed, 23 Mar 2022, Jillian Morgan wrote: I had to add --allowerasing to my dnf update

[ovirt-users] Re: dnf update fails with oVirt 4.4 on centos 8 stream due to ansible package conflicts.

2022-03-23 Thread Jillian Morgan
I had to add --allowerasing to my dnf update command to get it to go through (which it did, cleanly removing the old ansible package and replacing it with ansible-core). I suspect that the new ansible-core package doesn't properly obsolete the older ansible package. Trying to Upgrade hosts from

[ovirt-users] Re: dnf update fails with oVirt 4.4 on centos 8 stream due to ansible package conflicts.

2022-03-23 Thread Christoph Timm
Hi List, I see the same issue on my CentOS Stream 8 hosts and engine. I'm running 4.4.10. My systems are all migrated from CentOS 8 to CentOS Stream 8. Might this be caused by that? Best regards Christoph Am 20.02.22 um 19:58 schrieb Gilboa Davara: I managed to upgrade a couple of 8-streams

[ovirt-users] Re: dnf update fails with oVirt 4.4 on centos 8 stream due to ansible package conflicts.

2022-02-20 Thread Gilboa Davara
I managed to upgrade a couple of 8-streams based clusters w/ --nobest, and thus far, I've yet to experience any issues (knocks wood feaviously). - Gilboa On Sat, Feb 19, 2022 at 3:21 PM Daniel McCoshen wrote: > Hey all, > I'm running ovirt 4.4 in production (4.4.5-11-1.el8), and I'm attempting