Re: [ovirt-users] Several VM's stuck in Migration

2016-04-01 Thread Andrew Wippler
I was in the process of upgrading from 3.5.5 to 3.6.4 when it happened. I am 
sure there were version mismatches.

I think what generated this issue was that I edited the cluster the host 
belonged to while it was going down for maintenance. This caused the tasks tab 
to show multiple tasks of the host going down for maintenance. They all 
eventually went into en error state and the task kept repeating itself until I 
rebooted the host.

Andrew Wippler | Sr. Systems Administrator | Lancaster Baptist Church | Dr. 
Paul Chappell, Pastor


From: Michal Skrivanek <michal.skriva...@redhat.com>
Sent: Friday, April 01, 2016 1:00 AM
To: Andrew Wippler
Cc: users@ovirt.org
Subject: Re: [ovirt-users] Several VM's stuck in Migration


On 31 Mar 2016, at 19:48, Andrew Wippler 
<andrew.wipp...@lancasterbaptist.org<mailto:andrew.wipp...@lancasterbaptist.org>>
 wrote:

Mark,

Hopefully you have resolved your stuck VM issue by now (nearly two months 
later). I came across this email from a google search. I was having the same 
exact problem with VMs being stuck in migration mode. The trigger to the VM 
migration issue was that I was setting my Host into maintenance mode. It 
migrated half of the active VMs successfully and the other half were stuck.

Hi,
It would be great to get logs from the system, or at least describe the 
specifics (anything special? gluster? old version?)
otherwise no one will ever be able to help;)

Thanks,
michal


There were two things I had to do to fix all of my stuck VMs:
1. I shut down the host (long enough for oVirt to fence it and notice that it 
was down). I then powered it on and "confirmed host as rebooted." This reset 
the active VM count on the host and turned on my HA VMs on other hosts.
2. For the one VM that was still stuck after a host reboot, I had to login to 
postgres and set the status to 0 on that VM. This allowed me to shut down the 
migrating VM and start it back up. (I do not think I would have had to do this 
step if I did not alter the database entry for this VM before rebooting the 
host.)

For step 2, I used the methods described here: 
https://access.redhat.com/discussions/688043 and as seen below:
ssh ovirt-engine
su postgres
psql
\connect engine
SELECT vm_guid status FROM vm_static WHERE vm_name='';
UPDATE vm_dynamic SET status=0 WHERE vm_guid='';
UPDATE vm_dynamic SET run_on_vds = null  WHERE vm_guid='';
\q
(I was then able to shut down the VM)

--
Andrew Wippler <andrew.wipp...@lancasterbaptist.org> | Sr. Systems 
Administrator | Lancaster Baptist Church

___
Users mailing list
Users@ovirt.org<mailto:Users@ovirt.org>
http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Several VM's stuck in Migration

2016-04-01 Thread Michal Skrivanek

> On 31 Mar 2016, at 19:48, Andrew Wippler 
>  wrote:
> 
> Mark,
> 
> Hopefully you have resolved your stuck VM issue by now (nearly two months 
> later). I came across this email from a google search. I was having the same 
> exact problem with VMs being stuck in migration mode. The trigger to the VM 
> migration issue was that I was setting my Host into maintenance mode. It 
> migrated half of the active VMs successfully and the other half were stuck.

Hi,
It would be great to get logs from the system, or at least describe the 
specifics (anything special? gluster? old version?)
otherwise no one will ever be able to help;)

Thanks,
michal

> 
> There were two things I had to do to fix all of my stuck VMs:
> 1. I shut down the host (long enough for oVirt to fence it and notice that it 
> was down). I then powered it on and "confirmed host as rebooted." This reset 
> the active VM count on the host and turned on my HA VMs on other hosts.
> 2. For the one VM that was still stuck after a host reboot, I had to login to 
> postgres and set the status to 0 on that VM. This allowed me to shut down the 
> migrating VM and start it back up. (I do not think I would have had to do 
> this step if I did not alter the database entry for this VM before rebooting 
> the host.)
> 
> For step 2, I used the methods described here: 
> https://access.redhat.com/discussions/688043 
>  and as seen below:
> ssh ovirt-engine
> su postgres
> psql
> \connect engine
> SELECT vm_guid status FROM vm_static WHERE vm_name='';
> UPDATE vm_dynamic SET status=0 WHERE vm_guid='';
> UPDATE vm_dynamic SET run_on_vds = null  WHERE vm_guid='';
> \q
> (I was then able to shut down the VM)
> 
> -- 
> Andrew Wippler  
>  | Sr. Systems 
> Administrator | Lancaster Baptist Church
> 
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Several VM's stuck in Migration

2016-03-31 Thread Andrew Wippler
Mark,

Hopefully you have resolved your stuck VM issue by now (nearly two months 
later). I came across this email from a google search. I was having the same 
exact problem with VMs being stuck in migration mode. The trigger to the VM 
migration issue was that I was setting my Host into maintenance mode. It 
migrated half of the active VMs successfully and the other half were stuck.

There were two things I had to do to fix all of my stuck VMs:
1. I shut down the host (long enough for oVirt to fence it and notice that it 
was down). I then powered it on and "confirmed host as rebooted." This reset 
the active VM count on the host and turned on my HA VMs on other hosts.
2. For the one VM that was still stuck after a host reboot, I had to login to 
postgres and set the status to 0 on that VM. This allowed me to shut down the 
migrating VM and start it back up. (I do not think I would have had to do this 
step if I did not alter the database entry for this VM before rebooting the 
host.)

For step 2, I used the methods described here: 
https://access.redhat.com/discussions/688043 and as seen below:
ssh ovirt-engine
su postgres
psql
\connect engine
SELECT vm_guid status FROM vm_static WHERE vm_name='';
UPDATE vm_dynamic SET status=0 WHERE vm_guid='';
UPDATE vm_dynamic SET run_on_vds = null  WHERE vm_guid='';
\q
(I was then able to shut down the VM)

--
Andrew Wippler  | Sr. Systems 
Administrator | Lancaster Baptist Church

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Several VM's stuck in Migration

2016-02-05 Thread Mark Steele
I was able to clear the stuck items by restarting the Host.

***
*Mark Steele*
CIO / VP Technical Operations | TelVue Corporation
TelVue - We Share Your Vision
800.885.8886 x128 | mste...@telvue.com | http://www.telvue.com
twitter: http://twitter.com/telvue | facebook:
https://www.facebook.com/telvue
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Several VM's stuck in Migration

2016-02-03 Thread Mark Steele
Hello,

We recently had our storage array hang. We were able to get the disk array
back online, however several of our VM's attempted to migrate from one Host
to another. Now that the storage is online, several of the VM's still
indicate they are in a state of migration and I cannot manage them from
withing the ovirt engine web administration gui.

Most of the VM's are actually running properly and I can access them either
via ssh or RDP (depending on the OS).

I have attempted to clear the migration status with the following:

- service ovirt-engine restart (on the ovirt-engine vm)
- reboot ovirt-engine vm
- PGPASSWORD=### ./unlock_entity.sh -t vm vm-name
- restart the vm from within the vm

additionally - i went on the HV of one of the VM's and did:

vdsClient -s 0 destroy vm_guid

unfortunately, that removed all traces of the vm from that HV and it was
not on any of the other three HV's - although ovirt-engine still shows it
and reports it as migrating.

I'd like to clear the migrating status of the affected VM's and figure out
how to recover the missing one.

Any help would be appreciated. I am not the person who originally setup the
ovirt installation, so I am not sure where to go to pull logs.

Thank you for your assistance.

***
*Mark Steele*
CIO / VP Technical Operations | TelVue Corporation
TelVue - We Share Your Vision
800.885.8886 x128 | mste...@telvue.com | http://www.telvue.com
twitter: http://twitter.com/telvue | facebook:
https://www.facebook.com/telvue

This
email has been sent from a virus-free computer protected by Avast.
www.avast.com

<#DDB4FAA8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users