Re: [ovirt-users] Warning - MacOS SSH Terminal / oVirt Engine Errors

2017-12-30 Thread Yedidyah Bar David
On Fri, Dec 29, 2017 at 9:41 PM, Maton, Brett  wrote:
> Works just fine from a vanilla Mac OS SSH session, I updated 3 clusters this
> week from a mac
>
> On 29 December 2017 at 13:27, Chris Adams  wrote:
>>
>> Once upon a time, andreil1  said:
>> > Hi !
>> >
>> > I would like to warn all who try to use engine-setup via MacOS X SSH
>> > terminal.
>> > It throws a lot of errors and fails (seems to relate to differently
>> > named UTF8 locales).
>> > From Linux PC everything is fine.
>> >
>> >
>> >
>> > [root@node00 ~]# engine-setup
>> > [ ERROR ] Yum unknown locale: UTF-8
>> > [ ERROR ] Yum unknown locale: UTF-8
>>
>> Is it really setting the locale ($LANG) to UTF-8?  If so, that's wrong;
>> UTF-8 is a character encoding, not a locale.  A proper locale would be
>> something like en_US.utf8.
>>
>> You should be able to override it after login by setting it, like:
>>
>> # export LANG=en_US.utf8

See also:

https://bugzilla.redhat.com/show_bug.cgi?id=1366916

>>
>> --
>> Chris Adams 
>> ___
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>



-- 
Didi
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Warning - MacOS SSH Terminal / oVirt Engine Errors

2017-12-29 Thread Maton, Brett
Works just fine from a vanilla Mac OS SSH session, I updated 3 clusters
this week from a mac

On 29 December 2017 at 13:27, Chris Adams  wrote:

> Once upon a time, andreil1  said:
> > Hi !
> >
> > I would like to warn all who try to use engine-setup via MacOS X SSH
> terminal.
> > It throws a lot of errors and fails (seems to relate to differently
> named UTF8 locales).
> > From Linux PC everything is fine.
> >
> >
> >
> > [root@node00 ~]# engine-setup
> > [ ERROR ] Yum unknown locale: UTF-8
> > [ ERROR ] Yum unknown locale: UTF-8
>
> Is it really setting the locale ($LANG) to UTF-8?  If so, that's wrong;
> UTF-8 is a character encoding, not a locale.  A proper locale would be
> something like en_US.utf8.
>
> You should be able to override it after login by setting it, like:
>
> # export LANG=en_US.utf8
>
> --
> Chris Adams 
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Warning - MacOS SSH Terminal / oVirt Engine Errors

2017-12-29 Thread Vinícius Ferrão
Assuming you’re using bash, put this on your .profile on local macOS machine:

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

V.

> On 29 Dec 2017, at 11:24, andreil1  wrote:
> 
> Hi !
> 
> I would like to warn all who try to use engine-setup via MacOS X SSH terminal.
> It throws a lot of errors and fails (seems to relate to differently named 
> UTF8 locales). 
> From Linux PC everything is fine.
> 
> 
> 
> [root@node00 ~]# engine-setup 
> [ ERROR ] Yum unknown locale: UTF-8
> [ ERROR ] Yum unknown locale: UTF-8
> [ INFO  ] Stage: Initializing
> [ INFO  ] Stage: Environment setup
>  Configuration files: 
> ['/etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf', 
> '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', 
> '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
>  Log file: 
> /var/log/ovirt-engine/setup/ovirt-engine-setup-20171229131812-y5rhix.log
>  Version: otopi-1.7.5 (otopi-1.7.5-1.el7.centos)
> [ ERROR ] Failed to execute stage 'Environment setup': unknown locale: UTF-8
> [ INFO  ] Stage: Clean up
>  Log file is located at 
> /var/log/ovirt-engine/setup/ovirt-engine-setup-20171229131812-y5rhix.log
> [ ERROR ] Failed to execute stage 'Clean up': 'NoneType' object has no 
> attribute 'cleanup'
> [ INFO  ] Generating answer file 
> '/var/lib/ovirt-engine/setup/answers/20171229131815-setup.conf'
> [ INFO  ] Stage: Pre-termination
> [ INFO  ] Stage: Termination
> [ ERROR ] Execution of setup failed
> [root@node00 ~]# Connection to 192.168.0.4 closed by remote host.
> Connection to 192.168.0.4 closed.
> iMacG5:~ g5$ 
> 
> 
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Warning - MacOS SSH Terminal / oVirt Engine Errors

2017-12-29 Thread Chris Adams
Once upon a time, andreil1  said:
> Hi !
> 
> I would like to warn all who try to use engine-setup via MacOS X SSH terminal.
> It throws a lot of errors and fails (seems to relate to differently named 
> UTF8 locales). 
> From Linux PC everything is fine.
> 
> 
> 
> [root@node00 ~]# engine-setup 
> [ ERROR ] Yum unknown locale: UTF-8
> [ ERROR ] Yum unknown locale: UTF-8

Is it really setting the locale ($LANG) to UTF-8?  If so, that's wrong;
UTF-8 is a character encoding, not a locale.  A proper locale would be
something like en_US.utf8.

You should be able to override it after login by setting it, like:

# export LANG=en_US.utf8

-- 
Chris Adams 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Warning - MacOS SSH Terminal / oVirt Engine Errors

2017-12-29 Thread andreil1
Hi !

I would like to warn all who try to use engine-setup via MacOS X SSH terminal.
It throws a lot of errors and fails (seems to relate to differently named UTF8 
locales). 
>From Linux PC everything is fine.



[root@node00 ~]# engine-setup 
[ ERROR ] Yum unknown locale: UTF-8
[ ERROR ] Yum unknown locale: UTF-8
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
  Configuration files: 
['/etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf', 
'/etc/ovirt-engine-setup.conf.d/10-packaging.conf', 
'/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
  Log file: 
/var/log/ovirt-engine/setup/ovirt-engine-setup-20171229131812-y5rhix.log
  Version: otopi-1.7.5 (otopi-1.7.5-1.el7.centos)
[ ERROR ] Failed to execute stage 'Environment setup': unknown locale: UTF-8
[ INFO  ] Stage: Clean up
  Log file is located at 
/var/log/ovirt-engine/setup/ovirt-engine-setup-20171229131812-y5rhix.log
[ ERROR ] Failed to execute stage 'Clean up': 'NoneType' object has no 
attribute 'cleanup'
[ INFO  ] Generating answer file 
'/var/lib/ovirt-engine/setup/answers/20171229131815-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed
[root@node00 ~]# Connection to 192.168.0.4 closed by remote host.
Connection to 192.168.0.4 closed.
iMacG5:~ g5$ 


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users