[ovirt-users] ovirt-ha-agent not running

2019-12-07 Thread Stefan Wolf
hello, since some days ovirt-ha-agent is not running anymore i ve 4 ovirt hosts and only on one host the agent is running. maybe it was from an update, because i lost one agent after an other. i ve done a complete fresh install for the host with the latest ovirt node. I ve got on tree hosts

[ovirt-users] ovirt-ha-agent failed to start

2018-10-03 Thread mustafa . taha . mu95
hi i try to start ovirt-ha-agent in my self-host machine but it does not work if i run journalctl -xe it shows : Oct 03 04:33:24 ovirtnode44.exalt.ps ovirt-ha-agent[81909]: ovirt-ha-agent ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine ERROR Failed to start necessary mo Oct 03

Re: [ovirt-users] ovirt-ha-agent service errors

2017-08-23 Thread Vadim
Hi, All after upgrade to 4.1.5 no any error messages ;-) Thanks to TEAM Пнд 21 Авг 2017 14:29:49 +0300, Vadim написал: > Hi, All > > ovirt 4.1.4 fresh install on two hosts with hosted-engine on both. > gluster volume is replica 3 with two vdsm hosts and one VM under esxi > >

[ovirt-users] ovirt-ha-agent service errors

2017-08-21 Thread Vadim
Hi, All ovirt 4.1.4 fresh install on two hosts with hosted-engine on both. gluster volume is replica 3 with two vdsm hosts and one VM under esxi working only one vm for HE sometimes have such errors in ha-agent # service ovirt-ha-agent status Redirecting to /bin/systemctl status

Re: [ovirt-users] ovirt-ha-agent cpu usage

2017-04-27 Thread Simone Tiraboschi
On Wed, Apr 26, 2017 at 6:14 PM, Gianluca Cecchi wrote: > On Wed, Apr 26, 2017 at 4:54 PM, Simone Tiraboschi > wrote: > >> >> >> On Wed, Apr 26, 2017 at 4:52 PM, Gianluca Cecchi < >> gianluca.cec...@gmail.com> wrote: >> >>> On Wed, Apr 26, 2017 at

Re: [ovirt-users] ovirt-ha-agent cpu usage

2017-04-26 Thread Gianluca Cecchi
On Wed, Apr 26, 2017 at 4:54 PM, Simone Tiraboschi wrote: > > > On Wed, Apr 26, 2017 at 4:52 PM, Gianluca Cecchi < > gianluca.cec...@gmail.com> wrote: > >> On Wed, Apr 26, 2017 at 4:28 PM, Simone Tiraboschi >> wrote: >> >>> >>> >>> >>> On 4.1.1, the 96%

Re: [ovirt-users] ovirt-ha-agent cpu usage

2017-04-26 Thread Simone Tiraboschi
On Wed, Apr 26, 2017 at 4:52 PM, Gianluca Cecchi wrote: > On Wed, Apr 26, 2017 at 4:28 PM, Simone Tiraboschi > wrote: > >> >> >> >> On 4.1.1, the 96% of the cpu time of ovirt-ha-agent is still spent in >> connect() in

Re: [ovirt-users] ovirt-ha-agent cpu usage

2017-04-26 Thread Gianluca Cecchi
On Wed, Apr 26, 2017 at 4:28 PM, Simone Tiraboschi wrote: > > > > On 4.1.1, the 96% of the cpu time of ovirt-ha-agent is still spent in > connect() in /usr/lib/python2.7/site-packages/vdsm/jsonrpcvdscli.py > and the 95.98% is in Schema.__init__ in /usr/lib/python2.7/site- >

Re: [ovirt-users] ovirt-ha-agent cpu usage

2017-04-26 Thread Simone Tiraboschi
On Wed, Apr 26, 2017 at 1:28 PM, Simone Tiraboschi wrote: > > > On Wed, Apr 26, 2017 at 12:52 PM, Nir Soffer wrote: > >> On Wed, Apr 26, 2017 at 11:36 AM Gianluca Cecchi < >> gianluca.cec...@gmail.com> wrote: >> >>> On Tue, Apr 25, 2017 at 11:28 PM, Nir

Re: [ovirt-users] ovirt-ha-agent cpu usage

2017-04-26 Thread Simone Tiraboschi
On Wed, Apr 26, 2017 at 12:52 PM, Nir Soffer wrote: > On Wed, Apr 26, 2017 at 11:36 AM Gianluca Cecchi < > gianluca.cec...@gmail.com> wrote: > >> On Tue, Apr 25, 2017 at 11:28 PM, Nir Soffer wrote: >> >>> >>> >>> Hi Gianluca, >>> >>> You can run this on

Re: [ovirt-users] ovirt-ha-agent cpu usage

2017-04-26 Thread Nir Soffer
On Wed, Apr 26, 2017 at 11:36 AM Gianluca Cecchi wrote: > On Tue, Apr 25, 2017 at 11:28 PM, Nir Soffer wrote: > >> >> >> Hi Gianluca, >> >> You can run this on the host: >> >> $ python -c "import yaml; print 'CLoader:', hasattr(yaml, 'CLoader')" >>

Re: [ovirt-users] ovirt-ha-agent cpu usage

2017-04-26 Thread Gianluca Cecchi
On Tue, Apr 25, 2017 at 11:28 PM, Nir Soffer wrote: > > > Hi Gianluca, > > You can run this on the host: > > $ python -c "import yaml; print 'CLoader:', hasattr(yaml, 'CLoader')" > CLoader: True > > If you get "CLoader: False", you have some packaging issue, CLoader > is

Re: [ovirt-users] ovirt-ha-agent cpu usage

2017-04-24 Thread Gianluca Cecchi
On Fri, Oct 7, 2016 at 3:35 PM, Simone Tiraboschi wrote: > > > > If I can apply the patch also to 4.0.3 I'm going to see if there is then a > different behavior. > Let me know, > > > I'm trying it right now. > Any other tests will be really appreciated. > > The patch is

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Sam Cappello
it worked for me as well - load avg. < 1 now, ovirt-ha-agent pops up in top periodically, but not on top using 100% CPU all the time anymore. thanks! sam Gianluca Cecchi wrote on 10/7/2016 10:13 AM: On Fri, Oct 7, 2016 at 3:35 PM, Simone Tiraboschi

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Michal Skrivanek
> On 07 Oct 2016, at 16:10, Simone Tiraboschi wrote: > > > >> On Fri, Oct 7, 2016 at 4:02 PM, Michal Skrivanek >> wrote: >> >>> On 7 Oct 2016, at 15:28, Simone Tiraboschi wrote: >>> >>> >>> >>> On Fri, Oct 7, 2016

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Nir Soffer
> > And a bright new 3-minutes video here: > https://drive.google.com/file/d/0BwoPbcrMv8mvVzBPUVRQa1pwVnc/ > view?usp=sharing > > It seems that now ovirt-ha-agent or is not present in top cpu process or > at least has ranges between 5% and 12% and not more > 5-12% is probably 10 times more

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Gianluca Cecchi
On Fri, Oct 7, 2016 at 3:35 PM, Simone Tiraboschi wrote: > > > On Fri, Oct 7, 2016 at 3:22 PM, Gianluca Cecchi > wrote: > >> On Fri, Oct 7, 2016 at 2:59 PM, Nir Soffer wrote: >> >>> wasn’t it suppose to be fixed to reuse

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Simone Tiraboschi
On Fri, Oct 7, 2016 at 4:02 PM, Michal Skrivanek < michal.skriva...@redhat.com> wrote: > > On 7 Oct 2016, at 15:28, Simone Tiraboschi wrote: > > > > On Fri, Oct 7, 2016 at 3:25 PM, Michal Skrivanek < > michal.skriva...@redhat.com> wrote: > >> >> On 7 Oct 2016, at 14:59, Nir

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Michal Skrivanek
> On 7 Oct 2016, at 15:28, Simone Tiraboschi wrote: > > > > On Fri, Oct 7, 2016 at 3:25 PM, Michal Skrivanek > wrote: > >> On 7 Oct 2016, at 14:59, Nir Soffer >

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Simone Tiraboschi
On Fri, Oct 7, 2016 at 3:22 PM, Gianluca Cecchi wrote: > On Fri, Oct 7, 2016 at 2:59 PM, Nir Soffer wrote: > >> >>> wasn’t it suppose to be fixed to reuse the connection? Like all the >>> other clients (vdsm migration code:-) >>> >> >> This is

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Michal Skrivanek
> On 7 Oct 2016, at 14:59, Nir Soffer wrote: > > On Fri, Oct 7, 2016 at 3:52 PM, Michal Skrivanek > wrote: > >> On 7 Oct 2016, at 14:42, Nir Soffer > >

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Gianluca Cecchi
On Fri, Oct 7, 2016 at 2:59 PM, Nir Soffer wrote: > >> wasn’t it suppose to be fixed to reuse the connection? Like all the other >> clients (vdsm migration code:-) >> > > This is orthogonal issue. > > >> Does schema validation matter then if there would be only one connection

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Nir Soffer
On Fri, Oct 7, 2016 at 3:52 PM, Michal Skrivanek < michal.skriva...@redhat.com> wrote: > > On 7 Oct 2016, at 14:42, Nir Soffer wrote: > > On Wed, Oct 5, 2016 at 1:33 PM, Simone Tiraboschi > wrote: > >> >> >> On Wed, Oct 5, 2016 at 10:34 AM, Nir Soffer

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Michal Skrivanek
> On 7 Oct 2016, at 14:42, Nir Soffer wrote: > > On Wed, Oct 5, 2016 at 1:33 PM, Simone Tiraboschi > wrote: > > > On Wed, Oct 5, 2016 at 10:34 AM, Nir Soffer > wrote: > On

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-07 Thread Nir Soffer
On Wed, Oct 5, 2016 at 1:33 PM, Simone Tiraboschi wrote: > > > On Wed, Oct 5, 2016 at 10:34 AM, Nir Soffer wrote: > >> On Wed, Oct 5, 2016 at 10:24 AM, Simone Tiraboschi >> wrote: >> >>> >>> >>> On Wed, Oct 5, 2016 at 9:17 AM,

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-05 Thread Simone Tiraboschi
On Wed, Oct 5, 2016 at 10:34 AM, Nir Soffer wrote: > On Wed, Oct 5, 2016 at 10:24 AM, Simone Tiraboschi > wrote: > >> >> >> On Wed, Oct 5, 2016 at 9:17 AM, gregor wrote: >> >>> Hi, >>> >>> did you found a solution or cause for

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-05 Thread Nir Soffer
On Wed, Oct 5, 2016 at 10:24 AM, Simone Tiraboschi wrote: > > > On Wed, Oct 5, 2016 at 9:17 AM, gregor wrote: > >> Hi, >> >> did you found a solution or cause for this high CPU usage? >> I have installed the self hosted engine on another server and

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-05 Thread Simone Tiraboschi
On Wed, Oct 5, 2016 at 9:17 AM, gregor wrote: > Hi, > > did you found a solution or cause for this high CPU usage? > I have installed the self hosted engine on another server and there is > no VM running but ovirt-ha-agent uses heavily the CPU. > Yes, it's due to the

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-10-05 Thread gregor
Hi, did you found a solution or cause for this high CPU usage? I have installed the self hosted engine on another server and there is no VM running but ovirt-ha-agent uses heavily the CPU. cheers gregor On 08/08/16 15:09, Gianluca Cecchi wrote: > On Mon, Aug 8, 2016 at 1:03 PM, Roy Golan

Re: [ovirt-users] ovirt-ha-agent

2016-08-27 Thread Sandro Bonazzola
Adding Martin. Il 26/Ago/2016 11:14, "David Gossage" ha scritto: > > On Fri, Aug 26, 2016 at 1:38 AM, Renout Gerrits wrote: >> >> Depends on your systemd configuration. ovirt-ha-agent and broker daemon's both log to stdout and it's own logfile. All

Re: [ovirt-users] ovirt-ha-agent

2016-08-26 Thread David Gossage
On Fri, Aug 26, 2016 at 1:38 AM, Renout Gerrits wrote: > Depends on your systemd configuration. ovirt-ha-agent and broker daemon's > both log to stdout and it's own logfile. All messages to stdout will go to > journald and be forwarded to /var/log/messages (ForwardToSyslog=yes in

Re: [ovirt-users] ovirt-ha-agent

2016-08-26 Thread Renout Gerrits
Depends on your systemd configuration. ovirt-ha-agent and broker daemon's both log to stdout and it's own logfile. All messages to stdout will go to journald and be forwarded to /var/log/messages (ForwardToSyslog=yes in /etc/systemd/journald.conf I think). So the ovirt-ha-agent doesn't log to

[ovirt-users] ovirt-ha-agent

2016-08-25 Thread David Gossage
This service seems to be logging to both /var/log/messages and /var/log/ovirt-hosted-engine-ha/agent.log Anything that may be causing that? Centos7 ovirt 3.6.7 MainThread::INFO::2016-08-25 15:38:36,912::ovf_store::109::ovirt_hosted_engine_ha.lib.ovf.ovf_store.OVFStore::(getEngineVMOVF)

Re: [ovirt-users] ovirt-ha-agent and too many open files error

2016-08-10 Thread Gianluca Cecchi
On Tue, Aug 9, 2016 at 6:54 PM, Simone Tiraboschi wrote: > > > Ciao Gianluca, > can you please report which vdsm version are using there? > we had a similar issue in the past but it should be already solved: > https://bugzilla.redhat.com/1343005 > > > Gianluca > > > > > >

Re: [ovirt-users] ovirt-ha-agent and too many open files error

2016-08-09 Thread Simone Tiraboschi
On Tue, Aug 9, 2016 at 4:59 PM, Gianluca Cecchi wrote: > Hello, > I have a 4.0 test environment (single host with self hosted engine) where I > have 6 VMs defined (5 running) and no much activity. > > I do't monitor this system very much. > > Now I have connected to it

[ovirt-users] ovirt-ha-agent and too many open files error

2016-08-09 Thread Gianluca Cecchi
Hello, I have a 4.0 test environment (single host with self hosted engine) where I have 6 VMs defined (5 running) and no much activity. I do't monitor this system very much. Now I have connected to it to evaluate upgrade to 4.0.1 and see that about 15 days ago the ovirt-ha-agent died because of

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-08-08 Thread Gianluca Cecchi
On Mon, Aug 8, 2016 at 1:03 PM, Roy Golan wrote: > Does the spikes correlates with info messages on extracting the ovf? > >> >> >> yes, it seems so and it happens every 14-15 seconds These are the lines I see scrolling in agent.log when I notice cpu spikes in

Re: [ovirt-users] ovirt-ha-agent cpu usage

2016-08-08 Thread Roy Golan
Does the spikes correlates with info messages on extracting the ovf? On Aug 8, 2016 1:33 PM, "Gianluca Cecchi" wrote: > Hello, > I have a test machine that is a nuc6 with an i5 and 32G of ram and SSD > disks. > It is configured as a single host environment with Self

[ovirt-users] ovirt-ha-agent cpu usage

2016-08-08 Thread Gianluca Cecchi
Hello, I have a test machine that is a nuc6 with an i5 and 32G of ram and SSD disks. It is configured as a single host environment with Self Hosted Engine VM. Both host and SHE are CentOS 7.2 and oVirt version is 3.6.6.2-1.el7 I notice that having 3 VMs powered on and making nothing special

Re: [ovirt-users] ovirt-ha-agent keeps quitting - 4.0.0

2016-07-17 Thread Yaniv Dary
The other issue will be fixed in 4.0.2: https://bugzilla.redhat.com/show_bug.cgi?id=1348907 Yaniv Dary Technical Product Manager Red Hat Israel Ltd. 34 Jerusalem Road Building A, 4th floor Ra'anana, Israel 4350109 Tel : +972 (9) 7692306 8272306 Email: yd...@redhat.com IRC : ydary On

Re: [ovirt-users] ovirt-ha-agent keeps quitting - 4.0.0

2016-07-17 Thread Artyom Lukianov
We had the bug related to this issue https://bugzilla.redhat.com/show_bug.cgi?id=1343005. It must be fixed in recent versions. Best Regards On Thu, Jul 14, 2016 at 8:14 PM, Gervais de Montbrun wrote: > Hey Folks, > > I upgraded my oVirt cluster from 3.6.7 to 4.0.0