Re: [ovirt-users] ovirt 4.0 repos

2017-09-26 Thread Yedidyah Bar David
On Tue, Sep 26, 2017 at 2:21 AM, Edward Clay  wrote:
> Hello, I've recently ran into a couple of problems. One that I'm noticing
> right now is that when I do a yum check-update I'm getting a 404 .
>
> yum clean all
> yum check-update
> Loaded plugins: fastestmirror, versionlock
> base
> | 3.6 kB  00:00:00
> http://mirror.centos.org/centos/7/virt/x86_64/ovirt-4.0/repodata/repomd.xml:
> [Errno 14] HTTP Error 404 - Not Found
> Trying other mirror.
> To address this issue please refer to the below knowledge base article
>
> https://access.redhat.com/articles/1320623
>
> If above article doesn't help to resolve this issue please create a bug on
> https://bugs.centos.org/
>
>
>
>  One of the configured repositories failed (CentOS-7 - oVirt 4.0),
>  and yum doesn't have enough cached data to continue. At this point the only
>  safe thing yum can do is fail. There are a few ways to work "fix" this:
>
>  1. Contact the upstream for the repository and get them to fix the
> problem.
>
>  2. Reconfigure the baseurl/etc. for the repository, to point to a
> working
> upstream. This is most often useful if you are using a newer
> distribution release than is supported by the repository (and the
> packages for the previous distribution release still work).
>
>  3. Run the command with the repository temporarily disabled
> yum --disablerepo=centos-ovirt40-release ...
>
>  4. Disable the repository permanently, so yum won't use it by default.
> Yum
> will then just ignore the repository until you permanently enable it
> again or use --enablerepo for temporary usage:
>
> yum-config-manager --disable centos-ovirt40-release
> or
> subscription-manager repos --disable=centos-ovirt40-release
>
>  5. Configure the failing repository to be skipped, if it is
> unavailable.
> Note that yum will try to contact the repo. when it runs most
> commands,
> so will have to try and fail each time (and thus. yum will be be
> much
> slower). If it is a very temporary problem though, this is often a
> nice
> compromise:
>
> yum-config-manager --save
> --setopt=centos-ovirt40-release.skip_if_unavailable=true
>
> failure: repodata/repomd.xml from centos-ovirt40-release: [Errno 256] No
> more mirrors to try.
> http://mirror.centos.org/centos/7/virt/x86_64/ovirt-4.0/repodata/repomd.xml:
> [Errno 14] HTTP Error 404 - Not Found
> I have the following two files in /etc/yum.repo.d that I believe are used to
> point me at ovirt repos.
>
> -rw-r--r--. 1 root root 1672 Feb  7  2017 ovirt-4.0-dependencies.repo
> [ovirt-4.0-epel]
> name=Extra Packages for Enterprise Linux 7 - $basearch
> #baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
> mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7=$basearch
> failovermethod=priority
> enabled=1
> includepkgs=epel-release,python-uinput,puppet,python-lockfile,python-cpopen,python-ordereddict,python-pthreading,python-inotify,python-argparse,novnc,python-ply,python-kitchen,python-daemon,python-websockify,livecd-tools,spice-html5,mom,python-IPy,python-ioprocess,ioprocess,safelease,python-paramiko,python2-paramiko,python2-crypto,libtomcrypt,libtommath,python-cheetah,python-ecdsa,python2-ecdsa,python-markdown,rubygem-rgen,ovirt-guest-agent*,userspace-rcu,protobuf-java,objenesis,python34*
> gpgcheck=1
> gpgkey=https://dl.fedoraproject.org/pub/epel/RPM-GPG-KEY-EPEL-7
>
> [ovirt-4.0-centos-gluster37]
> name=CentOS-7 - Gluster 3.7
> baseurl=http://mirror.centos.org/centos/7/storage/$basearch/gluster-3.7/
> gpgcheck=1
> enabled=1
> gpgkey=https://raw.githubusercontent.com/CentOS-Storage-SIG/centos-release-storage-common/master/RPM-GPG-KEY-CentOS-SIG-Storage
>
> [ovirt-4.0-patternfly1-noarch-epel]
> name=Copr repo for patternfly1 owned by patternfly
> baseurl=http://copr-be.cloud.fedoraproject.org/results/patternfly/patternfly1/epel-7-$basearch/
> enabled=1
> skip_if_unavailable=1
> gpgcheck=0
>
> [virtio-win-stable]
> name=virtio-win builds roughly matching what was shipped in latest RHEL
> baseurl=http://fedorapeople.org/groups/virt/virtio-win/repo/stable
> enabled=1
> skip_if_unavailable=1
> gpgcheck=0
>
> [centos-ovirt40-release]
> name=CentOS-7 - oVirt 4.0
> baseurl=http://mirror.centos.org/centos/7/virt/$basearch/ovirt-4.0/
> gpgcheck=0
> enabled=1
>
> -rw-r--r--. 1 root root  289 Feb  7  2017 ovirt-4.0.repo
> [ovirt-4.0]
> name=Latest oVirt 4.0 Release
> #baseurl=http://resources.ovirt.org/pub/ovirt-4.0/rpm/el$releasever/
> mirrorlist=http://resources.ovirt.org/pub/yum-repo/mirrorlist-ovirt-4.0-el$releasever
> enabled=1
> skip_if_unavailable=1
> gpgcheck=1
> gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-ovirt-4.0
>
> Should the 4.0 version/repos still be available and if so what's wrong with
> my curent config?

I think this was fixed by:

https://gerrit.ovirt.org/#/q/Iecea1ed38665d7e18adedc2ca07a4cd8f8a4de65,n,z

Can you 

[ovirt-users] ovirt 4.0 repos

2017-09-25 Thread Edward Clay
Hello, I've recently ran into a couple of problems.  One that I'm
noticing right now is that when I do a yum check-update I'm getting a
404 .

yum clean allyum check-updateLoaded plugins: fastestmirror,
versionlockbase
  | 3.6
kB  00:00:00 http://mirror.centos.org/centos/7/virt/x86_64/ovirt-4.
0/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not FoundTrying
other mirror.To address this issue please refer to the below knowledge
base article 
https://access.redhat.com/articles/1320623
If above article doesn't help to resolve this issue please create a bug
on https://bugs.centos.org/


 One of the configured repositories failed (CentOS-7 - oVirt 4.0), and
yum doesn't have enough cached data to continue. At this point the
only safe thing yum can do is fail. There are a few ways to work "fix"
this:
 1. Contact the upstream for the repository and get them to fix the
problem.
 2. Reconfigure the baseurl/etc. for the repository, to point to a
workingupstream. This is most often useful if you are using a
newerdistribution release than is supported by the repository
(and thepackages for the previous distribution release still
work).
 3. Run the command with the repository temporarily
disabledyum --disablerepo=centos-ovirt40-release ...
 4. Disable the repository permanently, so yum won't use it by
default. Yumwill then just ignore the repository until you
permanently enable itagain or use --enablerepo for temporary
usage:
yum-config-manager --disable centos-ovirt40-
releaseorsubscription-manager repos --
disable=centos-ovirt40-release
 5. Configure the failing repository to be skipped, if it is
unavailable.Note that yum will try to contact the repo. when it
runs most commands,so will have to try and fail each time (and
thus. yum will be be muchslower). If it is a very temporary
problem though, this is often a nicecompromise:
yum-config-manager --save --setopt=centos-ovirt40-
release.skip_if_unavailable=true
failure: repodata/repomd.xml from centos-ovirt40-release: [Errno 256]
No more mirrors to try.http://mirror.centos.org/centos/7/virt/x86_64/ov
irt-4.0/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found I
have the following two files in /etc/yum.repo.d that I believe are used
to point me at ovirt repos.
-rw-r--r--. 1 root root 1672 Feb  7  2017 ovirt-4.0-
dependencies.repo[ovirt-4.0-epel]name=Extra Packages for Enterprise
Linux 7 - $basearch#baseurl=http://download.fedoraproject.org/pub/epel/
7/$basearchmirrorlist=https://mirrors.fedoraproject.org/metalink?repo=e
pel-7=$basearchfailovermethod=priorityenabled=1includepkgs=epel-
release,python-uinput,puppet,python-lockfile,python-cpopen,python-
ordereddict,python-pthreading,python-inotify,python-
argparse,novnc,python-ply,python-kitchen,python-daemon,python-
websockify,livecd-tools,spice-html5,mom,python-IPy,python-
ioprocess,ioprocess,safelease,python-paramiko,python2-paramiko,python2-
crypto,libtomcrypt,libtommath,python-cheetah,python-ecdsa,python2-
ecdsa,python-markdown,rubygem-rgen,ovirt-guest-agent*,userspace-
rcu,protobuf-
java,objenesis,python34*gpgcheck=1gpgkey=https://dl.fedoraproject.org/p
ub/epel/RPM-GPG-KEY-EPEL-7
[ovirt-4.0-centos-gluster37]name=CentOS-7 - Gluster 3.7baseurl=http://m
irror.centos.org/centos/7/storage/$basearch/gluster-
3.7/gpgcheck=1enabled=1gpgkey=https://raw.githubusercontent.com/CentOS-
Storage-SIG/centos-release-storage-common/master/RPM-GPG-KEY-CentOS-
SIG-Storage
[ovirt-4.0-patternfly1-noarch-epel]name=Copr repo for patternfly1 owned
by patternflybaseurl=http://copr-be.cloud.fedoraproject.org/results/pat
ternfly/patternfly1/epel-7-
$basearch/enabled=1skip_if_unavailable=1gpgcheck=0
[virtio-win-stable]name=virtio-win builds roughly matching what was
shipped in latest RHELbaseurl=http://fedorapeople.org/groups/virt/virti
o-win/repo/stableenabled=1skip_if_unavailable=1gpgcheck=0
[centos-ovirt40-release]name=CentOS-7 - oVirt 4.0baseurl=http://mirror.
centos.org/centos/7/virt/$basearch/ovirt-4.0/gpgcheck=0enabled=1
-rw-r--r--. 1 root root  289 Feb  7  2017 ovirt-4.0.repo[ovirt-
4.0]name=Latest oVirt 4.0 Release#baseurl=http://resources.ovirt.org/pu
b/ovirt-
4.0/rpm/el$releasever/mirrorlist=http://resources.ovirt.org/pub/yum-
repo/mirrorlist-ovirt-4.0-
el$releaseverenabled=1skip_if_unavailable=1gpgcheck=1gpgkey=file:///etc
/pki/rpm-gpg/RPM-GPG-ovirt-4.0
Should the 4.0 version/repos still be available and if so what's wrong
with my curent config?
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users