Re: [ovirt-users] problem after rebooting the node

2017-02-09 Thread Yaniv Kaul
On Thu, Feb 9, 2017 at 9:51 AM, Shalabh Goel 
wrote:

> Sorry for the late reply. Actually the problem is with only one of my
> three nodes. So I think that it is an issue with the upgrade. I am using
> Ovirt-ng node OS. I will just re-install ovirt-ng OS on this node and
> upgrade it the way I did others.
>
> Actually, I upgraded my storage node (NFS) and lost all my data since it
> was in a separate folder in root (/iso and /vm) which got deleted after I
> upgraded my node. So I will have to start all over again. :(
>
> Anyway thanks for the help. Please just update the documentation on how to
> upgrade the Ovirt-ng nodes properly (I did ask about that but never got a
> reply :P).
>

You could help updating documentation (it's all in Github). See
https://github.com/oVirt/ovirt-site
Y.


>
>
> On Mon, Feb 6, 2017 at 5:00 PM, Edward Haas  wrote:
>
>> The ones you mentioned before, we just need the whole files and not
>> snippets of them.
>> vdsm.log, supervdsm.log, messages.log and the ovs ones you previously
>> mentioned.
>>
>> On Mon, Feb 6, 2017 at 1:14 PM, Shalabh Goel 
>> wrote:
>>
>>> which all log files? Actually I am new to Ovirt, so it would be really
>>> helpful if  you can tell me which ones??
>>>
>>> Thanks
>>>
>>> On Mon, Feb 6, 2017 at 4:39 PM, Edward Haas  wrote:
>>>
 Please package the logs (tar or zip) and send them.

 On Mon, Feb 6, 2017 at 12:05 PM, Shalabh Goel 
 wrote:

> Yes, I am using OVS as the switch type and I did not know that it was
> not supported officially.
>
> The output of ovs-vsctl show is as follows:
>
> f634d53e-4849-488b-8454-6b1fafa7c6ac
> ovs_version: "2.6.90"
>
> I am attaching OVS switch logs below:
>
> /var/log/openvswitch/ovsdb-server.log
>
>
> 2017-02-06T09:46:07.788Z|1|vlog|INFO|opened log file
> /var/log/openvswitch/ovsdb-server.log
> 2017-02-06T09:46:07.791Z|2|ovsdb_server|INFO|ovsdb-server (Open
> vSwitch) 2.6.90
> 2017-02-06T09:46:17.802Z|3|memory|INFO|2296 kB peak resident set
> size after 10.0 seconds
> 2017-02-06T09:46:17.802Z|4|memory|INFO|cells:16 json-caches:1
> monitors:1 sessions:1
>
> ovs-vswitchd.log
>
>
> 2017-02-06T09:46:07.999Z|1|vlog|INFO|opened log file
> /var/log/openvswitch/ovs-vswitchd.log
> 2017-02-06T09:46:08.036Z|2|ovs_numa|INFO|Discovered 24 CPU cores
> on NUMA node 0
> 2017-02-06T09:46:08.036Z|3|ovs_numa|INFO|Discovered 24 CPU cores
> on NUMA node 1
> 2017-02-06T09:46:08.036Z|4|ovs_numa|INFO|Discovered 2 NUMA nodes
> and 48 CPU cores
> 2017-02-06T09:46:08.037Z|5|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
> connecting...
> 2017-02-06T09:46:08.037Z|6|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
> connected
> 2017-02-06T09:46:08.039Z|7|bridge|INFO|ovs-vswitchd (Open
> vSwitch) 2.6.90
>
> What should I do now?
>
> The engine says that "Host host2 does not comply with the cluster
> Default networks, the following networks are missing on host: 'ovirtmgmt'
> "
>
> What other logs should I attach?
>
> Thanks
>
> Shalabh Goel
>
> On Sun, Feb 5, 2017 at 1:10 PM, Edward Haas  wrote:
>
>> Based on what I can see, you used OVS as the switch type and it seems
>> ovs (openvswitch) is not properly installed on your host.
>> Make sure that you have ovs operational by issuing "ovs-vsctl show".
>>
>> You should note that OVS network support is not an official release
>> feature, and you should use it on 4.1 and up versions.
>> Fixes will be probably submitted to master (appearing in nightly
>> builds).
>>
>> Next time please include the mailing-list in your replies and attach
>> the log files, it is less spamming.
>>
>> Thanks,
>> Edy.
>>
>> On Fri, Feb 3, 2017 at 5:07 AM, Shalabh Goel > > wrote:
>>
>>> log from messages
>>>
>>> Feb  3 08:27:53 ovirtnode3 ovs-vsctl: 
>>> ovs|1|db_ctl_base|ERR|unix:/var/run/openvswitch/db.sock:
>>> database connection failed (No such file or directory)
>>> Feb  3 08:27:53 ovirtnode3 journal: vdsm vds ERROR Executing
>>> commands failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock:
>>> database connection failed (No su
>>> ch file or directory)#012Traceback (most recent call last):#012
>>> File "/usr/share/vdsm/API.py", line 1531, in setupNetworks#012
>>> supervdsm.getProxy().setup
>>> Networks(networks, bondings, options)#012  File
>>> "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 53, in
>>> __call__#012return callMethod()#012  Fi
>>> le "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 51,
>>> in #012

Re: [ovirt-users] problem after rebooting the node

2017-02-08 Thread Shalabh Goel
Sorry for the late reply. Actually the problem is with only one of my three
nodes. So I think that it is an issue with the upgrade. I am using Ovirt-ng
node OS. I will just re-install ovirt-ng OS on this node and upgrade it the
way I did others.

Actually, I upgraded my storage node (NFS) and lost all my data since it
was in a separate folder in root (/iso and /vm) which got deleted after I
upgraded my node. So I will have to start all over again. :(

Anyway thanks for the help. Please just update the documentation on how to
upgrade the Ovirt-ng nodes properly (I did ask about that but never got a
reply :P).

On Mon, Feb 6, 2017 at 5:00 PM, Edward Haas  wrote:

> The ones you mentioned before, we just need the whole files and not
> snippets of them.
> vdsm.log, supervdsm.log, messages.log and the ovs ones you previously
> mentioned.
>
> On Mon, Feb 6, 2017 at 1:14 PM, Shalabh Goel 
> wrote:
>
>> which all log files? Actually I am new to Ovirt, so it would be really
>> helpful if  you can tell me which ones??
>>
>> Thanks
>>
>> On Mon, Feb 6, 2017 at 4:39 PM, Edward Haas  wrote:
>>
>>> Please package the logs (tar or zip) and send them.
>>>
>>> On Mon, Feb 6, 2017 at 12:05 PM, Shalabh Goel 
>>> wrote:
>>>
 Yes, I am using OVS as the switch type and I did not know that it was
 not supported officially.

 The output of ovs-vsctl show is as follows:

 f634d53e-4849-488b-8454-6b1fafa7c6ac
 ovs_version: "2.6.90"

 I am attaching OVS switch logs below:

 /var/log/openvswitch/ovsdb-server.log


 2017-02-06T09:46:07.788Z|1|vlog|INFO|opened log file
 /var/log/openvswitch/ovsdb-server.log
 2017-02-06T09:46:07.791Z|2|ovsdb_server|INFO|ovsdb-server (Open
 vSwitch) 2.6.90
 2017-02-06T09:46:17.802Z|3|memory|INFO|2296 kB peak resident set
 size after 10.0 seconds
 2017-02-06T09:46:17.802Z|4|memory|INFO|cells:16 json-caches:1
 monitors:1 sessions:1

 ovs-vswitchd.log


 2017-02-06T09:46:07.999Z|1|vlog|INFO|opened log file
 /var/log/openvswitch/ovs-vswitchd.log
 2017-02-06T09:46:08.036Z|2|ovs_numa|INFO|Discovered 24 CPU cores
 on NUMA node 0
 2017-02-06T09:46:08.036Z|3|ovs_numa|INFO|Discovered 24 CPU cores
 on NUMA node 1
 2017-02-06T09:46:08.036Z|4|ovs_numa|INFO|Discovered 2 NUMA nodes
 and 48 CPU cores
 2017-02-06T09:46:08.037Z|5|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
 connecting...
 2017-02-06T09:46:08.037Z|6|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
 connected
 2017-02-06T09:46:08.039Z|7|bridge|INFO|ovs-vswitchd (Open vSwitch)
 2.6.90

 What should I do now?

 The engine says that "Host host2 does not comply with the cluster
 Default networks, the following networks are missing on host: 'ovirtmgmt'
 "

 What other logs should I attach?

 Thanks

 Shalabh Goel

 On Sun, Feb 5, 2017 at 1:10 PM, Edward Haas  wrote:

> Based on what I can see, you used OVS as the switch type and it seems
> ovs (openvswitch) is not properly installed on your host.
> Make sure that you have ovs operational by issuing "ovs-vsctl show".
>
> You should note that OVS network support is not an official release
> feature, and you should use it on 4.1 and up versions.
> Fixes will be probably submitted to master (appearing in nightly
> builds).
>
> Next time please include the mailing-list in your replies and attach
> the log files, it is less spamming.
>
> Thanks,
> Edy.
>
> On Fri, Feb 3, 2017 at 5:07 AM, Shalabh Goel 
> wrote:
>
>> log from messages
>>
>> Feb  3 08:27:53 ovirtnode3 ovs-vsctl: 
>> ovs|1|db_ctl_base|ERR|unix:/var/run/openvswitch/db.sock:
>> database connection failed (No such file or directory)
>> Feb  3 08:27:53 ovirtnode3 journal: vdsm vds ERROR Executing commands
>> failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
>> connection failed (No su
>> ch file or directory)#012Traceback (most recent call last):#012  File
>> "/usr/share/vdsm/API.py", line 1531, in setupNetworks#012
>> supervdsm.getProxy().setup
>> Networks(networks, bondings, options)#012  File
>> "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 53, in
>> __call__#012return callMethod()#012  Fi
>> le "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 51, in
>> #012**kwargs)#012  File "", line 2, in
>> setupNetworks#012  File "/usr
>> /lib64/python2.7/multiprocessing/managers.py", line 773, in
>> _callmethod#012raise convert_to_error(kind,
>> result)#012ConfigNetworkError: (21, 'Executing co
>> mmands failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock:
>> 

Re: [ovirt-users] problem after rebooting the node

2017-02-06 Thread Edward Haas
The ones you mentioned before, we just need the whole files and not
snippets of them.
vdsm.log, supervdsm.log, messages.log and the ovs ones you previously
mentioned.

On Mon, Feb 6, 2017 at 1:14 PM, Shalabh Goel 
wrote:

> which all log files? Actually I am new to Ovirt, so it would be really
> helpful if  you can tell me which ones??
>
> Thanks
>
> On Mon, Feb 6, 2017 at 4:39 PM, Edward Haas  wrote:
>
>> Please package the logs (tar or zip) and send them.
>>
>> On Mon, Feb 6, 2017 at 12:05 PM, Shalabh Goel 
>> wrote:
>>
>>> Yes, I am using OVS as the switch type and I did not know that it was
>>> not supported officially.
>>>
>>> The output of ovs-vsctl show is as follows:
>>>
>>> f634d53e-4849-488b-8454-6b1fafa7c6ac
>>> ovs_version: "2.6.90"
>>>
>>> I am attaching OVS switch logs below:
>>>
>>> /var/log/openvswitch/ovsdb-server.log
>>>
>>>
>>> 2017-02-06T09:46:07.788Z|1|vlog|INFO|opened log file
>>> /var/log/openvswitch/ovsdb-server.log
>>> 2017-02-06T09:46:07.791Z|2|ovsdb_server|INFO|ovsdb-server (Open
>>> vSwitch) 2.6.90
>>> 2017-02-06T09:46:17.802Z|3|memory|INFO|2296 kB peak resident set
>>> size after 10.0 seconds
>>> 2017-02-06T09:46:17.802Z|4|memory|INFO|cells:16 json-caches:1
>>> monitors:1 sessions:1
>>>
>>> ovs-vswitchd.log
>>>
>>>
>>> 2017-02-06T09:46:07.999Z|1|vlog|INFO|opened log file
>>> /var/log/openvswitch/ovs-vswitchd.log
>>> 2017-02-06T09:46:08.036Z|2|ovs_numa|INFO|Discovered 24 CPU cores on
>>> NUMA node 0
>>> 2017-02-06T09:46:08.036Z|3|ovs_numa|INFO|Discovered 24 CPU cores on
>>> NUMA node 1
>>> 2017-02-06T09:46:08.036Z|4|ovs_numa|INFO|Discovered 2 NUMA nodes
>>> and 48 CPU cores
>>> 2017-02-06T09:46:08.037Z|5|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
>>> connecting...
>>> 2017-02-06T09:46:08.037Z|6|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
>>> connected
>>> 2017-02-06T09:46:08.039Z|7|bridge|INFO|ovs-vswitchd (Open vSwitch)
>>> 2.6.90
>>>
>>> What should I do now?
>>>
>>> The engine says that "Host host2 does not comply with the cluster
>>> Default networks, the following networks are missing on host: 'ovirtmgmt'
>>> "
>>>
>>> What other logs should I attach?
>>>
>>> Thanks
>>>
>>> Shalabh Goel
>>>
>>> On Sun, Feb 5, 2017 at 1:10 PM, Edward Haas  wrote:
>>>
 Based on what I can see, you used OVS as the switch type and it seems
 ovs (openvswitch) is not properly installed on your host.
 Make sure that you have ovs operational by issuing "ovs-vsctl show".

 You should note that OVS network support is not an official release
 feature, and you should use it on 4.1 and up versions.
 Fixes will be probably submitted to master (appearing in nightly
 builds).

 Next time please include the mailing-list in your replies and attach
 the log files, it is less spamming.

 Thanks,
 Edy.

 On Fri, Feb 3, 2017 at 5:07 AM, Shalabh Goel 
 wrote:

> log from messages
>
> Feb  3 08:27:53 ovirtnode3 ovs-vsctl: 
> ovs|1|db_ctl_base|ERR|unix:/var/run/openvswitch/db.sock:
> database connection failed (No such file or directory)
> Feb  3 08:27:53 ovirtnode3 journal: vdsm vds ERROR Executing commands
> failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
> connection failed (No su
> ch file or directory)#012Traceback (most recent call last):#012  File
> "/usr/share/vdsm/API.py", line 1531, in setupNetworks#012
> supervdsm.getProxy().setup
> Networks(networks, bondings, options)#012  File
> "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 53, in
> __call__#012return callMethod()#012  Fi
> le "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 51, in
> #012**kwargs)#012  File "", line 2, in
> setupNetworks#012  File "/usr
> /lib64/python2.7/multiprocessing/managers.py", line 773, in
> _callmethod#012raise convert_to_error(kind,
> result)#012ConfigNetworkError: (21, 'Executing co
> mmands failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
> connection failed (No such file or directory)')
>
> Log from vdsm.log
>
> Reactor thread::INFO::2017-02-03 08:32:24,638::protocoldetector
> ::72::ProtocolDetector.AcceptorImpl::(handle_accept) Accepted
> connection from ::1:53082
> Reactor thread::DEBUG::2017-02-03 08:32:24,643::protocoldetector
> ::91::ProtocolDetector.Detector::(__init__) Using required_size=11
> Reactor thread::INFO::2017-02-03 08:32:24,643::protocoldetector
> ::127::ProtocolDetector.Detector::(handle_read) Detected protocol xml
> from ::1:53082
> Reactor thread::DEBUG::2017-02-03 08:32:24,643::bindingxmlrpc::1
> 317::XmlDetector::(handle_socket) xml over http detected from ('::1',
> 53082)
> BindingXMLRPC::INFO::2017-02-03 
> 

Re: [ovirt-users] problem after rebooting the node

2017-02-06 Thread Shalabh Goel
which all log files? Actually I am new to Ovirt, so it would be really
helpful if  you can tell me which ones??

Thanks

On Mon, Feb 6, 2017 at 4:39 PM, Edward Haas  wrote:

> Please package the logs (tar or zip) and send them.
>
> On Mon, Feb 6, 2017 at 12:05 PM, Shalabh Goel 
> wrote:
>
>> Yes, I am using OVS as the switch type and I did not know that it was not
>> supported officially.
>>
>> The output of ovs-vsctl show is as follows:
>>
>> f634d53e-4849-488b-8454-6b1fafa7c6ac
>> ovs_version: "2.6.90"
>>
>> I am attaching OVS switch logs below:
>>
>> /var/log/openvswitch/ovsdb-server.log
>>
>>
>> 2017-02-06T09:46:07.788Z|1|vlog|INFO|opened log file
>> /var/log/openvswitch/ovsdb-server.log
>> 2017-02-06T09:46:07.791Z|2|ovsdb_server|INFO|ovsdb-server (Open
>> vSwitch) 2.6.90
>> 2017-02-06T09:46:17.802Z|3|memory|INFO|2296 kB peak resident set
>> size after 10.0 seconds
>> 2017-02-06T09:46:17.802Z|4|memory|INFO|cells:16 json-caches:1
>> monitors:1 sessions:1
>>
>> ovs-vswitchd.log
>>
>>
>> 2017-02-06T09:46:07.999Z|1|vlog|INFO|opened log file
>> /var/log/openvswitch/ovs-vswitchd.log
>> 2017-02-06T09:46:08.036Z|2|ovs_numa|INFO|Discovered 24 CPU cores on
>> NUMA node 0
>> 2017-02-06T09:46:08.036Z|3|ovs_numa|INFO|Discovered 24 CPU cores on
>> NUMA node 1
>> 2017-02-06T09:46:08.036Z|4|ovs_numa|INFO|Discovered 2 NUMA nodes and
>> 48 CPU cores
>> 2017-02-06T09:46:08.037Z|5|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
>> connecting...
>> 2017-02-06T09:46:08.037Z|6|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
>> connected
>> 2017-02-06T09:46:08.039Z|7|bridge|INFO|ovs-vswitchd (Open vSwitch)
>> 2.6.90
>>
>> What should I do now?
>>
>> The engine says that "Host host2 does not comply with the cluster Default
>> networks, the following networks are missing on host: 'ovirtmgmt'"
>>
>> What other logs should I attach?
>>
>> Thanks
>>
>> Shalabh Goel
>>
>> On Sun, Feb 5, 2017 at 1:10 PM, Edward Haas  wrote:
>>
>>> Based on what I can see, you used OVS as the switch type and it seems
>>> ovs (openvswitch) is not properly installed on your host.
>>> Make sure that you have ovs operational by issuing "ovs-vsctl show".
>>>
>>> You should note that OVS network support is not an official release
>>> feature, and you should use it on 4.1 and up versions.
>>> Fixes will be probably submitted to master (appearing in nightly builds).
>>>
>>> Next time please include the mailing-list in your replies and attach the
>>> log files, it is less spamming.
>>>
>>> Thanks,
>>> Edy.
>>>
>>> On Fri, Feb 3, 2017 at 5:07 AM, Shalabh Goel 
>>> wrote:
>>>
 log from messages

 Feb  3 08:27:53 ovirtnode3 ovs-vsctl: 
 ovs|1|db_ctl_base|ERR|unix:/var/run/openvswitch/db.sock:
 database connection failed (No such file or directory)
 Feb  3 08:27:53 ovirtnode3 journal: vdsm vds ERROR Executing commands
 failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
 connection failed (No su
 ch file or directory)#012Traceback (most recent call last):#012  File
 "/usr/share/vdsm/API.py", line 1531, in setupNetworks#012
 supervdsm.getProxy().setup
 Networks(networks, bondings, options)#012  File
 "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 53, in
 __call__#012return callMethod()#012  Fi
 le "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 51, in
 #012**kwargs)#012  File "", line 2, in
 setupNetworks#012  File "/usr
 /lib64/python2.7/multiprocessing/managers.py", line 773, in
 _callmethod#012raise convert_to_error(kind,
 result)#012ConfigNetworkError: (21, 'Executing co
 mmands failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
 connection failed (No such file or directory)')

 Log from vdsm.log

 Reactor thread::INFO::2017-02-03 08:32:24,638::protocoldetector
 ::72::ProtocolDetector.AcceptorImpl::(handle_accept) Accepted
 connection from ::1:53082
 Reactor thread::DEBUG::2017-02-03 08:32:24,643::protocoldetector
 ::91::ProtocolDetector.Detector::(__init__) Using required_size=11
 Reactor thread::INFO::2017-02-03 08:32:24,643::protocoldetector
 ::127::ProtocolDetector.Detector::(handle_read) Detected protocol xml
 from ::1:53082
 Reactor thread::DEBUG::2017-02-03 08:32:24,643::bindingxmlrpc::1
 317::XmlDetector::(handle_socket) xml over http detected from ('::1',
 53082)
 BindingXMLRPC::INFO::2017-02-03 
 08:32:24,643::xmlrpc::73::vds.XMLRPCServer::(handle_request)
 Starting request handler for ::1:53082
 Thread-20::INFO::2017-02-03 08:32:24,644::xmlrpc::83::vds.
 XMLRPCServer::(_process_requests) Request handler for ::1:53082 started
 Thread-20::DEBUG::2017-02-03 
 08:32:24,644::bindingxmlrpc::1263::vds::(wrapper)
 client [::1]::call getAllVmStats with () {}
 

Re: [ovirt-users] problem after rebooting the node

2017-02-06 Thread Edward Haas
Please package the logs (tar or zip) and send them.

On Mon, Feb 6, 2017 at 12:05 PM, Shalabh Goel 
wrote:

> Yes, I am using OVS as the switch type and I did not know that it was not
> supported officially.
>
> The output of ovs-vsctl show is as follows:
>
> f634d53e-4849-488b-8454-6b1fafa7c6ac
> ovs_version: "2.6.90"
>
> I am attaching OVS switch logs below:
>
> /var/log/openvswitch/ovsdb-server.log
>
>
> 2017-02-06T09:46:07.788Z|1|vlog|INFO|opened log file
> /var/log/openvswitch/ovsdb-server.log
> 2017-02-06T09:46:07.791Z|2|ovsdb_server|INFO|ovsdb-server (Open
> vSwitch) 2.6.90
> 2017-02-06T09:46:17.802Z|3|memory|INFO|2296 kB peak resident set size
> after 10.0 seconds
> 2017-02-06T09:46:17.802Z|4|memory|INFO|cells:16 json-caches:1
> monitors:1 sessions:1
>
> ovs-vswitchd.log
>
>
> 2017-02-06T09:46:07.999Z|1|vlog|INFO|opened log file
> /var/log/openvswitch/ovs-vswitchd.log
> 2017-02-06T09:46:08.036Z|2|ovs_numa|INFO|Discovered 24 CPU cores on
> NUMA node 0
> 2017-02-06T09:46:08.036Z|3|ovs_numa|INFO|Discovered 24 CPU cores on
> NUMA node 1
> 2017-02-06T09:46:08.036Z|4|ovs_numa|INFO|Discovered 2 NUMA nodes and
> 48 CPU cores
> 2017-02-06T09:46:08.037Z|5|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
> connecting...
> 2017-02-06T09:46:08.037Z|6|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
> connected
> 2017-02-06T09:46:08.039Z|7|bridge|INFO|ovs-vswitchd (Open vSwitch)
> 2.6.90
>
> What should I do now?
>
> The engine says that "Host host2 does not comply with the cluster Default
> networks, the following networks are missing on host: 'ovirtmgmt'"
>
> What other logs should I attach?
>
> Thanks
>
> Shalabh Goel
>
> On Sun, Feb 5, 2017 at 1:10 PM, Edward Haas  wrote:
>
>> Based on what I can see, you used OVS as the switch type and it seems ovs
>> (openvswitch) is not properly installed on your host.
>> Make sure that you have ovs operational by issuing "ovs-vsctl show".
>>
>> You should note that OVS network support is not an official release
>> feature, and you should use it on 4.1 and up versions.
>> Fixes will be probably submitted to master (appearing in nightly builds).
>>
>> Next time please include the mailing-list in your replies and attach the
>> log files, it is less spamming.
>>
>> Thanks,
>> Edy.
>>
>> On Fri, Feb 3, 2017 at 5:07 AM, Shalabh Goel 
>> wrote:
>>
>>> log from messages
>>>
>>> Feb  3 08:27:53 ovirtnode3 ovs-vsctl: 
>>> ovs|1|db_ctl_base|ERR|unix:/var/run/openvswitch/db.sock:
>>> database connection failed (No such file or directory)
>>> Feb  3 08:27:53 ovirtnode3 journal: vdsm vds ERROR Executing commands
>>> failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
>>> connection failed (No su
>>> ch file or directory)#012Traceback (most recent call last):#012  File
>>> "/usr/share/vdsm/API.py", line 1531, in setupNetworks#012
>>> supervdsm.getProxy().setup
>>> Networks(networks, bondings, options)#012  File
>>> "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 53, in
>>> __call__#012return callMethod()#012  Fi
>>> le "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 51, in
>>> #012**kwargs)#012  File "", line 2, in
>>> setupNetworks#012  File "/usr
>>> /lib64/python2.7/multiprocessing/managers.py", line 773, in
>>> _callmethod#012raise convert_to_error(kind,
>>> result)#012ConfigNetworkError: (21, 'Executing co
>>> mmands failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
>>> connection failed (No such file or directory)')
>>>
>>> Log from vdsm.log
>>>
>>> Reactor thread::INFO::2017-02-03 08:32:24,638::protocoldetector
>>> ::72::ProtocolDetector.AcceptorImpl::(handle_accept) Accepted
>>> connection from ::1:53082
>>> Reactor thread::DEBUG::2017-02-03 08:32:24,643::protocoldetector
>>> ::91::ProtocolDetector.Detector::(__init__) Using required_size=11
>>> Reactor thread::INFO::2017-02-03 08:32:24,643::protocoldetector
>>> ::127::ProtocolDetector.Detector::(handle_read) Detected protocol xml
>>> from ::1:53082
>>> Reactor thread::DEBUG::2017-02-03 08:32:24,643::bindingxmlrpc::1
>>> 317::XmlDetector::(handle_socket) xml over http detected from ('::1',
>>> 53082)
>>> BindingXMLRPC::INFO::2017-02-03 
>>> 08:32:24,643::xmlrpc::73::vds.XMLRPCServer::(handle_request)
>>> Starting request handler for ::1:53082
>>> Thread-20::INFO::2017-02-03 08:32:24,644::xmlrpc::83::vds.
>>> XMLRPCServer::(_process_requests) Request handler for ::1:53082 started
>>> Thread-20::DEBUG::2017-02-03 
>>> 08:32:24,644::bindingxmlrpc::1263::vds::(wrapper)
>>> client [::1]::call getAllVmStats with () {}
>>> Thread-20::DEBUG::2017-02-03 
>>> 08:32:24,644::bindingxmlrpc::1270::vds::(wrapper)
>>> return getAllVmStats with {'status': {'message': 'Done', 'code': 0},
>>> 'statsLis
>>> t': (suppressed)}
>>> Thread-20::INFO::2017-02-03 
>>> 08:32:24,644::bindingxmlrpc::1297::vds::(wrapper)
>>> RPC call getAllVmStats finished (code=0) in 0.00 seconds

Re: [ovirt-users] problem after rebooting the node

2017-02-06 Thread Shalabh Goel
Yes, I am using OVS as the switch type and I did not know that it was not
supported officially.

The output of ovs-vsctl show is as follows:

f634d53e-4849-488b-8454-6b1fafa7c6ac
ovs_version: "2.6.90"

I am attaching OVS switch logs below:

/var/log/openvswitch/ovsdb-server.log


2017-02-06T09:46:07.788Z|1|vlog|INFO|opened log file
/var/log/openvswitch/ovsdb-server.log
2017-02-06T09:46:07.791Z|2|ovsdb_server|INFO|ovsdb-server (Open
vSwitch) 2.6.90
2017-02-06T09:46:17.802Z|3|memory|INFO|2296 kB peak resident set size
after 10.0 seconds
2017-02-06T09:46:17.802Z|4|memory|INFO|cells:16 json-caches:1
monitors:1 sessions:1

ovs-vswitchd.log


2017-02-06T09:46:07.999Z|1|vlog|INFO|opened log file
/var/log/openvswitch/ovs-vswitchd.log
2017-02-06T09:46:08.036Z|2|ovs_numa|INFO|Discovered 24 CPU cores on
NUMA node 0
2017-02-06T09:46:08.036Z|3|ovs_numa|INFO|Discovered 24 CPU cores on
NUMA node 1
2017-02-06T09:46:08.036Z|4|ovs_numa|INFO|Discovered 2 NUMA nodes and 48
CPU cores
2017-02-06T09:46:08.037Z|5|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
connecting...
2017-02-06T09:46:08.037Z|6|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
connected
2017-02-06T09:46:08.039Z|7|bridge|INFO|ovs-vswitchd (Open vSwitch)
2.6.90

What should I do now?

The engine says that "Host host2 does not comply with the cluster Default
networks, the following networks are missing on host: 'ovirtmgmt'"

What other logs should I attach?

Thanks

Shalabh Goel

On Sun, Feb 5, 2017 at 1:10 PM, Edward Haas  wrote:

> Based on what I can see, you used OVS as the switch type and it seems ovs
> (openvswitch) is not properly installed on your host.
> Make sure that you have ovs operational by issuing "ovs-vsctl show".
>
> You should note that OVS network support is not an official release
> feature, and you should use it on 4.1 and up versions.
> Fixes will be probably submitted to master (appearing in nightly builds).
>
> Next time please include the mailing-list in your replies and attach the
> log files, it is less spamming.
>
> Thanks,
> Edy.
>
> On Fri, Feb 3, 2017 at 5:07 AM, Shalabh Goel 
> wrote:
>
>> log from messages
>>
>> Feb  3 08:27:53 ovirtnode3 ovs-vsctl: 
>> ovs|1|db_ctl_base|ERR|unix:/var/run/openvswitch/db.sock:
>> database connection failed (No such file or directory)
>> Feb  3 08:27:53 ovirtnode3 journal: vdsm vds ERROR Executing commands
>> failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
>> connection failed (No su
>> ch file or directory)#012Traceback (most recent call last):#012  File
>> "/usr/share/vdsm/API.py", line 1531, in setupNetworks#012
>> supervdsm.getProxy().setup
>> Networks(networks, bondings, options)#012  File
>> "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 53, in
>> __call__#012return callMethod()#012  Fi
>> le "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 51, in
>> #012**kwargs)#012  File "", line 2, in
>> setupNetworks#012  File "/usr
>> /lib64/python2.7/multiprocessing/managers.py", line 773, in
>> _callmethod#012raise convert_to_error(kind,
>> result)#012ConfigNetworkError: (21, 'Executing co
>> mmands failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
>> connection failed (No such file or directory)')
>>
>> Log from vdsm.log
>>
>> Reactor thread::INFO::2017-02-03 08:32:24,638::protocoldetector
>> ::72::ProtocolDetector.AcceptorImpl::(handle_accept) Accepted connection
>> from ::1:53082
>> Reactor thread::DEBUG::2017-02-03 08:32:24,643::protocoldetector
>> ::91::ProtocolDetector.Detector::(__init__) Using required_size=11
>> Reactor thread::INFO::2017-02-03 08:32:24,643::protocoldetector
>> ::127::ProtocolDetector.Detector::(handle_read) Detected protocol xml
>> from ::1:53082
>> Reactor thread::DEBUG::2017-02-03 08:32:24,643::bindingxmlrpc::1
>> 317::XmlDetector::(handle_socket) xml over http detected from ('::1',
>> 53082)
>> BindingXMLRPC::INFO::2017-02-03 
>> 08:32:24,643::xmlrpc::73::vds.XMLRPCServer::(handle_request)
>> Starting request handler for ::1:53082
>> Thread-20::INFO::2017-02-03 08:32:24,644::xmlrpc::83::vds.
>> XMLRPCServer::(_process_requests) Request handler for ::1:53082 started
>> Thread-20::DEBUG::2017-02-03 
>> 08:32:24,644::bindingxmlrpc::1263::vds::(wrapper)
>> client [::1]::call getAllVmStats with () {}
>> Thread-20::DEBUG::2017-02-03 
>> 08:32:24,644::bindingxmlrpc::1270::vds::(wrapper)
>> return getAllVmStats with {'status': {'message': 'Done', 'code': 0},
>> 'statsLis
>> t': (suppressed)}
>> Thread-20::INFO::2017-02-03 08:32:24,644::bindingxmlrpc::1297::vds::(wrapper)
>> RPC call getAllVmStats finished (code=0) in 0.00 seconds
>> Thread-20::INFO::2017-02-03 08:32:24,645::xmlrpc::91::vds.
>> XMLRPCServer::(_process_requests) Request handler for ::1:53082 stopped
>> periodic/0::DEBUG::2017-02-03 08:32:24,907::sampling::508::v
>> irt.sampling.VMBulkSampler::(__call__) sampled timestamp 4347942.15
>> elapsed 0.010 

Re: [ovirt-users] problem after rebooting the node

2017-02-04 Thread Edward Haas
Based on what I can see, you used OVS as the switch type and it seems ovs
(openvswitch) is not properly installed on your host.
Make sure that you have ovs operational by issuing "ovs-vsctl show".

You should note that OVS network support is not an official release
feature, and you should use it on 4.1 and up versions.
Fixes will be probably submitted to master (appearing in nightly builds).

Next time please include the mailing-list in your replies and attach the
log files, it is less spamming.

Thanks,
Edy.

On Fri, Feb 3, 2017 at 5:07 AM, Shalabh Goel 
wrote:

> log from messages
>
> Feb  3 08:27:53 ovirtnode3 ovs-vsctl: ovs|1|db_ctl_base|ERR|
> unix:/var/run/openvswitch/db.sock: database connection failed (No such
> file or directory)
> Feb  3 08:27:53 ovirtnode3 journal: vdsm vds ERROR Executing commands
> failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection
> failed (No su
> ch file or directory)#012Traceback (most recent call last):#012  File
> "/usr/share/vdsm/API.py", line 1531, in setupNetworks#012
> supervdsm.getProxy().setup
> Networks(networks, bondings, options)#012  File 
> "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py",
> line 53, in __call__#012return callMethod()#012  Fi
> le "/usr/lib/python2.7/site-packages/vdsm/supervdsm.py", line 51, in
> #012**kwargs)#012  File "", line 2, in
> setupNetworks#012  File "/usr
> /lib64/python2.7/multiprocessing/managers.py", line 773, in
> _callmethod#012raise convert_to_error(kind,
> result)#012ConfigNetworkError: (21, 'Executing co
> mmands failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database
> connection failed (No such file or directory)')
>
> Log from vdsm.log
>
> Reactor thread::INFO::2017-02-03 08:32:24,638::protocoldetector::72::
> ProtocolDetector.AcceptorImpl::(handle_accept) Accepted connection from
> ::1:53082
> Reactor thread::DEBUG::2017-02-03 08:32:24,643::protocoldetector::91::
> ProtocolDetector.Detector::(__init__) Using required_size=11
> Reactor thread::INFO::2017-02-03 08:32:24,643::protocoldetector::127::
> ProtocolDetector.Detector::(handle_read) Detected protocol xml from
> ::1:53082
> Reactor thread::DEBUG::2017-02-03 08:32:24,643::bindingxmlrpc::
> 1317::XmlDetector::(handle_socket) xml over http detected from ('::1',
> 53082)
> BindingXMLRPC::INFO::2017-02-03 
> 08:32:24,643::xmlrpc::73::vds.XMLRPCServer::(handle_request)
> Starting request handler for ::1:53082
> Thread-20::INFO::2017-02-03 08:32:24,644::xmlrpc::83::vds.
> XMLRPCServer::(_process_requests) Request handler for ::1:53082 started
> Thread-20::DEBUG::2017-02-03 08:32:24,644::bindingxmlrpc::1263::vds::(wrapper)
> client [::1]::call getAllVmStats with () {}
> Thread-20::DEBUG::2017-02-03 08:32:24,644::bindingxmlrpc::1270::vds::(wrapper)
> return getAllVmStats with {'status': {'message': 'Done', 'code': 0},
> 'statsLis
> t': (suppressed)}
> Thread-20::INFO::2017-02-03 08:32:24,644::bindingxmlrpc::1297::vds::(wrapper)
> RPC call getAllVmStats finished (code=0) in 0.00 seconds
> Thread-20::INFO::2017-02-03 08:32:24,645::xmlrpc::91::vds.
> XMLRPCServer::(_process_requests) Request handler for ::1:53082 stopped
> periodic/0::DEBUG::2017-02-03 08:32:24,907::sampling::508::
> virt.sampling.VMBulkSampler::(__call__) sampled timestamp 4347942.15
> elapsed 0.010 acquired True d
> omains all
> periodic/2::DEBUG::2017-02-03 08:32:24,908::task::599::
> storage.TaskManager.Task::(_updateState) 
> (Task='bb07f89c-6165-42bc-902f-1b7701b813fa')
> moving from sta
> te init -> state preparing
> periodic/2::INFO::2017-02-03 08:32:24,908::logUtils::49::dispatcher::(wrapper)
> Run and protect: repoStats(options=None)
> periodic/2::INFO::2017-02-03 08:32:24,908::logUtils::52::dispatcher::(wrapper)
> Run and protect: repoStats, Return response: {}
> periodic/2::DEBUG::2017-02-03 08:32:24,909::task::1195::
> storage.TaskManager.Task::(prepare) 
> (Task='bb07f89c-6165-42bc-902f-1b7701b813fa')
> finished: {}
> periodic/2::DEBUG::2017-02-03 08:32:24,909::task::599::
> storage.TaskManager.Task::(_updateState) 
> (Task='bb07f89c-6165-42bc-902f-1b7701b813fa')
> moving from sta
> te preparing -> state finished
> periodic/2::DEBUG::2017-02-03 08:32:24,909::resourceManager:
> :910::storage.ResourceManager.Owner::(releaseAll) Owner.releaseAll
> requests {} resources {}
> periodic/2::DEBUG::2017-02-03 08:32:24,909::resourceManager:
> :947::storage.ResourceManager.Owner::(cancelAll) Owner.cancelAll requests
> {}
> periodic/2::DEBUG::2017-02-03 08:32:24,909::task::997::
> storage.TaskManager.Task::(_decref) 
> (Task='bb07f89c-6165-42bc-902f-1b7701b813fa')
> ref 0 aborting False
> jsonrpc/4::DEBUG::2017-02-03 08:32:26,653::__init__::532::
> jsonrpc.JsonRpcServer::(_handle_request) Calling 'Host.getAllVmStats' in
> bridge with {}
> jsonrpc/4::DEBUG::2017-02-03 08:32:26,653::__init__::557::
> jsonrpc.JsonRpcServer::(_handle_request) Return 'Host.getAllVmStats' in
> bridge with (suppressed)
> jsonrpc/4::INFO::2017-02-03 

Re: [ovirt-users] problem after rebooting the node

2017-02-02 Thread Edward Haas
Hello Shalabh,

Please provide the logs from your node:
- messages
- vdsm/vdsm.log, vdsm/supervdsm.log

It may be that you are missing openvswitch installed, although VDSM should
not require it for its operation.

Thanks,
Edy.


On Thu, Feb 2, 2017 at 2:10 PM, Shalabh Goel 
wrote:

> HI,
>
> I am getting the following error on my node after rebooting it.
>
> VDSM ovirtnode2 command HostSetupNetworksVDS failed: Executing commands
> failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection
> failed (No such file or directory)
>
>
> To solve this, I am trying to restart ovsdb-server using the following
> command,
>
> ovsdb-server --remote=punix:*/var/run/openvswitch/db.sock*
> --remote=db:Open_vSwitch,Open_vSwitch,manager_options
> --private-key=db:Open_vSwitch,SSL,private_key--certificate=
> db:Open_vSwitch,SSL,certificate 
> --bootstrap-ca-cert=db:Open_vSwitch,SSL,ca_cert
> --pidfile --detach
>
> But I am getting the following error.
>
> ovsdb-server: /var/run/openvswitch/ovsdb-server.pid.tmp: create failed
> (No such file or directory)
>
> How to restart the ovsdb-server?? Also ovirtmgmt network is missing from
> my node. It happened after I rebooted my node after it got upgraded to
> Ovirt 4.1
>
> --
> Shalabh Goel
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] problem after rebooting the node

2017-02-02 Thread Shalabh Goel
HI,

I am getting the following error on my node after rebooting it.

VDSM ovirtnode2 command HostSetupNetworksVDS failed: Executing commands
failed: ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection
failed (No such file or directory)


To solve this, I am trying to restart ovsdb-server using the following
command,

ovsdb-server --remote=punix:*/var/run/openvswitch/db.sock*
--remote=db:Open_vSwitch,Open_vSwitch,manager_options
--private-key=db:Open_vSwitch,SSL,private_key--certificate=db:Open_vSwitch,SSL,certificate
--bootstrap-ca-cert=db:Open_vSwitch,SSL,ca_cert --pidfile --detach

But I am getting the following error.

ovsdb-server: /var/run/openvswitch/ovsdb-server.pid.tmp: create failed (No
such file or directory)

How to restart the ovsdb-server?? Also ovirtmgmt network is missing from my
node. It happened after I rebooted my node after it got upgraded to Ovirt
4.1

-- 
Shalabh Goel
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users