Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-06-08 Thread Will Dennis
No, I didn't see (notice) that step / instructions anywhere... How to do that? -Original Message- From: Simone Tiraboschi [mailto:stira...@redhat.com] Sent: Wednesday, June 08, 2016 10:23 AM To: Will Dennis Cc: jvdw...@xs4all.nl; users@ovirt.org; Michal Skrivanek Subject: Re:

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-06-08 Thread Simone Tiraboschi
On Wed, Jun 8, 2016 at 4:22 PM, Will Dennis wrote: > FYI, here are the results of 'engine-config -g [...]' on my engine VM: > > [root@ovirt-engine-01 ~]# sudo engine-config -g UserDefinedVMProperties > UserDefinedVMProperties: version: 3.0 > UserDefinedVMProperties:

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-06-08 Thread Will Dennis
FYI, here are the results of 'engine-config -g [...]' on my engine VM: [root@ovirt-engine-01 ~]# sudo engine-config -g UserDefinedVMProperties UserDefinedVMProperties: version: 3.0 UserDefinedVMProperties: version: 3.1 UserDefinedVMProperties: version: 3.2 UserDefinedVMProperties: version:

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-06-08 Thread Will Dennis
Hi Simone, These are the instructions I followed, which I found at: https://www.ovirt.org/develop/developer-guide/engine/engine-config-examples/ Adding VM custom properties (macspoof) # engine-config -s "UserDefinedVMProperties=macspoof=(true|false)" # service ovirt-engine restart

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-06-08 Thread Simone Tiraboschi
On Wed, Jun 8, 2016 at 12:00 AM, Will Dennis wrote: > The "-r" arg to virsh makes all the difference :) (much to learn...) > > [root@ovirt-node-03 ~]# virsh -r list > IdName State > > 6

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-06-07 Thread Will Dennis
The "-r" arg to virsh makes all the difference :) (much to learn...) [root@ovirt-node-03 ~]# virsh -r list IdName State 6 proxmox-01 running 7 proxmox-02 running

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-06-07 Thread Will Dennis
Oops, missed that comment... When I try an operation with virsh, it asks me for credentials that it doesn't accept... [root@ovirt-node-03 ~]# virsh list Please enter your authentication name: root Please enter your password: error: failed to connect to the hypervisor error: no valid connection

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-06-07 Thread Yedidyah Bar David
On Tue, Jun 7, 2016 at 12:04 AM, Will Dennis wrote: > Sorry, got away from this for a while attending to other work, but back at it > now... Anyone have any ideas on how I may further troubleshoot this issue? Edward later asked you to post the domxml. You can find it with

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-06-06 Thread Will Dennis
Sorry, got away from this for a while attending to other work, but back at it now... Anyone have any ideas on how I may further troubleshoot this issue? Thanks -Original Message- From: Will Dennis Sent: Wednesday, May 18, 2016 11:39 AM To: 'Michal Skrivanek'; 'Yedidyah Bar David' Cc:

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-23 Thread Edward Haas
On Wed, May 18, 2016 at 6:39 PM, Will Dennis wrote: > Sadly, having set the 'macspoof' key to 'true' in Custom Properties in the > VM Edit dialog, then restarting the VM thereafter, I'm still not seeing the > container's MAC address in the relevant bridge's MAC table in

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-18 Thread Will Dennis
Sadly, having set the 'macspoof' key to 'true' in Custom Properties in the VM Edit dialog, then restarting the VM thereafter, I'm still not seeing the container's MAC address in the relevant bridge's MAC table in oVirt, and the container is failing to lease a DHCP address from the external

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-18 Thread Will Dennis
Yup, I see it now in the Admin portal VM Edit dialog - thanks! Will -Original Message- From: Michal Skrivanek [mailto:mskri...@redhat.com] Sent: Wednesday, May 18, 2016 2:37 AM To: Yedidyah Bar David Cc: Will Dennis; users@ovirt.org Subject: Re: [ovirt-users] virt-in-virt problem: DHCP

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-18 Thread Michal Skrivanek
> On 15 May 2016, at 07:24, Yedidyah Bar David wrote: > >> On Wed, May 11, 2016 at 5:17 PM, Will Dennis wrote: >> OK; I searched the oVirt site for 'engine-config' (unfamiliar with it) and >> found the following page: >>

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-14 Thread Yedidyah Bar David
On Wed, May 11, 2016 at 5:17 PM, Will Dennis wrote: > OK; I searched the oVirt site for 'engine-config' (unfamiliar with it) and > found the following page: > https://www.ovirt.org/develop/developer-guide/engine/engine-config-examples/ > > I see the instructions on it for

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-11 Thread Will Dennis
OK; I searched the oVirt site for 'engine-config' (unfamiliar with it) and found the following page: https://www.ovirt.org/develop/developer-guide/engine/engine-config-examples/ I see the instructions on it for "Adding VM custom properties (macspoof)", so I did execute the referenced

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-10 Thread Yedidyah Bar David
On Tue, May 10, 2016 at 8:36 PM, Will Dennis wrote: > Hi Simone, > > Sorry but I'm just getting back to this... Not sure where/how one might > implement the hook you have indicated... It looks to be VM-specific, but I > don't see anywhere in either the Admin UI or the User

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-10 Thread Will Dennis
Hi Simone, Sorry but I'm just getting back to this... Not sure where/how one might implement the hook you have indicated... It looks to be VM-specific, but I don't see anywhere in either the Admin UI or the User portal UI to set such a parameter... Can you give me instructions on how to

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-09 Thread Simone Tiraboschi
On Sat, May 7, 2016 at 11:06 AM, Yaniv Kaul wrote: > > > On Fri, May 6, 2016 at 11:07 PM, Will Dennis wrote: >> >> That’s in iptables, right? I have iptables disabled on my oVirt nodes... > > > No, it's a L2 filter libvirt sets up, I believe using

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-07 Thread Yaniv Kaul
On Fri, May 6, 2016 at 11:07 PM, Will Dennis wrote: > That’s in iptables, right? I have iptables disabled on my oVirt nodes... > No, it's a L2 filter libvirt sets up, I believe using ebtables. Y. > > > *From:* Yaniv Kaul [mailto:yk...@redhat.com] > *Sent:* Friday, May

Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-06 Thread Will Dennis
That’s in iptables, right? I have iptables disabled on my oVirt nodes... From: Yaniv Kaul [mailto:yk...@redhat.com] Sent: Friday, May 06, 2016 3:50 PM To: Will Dennis Subject: Re: [ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM Long shot - you need to disable the

[ovirt-users] virt-in-virt problem: DHCP failing for a container in a oVirt VM

2016-05-06 Thread Will Dennis
Hi all, Have an interesting problem - I am running a VM in oVirt that is running Proxmox VE 4.1 OS, which I have spun up a container on. The container is set for DHCP, and I have verified that it is sending Discover packets as normal, and that these packets are making it out of the Proxmox VM