Re: [ovirt-users] xml config file being used in ovirt different from virsh?

2016-08-14 Thread Yaniv Dary
You should only use the management to keep changes.
We added network filtering options in 4.0.
There is also a option of VDSM hook for things that are not supported via
the manager.

Yaniv Dary
Technical Product Manager
Red Hat Israel Ltd.
34 Jerusalem Road
Building A, 4th floor
Ra'anana, Israel 4350109

Tel : +972 (9) 7692306
8272306
Email: yd...@redhat.com
IRC : ydary


On Sat, Aug 13, 2016 at 12:15 AM, Bill Bill <jax2...@outlook.com> wrote:

> It seems like when starting the VM through the oVirt dashboard, it’s
> either overwriting or removing those values.
>
>
>
> *From: *Bill Bill <jax2...@outlook.com>
> *Sent: *Friday, August 12, 2016 3:04 PM
> *To: *users@ovirt.org
> *Subject: *xml config file being used in ovirt different from virsh?
>
>
>
> I have a VM with network filtering enabled, specifically the clean-traffic
> filter.
>
>
>
> Through virsh, I modify the configuration to reflect changes like this:
>
>
>
>  
>
> 
>
> 
>
>   
>
>
>
> This only allows those two specified IP’s to communicate on the VM. I’ve
> defined the xml through virsh.
>
>
>
> Now, if I start the VM directly through virsh, those rules apply and work
> correctly. I can add any other random IP from the same subnet and it does
> not work, as expected. Only the two Ip’s specified above will respond.
>
>
>
> This unfortunately, makes the VM appear to be down from with the ovirt
> dashboard if it’s started manually through virsh.
>
>
>
> If I edit the machine through virsh but do not start it and then go onto
> oVirt to start the VM, it seems the configuration is not loaded – does
> oVirt load a different configuration file other than
> /etc/libvirt/qemu/machine.xml?
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] xml config file being used in ovirt different from virsh?

2016-08-12 Thread Bill Bill
It seems like when starting the VM through the oVirt dashboard, it’s either 
overwriting or removing those values.

From: Bill Bill
Sent: Friday, August 12, 2016 3:04 PM
To: users@ovirt.org
Subject: xml config file being used in ovirt different from virsh?

I have a VM with network filtering enabled, specifically the clean-traffic 
filter.

Through virsh, I modify the configuration to reflect changes like this:

 


  

This only allows those two specified IP’s to communicate on the VM. I’ve 
defined the xml through virsh.

Now, if I start the VM directly through virsh, those rules apply and work 
correctly. I can add any other random IP from the same subnet and it does not 
work, as expected. Only the two Ip’s specified above will respond.

This unfortunately, makes the VM appear to be down from with the ovirt 
dashboard if it’s started manually through virsh.

If I edit the machine through virsh but do not start it and then go onto oVirt 
to start the VM, it seems the configuration is not loaded – does oVirt load a 
different configuration file other than /etc/libvirt/qemu/machine.xml?
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] xml config file being used in ovirt different from virsh?

2016-08-12 Thread Bill Bill
I have a VM with network filtering enabled, specifically the clean-traffic 
filter.

Through virsh, I modify the configuration to reflect changes like this:

 


  

This only allows those two specified IP’s to communicate on the VM. I’ve 
defined the xml through virsh.

Now, if I start the VM directly through virsh, those rules apply and work 
correctly. I can add any other random IP from the same subnet and it does not 
work, as expected. Only the two Ip’s specified above will respond.

This unfortunately, makes the VM appear to be down from with the ovirt 
dashboard if it’s started manually through virsh.

If I edit the machine through virsh but do not start it and then go onto oVirt 
to start the VM, it seems the configuration is not loaded – does oVirt load a 
different configuration file other than /etc/libvirt/qemu/machine.xml?
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users