[SOGo] BTS activities for Thursday, July 07 2016

2016-07-07 Thread SOGo reporter
Title: BTS activities for Thursday, July 07 2016





  
BTS Activities

  Home page: http://www.sogo.nu/bugs
  Project: SOGo
  For the period covering: Thursday, July 07 2016

  
  
idlast updatestatus (resolution)categorysummary
	
	
	  
	
2921
	2016-07-07 03:19:55
	updated (open)
	with SOGo
	ADD Read Only fonction
	
	  
	
3760
	2016-07-07 23:23:39
	assigned (reopened)
	Packaging (Debian)
	Not published package sogo in binary-amd64/Packages
	
	  
	
  
  


-- users@sogo.nuhttps://inverse.ca/sogo/lists

[SOGo] Send As

2016-07-07 Thread Keith Williams

Hi all,

Sorry if this has been asked before, but does Sogo v3 support Outlook 
2013/6 "Send on behalf of", or "Send As" another user via Active Sync?


Similar to this described here:

https://technet.microsoft.com/en-us/library/aa998291(v=exchg.80).aspx

Appreciate any assistance.

Regards,

--

Keith

--
users@sogo.nu
https://inverse.ca/sogo/lists


[SOGo] Error in autocomplete when sending email from webmail - Bug #3513 e #3573

2016-07-07 Thread Marco

Hi,

we found today the problem causing the bug reported #3513 e #3573.

Composing a new email from SOGo webmail version 3, when you try to write 
down the email address in the "To" field, the email address is wrongly 
completed when you press '@', just like you press 'Return' instead. 
This issue does not let you write a complete email address not included 
in address book.


The issue happens in the following environment:

- Mac OS X

- Browser Safari or Chrome

- Italian keyboard layout (the '@' character and ';' character have the 
same keycode 186)



The workaround we found is the following.

In file:

WebServerResources/js/vendor/angular-material.min.js

change row 25316:

if (this.separatorKeys.indexOf(event.keyCode) !== -1)

in

if (this.separatorKeys.indexOf(event.keyCode) !== -1 && 
!(navigator.appVersion.indexOf("Mac") != -1 && event.keyCode == 186 && 
event.altKey)) {



In other words, it is an exception into angular material framework.


I am aware that this is not an elegant solution, but it is another step 
beyond to understand and fix the issue.



Maybe the 'separatorKeys' list does not include the alt+186 combination 
as an exception for completing the email address?


Is it possible to fix the code in order to include this case?


Thank you

Marco




--
users@sogo.nu
https://inverse.ca/sogo/lists


[SOGo] Forwarding Appointment with additional Text

2016-07-07 Thread Marc Patermann

Hi,

this is more a Lightning issue I think, but:

when someone forwards a appointment mail in Thunderbird and adds some 
text, the additional text is not displayed at the recipient side. The 
calendar attachment hides all the additional Text.


Is there something one can do about it?
(Other than disable the inline display of attachments at all which 
disables the appointment handling in TB/Lightning also.)


The funny thing is, that only happens when the calendar item is 
available in a synced and subscribed calendar.



Marc
--
users@sogo.nu
https://inverse.ca/sogo/lists


[SOGo] [urgent] SOGo object not found index

2016-07-07 Thread Pablo Abelenda
Hi,

I've been hit by this issue. My SOGo instance stopped to work. It shows

object not found: SOGo => index

Logs are full of:

{{{
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find
MainUIProduct class!
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find locale for
language: Dutch
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find
MainUIProduct class!
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find locale for
language: French
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find
MainUIProduct class!
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find locale for
language: Spanish
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find
MainUIProduct class!
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find locale for
language: Italian
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find
MainUIProduct class!
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find locale for
language: Portuguese
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find
MainUIProduct class!
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find locale for
language: ptBR
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find
MainUIProduct class!
Jul 07 09:17:26 sogod [12176]: [ERROR] [we-rm] did not find locale for
language: English
Jul 07 09:17:26 sogod [12176]: 192.168.10.81, 192.168.10.13 "GET
/SOGo/index HTTP/1.1" 404 34/0 0.069 - - 912K
}}}

Any clues?

-- 
Pablo Abelenda



signature.asc
Description: OpenPGP digital signature


Re: [SOGo] Package gnustep-base-libs-1.24.6-6.el7.centos.x86_64.rpm is not signed - CentOS 7

2016-07-07 Thread "J. Echter"

Am 04.07.2016 um 21:22 schrieb Patrice Levesque (pleves...@inverse.ca):



i wanted to try out SOGo V3 on CentOS 7, but yum denies the install
with above error.


Just updated the CentOS 7 repo, adding signatures; let me know if the
newer packages still complain.

(I would suggest a `yum clean all` first, to ensure local copies of
packages fetched pre-signatures are not playing tricks on you.)





Hi,

this time i had no complains from yum.

Thank you!
--
users@sogo.nu
https://inverse.ca/sogo/lists