Re: [SOGo] sogosync issues - beginners trouble :)

2012-09-22 Thread Rémi Letot
Christian Rößner c...@roessner-network-solutions.com writes:

 I am playing around with sogosync for the first time. Therefor I cloned the 
 current git and modified all config files as described in the online 
 documentation.
 
 So far I get some conversation between my iPhone 4S and the sogosync stuff.
 
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net]  Start
 16/09/2012 11:42:09 [27472] [ INFO]
 [de10...@srvint.net] Version='SVN
 checkout' method='POST' from='5.43.170.134' cmd='FolderSync'
 getUser='de10...@srvint.net'
 devId='ApplDNQGN393DTDF' devType='iPhone'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Used timezone 
 'Europe/Berlin'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/combined/combined.php'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/caldav.php'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/carddav.php'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/imap.php'
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] Combined 3 
 backends loaded.
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] 
 Request::ProcessHeaders() ASVersion: 2.5
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] 
 AuthenticationRequiredException: Access denied. Please send authorisation 
 information - code: 0
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] User-agent: 
 'Apple-iPhone4C1/902.206'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] 
 ZPush::PrintZPushLegal()
 16/09/2012 11:42:09 [27472] [ WARN] [de10...@srvint.net] IP: 5.43.170.134 
 failed to authenticate user 'de10...@srvint.net'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] TopCollector(): 
 Initialized mutexid Resource id #120 and memid Resource id #121.
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net]  End
 

 I am completely stuck. It is not an TLS issue as I see data in the log files. 
 If the handshake would have fallen, I would see nothing. So the script itself 
 is working.

 I changed my username and added it to the config.php user array. I created 
 the file /var/log/z-push/croessner.log and gave correct permissions (I 
 think). But nothing is written to the log file.

 Even in the z-push.log file itself, I can not see any backend activity. As I 
 looked into the backend php files, shouldn't there be any lines concerning 
 smething like Logon-XYZ or so?

 Can someone help me? What information is required?

Hello,

to test it without the iphone interferring, can you try with a browser ?

https://sogo.mydomain.com/Microsoft-Server-ActiveSync

Your browser should ask for a login/password, and then show a page with
Z-Push - Open Source ActiveSync and the message GET not supported.

In my z-push.log, I see my user authenticating to each backend
separately, and then Combined-Logon() success

Note that I disabled the imap part in the combined backend, so this
might make a difference, but anyway testing with a browser might help
spot the troublemaker.

HTH,
-- 
Rémi

-- 
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] sogosync issues - beginners trouble :)

2012-09-17 Thread Christian Rößner
Hi,

 I am playing around with sogosync for the first time. Therefor I cloned the 
 current git and modified all config files as described in the online 
 documentation.
 
 So far I get some conversation between my iPhone 4S and the sogosync stuff.
 
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net]  Start
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] Version='SVN 
 checkout' method='POST' from='5.43.170.134' cmd='FolderSync' 
 getUser='de10...@srvint.net' devId='ApplDNQGN393DTDF' devType='iPhone'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Used timezone 
 'Europe/Berlin'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/combined/combined.php'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/caldav.php'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/carddav.php'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/imap.php'
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] Combined 3 backends 
 loaded.
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] 
 Request::ProcessHeaders() ASVersion: 2.5
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] 
 AuthenticationRequiredException: Access denied. Please send authorisation 
 information - code: 0
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] User-agent: 
 'Apple-iPhone4C1/902.206'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] 
 ZPush::PrintZPushLegal()
 16/09/2012 11:42:09 [27472] [ WARN] [de10...@srvint.net] IP: 5.43.170.134 
 failed to authenticate user 'de10...@srvint.net'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] TopCollector(): 
 Initialized mutexid Resource id #120 and memid Resource id #121.
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net]  End
 
I dived a little bit deeper. It seems, something does not work with TLS. Can 
somebody confirm this from my tshark output (attached)? What would I have to 
change in Apache (Ubuntu 12.04) to get the iPhone working? It seems that the 
Exchange connection works differently than regular https. If I open Safari and 
go to https://www.roessner-net.de everything works as expected. I have 
installed the CA on the device. So I guess it has to do with ciphers and that 
the server and the device can not agree to a common cipher spec.

Thanks in advance

-- 
users@sogo.nu
https://inverse.ca/sogo/lists  0.00 5.43.170.134 - 193.239.107.39 TCP 78 52824  https [SYN] Seq=0 
Win=65535 Len=0 MSS=1452 WS=16 TSval=182681208 TSecr=0 SACK_PERM=1
  0.39 193.239.107.39 - 5.43.170.134 TCP 74 https  52824 [SYN, ACK] Seq=0 
Ack=1 Win=14480 Len=0 MSS=1460 SACK_PERM=1 TSval=535521934 TSecr=182681208 WS=16
  0.052620 5.43.170.134 - 193.239.107.39 TCP 60 52824  https [RST] Seq=1 
Win=0 Len=0
  3.043802 5.43.170.134 - 193.239.107.39 TCP 78 52830  https [SYN] Seq=0 
Win=65535 Len=0 MSS=1452 WS=16 TSval=182684208 TSecr=0 SACK_PERM=1
  3.043844 193.239.107.39 - 5.43.170.134 TCP 74 https  52830 [SYN, ACK] Seq=0 
Ack=1 Win=14480 Len=0 MSS=1460 SACK_PERM=1 TSval=535522695 TSecr=182684208 WS=16
  3.105320 5.43.170.134 - 193.239.107.39 TCP 66 52830  https [ACK] Seq=1 
Ack=1 Win=132480 Len=0 TSval=182684315 TSecr=535522695
  3.122786 5.43.170.134 - 193.239.107.39 SSL 252 Client Hello
  3.122817 193.239.107.39 - 5.43.170.134 TCP 66 https  52830 [ACK] Seq=1 
Ack=187 Win=15552 Len=0 TSval=535522715 TSecr=182684325
  3.123353 193.239.107.39 - 5.43.170.134 TLSv1.2 2946 Server Hello
  3.123392 193.239.107.39 - 5.43.170.134 TLSv1.2 668 Certificate, Server Hello 
Done
  3.189791 5.43.170.134 - 193.239.107.39 TCP 66 52830  https [ACK] Seq=187 
Ack=2881 Win=129600 Len=0 TSval=182684391 TSecr=535522715
  3.191879 5.43.170.134 - 193.239.107.39 TCP 66 52830  https [ACK] Seq=187 
Ack=3483 Win=128992 Len=0 TSval=182684393 TSecr=535522715
  3.333859 5.43.170.134 - 193.239.107.39 TLSv1.2 333 Client Key Exchange
  3.336326 5.43.170.134 - 193.239.107.39 TLSv1.2 72 Change Cipher Spec
  3.342466 5.43.170.134 - 193.239.107.39 TLSv1.2 151 Encrypted Handshake 
Message
  3.345788 193.239.107.39 - 5.43.170.134 TCP 66 https  52830 [ACK] Seq=3483 
Ack=545 Win=16624 Len=0 TSval=535522771 TSecr=182684490
  3.346037 193.239.107.39 - 5.43.170.134 TLSv1.2 157 Change Cipher Spec, 
Encrypted Handshake Message
  3.490472 5.43.170.134 - 193.239.107.39 TCP 66 52830  https [ACK] Seq=545 
Ack=3574 Win=130976 Len=0 TSval=182684669 TSecr=535522771
  3.548270 5.43.170.134 - 193.239.107.39 TLSv1.2 439 Application Data
  3.566518 193.239.107.39 - 5.43.170.134 TLSv1.2 950 Application Data, 
Application Data, Application Data, Application Data
  3.692505 5.43.170.134 - 193.239.107.39 TCP 66 52830  https [ACK] Seq=918 
Ack=4458 Win=130176 Len=0 TSval=182684866 TSecr=535522826
  3.735983 5.43.170.134 - 193.239.107.39 TLSv1.2 599 

Re: [SOGo] sogosync issues - beginners trouble :)

2012-09-17 Thread Christian Rößner
 I am playing around with sogosync for the first time. Therefor I cloned the 
 current git and modified all config files as described in the online 
 documentation.
 
 So far I get some conversation between my iPhone 4S and the sogosync stuff.
 
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net]  Start
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] Version='SVN 
 checkout' method='POST' from='5.43.170.134' cmd='FolderSync' 
 getUser='de10...@srvint.net' devId='ApplDNQGN393DTDF' devType='iPhone'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Used timezone 
 'Europe/Berlin'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/combined/combined.php'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/caldav.php'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/carddav.php'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
 file: '/var/www/sogosync/backend/imap.php'
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] Combined 3 backends 
 loaded.
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] 
 Request::ProcessHeaders() ASVersion: 2.5
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] 
 AuthenticationRequiredException: Access denied. Please send authorisation 
 information - code: 0
 16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] User-agent: 
 'Apple-iPhone4C1/902.206'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] 
 ZPush::PrintZPushLegal()
 16/09/2012 11:42:09 [27472] [ WARN] [de10...@srvint.net] IP: 5.43.170.134 
 failed to authenticate user 'de10...@srvint.net'
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] TopCollector(): 
 Initialized mutexid Resource id #120 and memid Resource id #121.
 16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net]  End
 

I am completely stuck. It is not an TLS issue as I see data in the log files. 
If the handshake would have fallen, I would see nothing. So the script itself 
is working.

I changed my username and added it to the config.php user array. I created the 
file /var/log/z-push/croessner.log and gave correct permissions (I think). But 
nothing is written to the log file.

Even in the z-push.log file itself, I can not see any backend activity. As I 
looked into the backend php files, shouldn't there be any lines concerning 
smething like Logon-XYZ or so?

Can someone help me? What information is required?

Thanks in advance

-Christian Rößner

---
Bachelor of Science Informatik
Erlenwiese 14, 36304 Alsfeld
T: +49 6631 78823400, F: +49 6631 78823409, M: +49 176 93118939
USt-IdNr.: DE225643613, http://www.roessner-network-solutions.com

-- 
users@sogo.nu
https://inverse.ca/sogo/lists

[SOGo] sogosync issues - beginners trouble :)

2012-09-16 Thread Christian Rößner
Hi,

I am playing around with sogosync for the first time. Therefor I cloned the 
current git and modified all config files as described in the online 
documentation.

So far I get some conversation between my iPhone 4S and the sogosync stuff.

16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net]  Start
16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] Version='SVN checkout' 
method='POST' from='5.43.170.134' cmd='FolderSync' getUser='de10...@srvint.net' 
devId='ApplDNQGN393DTDF' devType='iPhone'
16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Used timezone 
'Europe/Berlin'
16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
file: '/var/www/sogosync/backend/combined/combined.php'
16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
file: '/var/www/sogosync/backend/caldav.php'
16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
file: '/var/www/sogosync/backend/carddav.php'
16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] Including backend 
file: '/var/www/sogosync/backend/imap.php'
16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] Combined 3 backends 
loaded.
16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] 
Request::ProcessHeaders() ASVersion: 2.5
16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] 
AuthenticationRequiredException: Access denied. Please send authorisation 
information - code: 0
16/09/2012 11:42:09 [27472] [ INFO] [de10...@srvint.net] User-agent: 
'Apple-iPhone4C1/902.206'
16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] 
ZPush::PrintZPushLegal()
16/09/2012 11:42:09 [27472] [ WARN] [de10...@srvint.net] IP: 5.43.170.134 
failed to authenticate user 'de10...@srvint.net'
16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net] TopCollector(): 
Initialized mutexid Resource id #120 and memid Resource id #121.
16/09/2012 11:42:09 [27472] [DEBUG] [de10...@srvint.net]  End

But unfortunately authentication fails and I do not understand why. On my mail 
server, I see something like this:

Sep 16 11:38:37 mx0 dovecot: imap-login: Login: user=de10...@srvint.net, 
method=PLAIN, rip=5.43.170.134, lip=88.198.80.230, mpid=24820, TLS, 
session=Vm3pa87JpQAFK6qG

Currently I have a working Cal/CardDAC and mail account on the device. I added 
an Exchange account and got all check marks. But then after some seconds, the 
password dialog pops up and tells me my password was incorrect. Which service 
is used for authentication? Is it the IMAP-server or SOGo? Does the device 
contact all those services by itself or is authentication always be done from 
sogosync and I should see login attempts from my web server? If the latter is 
the case, then neither Mail nor Ca*DAV seems to work here.

I use https/imap+tls all over. Could this be a problem? I replaced /notls/norsh 
with /tls/norsh. Do I need to add certs CA stuff somewhere? Maybe things fail, 
because SSL fails?

Thanks in advance

-Christian Rößner

---
Bachelor of Science Informatik
Erlenwiese 14, 36304 Alsfeld
T: +49 6631 78823400, F: +49 6631 78823409, M: +49 176 93118939
USt-IdNr.: DE225643613, http://www.roessner-network-solutions.com

-- 
users@sogo.nu
https://inverse.ca/sogo/lists