Packet misses in Tomcat

2014-01-06 Thread Divyaprakash Y
Hi, I have been experiencing missing packets during my application testing using Tomcat Server. If someone can help me to identify what is happening, it will be of great value. Issue: Few packets do not reach the application servlet but tomcat receives them. The missing packets reach the HTTP

Re: Running native JNI calls in parallel from different Tomcat threads

2014-01-06 Thread Daniel Mikusa
On Jan 5, 2014, at 8:23 PM, Jasmeet Chhabra jasm...@chhabra-inc.com wrote: Hi, I have a Tomcat server that receives many web requests in parallel. The web requests make a native call using JNI to my library. These calls are long running (400 ms each call). What I have noticed is that even

Re: Packet misses in Tomcat

2014-01-06 Thread chris derham
Issue: Few packets do not reach the application servlet but tomcat receives them. The missing packets reach the HTTP layer and thereafter they disappear. This issue is not frequent but occasionally consistent. For the POSTs of missing packet I am not able to find the entry in

RE: Packet misses in Tomcat

2014-01-06 Thread Divyaprakash Y
Issue: Few packets do not reach the application servlet but tomcat receives them. The missing packets reach the HTTP layer and thereafter they disappear. This issue is not frequent but occasionally consistent. For the POSTs of missing packet I am not able to find the entry in

Re: Packet misses in Tomcat

2014-01-06 Thread André Warnier
Divyaprakash Y wrote: Issue: Few packets do not reach the application servlet but tomcat receives them. The missing packets reach the HTTP layer and thereafter they disappear. This issue is not frequent but occasionally consistent. For the POSTs of missing packet I am not able to find the

Re: JSVC error

2014-01-06 Thread vicky007aggarwal
Can somebody please suggest that how can we integrate jsvc with PSI PROBE application in order to have restart functionality Thanks, Vicky On Jan 4, 2014, at 10:16 AM, vicky vicky007aggar...@yahoo.co.in wrote: I'm able to build the jsvc successfully from

RE: Packet misses in Tomcat

2014-01-06 Thread Divyaprakash Y
Issue: Few packets do not reach the application servlet but tomcat receives them. The missing packets reach the HTTP layer and thereafter they disappear. This issue is not frequent but occasionally consistent. For the POSTs of missing packet I am not able to find the entry in

Re: rc-10 bug?

2014-01-06 Thread Peter
Thanks to an email from Martin, I had a strong indicator of where to look. I checked out tomcat 8 from trunk and  validated in eclipse in debug mode. (FYI build.properties.default is broken due to missing commons pool, had to tweak a bit). From webappclassloader.java snippet below (line 737),

RE: Packet misses in Tomcat

2014-01-06 Thread Divyaprakash Y
Issue: Few packets do not reach the application servlet but tomcat receives them. The missing packets reach the HTTP layer and thereafter they disappear. This issue is not frequent but occasionally consistent. For the POSTs of missing packet I am not able to find the entry in