Re: ISAPI and IIS 10 Logging Issue

2017-09-01 Thread tomcat
On 01.09.2017 22:21, Thomas, Michael wrote: All, When using the ISAPI Handler Mapping in IIS 10 on Windows 2016, the IIS logs are not identifying the URI Stem (cs-uri-stem) and URI Query (cs-uri-query) as expected. For EVERY request that the handler processes (e.g. .cfm), the cs-uri-stem

ISAPI and IIS 10 Logging Issue

2017-09-01 Thread Thomas, Michael
All, When using the ISAPI Handler Mapping in IIS 10 on Windows 2016, the IIS logs are not identifying the URI Stem (cs-uri-stem) and URI Query (cs-uri-query) as expected. For EVERY request that the handler processes (e.g. .cfm), the cs-uri-stem records an entry as

Re: Apache 7.0.81 - Can no longer use non-canonical paths in extraResourcePaths of VirtualDirContext

2017-09-01 Thread Mark Thomas
On 31/08/17 17:03, Constantin Erckenbrecht wrote: > Hi, > > A change in 7.0.81/7.0.80 changed the File resolution in VirtualDirContext. > > In 7.0.79 and before it was possible to use paths with /../ or any other > non-canonical path. This was particularly useful when using placeholders > that

Re: jre leak prevention

2017-09-01 Thread Mark Thomas
On 01/09/17 11:25, Johan Compagner wrote: > We tested it and the winner is: > > className="org.apache.catalina.core.JreMemoryLeakPreventionListener" > urlCacheProtection="false" /> > > i had my bets on the xmlParsingProtection but that wasn't it... When I took a look through the

Re: jre leak prevention

2017-09-01 Thread Johan Compagner
On 1 September 2017 at 11:10, Mark Thomas wrote: > On 01/09/17 10:03, Johan Compagner wrote: > > Hi, > > > > i got reports that running jasper reports is suddenly a lot slower when > > deployed.. > > (compared what he uses in developer) > > Running a report was 0-2 seconds in

Re: Performance issue 8.5.20 (metaspace related?)

2017-09-01 Thread Suvendu Sekhar Mondal
> Profiling the code I have been able to find the cause of the big metaspace > garbage… > Due to a bug, we were not caching remote interfaces when connecting to jboss > from the web sites. Other client kind was ok. > Fixed this problem today, it’s a few hours that the system is running fine. >

Re: jre leak prevention

2017-09-01 Thread Mark Thomas
On 01/09/17 10:03, Johan Compagner wrote: > Hi, > > i got reports that running jasper reports is suddenly a lot slower when > deployed.. > (compared what he uses in developer) > Running a report was 0-2 seconds in its developer but at least 10 seconds > when running deployed. > > We tracked it

jre leak prevention

2017-09-01 Thread Johan Compagner
Hi, i got reports that running jasper reports is suddenly a lot slower when deployed.. (compared what he uses in developer) Running a report was 0-2 seconds in its developer but at least 10 seconds when running deployed. We tracked it down, in developer the listener: was not in the