Re: wicket 6.3.0 WeldDecorator

2013-06-29 Thread Piratenvisier
Thanks martin with jetty version 8.1.3.v20120416 its O.K. with jetty version 9.0.2.v20130417 same error Am 24.06.2013 13:48, schrieb Martin Grigorov: You need to use Jetty 8.x On Mon, Jun 24, 2013 at 2:44 PM, Piratenvisier hansheinrichbr...@yahoo.dewrote: Hi, Martin error is also in 6.8.0:

Re: wicket and flow

2013-06-29 Thread Piratenvisier
Hello Martin, a central class in Webflow is PageFlowRequestCycleProcessor: public class PageFlowRequestCycleProcessor extends WebRequestCycleProcessor { /** {@inheritDoc} */ @Override public IRequestTarget_*resolve*_(RequestCycle requestCycle, RequestParameters

Re: DI Through Constructors w/Wicket

2013-06-29 Thread William Speirs
I'm just getting to this now... weekend coder. @MartinGrigorov - this looks exactly like what I want, or parts of it at least... I'll certainly check it out. And you're right, I shouldn't be so skeptical, you Wicket folks seem to always come through with some library when I ask a question :-)

Re: clustering and failover

2013-06-29 Thread William Speirs
Another consideration is if you're using any authentication that relies upon the tomcat session, then bouncing to another box (if you're doing round-robin load balanced) would mean your users will have to reauthenticate. Been there, still have the bite marks from that :-) Bill- On Fri, Jun 28,