Re: 7.10.0 -> 7.11.0 error with WicketTester

2018-12-03 Thread Martin Grigorov
Wicket Bootstrap 0.10.18 has been released! On Mon, Dec 3, 2018 at 3:33 PM Francesco Chicchiriccò wrote: > On 2018/12/03 13:29:37, Martin Grigorov wrote: > > Yes, > > > > I will do it later today! > > Great, thank you. > > > On Mon, Dec 3, 2018 at 3:25 PM Francesco Chicchiriccò < >

Re: Wicket and Jersey Integration

2018-12-03 Thread Илья Нарыжный
Martin, Thank you - we were considering this library previously, but it's not JAX-RS compatible and don't have cool features for security/marshaling/etc. And that's why we used Jersey. But this time needed integration is so deep, so we can't keep 2 these components separately. Ernesto, Yes - I

Re: Using the summernote rich text editor with Wicket

2018-12-03 Thread Tobias Soloschenko
Please have a look at the javascript console of the browser (if there are any errors) and if the CSS files / JS files are present on your site. There were no recent changes and the files are within the code base of wicket bootstrap as I remember correctly. kind regards Tobias > Am 03.12.2018

Re: Using the summernote rich text editor with Wicket

2018-12-03 Thread dylanbozeman
I meant on my own site. I've got summernote and Wicket bootstrap but for some reason the WYSIWYG isn't displaying. Just the TextArea is showing up. -- Sent from: http://apache-wicket.1842946.n4.nabble.com/Users-forum-f1842947.html

Re: Using the summernote rich text editor with Wicket

2018-12-03 Thread Tobias Soloschenko
Hello, for me it is showing up: https://wb7.teliclab.info/summernote You have to use Wicket bootstrap and summernote. kind regards Tobias > Am 03.12.2018 um 19:28 schrieb dylanbozeman : > > Any idea why when I implement the code you provided there I don't get the > summernote Editor

Re: Using the summernote rich text editor with Wicket

2018-12-03 Thread dylanbozeman
Any idea why when I implement the code you provided there I don't get the summernote Editor displaying? Page loads find, TextArea component is showing up, but the summernote Editor just isn't there... -- Sent from: http://apache-wicket.1842946.n4.nabble.com/Users-forum-f1842947.html

Re: Using the summernote rich text editor with Wicket

2018-12-03 Thread dylanbozeman
Thank you. I'll look into these. -- Sent from: http://apache-wicket.1842946.n4.nabble.com/Users-forum-f1842947.html - To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org For additional commands, e-mail:

Re: Using the summernote rich text editor with Wicket

2018-12-03 Thread Francois Meillet
Hi Dylan, Have a look at https://github.com/l0rdn1kk0n/wicket-bootstrap/blob/wicket-7.x/bootstrap-samples/src/main/java/de/agilecoders/wicket/samples/pages/SummernotePage.java

Using the summernote rich text editor with Wicket

2018-12-03 Thread dylanbozeman
I am fairly new to Wicket and attempting to integrate summernote from bootstrap seen here: http://coding.teliclab.info/wicket-7.x/summernote I can't find anywhere on this page where an example java code and html markup are shown. I'm pretty much in the dark as far as configuring it. Does anyone

Re: 7.10.0 -> 7.11.0 error with WicketTester

2018-12-03 Thread Francesco Chicchiriccò
On 2018/12/03 13:29:37, Martin Grigorov wrote: > Yes, > > I will do it later today! Great, thank you. > On Mon, Dec 3, 2018 at 3:25 PM Francesco Chicchiriccò > wrote: > > > On 2018/12/03 13:08:26, Martin Grigorov wrote: > > > Check whether there is only one version of Wicket in your

Re: 7.10.0 -> 7.11.0 error with WicketTester

2018-12-03 Thread Martin Grigorov
Yes, I will do it later today! On Mon, Dec 3, 2018 at 3:25 PM Francesco Chicchiriccò wrote: > On 2018/12/03 13:08:26, Martin Grigorov wrote: > > Check whether there is only one version of Wicket in your classpath, > maybe > > some dependency (like Wicket-Bootstrap) brings something else than

Re: 7.10.0 -> 7.11.0 error with WicketTester

2018-12-03 Thread Francesco Chicchiriccò
On 2018/12/03 13:08:26, Martin Grigorov wrote: > Check whether there is only one version of Wicket in your classpath, maybe > some dependency (like Wicket-Bootstrap) brings something else than 7.11.0 > in the classpath. Nice catch Martin, that was it. For the moment, I'll exclude as follows:

Re: 7.10.0 -> 7.11.0 error with WicketTester

2018-12-03 Thread Martin Grigorov
Check whether there is only one version of Wicket in your classpath, maybe some dependency (like Wicket-Bootstrap) brings something else than 7.11.0 in the classpath. On Mon, Dec 3, 2018 at 3:06 PM Francesco Chicchiriccò wrote: > On 2018/12/03 12:57:00, Maxim Solodovnik wrote: > > The method

Re: 7.10.0 -> 7.11.0 error with WicketTester

2018-12-03 Thread Francesco Chicchiriccò
On 2018/12/03 12:57:00, Maxim Solodovnik wrote: > The method is here > https://github.com/apache/wicket/blob/wicket-7.x/wicket-request/src/main/java/org/apache/wicket/request/Url.java#L1123 > In all branches ... ..so my JDK must be lying? :-) > On Mon, 3 Dec 2018 at 19:50, Francesco

Re: 7.10.0 -> 7.11.0 error with WicketTester

2018-12-03 Thread Maxim Solodovnik
The method is here https://github.com/apache/wicket/blob/wicket-7.x/wicket-request/src/main/java/org/apache/wicket/request/Url.java#L1123 In all branches ... On Mon, 3 Dec 2018 at 19:50, Francesco Chicchiriccò wrote: > Hi all, > after upgrading from 7.10.0 to 7.11.0, I receive the following

7.10.0 -> 7.11.0 error with WicketTester

2018-12-03 Thread Francesco Chicchiriccò
Hi all, after upgrading from 7.10.0 to 7.11.0, I receive the following exception when executing tests via Wicket Tester: java.lang.NoSuchMethodError: org.apache.wicket.request.Url.setContextRelative(Z)V at

Re: Wicket 6.x -> Wicket 8.x extensions NestedTree expand fails ( Components can no longer be added)

2018-12-03 Thread nino martinez wael
I've debugged a lot further. But still unable to pinpoint it.. For now I've switched to rendering the full page instead, which of course works. We are a couple of things in conjunction with TREE, like wicket jquery ui draggable and droppable.. We also have a custom loading mechanism that pops a