Re: Issue with FileUpload.writeToTempFile()

2008-11-12 Thread Steve Swinsburg
Its just the line endings that are causing the issues with the  
formatting. There is an app called FLIP (http://ccrma-www.stanford.edu/~craig/utility/flip/ 
) which I just used on both files and it reformatted with proper Unix  
file endings (it converts between all variants).


I've attached the formatted files to the Jira as well.


cheers,
Steve




On 12 Nov 2008, at 07:58, Johan Compagner wrote:


If you use eclipse you should use the project specific format we have
defined for it. You should have a .settings dir or something like
that. Look at the wicket project preferences and look what formatter
you use there

On 11/12/08, Bruno Borges [EMAIL PROTECTED] wrote:

sure igor... :-) your opinion is more than welcome.

about the binary search specially. I will keep that in mind for  
future codes

:-) (and not just for wicket)

but, about the formatting, I really don't know what's going on. I'm  
using
Ganymede and I've been applying the EclipseCodeFormat.xml without  
success.
Whenever I save  the file or just format it manually, it does that  
with the
code. Sorry about that. I will disable it for future patches and  
will try to

format by hand. At least, the whole code won't be messed up.

and about the name of that method, I never would feel sad if you  
decide to

change it, really. :-) I took the first shot so I had  to come with
something, but there's no reason to not change it.

with everything said, I'll try to improve the quality (or the lack of
premature quality) of submited patches... :-D

thanks for your comments,
Bruno Borges
blog.brunoborges.com.br
+55 21 76727099

The glory of great men should always be
measured by the means they have used to
acquire it.
- Francois de La Rochefoucauld


On Tue, Nov 11, 2008 at 9:25 PM, Igor Vaynberg
[EMAIL PROTECTED]wrote:


hi bruno.

first off let me say that we really appreciate the patches...

but :) i would like to make a couple of small comments:

it would be nice if you used the same formatting settings as us.  
your

patches contain 90% noise which makes them hard to read.

try to use simpler names. normalizeFilename doesnt really say  
much.

what is normalize mean.

and this is the most important one, do not prematurely optimize and
know when to optimize. this method is called extremely rarely so the
requirement of maintaining the array ordered vs the speed  
improvement
doesnt make sense - too much of a maintenance headache, easy to  
make a

mistake, etc. further, in this particular case, a binary search is
slower then a linear search by, i would venture, about 5x.

thanks,

-igor

On Tue, Nov 11, 2008 at 11:03 AM,  [EMAIL PROTECTED] wrote:

JIRA issue created - *with patch included*

https://issues.apache.org/jira/browse/WICKET-1930

cheers,
Bruno

On Nov 11, 2008 4:11pm, Igor Vaynberg [EMAIL PROTECTED]  
wrote:


please open a jira issue.



-igor



On Tue, Nov 11, 2008 at 1:59 AM, Lauri Piispanen - Conmio Ltd

wrote:


Hi all,







I seem to be having a small portability glitch with


FileUpload.writeToTempFile(). Looking at the source code it  
seems to

be



using item.getFieldName(), which on my page translates to



filefields:1:upload. Windows doesn't really like colons, which
gives


me



the following stacktrace:







...snip until root cause...







Caused by: java.io.IOException: The parameter is incorrect



at java.io.WinNTFileSystem.createFileExclusively(Native Method)



at java.io.File.checkAndCreate(File.java:1704)



at java.io.File.createTempFile(File.java:1793)



at java.io.File.createTempFile(File.java:1830)



at







org 
.apache 
.wicket 
.markup 
.html.form.upload.FileUpload.writeToTempFile(FileUpload.java:189)







...snip...







On mac  linux this works just fine. I know that more elegant way

would


be



using the InputStream, but having a file is much more useful for

reading


image dimensions and file length etc. than juggling things in  
memory.







Sincerely,







--



Lauri Piispanen



Senior Product Architect



Conmio Ltd











-



To unsubscribe, e-mail: [EMAIL PROTECTED]



For additional commands, e-mail: [EMAIL PROTECTED]












-

To unsubscribe, e-mail: [EMAIL PROTECTED]

For additional commands, e-mail: [EMAIL PROTECTED]







-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]






-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]





smime.p7s
Description: S/MIME cryptographic signature


Re: Issue with FileUpload.writeToTempFile()

2008-11-11 Thread Igor Vaynberg
please open a jira issue.

-igor

On Tue, Nov 11, 2008 at 1:59 AM, Lauri Piispanen - Conmio Ltd
[EMAIL PROTECTED] wrote:
 Hi all,

 I seem to be having a small portability glitch with
 FileUpload.writeToTempFile(). Looking at the source code it seems to be
 using item.getFieldName(), which on my page translates to
 filefields:1:upload. Windows doesn't really like colons, which gives me
 the following stacktrace:

 ...snip until root cause...

 Caused by: java.io.IOException: The parameter is incorrect
   at java.io.WinNTFileSystem.createFileExclusively(Native Method)
   at java.io.File.checkAndCreate(File.java:1704)
   at java.io.File.createTempFile(File.java:1793)
   at java.io.File.createTempFile(File.java:1830)
   at
 org.apache.wicket.markup.html.form.upload.FileUpload.writeToTempFile(FileUpload.java:189)

 ...snip...

 On mac  linux this works just fine. I know that more elegant way would be
 using the InputStream, but having a file is much more useful for reading
 image dimensions and file length etc. than juggling things in memory.

 Sincerely,

 --
 Lauri Piispanen
   Senior Product Architect
  Conmio Ltd


 -
 To unsubscribe, e-mail: [EMAIL PROTECTED]
 For additional commands, e-mail: [EMAIL PROTECTED]



-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: Re: Issue with FileUpload.writeToTempFile()

2008-11-11 Thread bruno . borges

JIRA issue created - *with patch included*

https://issues.apache.org/jira/browse/WICKET-1930

cheers,
Bruno

On Nov 11, 2008 4:11pm, Igor Vaynberg [EMAIL PROTECTED] wrote:

please open a jira issue.



-igor



On Tue, Nov 11, 2008 at 1:59 AM, Lauri Piispanen - Conmio Ltd

wrote:

 Hi all,



 I seem to be having a small portability glitch with

 FileUpload.writeToTempFile(). Looking at the source code it seems to be

 using item.getFieldName(), which on my page translates to

 filefields:1:upload. Windows doesn't really like colons, which gives  

me


 the following stacktrace:



 ...snip until root cause...



 Caused by: java.io.IOException: The parameter is incorrect

 at java.io.WinNTFileSystem.createFileExclusively(Native Method)

 at java.io.File.checkAndCreate(File.java:1704)

 at java.io.File.createTempFile(File.java:1793)

 at java.io.File.createTempFile(File.java:1830)

 at

  

org.apache.wicket.markup.html.form.upload.FileUpload.writeToTempFile(FileUpload.java:189)




 ...snip...



 On mac  linux this works just fine. I know that more elegant way would  

be


 using the InputStream, but having a file is much more useful for reading

 image dimensions and file length etc. than juggling things in memory.



 Sincerely,



 --

 Lauri Piispanen

 Senior Product Architect

 Conmio Ltd





 -

 To unsubscribe, e-mail: [EMAIL PROTECTED]

 For additional commands, e-mail: [EMAIL PROTECTED]







-

To unsubscribe, e-mail: [EMAIL PROTECTED]

For additional commands, e-mail: [EMAIL PROTECTED]





Issue with FileUpload.writeToTempFile()

2008-11-11 Thread Lauri Piispanen - Conmio Ltd

Hi all,

I seem to be having a small portability glitch with 
FileUpload.writeToTempFile(). Looking at the source code it seems to be 
using item.getFieldName(), which on my page translates to 
filefields:1:upload. Windows doesn't really like colons, which gives 
me the following stacktrace:


...snip until root cause...

Caused by: java.io.IOException: The parameter is incorrect
   at java.io.WinNTFileSystem.createFileExclusively(Native Method)
   at java.io.File.checkAndCreate(File.java:1704)
   at java.io.File.createTempFile(File.java:1793)
   at java.io.File.createTempFile(File.java:1830)
   at 
org.apache.wicket.markup.html.form.upload.FileUpload.writeToTempFile(FileUpload.java:189)


...snip...

On mac  linux this works just fine. I know that more elegant way would 
be using the InputStream, but having a file is much more useful for 
reading image dimensions and file length etc. than juggling things in 
memory.


Sincerely,

--
Lauri Piispanen
   Senior Product Architect
  Conmio Ltd


-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: Re: Issue with FileUpload.writeToTempFile()

2008-11-11 Thread Igor Vaynberg
hi bruno.

first off let me say that we really appreciate the patches...

but :) i would like to make a couple of small comments:

it would be nice if you used the same formatting settings as us. your
patches contain 90% noise which makes them hard to read.

try to use simpler names. normalizeFilename doesnt really say much.
what is normalize mean.

and this is the most important one, do not prematurely optimize and
know when to optimize. this method is called extremely rarely so the
requirement of maintaining the array ordered vs the speed improvement
doesnt make sense - too much of a maintenance headache, easy to make a
mistake, etc. further, in this particular case, a binary search is
slower then a linear search by, i would venture, about 5x.

thanks,

-igor

On Tue, Nov 11, 2008 at 11:03 AM,  [EMAIL PROTECTED] wrote:
 JIRA issue created - *with patch included*

 https://issues.apache.org/jira/browse/WICKET-1930

 cheers,
 Bruno

 On Nov 11, 2008 4:11pm, Igor Vaynberg [EMAIL PROTECTED] wrote:

 please open a jira issue.



 -igor



 On Tue, Nov 11, 2008 at 1:59 AM, Lauri Piispanen - Conmio Ltd

 wrote:

  Hi all,

 

  I seem to be having a small portability glitch with

  FileUpload.writeToTempFile(). Looking at the source code it seems to be

  using item.getFieldName(), which on my page translates to

  filefields:1:upload. Windows doesn't really like colons, which gives

 me

  the following stacktrace:

 

  ...snip until root cause...

 

  Caused by: java.io.IOException: The parameter is incorrect

  at java.io.WinNTFileSystem.createFileExclusively(Native Method)

  at java.io.File.checkAndCreate(File.java:1704)

  at java.io.File.createTempFile(File.java:1793)

  at java.io.File.createTempFile(File.java:1830)

  at

 

 org.apache.wicket.markup.html.form.upload.FileUpload.writeToTempFile(FileUpload.java:189)

 

  ...snip...

 

  On mac  linux this works just fine. I know that more elegant way would

 be

  using the InputStream, but having a file is much more useful for reading

  image dimensions and file length etc. than juggling things in memory.

 

  Sincerely,

 

  --

  Lauri Piispanen

  Senior Product Architect

  Conmio Ltd

 

 

  -

  To unsubscribe, e-mail: [EMAIL PROTECTED]

  For additional commands, e-mail: [EMAIL PROTECTED]

 

 



 -

 To unsubscribe, e-mail: [EMAIL PROTECTED]

 For additional commands, e-mail: [EMAIL PROTECTED]





-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: Re: Issue with FileUpload.writeToTempFile()

2008-11-11 Thread Bruno Borges
sure igor... :-) your opinion is more than welcome.

about the binary search specially. I will keep that in mind for future codes
:-) (and not just for wicket)

but, about the formatting, I really don't know what's going on. I'm using
Ganymede and I've been applying the EclipseCodeFormat.xml without success.
Whenever I save  the file or just format it manually, it does that with the
code. Sorry about that. I will disable it for future patches and will try to
format by hand. At least, the whole code won't be messed up.

and about the name of that method, I never would feel sad if you decide to
change it, really. :-) I took the first shot so I had  to come with
something, but there's no reason to not change it.

with everything said, I'll try to improve the quality (or the lack of
premature quality) of submited patches... :-D

thanks for your comments,
Bruno Borges
blog.brunoborges.com.br
+55 21 76727099

The glory of great men should always be
measured by the means they have used to
acquire it.
- Francois de La Rochefoucauld


On Tue, Nov 11, 2008 at 9:25 PM, Igor Vaynberg [EMAIL PROTECTED]wrote:

 hi bruno.

 first off let me say that we really appreciate the patches...

 but :) i would like to make a couple of small comments:

 it would be nice if you used the same formatting settings as us. your
 patches contain 90% noise which makes them hard to read.

 try to use simpler names. normalizeFilename doesnt really say much.
 what is normalize mean.

 and this is the most important one, do not prematurely optimize and
 know when to optimize. this method is called extremely rarely so the
 requirement of maintaining the array ordered vs the speed improvement
 doesnt make sense - too much of a maintenance headache, easy to make a
 mistake, etc. further, in this particular case, a binary search is
 slower then a linear search by, i would venture, about 5x.

 thanks,

 -igor

 On Tue, Nov 11, 2008 at 11:03 AM,  [EMAIL PROTECTED] wrote:
  JIRA issue created - *with patch included*
 
  https://issues.apache.org/jira/browse/WICKET-1930
 
  cheers,
  Bruno
 
  On Nov 11, 2008 4:11pm, Igor Vaynberg [EMAIL PROTECTED] wrote:
 
  please open a jira issue.
 
 
 
  -igor
 
 
 
  On Tue, Nov 11, 2008 at 1:59 AM, Lauri Piispanen - Conmio Ltd
 
  wrote:
 
   Hi all,
 
  
 
   I seem to be having a small portability glitch with
 
   FileUpload.writeToTempFile(). Looking at the source code it seems to
 be
 
   using item.getFieldName(), which on my page translates to
 
   filefields:1:upload. Windows doesn't really like colons, which gives
 
  me
 
   the following stacktrace:
 
  
 
   ...snip until root cause...
 
  
 
   Caused by: java.io.IOException: The parameter is incorrect
 
   at java.io.WinNTFileSystem.createFileExclusively(Native Method)
 
   at java.io.File.checkAndCreate(File.java:1704)
 
   at java.io.File.createTempFile(File.java:1793)
 
   at java.io.File.createTempFile(File.java:1830)
 
   at
 
  
 
 
 org.apache.wicket.markup.html.form.upload.FileUpload.writeToTempFile(FileUpload.java:189)
 
  
 
   ...snip...
 
  
 
   On mac  linux this works just fine. I know that more elegant way
 would
 
  be
 
   using the InputStream, but having a file is much more useful for
 reading
 
   image dimensions and file length etc. than juggling things in memory.
 
  
 
   Sincerely,
 
  
 
   --
 
   Lauri Piispanen
 
   Senior Product Architect
 
   Conmio Ltd
 
  
 
  
 
   -
 
   To unsubscribe, e-mail: [EMAIL PROTECTED]
 
   For additional commands, e-mail: [EMAIL PROTECTED]
 
  
 
  
 
 
 
  -
 
  To unsubscribe, e-mail: [EMAIL PROTECTED]
 
  For additional commands, e-mail: [EMAIL PROTECTED]
 
 
 
 

 -
 To unsubscribe, e-mail: [EMAIL PROTECTED]
 For additional commands, e-mail: [EMAIL PROTECTED]




Re: Issue with FileUpload.writeToTempFile()

2008-11-11 Thread Johan Compagner
If you use eclipse you should use the project specific format we have
defined for it. You should have a .settings dir or something like
that. Look at the wicket project preferences and look what formatter
you use there

On 11/12/08, Bruno Borges [EMAIL PROTECTED] wrote:
 sure igor... :-) your opinion is more than welcome.

 about the binary search specially. I will keep that in mind for future codes
 :-) (and not just for wicket)

 but, about the formatting, I really don't know what's going on. I'm using
 Ganymede and I've been applying the EclipseCodeFormat.xml without success.
 Whenever I save  the file or just format it manually, it does that with the
 code. Sorry about that. I will disable it for future patches and will try to
 format by hand. At least, the whole code won't be messed up.

 and about the name of that method, I never would feel sad if you decide to
 change it, really. :-) I took the first shot so I had  to come with
 something, but there's no reason to not change it.

 with everything said, I'll try to improve the quality (or the lack of
 premature quality) of submited patches... :-D

 thanks for your comments,
 Bruno Borges
 blog.brunoborges.com.br
 +55 21 76727099

 The glory of great men should always be
 measured by the means they have used to
 acquire it.
 - Francois de La Rochefoucauld


 On Tue, Nov 11, 2008 at 9:25 PM, Igor Vaynberg
 [EMAIL PROTECTED]wrote:

 hi bruno.

 first off let me say that we really appreciate the patches...

 but :) i would like to make a couple of small comments:

 it would be nice if you used the same formatting settings as us. your
 patches contain 90% noise which makes them hard to read.

 try to use simpler names. normalizeFilename doesnt really say much.
 what is normalize mean.

 and this is the most important one, do not prematurely optimize and
 know when to optimize. this method is called extremely rarely so the
 requirement of maintaining the array ordered vs the speed improvement
 doesnt make sense - too much of a maintenance headache, easy to make a
 mistake, etc. further, in this particular case, a binary search is
 slower then a linear search by, i would venture, about 5x.

 thanks,

 -igor

 On Tue, Nov 11, 2008 at 11:03 AM,  [EMAIL PROTECTED] wrote:
  JIRA issue created - *with patch included*
 
  https://issues.apache.org/jira/browse/WICKET-1930
 
  cheers,
  Bruno
 
  On Nov 11, 2008 4:11pm, Igor Vaynberg [EMAIL PROTECTED] wrote:
 
  please open a jira issue.
 
 
 
  -igor
 
 
 
  On Tue, Nov 11, 2008 at 1:59 AM, Lauri Piispanen - Conmio Ltd
 
  wrote:
 
   Hi all,
 
  
 
   I seem to be having a small portability glitch with
 
   FileUpload.writeToTempFile(). Looking at the source code it seems to
 be
 
   using item.getFieldName(), which on my page translates to
 
   filefields:1:upload. Windows doesn't really like colons, which
   gives
 
  me
 
   the following stacktrace:
 
  
 
   ...snip until root cause...
 
  
 
   Caused by: java.io.IOException: The parameter is incorrect
 
   at java.io.WinNTFileSystem.createFileExclusively(Native Method)
 
   at java.io.File.checkAndCreate(File.java:1704)
 
   at java.io.File.createTempFile(File.java:1793)
 
   at java.io.File.createTempFile(File.java:1830)
 
   at
 
  
 
 
 org.apache.wicket.markup.html.form.upload.FileUpload.writeToTempFile(FileUpload.java:189)
 
  
 
   ...snip...
 
  
 
   On mac  linux this works just fine. I know that more elegant way
 would
 
  be
 
   using the InputStream, but having a file is much more useful for
 reading
 
   image dimensions and file length etc. than juggling things in memory.
 
  
 
   Sincerely,
 
  
 
   --
 
   Lauri Piispanen
 
   Senior Product Architect
 
   Conmio Ltd
 
  
 
  
 
   -
 
   To unsubscribe, e-mail: [EMAIL PROTECTED]
 
   For additional commands, e-mail: [EMAIL PROTECTED]
 
  
 
  
 
 
 
  -
 
  To unsubscribe, e-mail: [EMAIL PROTECTED]
 
  For additional commands, e-mail: [EMAIL PROTECTED]
 
 
 
 

 -
 To unsubscribe, e-mail: [EMAIL PROTECTED]
 For additional commands, e-mail: [EMAIL PROTECTED]




-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]