404 error using Wicket 1.5.4 and Websphere 6.1

2012-04-11 Thread rawe
Hi, after updating from Wicket 1.4 to 1.5.4 I get a 404 error when doing a form submit. I get this error when calling a SubmitLink or a normal page submit. It's working in Tomcat 6, but not with Websphere 6.1 My Log output is empty - no error log ! The only message is (german): Error 404:

Re: 404 error using Wicket 1.5.4 and Websphere 6.1

2012-04-11 Thread Martin Grigorov
Hi, On Wed, Apr 11, 2012 at 12:03 PM, rawe ralph.wey...@dachser.com wrote: Hi, after updating from Wicket 1.4 to 1.5.4 I get a 404 error when doing a form submit. I get this error when calling a SubmitLink or a normal page submit. It's working in Tomcat 6, but not with Websphere 6.1 My

Re: 404 error using Wicket 1.5.4 and Websphere 6.1

2012-04-11 Thread rawe
What I see in Firebug on tab network, when running the application under tomcat is: /POST page?9-3.IFormSubmitListener-frmOrderDetail 302 Moved Temporarily localhost:8080 0 127.0.0.1:8080/ Normally I get a status of 200. That's why Websphere can't find the page : 302 Moved Temporarily

Re: 404 error using Wicket 1.5.4 and Websphere 6.1

2012-04-11 Thread Martin Grigorov
Doing a redirect is a normal operation in the web. That's why there is a HTTP status code for it, even several codes - 3xy. Check http://en.wikipedia.org/wiki/Post/Redirect/Get On Wed, Apr 11, 2012 at 1:53 PM, rawe ralph.wey...@dachser.com wrote: What I see in Firebug on tab network, when

Re: 404 error using Wicket 1.5.4 and Websphere 6.1

2012-04-11 Thread rawe
Yes, also when a redirect is a normal operation it seems that Websphere 6.1 cannot handle it. see also the known problem with glassfish: https://issues.apache.org/jira/browse/WICKET-2732 https://issues.apache.org/jira/browse/WICKET-2732 -- View this message in context:

Re: 404 error using Wicket 1.5.4 and Websphere 6.1

2012-04-11 Thread Andrew Geery
Wicket 1.5 requires servlet 2.5 [ https://cwiki.apache.org/WICKET/migration-to-wicket-15.html#MigrationtoWicket1.5-%2528RC1%2529UpgradedtoServletAPI2.5 ], but WAS 6.1 only supports J2EE 1.4 (servlet 2.4) [ http://en.wikipedia.org/wiki/IBM_WebSphere_Application_Server#Version_6.1 ], so I wouldn't

Re: 404 error using Wicket 1.5.4 and Websphere 6.1

2012-04-11 Thread Martin Grigorov
On Wed, Apr 11, 2012 at 5:05 PM, Andrew Geery andrew.ge...@gmail.com wrote: Wicket 1.5 requires servlet 2.5 [ https://cwiki.apache.org/WICKET/migration-to-wicket-15.html#MigrationtoWicket1.5-%2528RC1%2529UpgradedtoServletAPI2.5 ], but WAS 6.1 only supports J2EE 1.4 (servlet 2.4) [

Re: 404 error using Wicket 1.5.4 and Websphere 6.1

2012-04-11 Thread rawe
Yes, I think the problem could be the servlet-api version. WAS 6.1 is running with servlet-api 2.4, so I won't install a wicket 1.5 application on it! Thanks for your help! Ralph -- View this message in context: