[xwiki-users] Redirect from user profile

2014-03-06 Thread kalor
Hi, I'm integrating xwiki with external web application. I want to be able to redirect from xwiki user profile, to user profile of external application. How can I redirect from profile, or at least how can I access user profile template, so I can modify it to manage redirection? Best regards

Re: [xwiki-users] compiling a custom XWikiAuthServiceImpl; was: SSO

2014-03-06 Thread Clemens Klein-Robbenhaar
On 03/04/2014 02:12 PM, Daniel Ebanja wrote: Hallo xwiki-users, i have a webapplication from which i direct users to XWIKI through a link. The idea i have now is using basic Authentication: http:// username:passw...@mywiki.xwiki.com/xwiki/bin/view/Main/WebHome?basicauth=1 The problem here

Re: [xwiki-users] Redirect from user profile

2014-03-06 Thread Clemens Klein-Robbenhaar
On 03/06/2014 12:11 PM, kalor wrote: Hi, I'm integrating xwiki with external web application. I want to be able to redirect from xwiki user profile, to user profile of external application. How can I redirect from profile, or at least how can I access user profile template, so I can modify

Re: [xwiki-users] Redirect from user profile

2014-03-06 Thread kalor
Thanks a lot for the answer, that's what I was looking for. Once you answered, solution seems obvious, but somehow I got stuck looking for this sheet document. It was a live-saving answer, thanks a lot again :) Karol -- View this message in context:

Re: [xwiki-users] XWiki and LDAP TLS binding

2014-03-06 Thread Claude Lepere
Hello! I didn't find how to give directly to XWiki the keystore password in xwiki.cfg or somewhere else. I used the Tomcat Java options: -Djavax.net.ssl.keyStore=/path-to-jks -Djavax.net.ssl.keyStorePassword=secret. Without this workaround, XWiki did not send the client certificate required by

[xwiki-users] Authentication and wizard problem on 5.4.2

2014-03-06 Thread Pascal BASTIEN
Hello, I installed xwiki 5.4.2 from scractch (because the upgrade from 5.4.1 didn't  work well) I use the .WAR on tomcat server and postgres database. The Wizard to install the UI extension aren't launch on first boot. Are there a way to manuelly launch? And worst the Admin/admin account

Re: [xwiki-users] Authentication and wizard problem on 5.4.2

2014-03-06 Thread vinc...@massol.net
Hi, On 6 Mar 2014 at 16:37:20, Pascal BASTIEN (pbasnews-xw...@yahoo.fr(mailto:pbasnews-xw...@yahoo.fr)) wrote: Hello, I installed xwiki 5.4.2 from scractch (because the upgrade from 5.4.1 didn't work well)  That’s a pity. It would be nice to know what was the problem so that we can

Re: [xwiki-users] Container macro with more than 2 columns

2014-03-06 Thread Jeremie BOUSQUET
Hello, I don't know if it is the place to discuss issues, or if I should put the following as comment of the issue in jira, but ... I can put it afterwards in jira. I thought about it, and imagined that only way around, would be to assign a different id to the column elements added by each

Re: [xwiki-users] Authentication and wizard problem on 5.4.2

2014-03-06 Thread Pascal BASTIEN
That’s a pity. It would be nice to know what was the problem so that we can reproduce and fix it, otherwise we won’t be able to improve it! :) Sure! I use the .WAR on tomcat server and postgres database. The Wizard to install the UI extension aren't launch on first boot. Are

Re: [xwiki-users] Authentication and wizard problem on 5.4.2

2014-03-06 Thread panyasan
I might have hit a similar problem. I have left a note on http://platform.xwiki.org/xwiki/bin/view/Features/DistributionWizard#Comments but I am not sure it will be read there: Using version 5.4.2 from Debian packages. Thanks for this guide, but it is not clear how to get from step You will be

Re: [xwiki-users] Authentication and wizard problem on 5.4.2 and encoding problems

2014-03-06 Thread Pascal BASTIEN
I remove status.xml the distribution wizard doesn't launch. I remove status.xml AND  delete and recreate my database... the distribution wizard launch... By the way, I have some encoding problems on tag and page: If i use bac à sable in a tag. The tag display like this: avec bac à sable.