Re: [xwiki-users] Welcome to the users mailing list

2014-07-03 Thread Jason Clemons
Hello, 

I'm new new new to xwiki, but I think it's pretty cool so far.  I've been
killing myself trying to work out where to add javascriptextension on an
app within minute page.  I want the javascript to create some handlers on
page load, hide some buttons, form validation etc.. for the life of me I
can't really figure out the best place to put my code.  Right now I've got
some javascript working by putting an {{html}} tag with a script tag on
the class sheet, but somehow it doesn't feel like the right way to do it.

Any help is greatly appreciated.

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] [myxwiki] new wiki request

2014-07-03 Thread Bogdan Doinea
Hello there,

My name is Bogdan and I want to use xwiki on your hosting for a prototyping
experiment I am doing with a development community trying to build some
smart things using Arduino and Pi boards.

Owner name: Bogdan Doinea
Wiki name: ioepl.myxwiki.org

Is it possible to set this up for me?

Thank you!
Bogdan
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Welcome to the users mailing list

2014-07-03 Thread Ecaterina Moraru (Valica)
Hi,

http://platform.xwiki.org/xwiki/bin/view/DevGuide/SkinExtensionsTutorial#HMinimalJavaScripteXtension

Thanks,
Caty


On Thu, Jul 3, 2014 at 9:51 AM, Jason Clemons jason.clem...@live.com
wrote:

 Hello,

 I'm new new new to xwiki, but I think it's pretty cool so far.  I've been
 killing myself trying to work out where to add javascriptextension on an
 app within minute page.  I want the javascript to create some handlers on
 page load, hide some buttons, form validation etc.. for the life of me I
 can't really figure out the best place to put my code.  Right now I've got
 some javascript working by putting an {{html}} tag with a script tag on
 the class sheet, but somehow it doesn't feel like the right way to do it.

 Any help is greatly appreciated.

 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] [myxwiki] new wiki request

2014-07-03 Thread Jason Clemons
Sure, yeah man.. let me shoot you over my social security number too.. 

-Original Message-
From: users [mailto:users-boun...@xwiki.org] On Behalf Of Bogdan Doinea
Sent: Thursday, July 3, 2014 12:21 AM
To: users@xwiki.org
Subject: [xwiki-users] [myxwiki] new wiki request

Hello there,

My name is Bogdan and I want to use xwiki on your hosting for a prototyping
experiment I am doing with a development community trying to build some
smart things using Arduino and Pi boards.

Owner name: Bogdan Doinea
Wiki name: ioepl.myxwiki.org

Is it possible to set this up for me?

Thank you!
Bogdan
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] [myxwiki] new wiki request

2014-07-03 Thread Hamster
Jason Clemons wrote
 Sure, yeah man.. let me shoot you over my social security number too.. 

I am not sure what the social security number remark is all about...but I
am sure that one of the developers will notice this topic and create a wiki
for you.

By the way, Arduino and (Raspberry)Pi is cool stuff! :-)



--
View this message in context: 
http://xwiki.475771.n2.nabble.com/myxwiki-new-wiki-request-tp7591192p7591200.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] [myxwiki] new wiki request

2014-07-03 Thread Bogdan Doinea
On Thu, Jul 3, 2014 at 12:55 PM, Hamster teun...@hotmail.com wrote:

 Jason Clemons wrote
  Sure, yeah man.. let me shoot you over my social security number too..

 I am not sure what the social security number remark is all about...but I
 am sure that one of the developers will notice this topic and create a wiki
 for you.

 By the way, Arduino and (Raspberry)Pi is cool stuff! :-)


Thanks! :) We're a small community built from enthusiasm around these
things. We also have a M2M router, but we are really at the beginning
and learning while doing.

XWiki sounds kind of cool for this collaborative work as it has good
github integration too.

Bogdan
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] GA JSX not loaded anymore after 4.0--6.0.1 migration

2014-07-03 Thread Sylvain MARIE
Hello,

After migrating the database content of XWiki 4.0 into a new XWiki 6.0.1 
engine, the GA tracking JSX is no longer loaded in the XWiki pages :-(
I checked :
. 
http://bimguides.vtreem.com/bin/admin/XWiki/XWikiPreferences?section=analytics 
reports Google Analytics™ is running  with the proper GA ID
. on 
http://bimguides.vtreem.com/bin/edit/XWiki/GoogleAnalyticsCode?editor=object 
the following attributes are set:
Use this extension « Always on this wiki »
Parse content: yes
caching: long (also tried default)
Still, the Google Analytics debugger extension reports that the GA JS code is 
not fetched by the XWiki page (and indeed, there is no GA script in the page 
html source).

Does anyone know if the JSX mechanics has changed between 4.0 and 6.0.1 ? (I 
may have overwritten working code with outdated code when I used my 4.0 
mysqldump result with the fresh 6.0.1 WAR ?)

Thanks for your help!
Sylvain


Sylvain MARIE
VTREEM.com

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] [myxwiki] new wiki request

2014-07-03 Thread Thomas Mortagne
You can access your new wiki on http://gruene-telgte.myxwiki.org.

Enjoy !

On Wed, Jul 2, 2014 at 4:50 PM, Peter Spieker pe...@diespiekers.de wrote:
 Dear administrators,

 Please create a new wiki.

 Description: I would like to get a wiki to discuss political issues within the
 local chapter of the german green party.

 Owner name: peterspieker

 Wiki name: gruene-telgte.myxwiki.org

 Cheers,

 Peter
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users



-- 
Thomas Mortagne
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] [myxwiki] new wiki request

2014-07-03 Thread Thomas Mortagne
You can access your new wiki on http://ioepl.myxwiki.org.

Enjoy !

On Thu, Jul 3, 2014 at 1:05 PM, Bogdan Doinea bogdan.doi...@gmail.com wrote:
 On Thu, Jul 3, 2014 at 12:55 PM, Hamster teun...@hotmail.com wrote:

 Jason Clemons wrote
  Sure, yeah man.. let me shoot you over my social security number too..

 I am not sure what the social security number remark is all about...but I
 am sure that one of the developers will notice this topic and create a wiki
 for you.

 By the way, Arduino and (Raspberry)Pi is cool stuff! :-)


 Thanks! :) We're a small community built from enthusiasm around these
 things. We also have a M2M router, but we are really at the beginning
 and learning while doing.

 XWiki sounds kind of cool for this collaborative work as it has good
 github integration too.

 Bogdan
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users



-- 
Thomas Mortagne
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] a newbie question about Autocompletion Application

2014-07-03 Thread Eduard Moraru
Hi Pascal,

How did you install the AutoCompletion Application? Did you use the
Extension Manager?

As you can see at the bottom [1] of the extension's page, it depends on the
Syntax Highlighting Application [2]. This is not an application by itself,
but rather a plugin for the Syntax Highlighting Application that enables
autocompletion, so you need to have them both installed.

I strongly suggest that you install it through the Extension Manager as it
will automatically take care of installing the Syntax Highlighting
Application and any other direct or indirect dependencies.

If EM is not an option and you insist on installing it manually, make sure
to follow the chain of dependencies and install all the required
components. I do not recommend you do this because it can be tedious and
error prone.

After successfully installing the Syntax Highlighting Application and the
AutoCompletion Application, open a wiki page and type inside a velocity
macro $xwiki. (without quotes) and then hit CTRL+SPACE.

There are still some issues to be fixed with it, so please report [3] any
problems you have with using it.

Let me know if that helped.

Thanks,
Eduard

--
[1]
http://extensions.xwiki.org/xwiki/bin/view/Extension/AutoCompletion+Application#HDependencies
[2]
http://extensions.xwiki.org/xwiki/bin/view/Extension/Syntax+Highlighting+Application
[3] http://jira.xwiki.org/browse/WIKIEDITOR


On Wed, Jul 2, 2014 at 8:32 PM, Pascal BASTIEN pbasnews-xw...@yahoo.fr
wrote:

 Hello,
 I try to use the autocompletion application (
 http://extensions.xwiki.org/xwiki/bin/view/Extension/AutoCompletion+Application)
 without success.
 Are they a shortcut to provide methods and all other things?

 I edit in xwiki mode, add my 2 velocity tags, typing $xwiki. and tab ...
 without result.


 Thxs for ur help

 Pascal B on Xwiki 6.0
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] GA JSX not loaded anymore after 4.0--6.0.1 migration

2014-07-03 Thread Eduard Moraru
Hi Sylvain,

Just a wild guess here, but for Always on this wiki options to work, the
page needs to be saved with programming rights (so by a user that has PR).
Maybe something happened during the migration and the page got saved by a
user not having PR.

Try to save the XWiki/GoogleAnalyticsCode
http://bimguides.vtreem.com/bin/edit/XWiki/GoogleAnalyticsCode?editor=object
page with the XWiki.Admin user, or any user having PR rights. This should
properly register the JSX.

Hope this helps,
Eduard


http://bimguides.vtreem.com/bin/edit/XWiki/GoogleAnalyticsCode?editor=object


On Thu, Jul 3, 2014 at 2:26 PM, Sylvain MARIE sylvain.ma...@vtreem.com
wrote:

 Hello,

 After migrating the database content of XWiki 4.0 into a new XWiki 6.0.1
 engine, the GA tracking JSX is no longer loaded in the XWiki pages :-(
 I checked :
 .
 http://bimguides.vtreem.com/bin/admin/XWiki/XWikiPreferences?section=analytics
 reports Google Analytics™ is running  with the proper GA ID
 . on
 http://bimguides.vtreem.com/bin/edit/XWiki/GoogleAnalyticsCode?editor=object
 the following attributes are set:
 Use this extension « Always on this wiki »
 Parse content: yes
 caching: long (also tried default)
 Still, the Google Analytics debugger extension reports that the GA JS code
 is not fetched by the XWiki page (and indeed, there is no GA script in the
 page html source).

 Does anyone know if the JSX mechanics has changed between 4.0 and 6.0.1 ?
 (I may have overwritten working code with outdated code when I used my 4.0
 mysqldump result with the fresh 6.0.1 WAR ?)

 Thanks for your help!
 Sylvain


 Sylvain MARIE
 VTREEM.com

 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] GA JSX not loaded anymore after 4.0--6.0.1 migration

2014-07-03 Thread Sylvain MARIE

Hi Eduard,

Good catch !!
Forcing my user to have programming rights and re-saving the 
GoogleAnalyticsCode page did the trick. Many thanks !
I don’t know if a warning could be issued when a JSX is edited by a user 
without PR rights ? It could definitely help detecting such problems.
Anyway, thanks for your speedy and spot-on answer :-)
Sylvain

Sylvain MARIE
VTREEM.com

Le 3 juil. 2014 à 14:19, Eduard Moraru enygma2...@gmail.com a écrit :

 Hi Sylvain,
 
 Just a wild guess here, but for Always on this wiki options to work, the
 page needs to be saved with programming rights (so by a user that has PR).
 Maybe something happened during the migration and the page got saved by a
 user not having PR.
 
 Try to save the XWiki/GoogleAnalyticsCode
 http://bimguides.vtreem.com/bin/edit/XWiki/GoogleAnalyticsCode?editor=object
 page with the XWiki.Admin user, or any user having PR rights. This should
 properly register the JSX.
 
 Hope this helps,
 Eduard
 
 
 http://bimguides.vtreem.com/bin/edit/XWiki/GoogleAnalyticsCode?editor=object
 
 
 On Thu, Jul 3, 2014 at 2:26 PM, Sylvain MARIE sylvain.ma...@vtreem.com
 wrote:
 
 Hello,
 
 After migrating the database content of XWiki 4.0 into a new XWiki 6.0.1
 engine, the GA tracking JSX is no longer loaded in the XWiki pages :-(
 I checked :
 .
 http://bimguides.vtreem.com/bin/admin/XWiki/XWikiPreferences?section=analytics
 reports Google Analytics™ is running  with the proper GA ID
 . on
 http://bimguides.vtreem.com/bin/edit/XWiki/GoogleAnalyticsCode?editor=object
 the following attributes are set:
Use this extension « Always on this wiki »
Parse content: yes
caching: long (also tried default)
 Still, the Google Analytics debugger extension reports that the GA JS code
 is not fetched by the XWiki page (and indeed, there is no GA script in the
 page html source).
 
 Does anyone know if the JSX mechanics has changed between 4.0 and 6.0.1 ?
 (I may have overwritten working code with outdated code when I used my 4.0
 mysqldump result with the fresh 6.0.1 WAR ?)
 
 Thanks for your help!
 Sylvain
 
 
 Sylvain MARIE
 VTREEM.com
 
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users
 
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] a newbie question about Autocompletion Application

2014-07-03 Thread Pascal BASTIEN


Thxs a lot: when we know Ctrl+space shortcut it is simpler :-)
I just edited this page to indicate the shortcut: 
http://extensions.xwiki.org/xwiki/bin/view/Extension/AutoCompletion+Application



 De : Eduard Moraru enygma2...@gmail.com
À : Pascal BASTIEN pbasnews-xw...@yahoo.fr; XWiki Users users@xwiki.org 
Envoyé le : Jeudi 3 juillet 2014 13h45
Objet : Re: [xwiki-users] a newbie question about Autocompletion Application
 


Hi Pascal,

How did you install the AutoCompletion Application? Did you use the Extension 
Manager?

As you can see at the bottom [1] of the extension's page, it depends on the 
Syntax Highlighting Application [2]. This is not an application by itself, but 
rather a plugin for the Syntax Highlighting Application that enables 
autocompletion, so you need to have them both installed.

I strongly suggest that you install it through the Extension Manager as it will 
automatically take care of installing the Syntax Highlighting Application and 
any other direct or indirect dependencies.


If EM is not an option and you insist on installing it manually, make sure to 
follow the chain of dependencies and install all the required components. I do 
not recommend you do this because it can be tedious and error prone.

After successfully installing the Syntax Highlighting Application and the 
AutoCompletion Application, open a wiki page and type inside a velocity macro 
$xwiki. (without quotes) and then hit CTRL+SPACE.


There are still some issues to be fixed with it, so please report [3] any 
problems you have with using it.

Let me know if that helped.

Thanks,
Eduard


--
[1] 
http://extensions.xwiki.org/xwiki/bin/view/Extension/AutoCompletion+Application#HDependencies
[2] 
http://extensions.xwiki.org/xwiki/bin/view/Extension/Syntax+Highlighting+Application
[3] http://jira.xwiki.org/browse/WIKIEDITOR




On Wed, Jul 2, 2014 at 8:32 PM, Pascal BASTIEN pbasnews-xw...@yahoo.fr wrote:

Hello,
I try to use the autocompletion application 
(http://extensions.xwiki.org/xwiki/bin/view/Extension/AutoCompletion+Application)
 without success.
Are they a shortcut to provide methods and all other things?

I edit in xwiki mode, add my 2 velocity tags, typing $xwiki. and tab ... 
without result.


Thxs for ur help

Pascal B on Xwiki 6.0
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] Change applicant context path

2014-07-03 Thread Hu Yang
Hi,

After I changed applicant context path, the search box still using the old 
context path, how to change it?

Thanks

Hu Yang

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] EXTERNAL: Re: Xwiki Logout

2014-07-03 Thread Brockmeier, Chris S
This logout is going to kill me! :)   Anyways, in my SSO Authenticator, I 
override the getAuth()  function and I'm currently looking for logout in the 
URI, if so I go ahead and invalidate the session and remove the weblogic 
jsessionId cookie.  Once the redirect occurs it appears that it obtains the 
original user along with his credentials.  It appears that absolutely nothing 
happens.  Any ideas?

Thanks,
Chris. 


-Original Message-
From: users [mailto:users-boun...@xwiki.org] On Behalf Of Brockmeier, Chris S
Sent: Tuesday, July 01, 2014 3:28 PM
To: XWiki Users
Subject: Re: [xwiki-users] EXTERNAL: Re: Xwiki Logout


We are authenticating against LDAP.   When we login via our product (which is 
run on weblogic) and then go to xwiki we are logged in and everything looks 
good, we can log out from our application and the xwiki again looks good.
Except there is a backdoor, where the user can go to xwiki and login directly 
w/o going through our product first.   At that point, if the user then tries to 
logout via the xwiki button, nothing really happens besides the logs filling up 
with errors.   

Does this help? 


   

-Original Message-
From: users [mailto:users-boun...@xwiki.org] On Behalf Of Guillaume Fenollar
Sent: Tuesday, July 01, 2014 1:59 PM
To: XWiki Users
Subject: EXTERNAL: Re: [xwiki-users] Xwiki Logout

Hello,

This is the role of any SSO to make you authenticate everytime you access a 
ressource. So when you click on Logout, it sends your credentials again and 
keep you loggued in. So it depends greatly on the type of your SSO, but for 
example for CAS, the only way would be to experiment Single Sign Out (which was 
experimental last time I looked to it).

The main problem is that the mod_cas for Apache doesn't have the ability to 
destroy the SSO cookie, which would be a 100% sure way to log you out.

What SSO have you implemented?

Guillaume


2014-07-01 20:13 GMT+02:00 Brockmeier, Chris S chris.s.brockme...@lmco.com
:

 Actually, please cancel that request.  I need the logout button to
 actually logout the user.When I view the log I get a whole bunch of
 Oracle10gDialect errors followed by a StackOverflowError
 SEVERE: Cannot send action notifications for document 
 [XWiki.XWikiLougout using action [logout]

 Any Ideas?

 Thanks,
 Chris.



 -Original Message-
 From: users [mailto:users-boun...@xwiki.org] On Behalf Of Brockmeier, 
 Chris S
 Sent: Tuesday, July 01, 2014 11:44 AM
 To: users@xwiki.org
 Subject: EXTERNAL: [xwiki-users] Xwiki Logout

 Hey all,

 I'm using an SSO authenticator to login to Xwiki.   The Xwiki has a logout
 button that doesn't appear to do anything (for SSO) once pressed .   Is
 there a way to disable this button?

 Thanks,
 Chris.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users