[xwiki-users] User forgot password link unavailable

2015-05-21 Thread Mahomed Hussein
Hi

It seems that the “forgot password” link is unavailable when blocking access to 
anonymous users (http://localhost/xwiki/bin/view/XWiki/ResetPassword). I am 
using a custom skin based on flamingo. No link shows up for resetting the 
password and if I go to the link directly, it redirects to the login page. If I 
then login, I correctly get the reset page.

Is this a bug or have I done something wrong? Thanks.


Kind regards,

Mahomed






___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] User forgot password link unavailable

2015-05-21 Thread Sergiu Dumitriu
It's not a bug, it's a feature

When you prevent access to unathenticated users, you really prevent
almost any access, including the reset password page. That is why it's
really not recommended to tick that box.

On 05/21/2015 06:55 AM, Mahomed Hussein wrote:
 Hi
 
 It seems that the “forgot password” link is unavailable when blocking access 
 to anonymous users (http://localhost/xwiki/bin/view/XWiki/ResetPassword). I 
 am using a custom skin based on flamingo. No link shows up for resetting the 
 password and if I go to the link directly, it redirects to the login page. If 
 I then login, I correctly get the reset page.
 
 Is this a bug or have I done something wrong? Thanks.
 
 
 Kind regards,
 
 Mahomed
 
-- 
Sergiu Dumitriu
http://purl.org/net/sergiu/
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users