Re: [xwiki-users] Upgrade To 8.0 - Permissions / Admin Pages Problem

2016-04-02 Thread Keith Davis
I deleted all of the 8%2E0 folders and reset the DB. Now it's loading with 8.0, 
but this time I never got the DW wizard at all. So I am switching us to 
production MySQL. I have a sneaky suspicion that the UI is not updated 
properly, but it's working (and it does seem faster, as the release notes 
indicate), so I am calling this good enough until we run into a problem.

Keith Davis (214) 906-5183


-Original Message-
From: users [mailto:users-boun...@xwiki.org] On Behalf Of Keith Davis
Sent: Sunday, April 3, 2016 12:10 AM
To: XWiki Users
Subject: Re: [xwiki-users] Upgrade To 8.0 - Permissions / Admin Pages Problem

I just tried again. After upgrading the application files, I skipped the 
Distribution Wizard and we still have the correct permissions. So I ran the DW 
and I got this:

Extension [org.xwiki.platform:xwiki-platform-distribution-flavor-8.0] is 
already installed on namespace [wiki:xwiki] class 
org.xwiki.extension.InstallException: Failed to resolve extension
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:690)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:339)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:297)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.start(AbstractInstallPlanJob.java:231)
at 
org.xwiki.extension.job.internal.InstallPlanJob.runInternal(InstallPlanJob.java:88)


So I removed all of the folders named "8%2E0", that allowed me to complete the 
DW. I did see a page about XWikiAdminGroup being changed, so I kept my old 
version this time. However, after the DW was complete, permissions are gone 
again.

Resetting back to 7.4.2 to try again.

Keith Davis (214) 906-5183

-Original Message-
From: users [mailto:users-boun...@xwiki.org] On Behalf Of Keith Davis
Sent: Friday, April 1, 2016 10:55 AM
To: XWiki Users
Subject: Re: [xwiki-users] Upgrade To 8.0 - Permissions / Admin Pages Problem

Hmm, no response. Does nobody have any ideas or are you all mad at me about my 
documentation comments?

Keith Davis (214) 906-5183

-Original Message-
From: users [mailto:users-boun...@xwiki.org] On Behalf Of Keith Davis
Sent: Monday, March 28, 2016 9:05 AM
To: XWiki Users
Subject: Re: [xwiki-users] Upgrade To 8.0 - Permissions / Admin Pages Problem

I still can't figure out what is causing this issue. We use LDAP (Active 
Directory) if that helps.

Keith Davis (214) 906-5183

From: Keith Davis
Sent: Friday, March 25, 2016 5:21 PM
To: 'XWiki Users'
Subject: RE: Upgrade To 8.0 - Permissions / Admin Pages Problem

Restored back to 7.4.2 (files and database). Not sure how to proceed. Can't 
upgrade with resolving this issue.

Keith Davis (214) 906-5183

From: Keith Davis
Sent: Friday, March 25, 2016 4:52 PM
To: 'XWiki Users'
Subject: RE: Upgrade To 8.0 - Permissions / Admin Pages Problem

When I attempt to upgrade back to 8.0, I get the Distribution Wizard and that 
attempts to upgrade and then fails:

Extension [org.xwiki.platform:xwiki-platform-distribution-flavor-8.0] is 
already installed on namespace [wiki:xwiki] class 
org.xwiki.extension.InstallException: Failed to resolve extension
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:690)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:339)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:297)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.start(AbstractInstallPlanJob.java:231)
at 
org.xwiki.extension.job.internal.InstallPlanJob.runInternal(InstallPlanJob.java:88)
at org.xwiki.job.AbstractJob.runInContext(AbstractJob.java:205)
at org.xwiki.job.AbstractJob.run(AbstractJob.java:188)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source) Caused by: class 
org.xwiki.extension.InstallException: Failed to create an install plan for 
extension dependency [org.xwiki.enterprise:xwiki-enterprise-ui-common-8.0]
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtensionDependency(AbstractInstallPlanJob.java:607)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtensionDependency(AbstractInstallPlanJob.java:574)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:831)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:688)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:339)
at 

Re: [xwiki-users] Upgrade To 8.0 - Permissions / Admin Pages Problem

2016-04-02 Thread Keith Davis
I just tried again. After upgrading the application files, I skipped the 
Distribution Wizard and we still have the correct permissions. So I ran the DW 
and I got this:

Extension [org.xwiki.platform:xwiki-platform-distribution-flavor-8.0] is 
already installed on namespace [wiki:xwiki]
class org.xwiki.extension.InstallException: Failed to resolve extension
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:690)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:339)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:297)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.start(AbstractInstallPlanJob.java:231)
at 
org.xwiki.extension.job.internal.InstallPlanJob.runInternal(InstallPlanJob.java:88)


So I removed all of the folders named "8%2E0", that allowed me to complete the 
DW. I did see a page about XWikiAdminGroup being changed, so I kept my old 
version this time. However, after the DW was complete, permissions are gone 
again.

Resetting back to 7.4.2 to try again.

Keith Davis (214) 906-5183

-Original Message-
From: users [mailto:users-boun...@xwiki.org] On Behalf Of Keith Davis
Sent: Friday, April 1, 2016 10:55 AM
To: XWiki Users
Subject: Re: [xwiki-users] Upgrade To 8.0 - Permissions / Admin Pages Problem

Hmm, no response. Does nobody have any ideas or are you all mad at me about my 
documentation comments?

Keith Davis (214) 906-5183

-Original Message-
From: users [mailto:users-boun...@xwiki.org] On Behalf Of Keith Davis
Sent: Monday, March 28, 2016 9:05 AM
To: XWiki Users
Subject: Re: [xwiki-users] Upgrade To 8.0 - Permissions / Admin Pages Problem

I still can't figure out what is causing this issue. We use LDAP (Active 
Directory) if that helps.

Keith Davis (214) 906-5183

From: Keith Davis
Sent: Friday, March 25, 2016 5:21 PM
To: 'XWiki Users'
Subject: RE: Upgrade To 8.0 - Permissions / Admin Pages Problem

Restored back to 7.4.2 (files and database). Not sure how to proceed. Can't 
upgrade with resolving this issue.

Keith Davis (214) 906-5183

From: Keith Davis
Sent: Friday, March 25, 2016 4:52 PM
To: 'XWiki Users'
Subject: RE: Upgrade To 8.0 - Permissions / Admin Pages Problem

When I attempt to upgrade back to 8.0, I get the Distribution Wizard and that 
attempts to upgrade and then fails:

Extension [org.xwiki.platform:xwiki-platform-distribution-flavor-8.0] is 
already installed on namespace [wiki:xwiki] class 
org.xwiki.extension.InstallException: Failed to resolve extension
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:690)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:339)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:297)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.start(AbstractInstallPlanJob.java:231)
at 
org.xwiki.extension.job.internal.InstallPlanJob.runInternal(InstallPlanJob.java:88)
at org.xwiki.job.AbstractJob.runInContext(AbstractJob.java:205)
at org.xwiki.job.AbstractJob.run(AbstractJob.java:188)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source) Caused by: class 
org.xwiki.extension.InstallException: Failed to create an install plan for 
extension dependency [org.xwiki.enterprise:xwiki-enterprise-ui-common-8.0]
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtensionDependency(AbstractInstallPlanJob.java:607)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtensionDependency(AbstractInstallPlanJob.java:574)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:831)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:688)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:339)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.installExtension(AbstractInstallPlanJob.java:297)
at 
org.xwiki.extension.job.internal.AbstractInstallPlanJob.start(AbstractInstallPlanJob.java:231)
at 
org.xwiki.extension.job.internal.InstallPlanJob.runInternal(InstallPlanJob.java:88)
at org.xwiki.job.AbstractJob.runInContext(AbstractJob.java:205)
   at org.xwiki.job.AbstractJob.run(AbstractJob.java:188)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source) Caused by: class 
org.xwiki.extension.InstallException: Failed to create an install 

Re: [xwiki-users] Macro Parameter as Array

2016-04-02 Thread Jesse Bright
For that matter are any other data types, like Boolean for example, allowed as 
macro parameters?

Regards,

Jesse

> On Apr 2, 2016, at 5:02 PM, Personal  wrote:
> 
> Is it possible to pass an array as a macro parameter? So far my attempts have 
> failed.
> 
> Macro code:
> #set( $a = $xcontext.macro.params.array)
> $a
> 
> #foreach($i in $a)
>  $i
> #end
> 
> 
> Page code:
> #set( $array = ['Chapter 1', 'Chapter 2', 'Chapter 3'])
> $array
> 
> #foreach($i in $array)
>  $i
> #end
> 
> {{test array=$array/}}
> 
> 
> The array processed in the page works as expected. The array passed to the 
> macro only prints up to the first space between Chapter and 1. I have also 
> tried to enter the array as a string which passes the string but the macro 
> does not treat it as an array, which doesn’t surprise me. The comments from 
> Stefan and Vincent on 
> http://platform.xwiki.org/xwiki/bin/view/DevGuide/WikiMacroTutorial seem to 
> touch on this issue but I do not understand the answer provided. Thank you 
> for any clarification to this issue you can provide.
> 
> Regards,
> 
> Jesse Bright
> ___
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] Macro Parameter as Array

2016-04-02 Thread Personal
Is it possible to pass an array as a macro parameter? So far my attempts have 
failed.

Macro code:
#set( $a = $xcontext.macro.params.array)
$a

#foreach($i in $a)
  $i
#end


Page code:
#set( $array = ['Chapter 1', 'Chapter 2', 'Chapter 3'])
$array

#foreach($i in $array)
  $i
#end

{{test array=$array/}}


The array processed in the page works as expected. The array passed to the 
macro only prints up to the first space between Chapter and 1. I have also 
tried to enter the array as a string which passes the string but the macro does 
not treat it as an array, which doesn’t surprise me. The comments from Stefan 
and Vincent on 
http://platform.xwiki.org/xwiki/bin/view/DevGuide/WikiMacroTutorial seem to 
touch on this issue but I do not understand the answer provided. Thank you for 
any clarification to this issue you can provide.

Regards,

Jesse Bright
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] change EmperorofIceCream.mywiki.org to LifeintheOffworldColonies.mywiki.org

2016-04-02 Thread Raymond Lai
Hello is it possible to change the name of my wiki? I am registered as Ray
Lai to the xwiki community.

thank you,
Ray
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users