[xwiki-users] Python macro scripting - available packages?

2016-05-25 Thread Sebastian Schafer
Hi, I'm trying to import some packages into the Python macro on Xwiki 7.2, and while standard packages import fine (working with os and re, etc.), some (like xlrd) don't. Looking through the scripting guide and macro documentation I could not figure out how the Python macro actually works. Is

Re: [xwiki-users] Xwiki-Entreprise-Web-8.1 WAR File Installation issues

2016-05-25 Thread Sebastien.Boulianne
Hi Vincent, I did: echo 'org.apache.catalina.core.ContainerBase.[Catalina].level = INFO' /var/lib/tomcat/webapps/ROOT/WEB-INF/classes/logging.properties echo 'org.apache.catalina.core.ContainerBase.[Catalina].handlers = java.util.logging.ConsoleHandler'

[xwiki-users] Setup a sepparate space for javascript

2016-05-25 Thread dullfig
Hello: I was wondering if anyone else has done this. My application is starting to need a whole bunch of javascript, and I was thinking of setting up a separate space (maybe call it js) where there is nothing but pages with javascript objects attached. That way I could set up a ClassSheet for

Re: [xwiki-users] Xwiki-Entreprise-Web-8.1 WAR File Installation issues

2016-05-25 Thread Vincent Massol
Hi, You need to enable tomcat debug to see the error, see: http://platform.xwiki.org/xwiki/bin/view/AdminGuide/InstallationTomcat#HSEVERE:ErrorlistenerStart Thanks -Vincent > On 25 May 2016, at 17:59, sebastien.boulia...@cpu.ca wrote: > > Hi all, > > I tried to install the

Re: [xwiki-users] Xwiki-Entreprise-Web-8.1 WAR File Installation issues

2016-05-25 Thread Mahomed Hussein
What OS are you running? Please provide the output of: cat /etc/lsb-release java -version update-alternatives --config java cat /etc/init.d/tomcat7 | grep JDK_DIRS= Kind regards, Mahomed Hussein Custodian Data Centre Email: maho...@custodiandc.com http://www.CustodianDC.com

[xwiki-users] Twitter Macro

2016-05-25 Thread Paul Pinkerton (ACLCO)
Trying to get this macro to work: http://extensions.xwiki.org/xwiki/bin/view/Extension/Twitter+Macro I seem to be missing something with it.What I really want to do is simply display a Twitter feed on a page. Any help is appreciated! Paul Pinkerton KnowledgeNow Project/ ACLCO

[xwiki-users] Xwiki-Entreprise-Web-8.1 WAR File Installation issues

2016-05-25 Thread Sebastien.Boulianne
Hi all, I tried to install the Xwiki-Entreprise-Web-8.1 WAR File on Tomcat and I get these errors... http://pastebin.com/T0Kfa7MS http://imgur.com/ejT0zAe ps aux | grep tomcat tomcat2152 4.4 15.0 3802340 724216 ? Ssl 10:45 0:12 /usr/lib/jvm/jre/bin/java -classpath

[xwiki-users] [Blog] Use the Apache HTTP library to interact with the XWiki RESTful API

2016-05-25 Thread Eduard Moraru
Hi, As promised, I`m sharing with you the addition of a new article on xwiki.org's blog: "Use the Apache HTTP library to interact with the XWiki RESTful API" by Mohamed Boussaa http://www.xwiki.org/xwiki/bin/view/Blog/Use+the+Apache+HTTP+library+to+interact+with+the+XWiki+RESTful+API As the

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Stéphane LASSIRE
Hello Clemens, I think you are right. I have a wheezy release. I make the backport of Tomcat to go from 7.0.28 et 7.0.56 but it is always not usable. I ask my provider to go back to the backup of last night. The end of the story for me was : plan a longer time for upgrading the system and then

Re: [xwiki-users] REST API ignores type parameter

2016-05-25 Thread Mark Sack
You're right - I was missing the wiki name. But, for some reason, I still can't get the queries to work. Here is what I've found so far. There is only one wiki - confirmed by the following REST call: http://10.1.16.192/wiki/rest/wikis/ which returns http://10.1.16.192:8080/wiki/rest/wikis/query;

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Clemens Klein-Robbenhaar
I see you are using tomcat 7.0.28 - probably your are still on wheezy? There are some bug reports for that message; it seems upgrading tomcat helps, e.g.: http://stackoverflow.com/q/23541532 http://stackoverflow.com/q/23484098 However the tomcat with wheezy is just too old:

Re: [xwiki-users] [ANN] Release of Nested Pages Migrator Application 0.5

2016-05-25 Thread Guillaume Delhumeau
The link is bad. The good one is: http://extensions.xwiki.org/xwiki/bin/view/Extension/Nested+Pages+Migrator+Application#Hv0.5 2016-05-25 13:13 GMT+02:00 Guillaume Delhumeau < guillaume.delhum...@xwiki.com>: > Hello > > A new version of the Nested Pages Migrator Application extension is >

[xwiki-users] [ANN] Release of Nested Pages Migrator Application 0.5

2016-05-25 Thread Guillaume Delhumeau
Hello A new version of the Nested Pages Migrator Application extension is available. See http://extensions.xwiki.org/xwiki/bin/view/Extension/Nested+Pages+Migrator+Application#Hv0.5 You can install or upgrade with the

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Thomas Mortagne
You are definitely using Oracle JDK 8 so I don't understand why you end up with this kind of error. I just upgraded to XWiki 8.0 with pretty much the same setup and all seems OK: * Ubuntu Server 14.04 * Oracle JDK 1.8.0_91 installed trough

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Thomas Mortagne
On Wed, May 25, 2016 at 12:30 PM, Thomas Mortagne wrote: > On Wed, May 25, 2016 at 11:33 AM, Vincent Massol wrote: >> Note: We’re going to have lots of issues like this if the apt doesn’t update >> the java version > > It's not that simple. The

Re: [xwiki-users] Error upgrading Debian - > Vincent

2016-05-25 Thread Thomas Mortagne
http://platform.xwiki.org/xwiki/bin/view/AdminGuide/InstallationViaAPT give you several repositories and explain what each one is about. """ Note that there is several repositories you can choose (as alternatives to the stable one you have in the previous example):

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Stéphane LASSIRE
Hello Thomas, The answer : root@CESAP-WIKI01:/var/log/tomcat7# ps aux | grep tomcat tomcat7 6355 7.3 6.7 2182572 275136 ? Sl 12:34 0:59 /usr/lib/jvm/java-8-oracle/bin/java -Djava.util.logging.config.file=/var/lib/tomcat7/conf/logging.properties -Djava.awt.headless=true -Xmx512m

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Thomas Mortagne
"Invalid byte tag in constant pool: 15" still looks like a Java version issue. Could you check what version of Java started with "ps aux | grep tomcat" ? On Wed, May 25, 2016 at 12:41 PM, Stéphane LASSIRE wrote: > Hello Thomas, > > So I take a look of all messages

Re: [xwiki-users] Error upgrading Debian - > Vincent

2016-05-25 Thread Stéphane LASSIRE
Hello Vincent, Yes I think some explanations was helpful I saw all problems encountered by Mohamed, so I planned to migrate to release 7.4, I follow the links : http://www.xwiki.org/xwiki/bin/view/Download/DownloadVersion/?projectVersion=7.4.3. But this procedure for Debian put the Xwiki

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Stéphane LASSIRE
Hello Thomas, So I take a look of all messages between you and Mohamed. *1* I put Java 8 root@CESAP-WIKI01:/var/log/tomcat7# java -version java version "1.8.0_91" Java(TM) SE Runtime Environment (build 1.8.0_91-b14) Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode) *2* Put tuning

Re: [xwiki-users] Help configuring Email Sending for User verification

2016-05-25 Thread Vincent Massol
All I can tell you is that XWiki is working fine for sending mail with TLS (I’ve tested it plenty of times using the gmail smtp server). You should also check the status you get in the mail sending status section in the admin. That should give you some details if the mail failed to be sent.

Re: [xwiki-users] Help configuring Email Sending for User verification

2016-05-25 Thread superuser
I tried changing port value to every possible value I could find on intenet. still no luck -- View this message in context: http://xwiki.475771.n2.nabble.com/Help-configuring-Email-Sending-for-User-verification-tp7599610p7599620.html Sent from the XWiki- Users mailing list archive at

Re: [xwiki-users] Help configuring Email Sending for User verification

2016-05-25 Thread superuser
I tried changing it to 143 as shown in image. still no luck -- View this message in context: http://xwiki.475771.n2.nabble.com/Help-configuring-Email-Sending-for-User-verification-tp7599610p7599619.html Sent from the XWiki- Users mailing list archive at Nabble.com.

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Vincent Massol
Note: We’re going to have lots of issues like this if the apt doesn’t update the java version At the very least we need to highlight this in the doc on http://platform.xwiki.org/xwiki/bin/view/AdminGuide/InstallationViaAPT Can someone do this? Thanks -Vincent > On 25 May 2016, at 11:17,

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Thomas Mortagne
8.1 requires Java 8 so you need to make sure you configure Tomcat to use it. Note: it's possible the JVM is explicitely set in /etc/default/tomact7 (in which case Tomcat won't use the default JVM). On Wed, May 25, 2016 at 11:03 AM, Stéphane LASSIRE wrote: > Hello all, >

Re: [xwiki-users] REST API ignores type parameter

2016-05-25 Thread Marius Dumitru Florea
Did you check http://platform.xwiki.org/xwiki/bin/view/Features/XWikiRESTfulAPI#HRootresources ? /wikis/query [since 6.4] using a SOLR query (there's no type parameter) /wikis/{wikiName}/query Allow to execute HQL, XWQL, Lucene or SOLR queries on the given {wikiName}. (has a type parameter) The

Re: [xwiki-users] XWiki 8.1 returning error 404

2016-05-25 Thread Thomas Mortagne
Actually AFAIK the right place is supposed to be /etc/default/tomcat7 which is then read by /etc/init.d/tomcat7. On Tue, May 24, 2016 at 8:25 PM, Mahomed Hussein wrote: > OK! Finally got it! > > I had to add the path to my new JDK to the JDK_DIRS variable in >

[xwiki-users] Filtering boolean values in AppWithinMinutes table

2016-05-25 Thread Ryszard Łach
Hi. In application created by AppWithinMinutes there is a non-functionality of filter on boolean-type columns. Values in such a column are shown as 'Yes/No' (with possible translations), but it is not possible to filter them by 'Yes/No' - one has to use '0' or '1'. It is very non-intuitive.

Re: [xwiki-users] Help configuring Email Sending for User verification

2016-05-25 Thread Vincent Massol
I haven’t followed this thread but port 25 is likely incorrect for TLS. Thanks -Vincent > On 25 May 2016, at 07:27, superuser wrote: > > No matter what settings I use in 'mail sending', the email is not sent. Below > are the details of my email server. Please help me >