Re: [xwiki-users] How to resend activation link

2016-08-16 Thread Mahomed Hussein
Thanks for the response. I'll log it tomorrow as an improvement. Though I'd be 
tempted to argue that it's a bug if it allows the account to get into a state 
where it can't be validated and has to be deleted and re-created. :-)


Kind regards,




Mahomed Hussein
Custodian Data Centre
Email: maho...@custodiandc.com
http://www.CustodianDC.com

-Original Message-
From: users [mailto:users-boun...@xwiki.org] On Behalf Of Vincent Massol
Sent: 16 August 2016 16:32
To: XWiki Users 
Subject: Re: [xwiki-users] How to resend activation link

Hi,

> On 03 Aug 2016, at 14:09, Mahomed Hussein  wrote:
>
> Any ideas please? I've tried to look at the code of the registration page and 
> I can't see how to butcher it resend the email.
>
> Ideally, what should happen is that the page that asks for the validation key 
> should give the option to update the email address and to also resend the 
> email (in case the user made a typo with the email in the first place). 
> Should I log this as a bug?

Sorry can’t help, I don’t know this feature well at all.

You could log an improvement but it doesn’t look like a bug to me.

Thanks
-Vincent

> Kind regards,
>
>
>
>
> Mahomed Hussein
> Custodian Data Centre
> Email: maho...@custodiandc.com
> http://www.CustodianDC.com
>
> -Original Message-
> From: users [mailto:users-boun...@xwiki.org] On Behalf Of Mahomed Hussein
> Sent: 02 August 2016 11:29
> To: XWiki Users 
> Subject: [xwiki-users] How to resend activation link
>
> Hi
>
> Is there a way to re-send the activation link/code to a user without having 
> to delete and recreate the user account? I’ve already configured permissions 
> for this user and I really don’t want to have to do it again please. I 
> created several users and they thought it was wiser to not activate it at the 
> time.
>
>
> Kind regards,
>
>
> Mahomed Hussein
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] LIvetable macro display objects on same page

2016-08-16 Thread Daniel Ullfig

what is the setting of your resultPage parameter of the tableOptions array?

I found while debugging my application that sometimes its something silly 
like the JSON should be returning "true" instead of true (without quotes). 
if the JSON is returning spaces in heading names, that will throw it off 
too.




-Original Message- 
From: Gerritjan Koekkoek

Sent: Tuesday, August 16, 2016 2:30 AM
To: XWiki Users
Subject: Re: [xwiki-users] LIvetable macro display objects on same page

Im on 6.4.7 (no things like terminal pages, but thanks, important as we will 
migrate)



I think the key question is:


Is there any dependancies between what is put in the parameters of the 
livable macro and the resulting JSON



These are the parameters I submit to the macro.

[personKey, observationType, measureNominal, withmilestone, byRole, 
withtopic]
{personKey={type=hidden, filterable=false, sortable=false}, 
observationType={type=hidden, filterable=false, sortable=false}, 
measureNominal={type=number, filterable=false, sortable=false, size=5}, 
withmilestone={type=text, filterable=false, sortable=false, size=5}, 
byRole={type=text, filterable=false, sortable=false, size=5}, 
withtopic={type=hidden, filterable=false, sortable=false, size=10}}
{className=WaihonaCode.observationClass, 
resultPage=Sandbox.testLivetableJSONGenerator, 
translationPrefix=waihonapedia.scorecards.growth.weight., rowCount=10, 
extraParams==RaiKoekkoek=weight=RaiKoekkoek_growthfeeding}



This is the generated JSON

{"totalrows": 2,"matchingtags" : {},"tags" : [],"reqNo": 
1,"returned rows": 2,"offset": 1,


"rows": [{"doc_viewable" : true, "personKey" : 
"RaiKoekkoek","measureNominal" : "2","withmilestone" : "birth","withtopic" : 
"growthfeeding","observationType" : "weight","byRole" : 
"dd"},{"doc_viewable" : true, "personKey" : "RaiKoekkoek","measureNominal" : 
"3","withmilestone" : "","withtopic" : "growthfeeding","observationType" : 
"weight","byRole" : "dd"}]


}

The live tabel does display the total rows and returned rows, but no data


Gerritjan Koekkoek
Vader van Rai Koekkoek (cdls) en voorzitter vereniging CdLS
Visit our website
Facebook
email




From: users  on behalf of Daniel Ullfig 


Sent: 15 August 2016 17:51:04
To: XWiki Users
Subject: Re: [xwiki-users] LIvetable macro display objects on same page

is the page that creates the JSON marked as terminal (no children)? you
might have to add "WebHome" to the name of the page.

Dan

-Original Message-
From: Gerritjan Koekkoek
Sent: Saturday, August 13, 2016 12:56 AM
To: XWiki Users
Subject: Re: [xwiki-users] LIvetable macro display objects on same page

Thanks,

Understand the part of the Array. Think I have that working


When I call the JSON directly it generates the following:

{

"totalrows": 2,

"matchingtags" : {},

"tags" : [],

"reqNo": "$numbertool.integer($request.reqNo)",

"returned rows": 2,

"offset": 1,

"rows": [{"doc_viewable" : true,

"personKey" : "RaiKoekkoek","odatetimestart" : "Tue Nov 02 11:00:44 CET
1999","odatetimeend" : "Fri Jul 15 11:03:11 CEST 2016","oyears" :
"","omonths" : "","measureInterval" : "","measureNominal" :
"2","measureOrdinal" : "","measureRatio" : "","withmilestone" :
"birth","withtopic" : "growthfeeding","observationType" : "weight","byRole"
: "dd",

"object_id" : "1",

"document_count" : "1",

"document_ref" :
"waihonapediaPrivat.RaiKoekkoek_growthfeeding"},{"doc_viewable" : true,

"personKey" : "RaiKoekkoek","odatetimestart" : "Fri Dec 31 03:09:07 CET
1999","odatetimeend" : "","oyears" : "","omonths" : "","measureInterval" :
"","measureNominal" : "3","measureOrdinal" : "","measureRatio" :
"","withmilestone" : "","withtopic" : "growthfeeding","observationType" :
"weight","byRole" : "dd",

"object_id" : "2",

"document_count" : "1",

"document_ref" : "waihonapediaPrivat.RaiKoekkoek_growthfeeding"}]

}


Which is good as the page holding the objects holds 2 objects that match
criteria and 2 other objects that do not match criteria.


Problem is that the table shows the Total rows but the records (table-rows)
are not showing

Is the JSON in the right format, what about doc_viewable?


Gerritjan Koekkoek
Vader van Rai Koekkoek (cdls) en voorzitter vereniging CdLS
Visit our website
Facebook
email




From: users  on behalf of Daniel Ullfig

Sent: 12 August 2016 22:43:40
To: XWiki Users
Subject: Re: [xwiki-users] LIvetable macro display objects on same page

you won't be able to use HQL because it will return a list of pages, all
pointing to the same page. A good starting point is the example given in the
Livetable Macro documentation. I used that as a 

Re: [xwiki-users] How to resend activation link

2016-08-16 Thread Vincent Massol
Hi,

> On 03 Aug 2016, at 14:09, Mahomed Hussein  wrote:
> 
> Any ideas please? I've tried to look at the code of the registration page and 
> I can't see how to butcher it resend the email.
> 
> Ideally, what should happen is that the page that asks for the validation key 
> should give the option to update the email address and to also resend the 
> email (in case the user made a typo with the email in the first place). 
> Should I log this as a bug?

Sorry can’t help, I don’t know this feature well at all.

You could log an improvement but it doesn’t look like a bug to me. 

Thanks
-Vincent

> Kind regards,
> 
> 
> 
> 
> Mahomed Hussein
> Custodian Data Centre
> Email: maho...@custodiandc.com
> http://www.CustodianDC.com
> 
> -Original Message-
> From: users [mailto:users-boun...@xwiki.org] On Behalf Of Mahomed Hussein
> Sent: 02 August 2016 11:29
> To: XWiki Users 
> Subject: [xwiki-users] How to resend activation link
> 
> Hi
> 
> Is there a way to re-send the activation link/code to a user without having 
> to delete and recreate the user account? I’ve already configured permissions 
> for this user and I really don’t want to have to do it again please. I 
> created several users and they thought it was wiser to not activate it at the 
> time.
> 
> 
> Kind regards,
> 
> 
> Mahomed Hussein
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] mobile/tablet support for new templates

2016-08-16 Thread Ecaterina Moraru (Valica)
Hi,

So yes the template are meant to work on mobile, but as you said the logic
behind the order of sections could be improved.

Regarding how to do it, you could  change the order of the .col-xs-*
containers and then use the '.pull-right' class for the contents section
(to make sure it still looks the same for desktop).

Would you be interested in providing a PR for these changes?
The code is available at
https://github.com/xwiki-contrib/application-templates/tree/master/application-templates-ui/src/main/resources/Templates

Thanks,
Caty

On Wed, Aug 3, 2016 at 6:16 PM, superuser  wrote:

> The new 4 templates in 8.2 are nice. But the view on mobile need to be
> corrected, i think.. e.g. the contents section of encyclopedia template
> should come at top but currently its at bottom when view on small screens.
> I
> dont intend to change the template structure for large/ PC screens (they
> are
> really good), but want to adjust for small screens.
> How can i do that?
> Also any help on 'how to reorganize content view on mobile' is appreciated.
>
>
>
> --
> View this message in context: http://xwiki.475771.n2.nabble.
> com/mobile-tablet-support-for-new-templates-tp7600556.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> ___
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Syntax Highlighting

2016-08-16 Thread Vincent Massol

> On 16 Aug 2016, at 16:51, Vincent Massol  wrote:
> 
> Hi Benedict,
> 
>> On 16 Aug 2016, at 16:35, Benedict NNcNannara  
>> wrote:
>> 
>> I have started a Wiki on Windows Programming  in a
>> new language called Hecsadecinnal .
>> It has code in the C# and C++ languages. I need syntax highlighting to make
>> the web site look respectable by modern standards. Does XWiki support
>> syntax highlighting?
> 
> Yep, see 
> http://extensions.xwiki.org/xwiki/bin/view/Extension/Syntax+Highlighting+Application

oops, actually I think what you need is the Code Macro actually:
http://extensions.xwiki.org/xwiki/bin/view/Extension/Code+Macro

Thanks
-Vincent

> Thanks
> -Vincent
> 

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Syntax Highlighting

2016-08-16 Thread Vincent Massol
Hi Benedict,

> On 16 Aug 2016, at 16:35, Benedict NNcNannara  
> wrote:
> 
> I have started a Wiki on Windows Programming  in a
> new language called Hecsadecinnal .
> It has code in the C# and C++ languages. I need syntax highlighting to make
> the web site look respectable by modern standards. Does XWiki support
> syntax highlighting?

Yep, see 
http://extensions.xwiki.org/xwiki/bin/view/Extension/Syntax+Highlighting+Application

Thanks
-Vincent

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] Syntax Highlighting

2016-08-16 Thread Benedict NNcNannara
I have started a Wiki on Windows Programming  in a
new language called Hecsadecinnal .
It has code in the C# and C++ languages. I need syntax highlighting to make
the web site look respectable by modern standards. Does XWiki support
syntax highlighting?
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] [xwiki-devs] [myxwiki] XWiki Enterprise 8.2.1 Upgrade

2016-08-16 Thread Vincent Massol
Thanks Thomas for doing this upgrade! :)
-Vincent

> On 04 Aug 2016, at 12:14, Thomas Mortagne  wrote:
> 
> Hi everyone,
> 
> myxwiki.org has been upgraded to XE 8.2.1. If you own a wiki hosted
> there you should have a look at the release notes for this version at:
> http://www.xwiki.org/xwiki/bin/view/ReleaseNotes/
> 
> You should automatically get an upgrade wizard for your wiki when you
> login as admin.
> For more details see the upgrade guide available at :
> http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Upgrade#HUpgradingwikidocuments
> 
> To be notified of the myxwiki.org server upgrade you can follow
> myxwiki on twitter:
> http://twitter.com/myxwiki
> 
> Thanks,
> -XWiki Community
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Question about panel sizing

2016-08-16 Thread Ecaterina Moraru (Valica)
Hi,

The width of panels is computed in layout.less.

Thanks,
Caty

On Tue, Aug 16, 2016 at 3:07 PM, Vincent Massol  wrote:

> Hi Rudi,
>
> > On 16 Aug 2016, at 13:58, Rudi Ritosalo  wrote:
> >
> > Hello,
> >
> > I am asking help on the matter of changing the left and right panel size
> of the XWiki i've installed. I'm using a war installed Xwiki 8.1 with a
> flamingo theme. So far from what I've gathered is
> > that usable panel sizes are small, medium and large. What I'm looking
> for is something between small and medium. Is there a .vm or a .css file in
> the WAR package where I can modify
> > the width of the panels manually? Or is there some other way to more
> precisely alter the width of the panels?
>
> I don’t have a precise answer but I’d use your browser dev tools and use
> CSS to find what to override.
>
> Then I’d use an SSX, see http://platform.xwiki.org/
> xwiki/bin/view/DevGuide/SkinExtensionsTutorial
>
> IMO that’s better than changing the default since it’ll allow you to
> upgrade with less problems in the future.
>
> Thanks
> -Vincent
>
> > Thanks in advance,
> >
> > Rudi
>
> ___
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] failed to execute velocity macros

2016-08-16 Thread Eduard Moraru
Oh, and remember to re-add the user to XWiki.XWikiAdminGroup, in case it
was removed by the delete operation.

On Tue, Aug 16, 2016 at 3:26 PM, Eduard Moraru  wrote:

> Hi, Tom,
>
> Depends how you`ve deleted the Admin user.
>
> If you`ve just sent it to the recycle bin, then going on the http://
> /xwiki/bin/view/XWiki/Admin page should show you the option to
> restore the profile page from recycle bin.
>
> If no such option exists (and you`ve deleted it from the recycle bin as
> well), the you have to recreate it. Just go to the same page, press the +
> (create page) button, make sure "Terminal page" is checked and hit
> "create", then "save". After that, go into object edit mode on the same
> page and add an object of the class XWiki.XWikiUser. Hit "Save" and the go
> into view mode where it should start looking like a user profile page
> again. The next thing would be to reset its password so that you can then
> log in with it at some point.
>
> Another option (instead of recreating it) would be to completely restore
> it by manually re-import just the XWiki.Admin page from the UI XAR, but I
> would need to know what exact XWiki version you have so I can give you the
> right link.
>
> Thanks,
> Eduard
>
> On Tue, Aug 16, 2016 at 12:31 PM, Tom Neumann 
> wrote:
>
>> Hi Eduard,
>>
>> thanks for your help!
>> How can I recreate the user if the macros don't work at that point?
>> It does not seem to work out.
>>
>> Thanks,
>> Tom
>>
>> > From: enygma2...@gmail.com
>> > Date: Tue, 16 Aug 2016 12:25:05 +0300
>> > To: users@xwiki.org
>> > Subject: Re: [xwiki-users] failed to execute velocity macros
>> >
>> > Hi,
>> >
>> > Deleting the XWiki.Admin user is not a good idea. It is generally used
>> as
>> > the last author and content editor of pretty much all the default XWiki
>> > documents, most of them containing scripts. A script can only execute if
>> > its last content author has the SCRIPT right. If that author is deleted,
>> > then the script also loses its right to execute. So it does not matter
>> what
>> > user you use to *see* the script, but what user you used to *save* the
>> > script (thus granting it the rights of this last user/author).
>> >
>> > My suggestion is that you undelete/recreate the XWiki.Admin user
>> (easiest
>> > option) and then disable it (i.e. mark it as inactive to not allow it to
>> > log in), if you don`t want to use it. This way the old scripts inside
>> wiki
>> > pages will resume functioning.
>> >
>> > Note that this is not only about the Admin user, so you need to be aware
>> > that once you delete a user, you "revoke" the right of execution for any
>> > scripts he might have authored. This is generally a good thing, but it
>> can
>> > also bite you, as you`ve seen.
>> >
>> > This extension might also be useful (but recommended only for users
>> other
>> > than XWiki.Admin):
>> > http://extensions.xwiki.org/xwiki/bin/view/Extension/Change+
>> Content+Author
>> >
>> > Hope this helps,
>> > Eduard
>> >
>> > On Tue, Aug 16, 2016 at 11:38 AM, Tom Neumann 
>> > wrote:
>> >
>> > > Hi all,
>> > >
>> > > I've got a problem with my xwiki build right now.
>> > > I configured LDAP and gave my LDAP user all the rights on the wiki,
>> but I
>> > > forgot to make him the owner of the wiki.
>> > > After that I logged in with the LDAP user and deleted the old admin
>> > > account and tried to set my LDAP user as owner of the wiki.
>> > >
>> > > Now every page shows this message:
>> > > Failed
>> > >  to execute the [velocity] macro. Cause: [The execution of the
>> > > [velocity] script macro is not allowed. Check the rights of its last
>> > > author or the parameters if it's rendered from another script.]. Click
>> > > on this message for details.
>> > >
>> > > Even the superuser account can't see the pages normally.
>> > > What can I do? Is there a setting to give velocity macro rights to
>> > > everybody?
>> > > Or can I edit the database somehow?...
>> > >
>> > > Thanks,
>> > > Tom
>> > >
>> > > ___
>> > > users mailing list
>> > > users@xwiki.org
>> > > http://lists.xwiki.org/mailman/listinfo/users
>> > >
>> > ___
>> > users mailing list
>> > users@xwiki.org
>> > http://lists.xwiki.org/mailman/listinfo/users
>>
>> ___
>> users mailing list
>> users@xwiki.org
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>
>
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] failed to execute velocity macros

2016-08-16 Thread Eduard Moraru
Hi, Tom,

Depends how you`ve deleted the Admin user.

If you`ve just sent it to the recycle bin, then going on the
http:///xwiki/bin/view/XWiki/Admin
page should show you the option to restore the profile page from recycle
bin.

If no such option exists (and you`ve deleted it from the recycle bin as
well), the you have to recreate it. Just go to the same page, press the +
(create page) button, make sure "Terminal page" is checked and hit
"create", then "save". After that, go into object edit mode on the same
page and add an object of the class XWiki.XWikiUser. Hit "Save" and the go
into view mode where it should start looking like a user profile page
again. The next thing would be to reset its password so that you can then
log in with it at some point.

Another option (instead of recreating it) would be to completely restore it
by manually re-import just the XWiki.Admin page from the UI XAR, but I
would need to know what exact XWiki version you have so I can give you the
right link.

Thanks,
Eduard

On Tue, Aug 16, 2016 at 12:31 PM, Tom Neumann 
wrote:

> Hi Eduard,
>
> thanks for your help!
> How can I recreate the user if the macros don't work at that point?
> It does not seem to work out.
>
> Thanks,
> Tom
>
> > From: enygma2...@gmail.com
> > Date: Tue, 16 Aug 2016 12:25:05 +0300
> > To: users@xwiki.org
> > Subject: Re: [xwiki-users] failed to execute velocity macros
> >
> > Hi,
> >
> > Deleting the XWiki.Admin user is not a good idea. It is generally used as
> > the last author and content editor of pretty much all the default XWiki
> > documents, most of them containing scripts. A script can only execute if
> > its last content author has the SCRIPT right. If that author is deleted,
> > then the script also loses its right to execute. So it does not matter
> what
> > user you use to *see* the script, but what user you used to *save* the
> > script (thus granting it the rights of this last user/author).
> >
> > My suggestion is that you undelete/recreate the XWiki.Admin user (easiest
> > option) and then disable it (i.e. mark it as inactive to not allow it to
> > log in), if you don`t want to use it. This way the old scripts inside
> wiki
> > pages will resume functioning.
> >
> > Note that this is not only about the Admin user, so you need to be aware
> > that once you delete a user, you "revoke" the right of execution for any
> > scripts he might have authored. This is generally a good thing, but it
> can
> > also bite you, as you`ve seen.
> >
> > This extension might also be useful (but recommended only for users other
> > than XWiki.Admin):
> > http://extensions.xwiki.org/xwiki/bin/view/Extension/
> Change+Content+Author
> >
> > Hope this helps,
> > Eduard
> >
> > On Tue, Aug 16, 2016 at 11:38 AM, Tom Neumann 
> > wrote:
> >
> > > Hi all,
> > >
> > > I've got a problem with my xwiki build right now.
> > > I configured LDAP and gave my LDAP user all the rights on the wiki,
> but I
> > > forgot to make him the owner of the wiki.
> > > After that I logged in with the LDAP user and deleted the old admin
> > > account and tried to set my LDAP user as owner of the wiki.
> > >
> > > Now every page shows this message:
> > > Failed
> > >  to execute the [velocity] macro. Cause: [The execution of the
> > > [velocity] script macro is not allowed. Check the rights of its last
> > > author or the parameters if it's rendered from another script.]. Click
> > > on this message for details.
> > >
> > > Even the superuser account can't see the pages normally.
> > > What can I do? Is there a setting to give velocity macro rights to
> > > everybody?
> > > Or can I edit the database somehow?...
> > >
> > > Thanks,
> > > Tom
> > >
> > > ___
> > > users mailing list
> > > users@xwiki.org
> > > http://lists.xwiki.org/mailman/listinfo/users
> > >
> > ___
> > users mailing list
> > users@xwiki.org
> > http://lists.xwiki.org/mailman/listinfo/users
>
> ___
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Question about panel sizing

2016-08-16 Thread Vincent Massol
Hi Rudi,

> On 16 Aug 2016, at 13:58, Rudi Ritosalo  wrote:
> 
> Hello,
> 
> I am asking help on the matter of changing the left and right panel size of 
> the XWiki i've installed. I'm using a war installed Xwiki 8.1 with a flamingo 
> theme. So far from what I've gathered is
> that usable panel sizes are small, medium and large. What I'm looking for is 
> something between small and medium. Is there a .vm or a .css file in the WAR 
> package where I can modify
> the width of the panels manually? Or is there some other way to more 
> precisely alter the width of the panels?

I don’t have a precise answer but I’d use your browser dev tools and use CSS to 
find what to override.

Then I’d use an SSX, see 
http://platform.xwiki.org/xwiki/bin/view/DevGuide/SkinExtensionsTutorial

IMO that’s better than changing the default since it’ll allow you to upgrade 
with less problems in the future.

Thanks
-Vincent

> Thanks in advance,
> 
> Rudi

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] Question about panel sizing

2016-08-16 Thread Rudi Ritosalo
Hello,

I am asking help on the matter of changing the left and right panel size of the 
XWiki i've installed. I'm using a war installed Xwiki 8.1 with a flamingo 
theme. So far from what I've gathered is
that usable panel sizes are small, medium and large. What I'm looking for is 
something between small and medium. Is there a .vm or a .css file in the WAR 
package where I can modify
the width of the panels manually? Or is there some other way to more precisely 
alter the width of the panels?

Thanks in advance,

Rudi



T?m? s?hk?postiviesti (liitteineen) saattaa sis?lt?? luottamuksellista tietoa, 
joka on tarkoitettu
vain vastaanottajalleen. Jos et ole oikea vastaanottaja, ilmoita viestin 
l?hett?j?lle tapahtuneesta
virheest? ja tuhoa viesti v?litt?m?sti. Viestin luvaton julkaiseminen, 
kopioiminen, jakelu tai muu
k?ytt? tai toimenpiteisiin ryhtyminen sen perusteella on ehdottomasti kielletty.

This message (including any attachments) may contain confidential information 
intended for
the person or entity to which it is addressed. If you are not the intended 
recipient, notify the
sender and delete this message immediately. Notice that disclosing, copying, 
distributing or any
other use of the message and its information, or taking any action based on it, 
is strictly prohibited.


___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] LIvetable macro display objects on same page

2016-08-16 Thread Gerritjan Koekkoek
Im on 6.4.7 (no things like terminal pages, but thanks, important as we will 
migrate)


I think the key question is:


Is there any dependancies between what is put in the parameters of the livable 
macro and the resulting JSON


These are the parameters I submit to the macro.

[personKey, observationType, measureNominal, withmilestone, byRole, withtopic]
{personKey={type=hidden, filterable=false, sortable=false}, 
observationType={type=hidden, filterable=false, sortable=false}, 
measureNominal={type=number, filterable=false, sortable=false, size=5}, 
withmilestone={type=text, filterable=false, sortable=false, size=5}, 
byRole={type=text, filterable=false, sortable=false, size=5}, 
withtopic={type=hidden, filterable=false, sortable=false, size=10}}
{className=WaihonaCode.observationClass, 
resultPage=Sandbox.testLivetableJSONGenerator, 
translationPrefix=waihonapedia.scorecards.growth.weight., rowCount=10, 
extraParams==RaiKoekkoek=weight=RaiKoekkoek_growthfeeding}


This is the generated JSON

{"totalrows": 2,"matchingtags" : {},"tags" : [],"reqNo": 
1,"returned rows": 2,"offset": 1,

"rows": [{"doc_viewable" : true, "personKey" : "RaiKoekkoek","measureNominal" : 
"2","withmilestone" : "birth","withtopic" : "growthfeeding","observationType" : 
"weight","byRole" : "dd"},{"doc_viewable" : true, "personKey" : 
"RaiKoekkoek","measureNominal" : "3","withmilestone" : "","withtopic" : 
"growthfeeding","observationType" : "weight","byRole" : "dd"}]

}

The live tabel does display the total rows and returned rows, but no data


Gerritjan Koekkoek
Vader van Rai Koekkoek (cdls) en voorzitter vereniging CdLS
Visit our website
Facebook
email




From: users  on behalf of Daniel Ullfig 

Sent: 15 August 2016 17:51:04
To: XWiki Users
Subject: Re: [xwiki-users] LIvetable macro display objects on same page

is the page that creates the JSON marked as terminal (no children)? you
might have to add "WebHome" to the name of the page.

Dan

-Original Message-
From: Gerritjan Koekkoek
Sent: Saturday, August 13, 2016 12:56 AM
To: XWiki Users
Subject: Re: [xwiki-users] LIvetable macro display objects on same page

Thanks,

Understand the part of the Array. Think I have that working


When I call the JSON directly it generates the following:

{

"totalrows": 2,

"matchingtags" : {},

"tags" : [],

"reqNo": "$numbertool.integer($request.reqNo)",

"returned rows": 2,

"offset": 1,

"rows": [{"doc_viewable" : true,

"personKey" : "RaiKoekkoek","odatetimestart" : "Tue Nov 02 11:00:44 CET
1999","odatetimeend" : "Fri Jul 15 11:03:11 CEST 2016","oyears" :
"","omonths" : "","measureInterval" : "","measureNominal" :
"2","measureOrdinal" : "","measureRatio" : "","withmilestone" :
"birth","withtopic" : "growthfeeding","observationType" : "weight","byRole"
: "dd",

"object_id" : "1",

"document_count" : "1",

"document_ref" :
"waihonapediaPrivat.RaiKoekkoek_growthfeeding"},{"doc_viewable" : true,

"personKey" : "RaiKoekkoek","odatetimestart" : "Fri Dec 31 03:09:07 CET
1999","odatetimeend" : "","oyears" : "","omonths" : "","measureInterval" :
"","measureNominal" : "3","measureOrdinal" : "","measureRatio" :
"","withmilestone" : "","withtopic" : "growthfeeding","observationType" :
"weight","byRole" : "dd",

"object_id" : "2",

"document_count" : "1",

"document_ref" : "waihonapediaPrivat.RaiKoekkoek_growthfeeding"}]

}


Which is good as the page holding the objects holds 2 objects that match
criteria and 2 other objects that do not match criteria.


Problem is that the table shows the Total rows but the records (table-rows)
are not showing

Is the JSON in the right format, what about doc_viewable?


Gerritjan Koekkoek
Vader van Rai Koekkoek (cdls) en voorzitter vereniging CdLS
Visit our website
Facebook
email




From: users  on behalf of Daniel Ullfig

Sent: 12 August 2016 22:43:40
To: XWiki Users
Subject: Re: [xwiki-users] LIvetable macro display objects on same page

you won't be able to use HQL because it will return a list of pages, all
pointing to the same page. A good starting point is the example given in the
Livetable Macro documentation. I used that as a starting point. You need to
read all the objects into an array using $doc.getObjects( 'myClass' ), where
myClass is the name of your xwiki object class.

Dan

-Original Message-
From: Gerritjan Koekkoek
Sent: Friday, August 12, 2016 8:47 AM
To: XWiki Users
Subject: Re: [xwiki-users] LIvetable macro display objects on same page

Yes, that's correct, thank you...

Is there a convenient way to generate the json for a set of objects of one
class on one page?


Gerritjan Koekkoek
Vader van Rai 

Re: [xwiki-users] failed to execute velocity macros

2016-08-16 Thread Eduard Moraru
Hi,

Deleting the XWiki.Admin user is not a good idea. It is generally used as
the last author and content editor of pretty much all the default XWiki
documents, most of them containing scripts. A script can only execute if
its last content author has the SCRIPT right. If that author is deleted,
then the script also loses its right to execute. So it does not matter what
user you use to *see* the script, but what user you used to *save* the
script (thus granting it the rights of this last user/author).

My suggestion is that you undelete/recreate the XWiki.Admin user (easiest
option) and then disable it (i.e. mark it as inactive to not allow it to
log in), if you don`t want to use it. This way the old scripts inside wiki
pages will resume functioning.

Note that this is not only about the Admin user, so you need to be aware
that once you delete a user, you "revoke" the right of execution for any
scripts he might have authored. This is generally a good thing, but it can
also bite you, as you`ve seen.

This extension might also be useful (but recommended only for users other
than XWiki.Admin):
http://extensions.xwiki.org/xwiki/bin/view/Extension/Change+Content+Author

Hope this helps,
Eduard

On Tue, Aug 16, 2016 at 11:38 AM, Tom Neumann 
wrote:

> Hi all,
>
> I've got a problem with my xwiki build right now.
> I configured LDAP and gave my LDAP user all the rights on the wiki, but I
> forgot to make him the owner of the wiki.
> After that I logged in with the LDAP user and deleted the old admin
> account and tried to set my LDAP user as owner of the wiki.
>
> Now every page shows this message:
> Failed
>  to execute the [velocity] macro. Cause: [The execution of the
> [velocity] script macro is not allowed. Check the rights of its last
> author or the parameters if it's rendered from another script.]. Click
> on this message for details.
>
> Even the superuser account can't see the pages normally.
> What can I do? Is there a setting to give velocity macro rights to
> everybody?
> Or can I edit the database somehow?...
>
> Thanks,
> Tom
>
> ___
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] failed to execute velocity macros

2016-08-16 Thread Tom Neumann
Hi all,

I've got a problem with my xwiki build right now.
I configured LDAP and gave my LDAP user all the rights on the wiki, but I 
forgot to make him the owner of the wiki.
After that I logged in with the LDAP user and deleted the old admin account and 
tried to set my LDAP user as owner of the wiki.

Now every page shows this message:
Failed
 to execute the [velocity] macro. Cause: [The execution of the 
[velocity] script macro is not allowed. Check the rights of its last 
author or the parameters if it's rendered from another script.]. Click 
on this message for details.

Even the superuser account can't see the pages normally.
What can I do? Is there a setting to give velocity macro rights to everybody?
Or can I edit the database somehow?...

Thanks,
Tom
  
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] myxwiki down still (or again)

2016-08-16 Thread Vincent Massol
Hi Regan and all,

I’m just back from holiday this morning. The myxwiki.org machine is not 
responding and I can’t even ssh to it. I’ve pinged the admin of that machine 
for help. Hopefully we should be able to get it back online sometime today.

Thanks and sorry about that
-Vincent

> On 16 Aug 2016, at 05:49, Regan Gill  wrote:
> 
> Hello,
> 
> It appears that myxwiki.org is down. I have been unable to access our xwiki 
> (http://scservicesub.myxwiki.org/) since August 13 and it appears down again 
> now. Has anyone looked at it?
> Thanks,Regan
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users