Re: [xwiki-users] Moving the Blog doesnt work

2017-03-25 Thread Clemens Klein-Robbenhaar
Are these domains on different subwikis? You might be able to install the Blog Application on the second domain in this case (it seems it did not already exist there) Otherwise ... some more information about what "it broke" means would be heplful just a guess fo mine clemens -

Re: [xwiki-users] Change Numbering in TOC Macro

2016-10-28 Thread Clemens Klein-Robbenhaar
On 10/26/2016 03:03 PM, Hofstätter Mario wrote: > There is an example on how to change TOC numbering: > http://extensions.xwiki.org/xwiki/bin/view/Extension/TOC+Macro#HExample3:Differentnumberingofsublists > However, it does not work, and even the screenshot on that page does not > display the

Re: [xwiki-users] XWiki failed to load due to mysql driver error

2016-10-12 Thread Clemens Klein-Robbenhaar
gt; I already kept mysql-connector-java-5.1.21.jar files in application library > but still getting above error while tomcat startup. > > Thanks & Regards, > Piyush > > > > _______________ > users mailing list > users@xwiki.o

Re: [xwiki-users] Program = Admin Expected Behavior?

2016-09-29 Thread Clemens Klein-Robbenhaar
Yes, this is the expected behaviour. The rationale behind this is that users with "Programming" right can add scripting content to pages that does not need to pass the usual permission checks; this is sometimes necessary for some "advanced" UI operations. As a consequence every user with

Re: [xwiki-users] Watchlist email links use localhost instead of server hostname

2016-09-23 Thread Clemens Klein-Robbenhaar
If I remember correctly, XWiki uses the first incoming request to store the information by which hostname it is called, and uses this information in the background thread that sends the watchlist mails. a) If you are sure that everyone accesses your wiki through the actual host name, you

[xwiki-users] [ANN] Publication Workflow Application v1.7 released

2016-09-08 Thread Clemens Klein-Robbenhaar
Hi all, a new release of the "XWiki Publication Workflow Application" is available right now: http://extensions.xwiki.org/xwiki/bin/view/Extension/XWiki+Publication+Workflow+Application This release mainly adds the new feature to support workflows for multi-language pages. Minor

Re: [xwiki-users] Can't Upgrade from XWiki 3.5.1

2016-07-26 Thread Clemens Klein-Robbenhaar
E > [dbo].[xwikifloats] ADD CONSTRAINT [FKFB291FBF1DFF14A1] FOREIGN KEY > ([XWF_ID], [XWF_NAME]) REFERENCES [dbo].[xwikiproperties] ([XWP_ID], > [XWP_NAME]) ON UPDATE CASCADE: There is already an object named > 'FKFB291FBF1DFF14A1' in the database./ > > Maybe it makes no sense to co

Re: [xwiki-users] Can't Upgrade from XWiki 3.5.1

2016-07-04 Thread Clemens Klein-Robbenhaar
ration. Now I'm stuck with a > new type of error, please see line 162 here http://pastebin.com/YLzwvxmh. > > Has somebody ever seen this? > > Thank you and best regards > Josef > > > Clemens Klein-Robbenhaar wrote >> Oh, this looks odd. >>

Re: [xwiki-users] Link to page on a sub-wiki

2016-06-29 Thread Clemens Klein-Robbenhaar
I feel even dumber. > Thanks for the help! > > 2016-06-29 14:45 GMT+02:00 Clemens Klein-Robbenhaar < > c.robbenh...@espresto.com>: > >> >> This looks totally strange to me. >> I just tried to reproduce with an old 7.0.1 installation I had lying >> arou

Re: [xwiki-users] Integrate clipboard.js into XWiki application

2016-06-29 Thread Clemens Klein-Robbenhaar
Uh, tough, is there something like a stack trace for the error message? First stop would be to check is the clipboard.min.js is really loaded and displays without error, but I guess it does as otherwise the problem would appear on page load already ... One thing that looks odd to me is: >

Re: [xwiki-users] Link to page on a sub-wiki

2016-06-29 Thread Clemens Klein-Robbenhaar
s of my link I copied the above to the address bar > of my browser and replaced "/create/" with "/view/" and voila, the page is > shown. So my link is indeed correct which makes the problem even stranger > ... > > Any further ideas? Otherwise it seems I need to hard-l

Re: [xwiki-users] NullPointerException at HqlSqlWalker.lookupProperty( HqlSqlWalker.java:560)

2016-06-29 Thread Clemens Klein-Robbenhaar
Uh, oh, this looks like this problem reported last year: http://markmail.org/thread/4iigsjpxdaw2qzzq the issue went away there when using mySQL - for unknown reasons, so that time we did not really find a solution. hope we can do better this time. - Ursprüngliche Nachricht - Von:

Re: [xwiki-users] Link to page on a sub-wiki

2016-06-28 Thread Clemens Klein-Robbenhaar
> paul > > Clemens Klein-Robbenhaar wrote: >> Maybe there is yet another whitespace missing, or the like? ___ users mailing list users@xwiki.org http://lists.xwiki.org/mailman/listinfo/users

Re: [xwiki-users] Link to page on a sub-wiki

2016-06-28 Thread Clemens Klein-Robbenhaar
Just a quick thought, maybe it helps: You can try: [[Label>>doc:Products:A Product.The Page]] the "doc" prefix should make sure the rest is interpreted as a path to a wiki page, not something else. Oh, and to which non-existing page does the link lead, if it is not the already existing page?

Re: [xwiki-users] Incident lors de l'enregistrement d'une page

2016-06-28 Thread Clemens Klein-Robbenhaar
Hi Wilfrid, I am not ignoring you, I am just puzzled by the problem (that I can not reproduce) :( Something is wrong with the application server, or the communication between the application server and the apache frontend server. Do you have access to the log files of the application

Re: [xwiki-users] Can't Upgrade from XWiki 3.5.1

2016-06-28 Thread Clemens Klein-Robbenhaar
tatements. > Please see http://pastebin.com/BFABwpNz. > > All the errors are in relation to the xwikidates table. > Do you have any idea how to fix this? > > Thanks again and best regards > Josef > > > Clemens Klein-Robbenhaar wrote >> It seems a DB migration

Re: [xwiki-users] Can't Upgrade from XWiki 3.5.1

2016-06-28 Thread Clemens Klein-Robbenhaar
It seems a DB migration failed; you can find the error in the log file after startup, above of the messages you posted. It is likely that it is the statistics migration You can try the SQL statements from here: http://jira.xwiki.org/browse/XWIKI-8129 as found in the release notes of 4.3:

Re: [xwiki-users] Integrate mocca calendar and meeting application extensions

2016-06-23 Thread Clemens Klein-Robbenhaar
I have to admit that I have not thought about that, and looking at the lack of replies, nobody else did so far. There is a calendar view for the meetings in the Meeting/calendarView Page: http://extensions.xwiki.org/xwiki/bin/view/Extension/Meeting+Application#HCalendarView but this one

Re: [xwiki-users] Incident lors de l'enregistrement d'une page

2016-06-23 Thread Clemens Klein-Robbenhaar
_____ > users mailing list > users@xwiki.org > http://lists.xwiki.org/mailman/listinfo/users > mit freundlichen Grüßen Clemens Klein-Robbenhaar -- Clemens Klein-Robbenhaar Software Development EsPresto AG Breite Str. 30-31 10178 Berlin/Germany Tel: +49.

Re: [xwiki-users] Incident lors de l'enregistrement d'une page

2016-06-22 Thread Clemens Klein-Robbenhaar
Hi Lewil, the error message "Bad gateway" does not come from XWiki directly, but from some other Server in between. Can you tell us more about your setup? Is there another Server running in front of XWiki, like an Apache Web Server or NginX ? Does the problem go away if you save the page

Re: [xwiki-users] xwiki 8.1 as Debian installation

2016-06-17 Thread Clemens Klein-Robbenhaar
hm, it looks like XWiki is not even able to produce an error message sometimes there is more information in the catalina.-MM-DD.log or the localhost.-MM-DD.log (but in this case I doubt it) just a guess: are you using Java8 or an older version? XWiki 8.x requires Java8 to run On:

Re: [xwiki-users] Xwiki replace " " with "+" on title

2016-06-17 Thread Clemens Klein-Robbenhaar
Hi Stefano, thanks for letting us know about the solution to your problem. On thing that has changed from tomcat7 to tomcat8 is that the default URL-Encoding has changed from ISO-8859-1 to UTF-8 (compare http://tomcat.apache.org/tomcat-7.0-doc/config/http.html with

Re: [xwiki-users] Xwiki replace " " with "+" on title

2016-06-15 Thread Clemens Klein-Robbenhaar
/xwiki.475771.n2.nabble.com/Xwiki-replace-with-on-title-tp7599972p7599978.html > Sent from the XWiki- Users mailing list archive at Nabble.com. > ___ > users mailing list > users@xwiki.org > http://lists.xwiki.org/mailman/listinfo/users

Re: [xwiki-users] Changing border-top color of basic tables

2016-06-15 Thread Clemens Klein-Robbenhaar
Not really a good advice, but kind of a workaround: when I have the problem of styling only tables inside the wiki-content and nothing else, I use the "Approach 2", except that the selector looks like #xwikicontent>table { ... } this selector does not style the livetables, because they are

Re: [xwiki-users] Error upgrading Debian

2016-05-25 Thread Clemens Klein-Robbenhaar
15" still looks like a Java version > issue. > > Could you check what version of Java started with "ps aux | grep tomcat" ? > > _______ > users mailing list > users@xwiki.org > http://lists.xwiki.org/mailman/listinfo/user

Re: [xwiki-users] relation Code and Translation key's App-Within-Minutes

2016-05-13 Thread Clemens Klein-Robbenhaar
> Facebook<https://www.facebook.com/gerritjan.koekkoek> > email<gerrit...@cdlsworld.org> > > > > ___ > users mailing list > users@xwiki.org > http://lists.xwiki.org/mailman/listinfo/users > mit freundlichen G

Re: [xwiki-users] Document save hook to modify content

2016-05-11 Thread Clemens Klein-Robbenhaar
Shameless Plug: If you want a document listener as a wiki page, you can check out) http://extensions.xwiki.org/xwiki/bin/view/Extension/RepairWikiLinks (install/import it into a demo instance and look at the page XWiki.RepairWikiLinksOnPageSave in the object editor). If you want to

Re: [xwiki-users] Missing border and background color of "code" macro in exported pdf

2016-05-09 Thread Clemens Klein-Robbenhaar
About the missing border: I forgot that there is this bug: http://jira.xwiki.org/browse/XWIKI-13163 "Border style is not displayed, when we specify it on the pdf.css" the workaround described in the issue works well, even though it is quite a a bit of copy & paste; the result looks like:

Re: [xwiki-users] Problem with SQL Server Database

2016-05-09 Thread Clemens Klein-Robbenhaar
e. Is this a well known issue and if what I do to >> resolve that problem? >> >> Regards, >> Sebastian. >> >> -Ursprüngliche Nachricht- >> Von: users [mailto:users-boun...@xwiki.org] Im Auftrag von Clemens >> Klein-Robbenhaar >> Gesendet: Mittwo

Re: [xwiki-users] Date format in FAQ application

2016-05-06 Thread Clemens Klein-Robbenhaar
The right format is probably '-MM-dd hh:mm:ss'. with only one 'm' for minute it tries to show minute as single digit when ever possible ... which is just what your got > Anybody, any idea ? I noticed the format is broken also in view/Main/AllDocs > table. > > R. > > On 2016-04-25

Re: [xwiki-users] Missing border and background color of "code" macro in exported pdf

2016-05-06 Thread Clemens Klein-Robbenhaar
Details about changing the rendering of the PDF are documented here: http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Configuration#HCustomizingthePDFexportLook26Feel In your case to change the background color the easiest solution is probably to attach a file named "pdf.css" to the page

Re: [xwiki-users] Running a second xwiki instance in a single apache tomcat installation

2016-05-04 Thread Clemens Klein-Robbenhaar
it is a known issue; please see answer here: http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Installation#HRunningmultipleinstancesofXWikiinthesamecontainer hth clemens > Dear all, > > thanks for your help regarding to my question about ACE related javascript > errors when editing

Re: [xwiki-users] robots.txt not found

2016-05-02 Thread Clemens Klein-Robbenhaar
> Deploy the XWiki Enterprise 8.0 WAR , install in Tomcat 8 > According to this article > http://platform.xwiki.org/xwiki/bin/view/Main/ShortURLs make > http://localhost:8080/xwiki/bin/view/Main/ as http://localhost:8080/Main/ > I remove tomcat ROOT folder,copy xwiki war and rename ROOT > now I

Re: [xwiki-users] Changing the app name in App Within Minutes

2016-05-02 Thread Clemens Klein-Robbenhaar
I have not tested with XWiki 6.0, but is it not possible to edit the start page of the app e.g. in the wiki editor and set the title to whatever you want ? (Admittedly the title input field is not shown in the AWM-Editor that comes up as default when clicking on edit) Clemens -

Re: [xwiki-users] how to cover one page title

2016-04-29 Thread Clemens Klein-Robbenhaar
the HTML as shown in the browser is not the same as the document title (which you can indeed set with $doc.setTitle("...") ) Instead you can look in the file .../xwiki/skins/flamingo/htmlheader.vm where the html title is computed - look for the section starting with the comment "Compute

Re: [xwiki-users] Can't get Export/Import to work

2016-04-22 Thread Clemens Klein-Robbenhaar
This blog post: http://cnedelcu.blogspot.de/2013/09/nginx-error-413-request-entity-too-large.html tells me nginx does not allow request bodies larger than 1mb by default if you use nginx you might want to update this configuration variable:

Re: [xwiki-users] Login cookie validation hash mismatch! Cookies have been tampered with

2016-03-09 Thread Clemens Klein-Robbenhaar
The code where this happens is in: https://github.com/xwiki/xwiki-platform/blob/master/xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/user/impl/xwiki/MyPersistentLoginManager.java#L564 I have to admit that I do not know much about that corner of XWiki code some

Re: [xwiki-users] Exporting all documents of a space

2016-03-08 Thread Clemens Klein-Robbenhaar
> > > _______ > users mailing list > users@xwiki.org > http://lists.xwiki.org/mailman/listinfo/users mit freundlichen Grüßen Clemens Klein-Robbenhaar -- Clemens Klein-Robbenhaar Software Development EsPrest

Re: [xwiki-users] Modifying macro.mv

2016-02-19 Thread Clemens Klein-Robbenhaar
Hi Mehdi: > Hello everyone, > > I am trying to modify the way the table of content (toc) macro behaves on > xwiki, and I have a few questions concerning that. > > 1- Is there anywhere else the macro is defined besides in macros.mv? the > changes I've made there did not show up on my xwiki

Re: [xwiki-users] Mocca Calendar and Meeting Calendar have different first days

2016-02-12 Thread Clemens Klein-Robbenhaar
How to chnage the first day of the week for MoccaCalendar is explained here: http://extensions.xwiki.org/xwiki/bin/view/Extension/MoccaCalendar?viewer=comments#xwikicomment_3 HTH Clemens > In the 7.4 release, the Mocca Calendar extension and the calendar view of the > Meeting Application

Re: [xwiki-users] Encoding bug in Document Tree Macro ?

2016-02-08 Thread Clemens Klein-Robbenhaar
On 02/08/2016 10:21 AM, Bruno wrote: > > Le 05/02/2016 16:19, Clemens Klein-Robbenhaar a écrit : >> >> On 02/05/2016 03:35 PM, Bruno wrote: >>> Hello, >>> >>> I work in a French engineering school. >>> I would like to install xwiki 7.4 fo

Re: [xwiki-users] Encoding bug in Document Tree Macro ?

2016-02-05 Thread Clemens Klein-Robbenhaar
On 02/05/2016 03:35 PM, Bruno wrote: > > Hello, > > I work in a French engineering school. > I would like to install xwiki 7.4 for my team. > > I encounter a problem whith accents : > When I create a page whose title contains accents (or French special > characters), childs documents are not

Re: [xwiki-users] Translation problems

2016-02-05 Thread Clemens Klein-Robbenhaar
> The workaround you suggested didn't have any effect. To analyse the problem a > bit further (and verify that I was creating the translation page correctly), > I inserted a spelling error in the Translations page. The spelling error was > displayed as expected if I deployed the app to a path

Re: [xwiki-users] Translation problems

2016-02-04 Thread Clemens Klein-Robbenhaar
On 02/03/2016 06:21 PM, Mark Sack wrote: > For the second problem, I discovered something that I can't quite understand > (perhaps because I am relatively new to this kind of development). > My setup is debian 8, openjdk 7, tomcat8, postgresql 9.4 (all installed from > the debian repositories).

Re: [xwiki-users] Translation problems

2016-02-03 Thread Clemens Klein-Robbenhaar
Hi Mark, > I'm setting up a XWiki 7.4 site with a pt_BR localization and am updating > empty translations as I go along according to our use cases. In the process > I've run into a couple of problems. > > Firstly, on the Blog Archive panel, the months are being displayed in > English. If I log

Re: [xwiki-users] XWiki 7.4 Distribution Wizard says: "We couldn't find any extension with id 'org.xwiki.enterprise:xwiki-enterprise-ui-mainwiki' and version '7.4'."

2016-01-29 Thread Clemens Klein-Robbenhaar
Hi Frank, [...] >> >>> I have to admit that if it is not the proxy-settings then I am getting >>> somewhat desperate about how to diagnose the problem. >>> I guess one could try to get stack traces from the server while it is >>> starting up >>> and use the java option "-Djavax.net.debug=all"

Re: [xwiki-users] XWiki 7.4 Distribution Wizard says: "We couldn't find any extension with id 'org.xwiki.enterprise:xwiki-enterprise-ui-mainwiki' and version '7.4'."

2016-01-28 Thread Clemens Klein-Robbenhaar
Hi Frank, > Hi Clemens, > >> I have to admit that I have been running out of ideas why the wiki cannot >> get a connection while "curl" can. >> >> One last try: has the gateway connecting the local network to the internet >> an application firewall or the like ? >> Something that sniffs

Re: [xwiki-users] XWiki 7.4 Distribution Wizard says: "We couldn't find any extension with id 'org.xwiki.enterprise:xwiki-enterprise-ui-mainwiki' and version '7.4'."

2016-01-26 Thread Clemens Klein-Robbenhaar
nterprise-ui-mainwiki' and version '7.4'." > On 22.01.16 15:12, Clemens Klein-Robbenhaar wrote: >> >> some random ideas: >> >> - in WEB-INF/xwiki.properties: are any settings for >> extension.repositories=... enabled >> or are they all c

Re: [xwiki-users] XWiki 7.4 Distribution Wizard says: "We couldn't find any extension with id 'org.xwiki.enterprise:xwiki-enterprise-ui-mainwiki' and version '7.4'."

2016-01-22 Thread Clemens Klein-Robbenhaar
t;>>> Apache Tomcat 8.0.30 (manually installed) and XWiki Enterprise 7.4 (WEB, >>>> manually installed). >>>> >>>> Any pointer to fix this problem are appreciated. >>>> >>>> Cheers >>>> Frank >>>> ______

Re: [xwiki-users] Mocca calendar - display 'short description' instead of title in month/week/day view

2016-01-20 Thread Clemens Klein-Robbenhaar
Ah, there is the "App within minutes" editor coming in"! Actually it is a leftover from the time when this extension has been bootstrapped from "App Within Minutes". I guess I better scrap this because the "automatically created edit form" is not really useful in this case, as you have figured

Re: [xwiki-users] Mocca calendar - display 'short description' instead of title in month/week/day view

2016-01-20 Thread Clemens Klein-Robbenhaar
Small Update: Release 2.5.1 is out now, fixing that issue: > I can confirm your results from step 1 to step 5. > This is indeed a bug that needs fixing; I have added it as > http://jira.xwiki.org/browse/MOCCACAL-91 > [...] >> >> 1. Created new XWiki 7.4 instance - distribution wizard doesn't

Re: [xwiki-users] Mocca calendar - display 'short description' instead of title in month/week/day view

2016-01-19 Thread Clemens Klein-Robbenhaar
> View this message in context: > http://xwiki.475771.n2.nabble.com/Mocca-calendar-display-short-description-instead-of-title-in-month-week-day-view-tp7597592p7597610.html > Sent from the XWiki- Users mailing list archive at Nabble.com. > ___________

Re: [xwiki-users] Mocca calendar - display 'short description' instead of title in month/week/day view

2016-01-18 Thread Clemens Klein-Robbenhaar
Hi Mark, > In our use of the calendar extension, I expect to have situations where the > title is repeated (sometimes for what are really recurring events and > sometimes not). For this reason, we'll leave the randomly generated string > in the title field. To start with, there is probably a bug

Re: [xwiki-users] [XWiki 7.3] Problem with group rights

2015-11-18 Thread Clemens Klein-Robbenhaar
navigate to individual group pages I get: "The requested page could > not be found." > > ASOL Email Un cordial saludo, > Iago Lluque > / > *Alínea Software Solutions S.L.* > Travesía del Comercio 3, 2º 36002 Pontevedra España > Tel: +34 986 845 699 > Em

Re: [xwiki-users] [XWiki 7.3] Problem with group rights

2015-11-18 Thread Clemens Klein-Robbenhaar
; URLs so the behaviour was like this: > - http://192.168.0.32:8085/xwiki/bin/view/XWiki/XWikiAdminGroup -> not found > - http://192.168.0.32:8085/xwiki/bin/XWiki/XWikiAdminGroup -> found > > Greetings, > Iago > // > El 18/11/2015 a las 10:54, Clemens Klein-Robbenhaar escribió: >

Re: [xwiki-users] XWiki startup HTTP 500 issue

2015-11-18 Thread Clemens Klein-Robbenhaar
You might want to check the log files in the tomcat installation directory for startup errors. (Unfortunately tomcat writes logs in several files, at least last time I checked. Just look into everything that has updated recently in the logs dir) A possible cause for the problem is that you

Re: [xwiki-users] [XWiki 7.3] Problem with group rights

2015-11-17 Thread Clemens Klein-Robbenhaar
> Hi all, > > I'm trying the new stable version of XWiki (7.3) and I'm facing problems with > group rights. > I'm unable to keep them set, as if I leave Rights page and then come back > again all rights I've tuned up remain unset (reseted to "default" I think...) > > Is anybody else having

Re: [xwiki-users] How to assign subdomains to each subwiki?

2015-11-03 Thread Clemens Klein-Robbenhaar
> I'd like to assign subdomains to each subwiki: > docs.my-xwiki.net, boards.my-xwiki.net, work.my-xwiki.net etc. > Is it possible? > Definitely yes: http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Virtualization#HHostnamebasedsubwikis note that you additionally need to configure the

Re: [xwiki-users] xwiki as our Intranet

2015-10-27 Thread Clemens Klein-Robbenhaar
uot; : xwiki:MainXX.Activity > - we see a clear error msg on GUI (ok) > > > We try to change "administration.users" > The option 'what kind of users can access the wiki' to > - only global users > > But it makes no difference. > > > Kind regards >

Re: [xwiki-users] xWiki - Change Navigation scheme

2015-10-02 Thread Clemens Klein-Robbenhaar
> Hey folks, > > I'm from Germany, so already sorry for my bloody english. > Lets see if I can beat that :p > I use the xe.panels.navigation for the navigation on my xWiki. Now the > following: I created pages, which has an difference between the url and the > name of the site. > > For

Re: [xwiki-users] Fwd: XWiki initialization failed! with xwiki-enterprise-web-7.2 ?

2015-09-17 Thread Clemens Klein-Robbenhaar
Hi *, > Hi Mohit, > > > On 1 Sep 2015 at 15:32:48, Mohit Gupta > (motgu...@gmail.com(mailto:motgu...@gmail.com)) wrote: > >> Hi Vincet, >> >> I took the latest war file(xwiki-enterprise-web-7.2-20150828.151901-292.war >> ) >> from the link >>

Re: [xwiki-users] XWiki 7.1 watchlist emails

2015-08-19 Thread Clemens Klein-Robbenhaar
After upgrading XWiki from 5 to 7.1 version, international characters in watchlist email notification message are corrupted (different charset). I tried send XWiki page using Share by Email and international characters are OK. Is there any way how to solve this problem? I tried switch

Re: [xwiki-users] XWiki initialization failed! with xwiki-enterprise-web-7.2 ?

2015-08-17 Thread Clemens Klein-Robbenhaar
Alternatively it might have something to do with the JDBC driver. XWiki wants a JDBC-4 driver for the 7.x series (This information can be found somewhere in the release notes for 7.0: http://www.xwiki.org/xwiki/bin/view/ReleaseNotes/ReleaseNotesXWiki70#HIssuesspecifictoXWiki7.0 ) Maybe you

Re: [xwiki-users] Reset WYSIWYG editor menu bar?

2015-05-19 Thread Clemens Klein-Robbenhaar
On 05/19/2015 01:07 AM, Arnold, Garth wrote: Hello, I am using XWiki 6.2.4. When altering my WYSIWYG editor settings (through Administration/Applications/WYSIWYG Editor), I first added the color and font PLUGINS, and then incorrectly edited the MENU BAR entries and specified color and

Re: [xwiki-users] Printing pages as displayed

2015-05-15 Thread Clemens Klein-Robbenhaar
Hi Mahomed, I just know an answer about the last one ... I hope the rest will be answered by others. If you want your skin customizations visible on the login page, too, then you need to make sure the anonymous user can view the page with the modifications. Giving the XWikiAllGroup view

Re: [xwiki-users] Printing pages as displayed

2015-05-15 Thread Clemens Klein-Robbenhaar
Message- From: users [mailto:users-boun...@xwiki.org] On Behalf Of Clemens Klein-Robbenhaar Sent: 15 May 2015 12:18 To: users@xwiki.org Subject: Re: [xwiki-users] Printing pages as displayed Hi Mahomed, I just know an answer about the last one ... I hope the rest will be answered

Re: [xwiki-users] Tomcat error 500 for pages with in title

2015-04-24 Thread Clemens Klein-Robbenhaar
small update: actually StackExchange has the solution: http://serverfault.com/questions/459369/disabling-url-decoding-in-nginx-proxy On 04/24/2015 10:16 AM, Clemens Klein-Robbenhaar wrote: We are getting closer to a solution ;) I am pretty sure that if you get the error via nginx

Re: [xwiki-users] Tomcat error 500 for pages with in title

2015-04-24 Thread Clemens Klein-Robbenhaar
? 2015-04-23 16:42 GMT+02:00 Clemens Klein-Robbenhaar c.robbenh...@espresto.com: I once had quite bad problems when having an apache in between who internally decoded an URI and then encoded it back, but only barely ... However it seems this is ruled out here, if the problem happens

Re: [xwiki-users] Tomcat error 500 for pages with in title

2015-04-23 Thread Clemens Klein-Robbenhaar
at all. 2015-04-23 13:10 GMT+02:00 Clemens Klein-Robbenhaar c.robbenh...@espresto.com: I installed tomcat8 as apache-tomcat-8.0.21, and java as jdk1.8.0_45 and cannot reproduce this either, at least not directly. After I create a page with name `Page with quotes`, I cannot trigger

Re: [xwiki-users] Tomcat error 500 for pages with in title

2015-04-23 Thread Clemens Klein-Robbenhaar
mailing list users@xwiki.org http://lists.xwiki.org/mailman/listinfo/users ___ users mailing list users@xwiki.org http://lists.xwiki.org/mailman/listinfo/users mit freundlichen Grüßen Clemens Klein-Robbenhaar -- Clemens Klein-Robbenhaar

Re: [xwiki-users] Accidently deleted wiki

2015-02-19 Thread Clemens Klein-Robbenhaar
On 02/19/2015 11:15 AM, vinc...@massol.net wrote: Hi Clemens, On 19 Feb 2015 at 10:56:57, Clemens Klein-Robbenhaar (c.robbenh...@espresto.com(mailto:c.robbenh...@espresto.com)) wrote: On 02/19/2015 10:12 AM, vinc...@massol.net wrote: Hi, On 19 Feb 2015 at 09:22:24, Thomas Mortagne

Re: [xwiki-users] Accidently deleted wiki

2015-02-19 Thread Clemens Klein-Robbenhaar
On 02/19/2015 10:12 AM, vinc...@massol.net wrote: Hi, On 19 Feb 2015 at 09:22:24, Thomas Mortagne (thomas.morta...@xwiki.com(mailto:thomas.morta...@xwiki.com)) wrote: On Thu, Feb 19, 2015 at 8:50 AM, vinc...@massol.net wrote: Hi Michael, On 18 Feb 2015 at 21:22:57, Michael Kurbatov

Re: [xwiki-users] Watchlist App Email Notification generates incorrect document links

2015-02-16 Thread Clemens Klein-Robbenhaar
Hi Alexander, I just have been able to reproduce the issue with the jetty-hsql package of XWiki 6.4.1 after a few modifications - it looks like a bug still running around in the wild. What you can do about it is: - create a bug report in http://jira.xwiki.org/ - if you want to debug it,

Re: [xwiki-users] Fw : Re: Need doc about access object in a page (and use doc)

2015-02-09 Thread Clemens Klein-Robbenhaar
On 02/09/2015 02:12 PM, Pascal BASTIEN wrote: This code (probably false) doesn't work. #set( $Class = $xwiki.getClass(MySpace.MyClass)) #foreach($prop in $class.properties) ## go through all properties * ${prop.prettyName} : $doc.display($prop.getName()) #end It works for me if I do

Re: [xwiki-users] Server side validation / block save

2015-02-09 Thread Clemens Klein-Robbenhaar
On 02/06/2015 11:04 PM, Jason Clemons wrote: Hey Clemens, Thanks so much for the response I really appreciate it. Ok.. I have the first part working which I think is the plumbing but I'm not sure of the next step. So far I've implemented this in my sheet page:

Re: [xwiki-users] Need doc about access object in a page (and use doc)

2015-02-09 Thread Clemens Klein-Robbenhaar
freundlichen Grüßen Clemens Klein-Robbenhaar -- Clemens Klein-Robbenhaar Software Development EsPresto AG Breite Str. 30-31 10178 Berlin/Germany Tel: +49.(0)30.90 226.763 Fax: +49.(0)30.90 226.760 robbenh...@espresto.com HRB 77554 B - Berlin-Charlottenburg Vorstand: Maya Biersack, Peter Biersack

Re: [xwiki-users] RSS feeds for Space-specific blogs

2015-02-05 Thread Clemens Klein-Robbenhaar
On 02/03/2015 06:07 PM, Jamal wrote: Hi, I've set up a blog for a single space using the blog inside an existing space option, so the blog URL is .../xwiki/bin/view/MySpace/Blog As per the documentation, I added the following line to the HTTP Meta Info section in the space's admin

Re: [xwiki-users] Server side validation / block save

2015-02-05 Thread Clemens Klein-Robbenhaar
On 02/03/2015 04:57 PM, Jason Clemons wrote: bump...please help :) On Jan 30, 2015, at 10:50 AM, Jason Clemons jason.clem...@live.com wrote: Hello all, I'm hoping someone can give me a suggestion to save my skin. When I was brand new to xwiki I quickly created an application for

Re: [xwiki-users] attachmentsinline.vm loses context: $doc “undefined”

2015-02-03 Thread Clemens Klein-Robbenhaar
://lists.xwiki.org/mailman/listinfo/users mit freundlichen Grüßen Clemens Klein-Robbenhaar -- Clemens Klein-Robbenhaar Software Development EsPresto AG Breite Str. 30-31 10178 Berlin/Germany Tel: +49.(0)30.90 226.763 Fax: +49.(0)30.90 226.760 robbenh...@espresto.com HRB 77554 B - Berlin-Charlottenburg

Re: [xwiki-users] Howto getprefix in a Sheet?

2015-02-03 Thread Clemens Klein-Robbenhaar
-Robbenhaar -- Clemens Klein-Robbenhaar Software Development EsPresto AG Breite Str. 30-31 10178 Berlin/Germany Tel: +49.(0)30.90 226.763 Fax: +49.(0)30.90 226.760 robbenh...@espresto.com HRB 77554 B - Berlin-Charlottenburg Vorstand: Maya Biersack, Peter Biersack Vorsitzender des Aufsichtsrats

Re: [xwiki-users] deleted wrong dir for solr...

2015-02-03 Thread Clemens Klein-Robbenhaar
message followed later down by a Caused by: ... That should be the source reason why it is not found Clemens Marc On 03 Feb 2015, at 10:20, Clemens Klein-Robbenhaar c.robbenh...@espresto.com wrote: On 02/03/2015 08:48 AM, Marc AUDEFROY wrote: Hello all, I migrated Xwiki to 6.3 to 6.4

Re: [xwiki-users] problem with xwiki appearance

2015-01-30 Thread Clemens Klein-Robbenhaar
On 01/30/2015 04:07 PM, vinc...@massol.net wrote: On 30 Jan 2015 at 15:56:54, Clemens Klein-Robbenhaar (c.robbenh...@espresto.com(mailto:c.robbenh...@espresto.com)) wrote: On 01/30/2015 11:20 AM, Дмитрий Федин wrote: Hello everyone! I have a problem with frames on my xwiki (http

Re: [xwiki-users] problem with xwiki appearance

2015-01-30 Thread Clemens Klein-Robbenhaar
On 01/30/2015 11:20 AM, Дмитрий Федин wrote: Hello everyone! I have a problem with frames on my xwiki (http://dafedin.myxwiki.org) . Look screenshot in attachment. I have updated wiki but it's dont helps. Help me! with respect? Dmytro the Problem is that the CSS files assumes you

Re: [xwiki-users] some issues upgrading to 6.4

2015-01-28 Thread Clemens Klein-Robbenhaar
On 01/28/2015 12:11 PM, ricardo.julio.rodriguez.fernan...@sergas.es wrote: Good morning! I've just updated a 6.3 installation to 6.4 and it seems to me that something went wrong... I think I followed the same steps I successfully did in previous upgrades of the 6.x series, but this time it

Re: [xwiki-users] Refreshing a LiveTable

2015-01-27 Thread Clemens Klein-Robbenhaar
On 01/27/2015 02:52 AM, Bryn Jeffries wrote: Is there a right way to make a LiveTable refresh? I do not know of a right way, but one that currently works is to fetch the livetable by its name, and refetch the current rows via some not-so obvious code, like: var livetable =

Re: [xwiki-users] column name in LiveTable rendered by documents macro

2015-01-22 Thread Clemens Klein-Robbenhaar
On 01/21/2015 06:23 PM, Jason Clemons wrote: Hello all, I've changed the columns that are rendered in my space index by adding a columns attribute as described by the article here http://extensions.xwiki.org/xwiki/bin/view/Extension/Documents+Macro and the column I added does show up as

Re: [xwiki-users] Add date of account creation (without time) in User Index problem

2015-01-14 Thread Clemens Klein-Robbenhaar
in that specific example, because it loads a document for every element in the result set into memory. If you do something with the data already loaded I think it should not be too inefficient. Personally I still think this is the way to go ... De : Clemens Klein-Robbenhaar c.robbenh

Re: [xwiki-users] Add date of account creation (without time) in User Index problem

2015-01-13 Thread Clemens Klein-Robbenhaar
On 01/13/2015 10:45 AM, Pascal BASTIEN wrote: Hello, To make it work I add this new property in XWiki.XWikiUsers class: /bin/edit/XWiki/XWikiUsers?editor=class Name: doc.creationDate Type: String PrettyName: Creation date I did not know that you can create class properties with a dot in

Re: [xwiki-users] Add date of account creation (without time) in User Index problem

2015-01-13 Thread Clemens Klein-Robbenhaar
On 01/13/2015 03:05 PM, Pascal BASTIEN wrote: Thxs a lot to explained me with clarity all of that and help me to understand better XWiki. Then with what you give me, I tried to add a format_date parameter () (or regexp) in columns properties to improve livetable. I failed because I didn't

Re: [xwiki-users] prevent page save

2015-01-12 Thread Clemens Klein-Robbenhaar
On 01/08/2015 04:52 PM, Jason Clemons wrote: Hello all, I've implemented some client side page validation using JavaScript which works well, but I want to implement some simple checks on server side also. I know how to evaluate the values in my UI using velocity after the page is

Re: [xwiki-users] Manipulate presentation of LiveTable column data

2015-01-08 Thread Clemens Klein-Robbenhaar
On 01/08/2015 03:15 AM, Bryn Jeffries wrote: I have a custom groovy script at DemoSpace.StudiesJSON that generates JSON of the form: { totalrows: 5, matchingtags: {}, tags : [], offset: 1, reqNo: 0, returnedrows: 1, rows: [{doc_viewable:true,study_id:3,study_name:My

Re: [xwiki-users] setting translation from groovy

2014-12-15 Thread Clemens Klein-Robbenhaar
[language]) translatedDoc.save(); } } Any advice would be greatly welcomed David Delbecq ___ users mailing list users@xwiki.org http://lists.xwiki.org/mailman/listinfo/users mit freundlichen Grüßen Clemens Klein-Robbenhaar

[xwiki-users] Mocca Calendar Application 2.2.1 released - with a glitch

2014-11-28 Thread Clemens Klein-Robbenhaar
To folks who have the Mocca Calendar[1] application installed in their XWiki instances: I have just released a new version 2.2.1 to which you might want to update to, as it contains quite a few bugfixes and improvements, thanks to patches send in by several contributors.[2] However the new

Re: [xwiki-users] Using HTML5 File Upload Widget for non-XWiki files

2014-11-15 Thread Clemens Klein-Robbenhaar
On 11/14/2014 11:24 PM, Bryn Jeffries wrote: I asked: I'd like to upload files through a custom File Upload servlet that runs from the same Tomcat server but is not part of XWiki. [...] Is it possible to make use of the supplied XWiki UI widgets to upload to this servlet? Any guidance

Re: [xwiki-users] permissions issue

2014-11-14 Thread Clemens Klein-Robbenhaar
On 11/12/2014 09:35 PM, Paul Pinkerton (ACLCO) wrote: I am struggling with a page permissions issue. What am I doing wrong here? I have done this before, but it doesn't seem to be working this time. I have a SPACE that is only available to a specific GROUP. That seems to be working just

Re: [xwiki-users] localization string missing - xe.blog.code.title

2014-11-14 Thread Clemens Klein-Robbenhaar
De: users [users-boun...@xwiki.org] en nombre de Clemens Klein-Robbenhaar [c.robbenh...@espresto.com] Enviado: martes, 11 de noviembre de 2014 15:39 Para: users@xwiki.org Asunto: Re: [xwiki-users] localization string missing - xe.blog.code.title On 11/11/2014 02:54 PM, Marius

Re: [xwiki-users] localization string missing - xe.blog.code.title

2014-11-11 Thread Clemens Klein-Robbenhaar
@xwiki.org http://lists.xwiki.org/mailman/listinfo/users ___ users mailing list users@xwiki.org http://lists.xwiki.org/mailman/listinfo/users mit freundlichen Grüßen Clemens Klein-Robbenhaar -- Clemens Klein-Robbenhaar Software Development EsPresto

Re: [xwiki-users] Question regarding AppServerTrustedAuthServiceImpl

2014-11-03 Thread Clemens Klein-Robbenhaar
On 11/03/2014 05:15 PM, Ji Zhang wrote: Guys, I am new to Xwiki. I have a xwiki deployed on tomcat 6. I need to use authentication against tomcat JDBC realm. AppServerTrustedAuthServiceImpl seems to my option. Are there some detailed documents or examples for using it? yes: add a

Re: [xwiki-users] deactive wizard distribution

2014-10-23 Thread Clemens Klein-Robbenhaar
/mailman/listinfo/users mit freundlichen Grüßen Clemens Klein-Robbenhaar -- Clemens Klein-Robbenhaar Software Development EsPresto AG Breite Str. 30-31 10178 Berlin/Germany Tel: +49.(0)30.90 226.763 Fax: +49.(0)30.90 226.760 robbenh...@espresto.com HRB 77554 B - Berlin-Charlottenburg Vorstand

Re: [xwiki-users] [Proposal] Mail Notification excludes own Changes

2014-10-17 Thread Clemens Klein-Robbenhaar
On 10/17/2014 12:43 PM, Peter Duever wrote: Hello XWiki Community, If I edit a page I get mail notifications for the pages I changed myself. I propose to change the API in the way that only changes done by others are sent. I guess that would be something like:

  1   2   >