Re: [xwiki-users] xwiki is not even trying to read the xwiki.cfg file

2009-01-21 Thread Paul Armstrong
At 2009-01-21T16:55-0500, Minton, Brian wrote:
 I have a pretty generic (just downloaded and unpacked) xwiki setup.  I
 tried to make some changes to webapps/xwiki/WEB-INF/xwiki.cfg but the
 file did not seem to even get read.  I looked at the atime of the
 file, and it was the same as when I edited it, not when I started the
 server.  This makes me think I'm putting the file in the wrong place.
 
Did the server actually restart?
Is atime turned off on that filesystem?

Something like the following on Solaris or MacOS:

#!/usr/sbin/dtrace -s
syscall::open*:entry
/NULL != strstr(copyinstr(arg0), xwiki.cfg)/
{
  @[execname, copyinstr(arg0)] = count();
}

Will tell you if it's ever opened (or if attempts are made at least).

Paul

-- 
End dual-measurement, let's finish going metric!
http://gometric.us/
http://www.metric.org/
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] blog listing is very slow

2009-01-04 Thread Paul Armstrong
At 2009-01-04T20:08+0100, Vincent Massol wrote:
 On Jan 4, 2009, at 5:49 PM, Elek M?rton wrote:
 
  Is it normal that the blog listing page
  (http://localhost:8080/xwiki/bin/view/Blog) is generated in 6-10
  seconds if I have only one word per title/content and in 25-30 seconds
  if I am using some more detailed articles?
 
  I am using XWiki 1.7 with 1.0 XWiki syntax + Mysql (with indexes).
 
  Is there any solution to achieve faster performance?
 
 Performance should be sub-second (a few ms) especially when executed  
 locally so you have a problem somewhere.
 
As per this bug, this is a known problem:
http://jira.xwiki.org/jira/browse/XWIKI-3022
 
 Can you start by verifying if the problem is in your database, in your  
 web server (if you have any) or in XWiki?
 Is this a large wiki?
 
From the bug above:

A load of the front page (which includes the blog on my site) takes
24,452 calls to MySQL with 22,940 calls recorded in the query log before
the limit statement.
I've got about 800 blog posts on my site so this seems a little
excessive.

During the time when it's doing the heavy querying, one core is stuck at
100% utilization.


For me, it can take 20-30 seconds to load that page. The workaround I'm
using is to cache the page, but that's only so effective.

Unfortunately, I've got a lot of things going on so haven't thrown
dtrace at it yet.

Paul

-- 
End dual-measurement, let's finish going metric!
http://gometric.us/
http://www.metric.org/
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] [xwiki] Clean URLs - Anyone knows why we have /bin/ in XWiki URLs?

2007-12-22 Thread Paul Armstrong
On Sat, Dec 22, 2007 at 10:40:44PM +0100, Paul Libbrecht wrote:
 As can see below, I have now managed to get as short x.org/bin/Main  
 which is fair.
 Note however that the settings above are not enough there are still  
 paths that use /xwiki or assume something such. I have seen two thus  
 far:
 - the WebSearch and LuceneSearch, in the path of the submit form
 - the Class-Sheet, used in the class-editor, to create new instances

The other thing that can be done is to put a reverse proxy in front of
xwiki and have it re-write that part of the URL out.

Paul

-- 
End dual-measurement, let's finish going metric!
http://gometric.us/
http://www.metric.org/

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] CAPTCHA for comments and registration

2007-11-05 Thread Paul Armstrong
On Mon, Nov 05, 2007 at 03:52:16PM -0800, marlon hendred wrote:
 Hi, can someone help me with setting up CAPTCHA with the albatross skin for
 registration and comments? Is there some example code I could look at? Or if
 someone has this working could they give some guidence? I have the captcha
 plugin enabled but I'm kinda stuck on what to do next. Thanks in advance.
 
Look in the dodo skin files.
Particularly:
captcha.vm
comments.vm
edit.vm
wysiwyg.vm

Paul

-- 
End dual-measurement, let's finish going metric!
http://gometric.us/
http://www.metric.org/

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Comments spam

2007-09-03 Thread Paul Armstrong
On Mon, Sep 03, 2007 at 05:17:30PM +0200, Antonio Goncalves wrote:
 BTW, is there a functionality to add simple captcha to add comments (like
 1+3=) ?

find dodo -exec grep -i captcha /dev/null {} \;
dodo/captcha.vm:#if ($captchaPlugin)
dodo/captcha.vm:  $captchaPlugin.displayCaptcha(edit,wiki_captcha)
dodo/wysiwyg.vm:#if ($captchaPlugin)
dodo/wysiwyg.vm:  $captchaPlugin.displayCaptcha(edit,wiki_captcha)
dodo/edit.vm:#if ($captchaPlugin)
dodo/edit.vm:  $captchaPlugin.displayCaptcha(edit,wiki_captcha)
dodo/comments.vm:#if ($captchaPlugin)
dodo/comments.vm: $captchaPlugin.displayCaptcha(comment,wiki_captcha)

Paul

-- 
End dual-measurement, let's finish going metric!
http://gometric.us/
http://www.metric.org/

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users