Re: [xwiki-users] Navigation Panel

2017-05-16 Thread Timo Dachs-Wegmann
Hi Vincent,

I've looked at the option for hiding spaces that are tagged as hidden but I 
can't hide all the pages I don't want to have in the navigation panel because 
they should be viewable by default... 

We had another navigation panel in an earlier version that displays the navi as 
an accordion bar. It hat a blacklist option as you can see below:
#set ($blacklistedSpaces = ['Main', 'AnnotationCode', 'ColorThemes', 
'XWiki', 'Panels', 'Scheduler', 'Stats', 'AppWithinMinutes', 'Blog'])


I tried using the tree macro and I've read the documentation about the custom 
document tree but neither in the first few tries :(.

Thank you for your answer and I hope that Marius will find a way to add a 
Blacklist feature :)

Kind regards,
Timo


Hi Timo,

> On 10 May 2017, at 14:50, Timo Dachs-Wegmann <t.wegm...@procitec.de> wrote:
> 
> Hello all,
> 
> I installed the latest version of XWiki (9.3.1) and I want to get a new 
> navigation panel since my old is a little bit buggy and outdated. 
> 
> I would like to have something like the document tree macro generates with 
> this command:
> 
>   {{velocity}}
>   #panelheader('Navi3')
>   {{documentTree showTranslations="false" showAttachments="false" 
> compact="true" showSpaces="true" limit=20/}}
>   #panelfooter()
>   {{/velocity}}
> 
> But the problem there is, that I can't blacklist the spaces I don't 
> want to be shown in this list…

If the spaces contain hidden pages or pages that the user doesn’t have 
permissions to view then it shouldn’t be listed. Maybe that’s a workaround that 
could work for you?

> There was a ticket already with this topic and I posted a comment 
> there, so hopefully they add this "feature" (yes for me it is a needed 
> feature) but I thought maybe you guys have a navigation bar that is generated 
> dynamicly and will work for me. (It should be a tree panel).
> Something like this:
> http://test.xwiki.org/xwiki/bin/view/Panels%20Tests/Navigation%20Panel
> #Attachments

If you want to control the content, maybe you could use the Tree macro: 
http://extensions.xwiki.org/xwiki/bin/view/Extension/Tree%20Macro

Or 
http://extensions.xwiki.org/xwiki/bin/view/Extension/Document+Tree+Macro#HCustomDocumentTree

EDIT: I see you’ve commented on 
https://jira.xwiki.org/browse/XWIKI-12895?focusedCommentId=94975=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-94975

I’ll reply there. 

Thanks
-Vincent

> Link to the JIRA ticket:
> https://jira.xwiki.org/browse/XWIKI-12895
> 
> 
> Mit freundlichen Grüßen
> 
> Timo Dachs-Wegmann
> -EDV-
> 
> 
> -
> PROCITEC GmbH Rastatter Strasse 41
> D-75179 Pforzheim
> Fon: +49 7231 15561-29
> Fax: +49 7231 15561-11
> Mailto: t.wegm...@procitec.de
> 
> Mannheim HRB 504702
> Geschäftsführer: Dipl.-Ing. (FH) Dipl.-Inf. (FH) Jens Heyen
> 
> 
> 
> 






[xwiki-users] Navigation Panel

2017-05-10 Thread Timo Dachs-Wegmann
Hello all,

I installed the latest version of XWiki (9.3.1) and I want to get a new 
navigation panel since my old is a little bit buggy and outdated. 

I would like to have something like the document tree macro generates with this 
command:

{{velocity}}
#panelheader('Navi3')
{{documentTree showTranslations="false" showAttachments="false" 
compact="true" showSpaces="true" limit=20/}}
#panelfooter()
{{/velocity}}

But the problem there is, that I can't blacklist the spaces I don't want to be 
shown in this list...
There was a ticket already with this topic and I posted a comment there, so 
hopefully they add this "feature" (yes for me it is a needed feature) but I 
thought maybe you guys have a navigation bar that 
is generated dynamicly and will work for me. (It should be a tree panel).
Something like this:
http://test.xwiki.org/xwiki/bin/view/Panels%20Tests/Navigation%20Panel#Attachments

Link to the JIRA ticket:
https://jira.xwiki.org/browse/XWIKI-12895


Mit freundlichen Grüßen  

Timo Dachs-Wegmann
-EDV- 


-
PROCITEC GmbH Rastatter Strasse 41
D-75179 Pforzheim
Fon: +49 7231 15561-29
Fax: +49 7231 15561-11
Mailto: t.wegm...@procitec.de 

Mannheim HRB 504702
Geschäftsführer: Dipl.-Ing. (FH) Dipl.-Inf. (FH) Jens Heyen






Re: [xwiki-users] Installation from .deb packages

2017-05-02 Thread Timo Dachs-Wegmann
Well, I don't know which one is needed. But there is a package called 
"default-mysql-server" maybe it's the one we are looking for here.

I have no time to test it now. But if you've trouble finding the right one, I 
try to find it sometime this week.

> The current dependencies in the package are:
>
> xwiki-enterprise-common (= [[version]]), mysql-server, libmysql-java (>= 
> 5.1.4), dbconfig-common
>
> having something like "mysql-server | mariadb-server" (i.e. need either 
> mysql-server or mariadb-server) is easy, just want to be what is the right 
> package.
>
>On Tue, May 2, 2017 at 12:32 PM, Timo Dachs-Wegmann <t.wegm...@procitec.de> 
>wrote:
>>
>> On Tue, May 2, 2017 at 11:42 AM, Timo Dachs-Wegmann <t.wegm...@procitec.de> 
>> wrote:
>>> Hello all,
>>>
>>>I have an issue installing the .deb packages from the maven repositories.
>>>
>>> The installation of xwiki-enterprise-tomcat8-mysql (and all other mysql 
>>> installations) has a dependency to the old "mysql-server" package from the 
>>> old versions of debian.
>>> It was replaced/removed in debian Jessie.
>>
>> I'm surprised you are the first one to report that and Ubuntu does not 
>> complain about this. What is the new package name ?
>>
>> So am I... Well, when I try to install it, it says that the package got 
>> replaced by: "mariadb-server-10.1"
>>
>> But I don't know if that’s true :/
>>
>> Maybe I'm getting something wrong but it doesn't work for me. Can someone 
>> confirm this?
>>
>>>
>>> It would be great if you could fix the dependency so the automatic 
>>> installation works as it should. :)
>>>
>>> Kind regards,
>>>
>>> Timo Dachs-Wegmann
>>> -IT-
>>>
>>>
>>
>>
>>
>> --
>> Thomas Mortagne
>>
>>
>>



--
Thomas Mortagne





Re: [xwiki-users] Installation from .deb packages

2017-05-02 Thread Timo Dachs-Wegmann

On Tue, May 2, 2017 at 11:42 AM, Timo Dachs-Wegmann <t.wegm...@procitec.de> 
wrote:
> Hello all,
>
> I have an issue installing the .deb packages from the maven repositories.
>
> The installation of xwiki-enterprise-tomcat8-mysql (and all other mysql 
> installations) has a dependency to the old "mysql-server" package from the 
> old versions of debian.
> It was replaced/removed in debian Jessie.

I'm surprised you are the first one to report that and Ubuntu does not complain 
about this. What is the new package name ?

So am I... Well, when I try to install it, it says that the package got 
replaced by: "mariadb-server-10.1"

But I don't know if that’s true :/

Maybe I'm getting something wrong but it doesn't work for me. Can someone 
confirm this?

>
> It would be great if you could fix the dependency so the automatic 
> installation works as it should. :)
>
> Kind regards,
>
> Timo Dachs-Wegmann
> -IT-
>
>



--
Thomas Mortagne





[xwiki-users] Installation from .deb packages

2017-05-02 Thread Timo Dachs-Wegmann
Hello all,

I have an issue installing the .deb packages from the maven repositories.

The installation of xwiki-enterprise-tomcat8-mysql (and all other mysql 
installations) has a dependency to the old "mysql-server" package from the old 
versions of debian.
It was replaced/removed in debian Jessie. 

It would be great if you could fix the dependency so the automatic installation 
works as it should. :)

Kind regards,

Timo Dachs-Wegmann
-IT- 




Re: [xwiki-users] Empty Pages after reimport

2017-04-26 Thread Timo Dachs-Wegmann
Still no progress on my side. 

Has someone an idea?


Kind regards,

Timo Dachs-Wegmann
-IT- 


-Ursprüngliche Nachricht-
Von: users [mailto:users-boun...@xwiki.org] Im Auftrag von Timo Dachs-Wegmann
Gesendet: Mittwoch, 12. April 2017 10:15
An: XWiki Users
Betreff: Re: [xwiki-users] Empty Pages after reimport

Hmm, no I can't find it :(

It seems to be an old plugin that was moved to legacy and was replaced by 
"Watchlist API"...
But we have 7.1.2 installed on the old xwiki...

"Starting with XWiki 7.0RC1, this plugin is deprecated and was moved to legacy. 
Please use the new Watchlist API component-based implementation instead."

So it should've already been replaced


Mit freundlichen Grüßen  

Timo Dachs-Wegmann
-EDV- 


-
PROCITEC GmbH Rastatter Strasse 41
D-75179 Pforzheim
Fon: +49 7231 15561-29
Fax: +49 7231 15561-11
Mailto: t.wegm...@procitec.de 

Mannheim HRB 504702
Geschäftsführer: Dipl.-Ing. (FH) Dipl.-Inf. (FH) Jens Heyen


-Ursprüngliche Nachricht-
Von: users [mailto:users-boun...@xwiki.org] Im Auftrag von BRUMM Steffen
Gesendet: Mittwoch, 12. April 2017 10:03
An: XWiki Users
Betreff: Re: [xwiki-users] Empty Pages after reimport

Hi,

seems that the jar cannot be found. Can you find " 
com.xpn.xwiki.plugin.watchlist.WatchListPlugin" on your old system? 

Mit freundlichen Grüßen, 

Steffen BRUMM
Programmierung
IT-Österreich 

Frankstahl Rohr- und Stahlhandelsges.m.b.H. 
Frankstahlstraße2
A-2353 Guntramsdorf
Tel: +43 50 50 3-343
www.frankstahl.com 

FÜR DIE UMWELT AKTIV: Frankstahl ist Partner von Global 2000

Firmensitz: Esteplatz 6, A-1030 Wien, FN 142511a Handelsgericht Wien, DVR 
0509361 Die Information in diesem Mail ist ausschließlich für den Empfänger 
bestimmt. Anderen Personen ist es nicht gestattet diese Information zu öffnen, 
zu kopieren oder zu verteilen. Falls Sie diese Information irrtümlich erhalten 
haben, kontaktieren Sie bitte den Absender und löschen Sie das Mail von Ihrem 
Computer. 


 
-Ursprüngliche Nachricht-
Von: users [mailto:users-boun...@xwiki.org] Im Auftrag von Timo Dachs-Wegmann
Gesendet: Mittwoch, 12. April 2017 09:31
An: XWiki Users
Betreff: Re: [xwiki-users] Empty Pages after reimport

Has anybody an idea? :)


Mit freundlichen Grüßen  

Timo Dachs-Wegmann
-EDV- 


-
PROCITEC GmbH Rastatter Strasse 41
D-75179 Pforzheim
Fon: +49 7231 15561-29
Fax: +49 7231 15561-11
Mailto: t.wegm...@procitec.de 

Mannheim HRB 504702
Geschäftsführer: Dipl.-Ing. (FH) Dipl.-Inf. (FH) Jens Heyen

-Ursprüngliche Nachricht-
Von: users [mailto:users-boun...@xwiki.org] Im Auftrag von Timo Dachs-Wegmann
Gesendet: Mittwoch, 5. April 2017 12:08
An: users@xwiki.org
Betreff: [xwiki-users] Empty Pages after reimport

Hello All,

I installed a new xwiki version (9.2 - current stable). I installed it with the 
debian packages and had no problems doing that. Then I made an mysql dump on 
the old wiki and made a rollback on the new machine. Then I copied the 
directory with all the directly written files to the new system (same 
directory). And I merged the configs from old to new, so that the configuration 
has to be the same.

But when I start the xwiki server it shows that it is loading to 100% but right 
after it switches to an empty login page. 
The URL shows this:
Xwiki.domain.de/xwiki/bin/login/XWiki/XWikiLogin?srid=j3QqKRs2=%2Fxwiki%2Fbin%2Fview%2FMain%2F%3Fsrid%3Dj3QqKRs2
But the page is completely blank.

I've logged the process of starting xwiki and found some error messages... But 
I can't get something out of it...
It would be nice if someone could help me with this. :- )


Kind regards

Timo Dachs-Wegmann
-IT-

LOG:

2017-04-05 11:49:02,383 [XWiki initialization] INFO  
.HibernateDataMigrationManager - Storage schema updates and data migrations are 
enabled 
2017-04-05 11:49:02,613 [XWiki initialization] INFO  
.HibernateDataMigrationManager - No data migration to apply for wiki [xwiki] 
currently in version [9] 
2017-04-05 11:49:02,614 [XWiki initialization] INFO  
.HibernateDataMigrationManager - Checking Hibernate mapping and updating schema 
if needed for wiki [xwiki] 
2017-04-05 11:49:04,639 [XWiki initialization] ERROR c.x.x.p.XWikiPluginManager 
- Cannot initialize plugin 
[com.xpn.xwiki.plugin.watchlist.WatchListPlugin]. This plugin will not be 
available. 
java.lang.ClassNotFoundException: com.xpn.xwiki.plugin.watchlist.WatchListPlugin
at org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:193)
at org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:180)
at java.security.AccessController.doPrivileged(Native Method)
at 
org.xwiki.classloader.URIClassLoader.findClass(URIClassLoader.java:179)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at 
org.xwiki.classloader.xwiki.internal.ContextNam

Re: [xwiki-users] Empty Pages after reimport

2017-04-12 Thread Timo Dachs-Wegmann
Hmm, no I can't find it :(

It seems to be an old plugin that was moved to legacy and was replaced by 
"Watchlist API"...
But we have 7.1.2 installed on the old xwiki...

"Starting with XWiki 7.0RC1, this plugin is deprecated and was moved to legacy. 
Please use the new Watchlist API component-based implementation instead."

So it should've already been replaced


Mit freundlichen Grüßen  

Timo Dachs-Wegmann
-EDV- 


-
PROCITEC GmbH Rastatter Strasse 41
D-75179 Pforzheim
Fon: +49 7231 15561-29
Fax: +49 7231 15561-11
Mailto: t.wegm...@procitec.de 

Mannheim HRB 504702
Geschäftsführer: Dipl.-Ing. (FH) Dipl.-Inf. (FH) Jens Heyen


-Ursprüngliche Nachricht-
Von: users [mailto:users-boun...@xwiki.org] Im Auftrag von BRUMM Steffen
Gesendet: Mittwoch, 12. April 2017 10:03
An: XWiki Users
Betreff: Re: [xwiki-users] Empty Pages after reimport

Hi,

seems that the jar cannot be found. Can you find " 
com.xpn.xwiki.plugin.watchlist.WatchListPlugin" on your old system? 

Mit freundlichen Grüßen, 

Steffen BRUMM
Programmierung
IT-Österreich 

Frankstahl Rohr- und Stahlhandelsges.m.b.H. 
Frankstahlstraße2
A-2353 Guntramsdorf
Tel: +43 50 50 3-343
www.frankstahl.com 

FÜR DIE UMWELT AKTIV: Frankstahl ist Partner von Global 2000

Firmensitz: Esteplatz 6, A-1030 Wien, FN 142511a Handelsgericht Wien, DVR 
0509361 Die Information in diesem Mail ist ausschließlich für den Empfänger 
bestimmt. Anderen Personen ist es nicht gestattet diese Information zu öffnen, 
zu kopieren oder zu verteilen. Falls Sie diese Information irrtümlich erhalten 
haben, kontaktieren Sie bitte den Absender und löschen Sie das Mail von Ihrem 
Computer. 


 
-Ursprüngliche Nachricht-
Von: users [mailto:users-boun...@xwiki.org] Im Auftrag von Timo Dachs-Wegmann
Gesendet: Mittwoch, 12. April 2017 09:31
An: XWiki Users
Betreff: Re: [xwiki-users] Empty Pages after reimport

Has anybody an idea? :)


Mit freundlichen Grüßen  

Timo Dachs-Wegmann
-EDV- 


-
PROCITEC GmbH Rastatter Strasse 41
D-75179 Pforzheim
Fon: +49 7231 15561-29
Fax: +49 7231 15561-11
Mailto: t.wegm...@procitec.de 

Mannheim HRB 504702
Geschäftsführer: Dipl.-Ing. (FH) Dipl.-Inf. (FH) Jens Heyen

-Ursprüngliche Nachricht-
Von: users [mailto:users-boun...@xwiki.org] Im Auftrag von Timo Dachs-Wegmann
Gesendet: Mittwoch, 5. April 2017 12:08
An: users@xwiki.org
Betreff: [xwiki-users] Empty Pages after reimport

Hello All,

I installed a new xwiki version (9.2 - current stable). I installed it with the 
debian packages and had no problems doing that. Then I made an mysql dump on 
the old wiki and made a rollback on the new machine. Then I copied the 
directory with all the directly written files to the new system (same 
directory). And I merged the configs from old to new, so that the configuration 
has to be the same.

But when I start the xwiki server it shows that it is loading to 100% but right 
after it switches to an empty login page. 
The URL shows this:
Xwiki.domain.de/xwiki/bin/login/XWiki/XWikiLogin?srid=j3QqKRs2=%2Fxwiki%2Fbin%2Fview%2FMain%2F%3Fsrid%3Dj3QqKRs2
But the page is completely blank.

I've logged the process of starting xwiki and found some error messages... But 
I can't get something out of it...
It would be nice if someone could help me with this. :- )


Kind regards

Timo Dachs-Wegmann
-IT-

LOG:

2017-04-05 11:49:02,383 [XWiki initialization] INFO  
.HibernateDataMigrationManager - Storage schema updates and data migrations are 
enabled 
2017-04-05 11:49:02,613 [XWiki initialization] INFO  
.HibernateDataMigrationManager - No data migration to apply for wiki [xwiki] 
currently in version [9] 
2017-04-05 11:49:02,614 [XWiki initialization] INFO  
.HibernateDataMigrationManager - Checking Hibernate mapping and updating schema 
if needed for wiki [xwiki] 
2017-04-05 11:49:04,639 [XWiki initialization] ERROR c.x.x.p.XWikiPluginManager 
- Cannot initialize plugin 
[com.xpn.xwiki.plugin.watchlist.WatchListPlugin]. This plugin will not be 
available. 
java.lang.ClassNotFoundException: com.xpn.xwiki.plugin.watchlist.WatchListPlugin
at org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:193)
at org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:180)
at java.security.AccessController.doPrivileged(Native Method)
at 
org.xwiki.classloader.URIClassLoader.findClass(URIClassLoader.java:179)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at 
org.xwiki.classloader.xwiki.internal.ContextNamespaceURLClassLoader.loadClass(ContextNamespaceURLClassLoader.java:176)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:348)
at 
com.xpn.xwiki.plugin.XWikiPluginManager.addPlugin(XWikiPluginManager.java:83)
at 
com.xpn.xwiki.plugin.XWikiPluginManager.addPlugi

Re: [xwiki-users] Empty Pages after reimport

2017-04-12 Thread Timo Dachs-Wegmann
Has anybody an idea? :)


Mit freundlichen Grüßen  

Timo Dachs-Wegmann
-EDV- 


-
PROCITEC GmbH Rastatter Strasse 41
D-75179 Pforzheim
Fon: +49 7231 15561-29
Fax: +49 7231 15561-11
Mailto: t.wegm...@procitec.de 

Mannheim HRB 504702
Geschäftsführer: Dipl.-Ing. (FH) Dipl.-Inf. (FH) Jens Heyen

-Ursprüngliche Nachricht-
Von: users [mailto:users-boun...@xwiki.org] Im Auftrag von Timo Dachs-Wegmann
Gesendet: Mittwoch, 5. April 2017 12:08
An: users@xwiki.org
Betreff: [xwiki-users] Empty Pages after reimport

Hello All,

I installed a new xwiki version (9.2 - current stable). I installed it with the 
debian packages and had no problems doing that. Then I made an mysql dump on 
the old wiki and made a rollback on the new machine. Then I copied the 
directory with all the directly written files to the new system (same 
directory). And I merged the configs from old to new, so that the configuration 
has to be the same.

But when I start the xwiki server it shows that it is loading to 100% but right 
after it switches to an empty login page. 
The URL shows this:
Xwiki.domain.de/xwiki/bin/login/XWiki/XWikiLogin?srid=j3QqKRs2=%2Fxwiki%2Fbin%2Fview%2FMain%2F%3Fsrid%3Dj3QqKRs2
But the page is completely blank.

I've logged the process of starting xwiki and found some error messages... But 
I can't get something out of it...
It would be nice if someone could help me with this. :- )


Kind regards

Timo Dachs-Wegmann
-IT-

LOG:

2017-04-05 11:49:02,383 [XWiki initialization] INFO  
.HibernateDataMigrationManager - Storage schema updates and data migrations are 
enabled 
2017-04-05 11:49:02,613 [XWiki initialization] INFO  
.HibernateDataMigrationManager - No data migration to apply for wiki [xwiki] 
currently in version [9] 
2017-04-05 11:49:02,614 [XWiki initialization] INFO  
.HibernateDataMigrationManager - Checking Hibernate mapping and updating schema 
if needed for wiki [xwiki] 
2017-04-05 11:49:04,639 [XWiki initialization] ERROR c.x.x.p.XWikiPluginManager 
- Cannot initialize plugin 
[com.xpn.xwiki.plugin.watchlist.WatchListPlugin]. This plugin will not be 
available. 
java.lang.ClassNotFoundException: com.xpn.xwiki.plugin.watchlist.WatchListPlugin
at org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:193)
at org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:180)
at java.security.AccessController.doPrivileged(Native Method)
at 
org.xwiki.classloader.URIClassLoader.findClass(URIClassLoader.java:179)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at 
org.xwiki.classloader.xwiki.internal.ContextNamespaceURLClassLoader.loadClass(ContextNamespaceURLClassLoader.java:176)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:348)
at 
com.xpn.xwiki.plugin.XWikiPluginManager.addPlugin(XWikiPluginManager.java:83)
at 
com.xpn.xwiki.plugin.XWikiPluginManager.addPlugins(XWikiPluginManager.java:118)
at com.xpn.xwiki.XWiki.preparePlugins(XWiki.java:1463)
at com.xpn.xwiki.XWiki.initXWiki(XWiki.java:1197)
at com.xpn.xwiki.XWiki.initXWiki(XWiki.java:1103)
at com.xpn.xwiki.XWiki.(XWiki.java:1076)
at 
com.xpn.xwiki.internal.XWikiInitializerJob.runInternal(XWikiInitializerJob.java:117)
at org.xwiki.job.AbstractJob.runInContext(AbstractJob.java:206)
at org.xwiki.job.AbstractJob.run(AbstractJob.java:189)
at java.lang.Thread.run(Thread.java:745)
2017-04-05 11:49:05,217 [XWiki Scheduler initialization] ERROR 
o.x.w.i.DefaultWatchListStore  - Failed to get automatic watch mode for user 
[XWiki.superadmin], using fallbacks 
com.xpn.xwiki.XWikiException: Error number 0 in 5: User [XWiki.superadmin] does 
not exists
at 
org.xwiki.watchlist.internal.DefaultWatchListStore.getWatchListObject(DefaultWatchListStore.java:119)
at 
org.xwiki.watchlist.internal.DefaultWatchListStore.getAutomaticWatchMode(DefaultWatchListStore.java:279)
at 
org.xwiki.watchlist.internal.AutomaticWatchModeListener.documentModifiedHandler(AutomaticWatchModeListener.java:153)
at 
org.xwiki.watchlist.internal.AutomaticWatchModeListener.onEvent(AutomaticWatchModeListener.java:129)
at 
org.xwiki.observation.internal.DefaultObservationManager.notify(DefaultObservationManager.java:304)
at 
org.xwiki.observation.internal.DefaultObservationManager.notify(DefaultObservationManager.java:269)
at com.xpn.xwiki.XWiki.saveDocument(XWiki.java:1775)
at com.xpn.xwiki.XWiki.saveDocument(XWiki.java:1681)
at com.xpn.xwiki.XWiki.saveDocument(XWiki.java:1671)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin.saveStatus(SchedulerPlugin.java:636)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin.scheduleJob(SchedulerPlugin.java:413

[xwiki-users] Empty Pages after reimport

2017-04-05 Thread Timo Dachs-Wegmann
Hello All,

I installed a new xwiki version (9.2 - current stable). I installed it with the 
debian packages and had no problems doing that. Then I made an mysql dump on 
the old wiki and made a rollback on the new machine. Then I copied the 
directory with all the directly written files to the new system (same 
directory). And I merged the configs from old to new, so that the configuration 
has to be the same.

But when I start the xwiki server it shows that it is loading to 100% but right 
after it switches to an empty login page. 
The URL shows this:
Xwiki.domain.de/xwiki/bin/login/XWiki/XWikiLogin?srid=j3QqKRs2=%2Fxwiki%2Fbin%2Fview%2FMain%2F%3Fsrid%3Dj3QqKRs2
But the page is completely blank.

I've logged the process of starting xwiki and found some error messages... But 
I can't get something out of it...
It would be nice if someone could help me with this. :- )


Kind regards

Timo Dachs-Wegmann
-IT-

LOG:

2017-04-05 11:49:02,383 [XWiki initialization] INFO  
.HibernateDataMigrationManager - Storage schema updates and data migrations are 
enabled 
2017-04-05 11:49:02,613 [XWiki initialization] INFO  
.HibernateDataMigrationManager - No data migration to apply for wiki [xwiki] 
currently in version [9] 
2017-04-05 11:49:02,614 [XWiki initialization] INFO  
.HibernateDataMigrationManager - Checking Hibernate mapping and updating schema 
if needed for wiki [xwiki] 
2017-04-05 11:49:04,639 [XWiki initialization] ERROR c.x.x.p.XWikiPluginManager 
- Cannot initialize plugin 
[com.xpn.xwiki.plugin.watchlist.WatchListPlugin]. This plugin will not be 
available. 
java.lang.ClassNotFoundException: com.xpn.xwiki.plugin.watchlist.WatchListPlugin
at org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:193)
at org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:180)
at java.security.AccessController.doPrivileged(Native Method)
at 
org.xwiki.classloader.URIClassLoader.findClass(URIClassLoader.java:179)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at 
org.xwiki.classloader.xwiki.internal.ContextNamespaceURLClassLoader.loadClass(ContextNamespaceURLClassLoader.java:176)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:348)
at 
com.xpn.xwiki.plugin.XWikiPluginManager.addPlugin(XWikiPluginManager.java:83)
at 
com.xpn.xwiki.plugin.XWikiPluginManager.addPlugins(XWikiPluginManager.java:118)
at com.xpn.xwiki.XWiki.preparePlugins(XWiki.java:1463)
at com.xpn.xwiki.XWiki.initXWiki(XWiki.java:1197)
at com.xpn.xwiki.XWiki.initXWiki(XWiki.java:1103)
at com.xpn.xwiki.XWiki.(XWiki.java:1076)
at 
com.xpn.xwiki.internal.XWikiInitializerJob.runInternal(XWikiInitializerJob.java:117)
at org.xwiki.job.AbstractJob.runInContext(AbstractJob.java:206)
at org.xwiki.job.AbstractJob.run(AbstractJob.java:189)
at java.lang.Thread.run(Thread.java:745)
2017-04-05 11:49:05,217 [XWiki Scheduler initialization] ERROR 
o.x.w.i.DefaultWatchListStore  - Failed to get automatic watch mode for user 
[XWiki.superadmin], using fallbacks 
com.xpn.xwiki.XWikiException: Error number 0 in 5: User [XWiki.superadmin] does 
not exists
at 
org.xwiki.watchlist.internal.DefaultWatchListStore.getWatchListObject(DefaultWatchListStore.java:119)
at 
org.xwiki.watchlist.internal.DefaultWatchListStore.getAutomaticWatchMode(DefaultWatchListStore.java:279)
at 
org.xwiki.watchlist.internal.AutomaticWatchModeListener.documentModifiedHandler(AutomaticWatchModeListener.java:153)
at 
org.xwiki.watchlist.internal.AutomaticWatchModeListener.onEvent(AutomaticWatchModeListener.java:129)
at 
org.xwiki.observation.internal.DefaultObservationManager.notify(DefaultObservationManager.java:304)
at 
org.xwiki.observation.internal.DefaultObservationManager.notify(DefaultObservationManager.java:269)
at com.xpn.xwiki.XWiki.saveDocument(XWiki.java:1775)
at com.xpn.xwiki.XWiki.saveDocument(XWiki.java:1681)
at com.xpn.xwiki.XWiki.saveDocument(XWiki.java:1671)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin.saveStatus(SchedulerPlugin.java:636)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin.scheduleJob(SchedulerPlugin.java:413)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin.register(SchedulerPlugin.java:317)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin.register(SchedulerPlugin.java:310)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin.restoreExistingJobs(SchedulerPlugin.java:295)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin.initAsync(SchedulerPlugin.java:164)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin.access$000(SchedulerPlugin.java:76)
at 
com.xpn.xwiki.plugin.scheduler.SchedulerPlugin$1.run(SchedulerPlugin.java:123

Re: [xwiki-users] PlantUML

2017-02-27 Thread Timo Dachs-Wegmann
Hi Vincent,

Thank you for your reply.

So the plugin just needs to fetch the image map from the plantUML Server?
And I guess I'm using an external plantuml server?! 


Kind regards,
Timo
-IT-


Note that another option is to return the result as SVG and let the browser 
display it:

http://www.plantuml.com/plantuml/svg/SyfFKj2rKt3CoKnELR1IoC_cAYtAKSXFKt02IcGMAqH7PvIK55ZfwvUNb-kbv-UdvwJg9UVdniO2

Notice the “svg/” part in the url instead of “img/“.

For this you’d just need to replace:

 println "[[image:"+serverurl+"img/"+encoded+"||style=\"max-width:100%\"]]”

With:

def svg = “${serverurl}/svg/${encoded}||style=\"max-width:100%\”".toURL().text
println “{{html clean=false}}${svg}{{/html}}"

Ofc the browser needs to be able to render svg.

Thanks
-Vincent

> On 27 Feb 2017, at 09:32, Vincent Massol <vinc...@massol.net> wrote:
> 
> Hi Timo,
> 
>> On 22 Feb 2017, at 14:19, Timo Dachs-Wegmann <t.wegm...@procitec.de> wrote:
>> 
>> Hello,
>> 
>> I want to draw a UML Diagram with the XWiki Plugin "PlantUML". As I tested 
>> it, I found a problem with the feature of including links in the diagram.
>> I can't connect an URL to an object, because XWiki seems to import the Macro 
>> as a picture (something like jpeg or gif). 
>> 
>> There is a good Manual on how to insert links on the HowTo Page of 
>> PlantUML.com ( http://plantuml.com/incubation ). The one I tried was a very 
>> basic test:
>>  @startuml
>>  Bob -> Alice : ok
>>  url of Bob is [[http://www.google.com]]
>>  @enduml
>> 
>> The problem with this is, that you can't click on "Bob" as a link because 
>> the link is not passed through to the XWiki page. 
>> Maybe you have an idea how to solve it or could tell me if there is a way to 
>> work around this.
> 
> I’ve not used this extension but its source code is at 
> https://github.com/xwiki-contrib/macro-plantuml
> 
> For example looking at:
> https://github.com/xwiki-contrib/macro-plantuml/blob/master/src/main/resources/XWiki/PlantUMLMacro.xml#L278
> 
> I see (for an externally configured plantuml server):
> 
>  println "[[image:"+serverurl+"img/"+encoded+"||style=\"max-width:100%\"]]"
> 
> This means this will call a URL to the plantuml server and that it returns an 
> image which xwiki only displays.
> 
> I’ve used your example here:
> http://www.plantuml.com/plantuml/uml/SoWkIImgAStDuNBAJrBGjLDmpCbCJbMmKiZFvYejob78JrC0IMGMAqH7PvIK55ZfwvUNb-kbv-UdvwJg9UVdniPoEQJcfG1D
>  and it works for the link (because it’s an image + an image map).
> 
> So AFAICS the reason it won’t work as is with xwiki is that the url used by 
> xwiki to get the image is 
> http://www.plantuml.com/plantuml/png/SyfFKj2rKt3CoKnELR1IoC_cAYtAKSXFKt02IcGMAqH7PvIK55ZfwvUNb-kbv-UdvwJg9UVdniO2
>  which returns only the image and not the image map.
> 
> Haha… found something. There’s another url to call to get the map:
> http://www.plantuml.com/plantuml/map/SyfFKj2rKt3CoKnELR1IoC_cAYtAKSXFKt02IcGMAqH7PvIK55ZfwvUNb-kbv-UdvwJg9UVdniO2
> 
> So it’s very easy to add support for this. The code needs to be modified with 
> something like this:
> 
> def htmlMap = “${serverurl}/map/${encoded}”.toURL().text
> println “{{html clean=false}}${htmlMap}{{/html}}"
> 
> And that should work! :)
> 
> You should create a jira issue at http://jira.xwiki.org/browse/PLANTUML for 
> this.
> 
> Thanks
> -Vincent
> 
>> 
>> Thank you in advance
>> 
>> Kind regards,
>> 
>> Timo Dachs-Wegmann
>> -IT-






Re: [xwiki-users] PlantUML

2017-02-27 Thread Timo Dachs-Wegmann
I guess there is no one else who has this problem?! 



Hello,

I want to draw a UML Diagram with the XWiki Plugin "PlantUML". As I tested it, 
I found a problem with the feature of including links in the diagram.
I can't connect an URL to an object, because XWiki seems to import the Macro as 
a picture (something like jpeg or gif). 

There is a good Manual on how to insert links on the HowTo Page of PlantUML.com 
( http://plantuml.com/incubation ). The one I tried was a very basic test:
@startuml
Bob -> Alice : ok
url of Bob is [[http://www.google.com]]
@enduml

The problem with this is, that you can't click on "Bob" as a link because the 
link is not passed through to the XWiki page. 
Maybe you have an idea how to solve it or could tell me if there is a way to 
work around this.

Thank you in advance

Kind regards,

Timo Dachs-Wegmann
-IT-








[xwiki-users] Upgrading xwiki

2017-02-24 Thread Timo Dachs-Wegmann
Hello,

I'm trying to upgrade our xwiki from 7.1.2 to 9.0.
I figured out how to do it with copying the xwiki.cfg, xwiki.properties and 
hibernate.cfg.xml but I can't use the new .jars in the WEB-INF/lib directory.
If I import the 9.0.jars tomcat7 can't find the xwiki Main page.

I tried to configure it in hibernate.cfg.xml but it looks okay to me. 

On the Upgrading Page 
http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Upgrade Tom Neumann said, 
that you have to copy the MySQL Connector file from the old xwiki installation. 
At first I couldn't find it so I replaced the whole WEB-INF/lib directory with 
the old one. That is working but now I have all the old .jars from 7.1.2...
So I decided to replace them with the new ones but that doesn't work because as 
I said above Tomcat won't find the pages. 
I tried to copy only one at a time to figure out which one needs to be 
configured or has to stay the same as in the old version but every .jar I copy 
gives me the same error...

Could you help me please? I have now a 9.0 Version running (as it says on the 
bottom of my page) but with all the 7.1.2 libs in the WEB-INF folder...


Thank you in advance.

Kind regards,
Timo Dachs-Wegmann
-IT- 






[xwiki-users] PlantUML

2017-02-22 Thread Timo Dachs-Wegmann
Hello,

I want to draw a UML Diagram with the XWiki Plugin "PlantUML". As I tested it, 
I found a problem with the feature of including links in the diagram.
I can't connect an URL to an object, because XWiki seems to import the Macro as 
a picture (something like jpeg or gif). 

There is a good Manual on how to insert links on the HowTo Page of PlantUML.com 
( http://plantuml.com/incubation ). The one I tried was a very basic test:
@startuml
Bob -> Alice : ok
url of Bob is [[http://www.google.com]]
@enduml

The problem with this is, that you can't click on "Bob" as a link because the 
link is not passed through to the XWiki page. 
Maybe you have an idea how to solve it or could tell me if there is a way to 
work around this.

Thank you in advance

Kind regards,

Timo Dachs-Wegmann
-IT-





[xwiki-users] export to pdf with intern links

2017-01-18 Thread Timo Dachs-Wegmann
Hello,

I have a problem with pdf export extensions. I want to export multiple sites in 
a defined space which is no problem at all. 
But it starts getting serious when I want to include links. 

The =1 for example works fine but it only includes the direct 
links to the website.

I need a possibility to change the links to the website to pdf intern links.
Can you see a way how this could work?

That means that I want to export for example a front page with links to other 
pages and export them as well and have an internal link to the pages below the 
front page in the pdf file .

Thank you in advance.

Kind regards

Timo Dachs-Wegmann
-IT- 

--