Re: [xwiki-users] Xwiki replace " " with "+" on title

2016-06-21 Thread stefbort
Hi.
Tanks Helged. The issue 59317 may be the cause. I did other two test and
with Tomcat 9 Xwiki dosn't work fine.
URIEncoding is not cause or solution.
At the moment I am using Tomcat 8.0.35 under Linux and It works fine.




--
View this message in context: 
http://xwiki.475771.n2.nabble.com/Xwiki-replace-with-on-title-tp7599972p7600031.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Xwiki replace " " with "+" on title

2016-06-17 Thread stefbort
Thenks Clemens.
I will read the Tomcat page about http connector. At the moment I am busy on
the configure and populate Xwiki.

At the next post.




--
View this message in context: 
http://xwiki.475771.n2.nabble.com/Xwiki-replace-with-on-title-tp7599972p7600010.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Xwiki replace " " with "+" on title

2016-06-16 Thread stefbort
Hi everybody.

 *FIXIED* 

The cause is Tomcat. With release 8 (maybe 9 too?) Xwiki don't works
correctly.
With release 7 it is a rock!

Like this I see the mysql connector release 6 dont'n works with Xwiki.

Tanks to all .



--
View this message in context: 
http://xwiki.475771.n2.nabble.com/Xwiki-replace-with-on-title-tp7599972p759.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Xwiki replace " " with "+" on title

2016-06-15 Thread stefbort
Thanks Clemens.


Clemens Klein-Robbenhaar wrote
> If you use URIEncoding="UTF8" in the connector of tomcat, all should be
> fine.

Done! But, unfurtunatly, not resolve.
With Jetty don't try. I need to deploy on Tomcat or Wildfly/Jboss.

Regards.






--
View this message in context: 
http://xwiki.475771.n2.nabble.com/Xwiki-replace-with-on-title-tp7599972p7599983.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Xwiki replace " " with "+" on title

2016-06-15 Thread stefbort
Hi Eduard.
I am sorry. I used no rigth names.

"Article" is a wiki page.
"Space" is a wiki page with dashboard.

About double titles are showed in the dashboard, in the list "My Recent
Modification" and if I search I can see two title in the search list.
If I create a new page after "Save & view" I will redirect in the rigth
page.
But now, to try again to write more information, I see more details:
- if I create a "simple" page I have a "norma" title. When I update the page
I will have 2 page: one is a original, one is updated. And I will have a new
title-line in the document automatic list for each version;
- if I create a page with dashboard I will see the "+" insted " ": the
original with "{{dashboard/}}" in the text and the second paga (page with
"+" in the title) with empty text. If I create a new page with location
inside this i will have 3 news dasboard-page. Example: "Space Two", "Space
Two", "Space%2BTwo"...

I will be crazy.

I can see this to go directly on port 8080 of Tomcat. I do not have any
reverse proxy.
OK. Perhaps the problem may be in the Tomcat confogiration? I am using, to
try, italian layout and italian codepage characters. The database in MariaDB
is in utf8_bin, as guide suggest.
When I used the old versione (6.4) I found no problem. Now I don't
understand.

I attach two screenshots.

Thanks.

 
 





--
View this message in context: 
http://xwiki.475771.n2.nabble.com/Xwiki-replace-with-on-title-tp7599972p7599978.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] Xwiki replace " " with "+" on title

2016-06-14 Thread stefbort
Hi.
I made a new Xwiki installazione, but when I create an article or a space
with a title likes "One two" I see two titles/names: "One two" and
"One+two".

Wath I made wrong?

I used "war" package 7.4.3 and 7.4.4-SNAPSHOT on CentOS 7.2 (as minimal
server) with OpenJDK 1.8.0_91, Tomcat 8.0.35, MariaDB 5.5.47 and the Oracle
mysql connector  5.1.9.

Thanks in advance.



--
View this message in context: 
http://xwiki.475771.n2.nabble.com/Xwiki-replace-with-on-title-tp7599972.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users