Re: [xwiki-users] A problem with xwiki macros

2016-08-22 Thread Edward Knyshov
Hi, Vincent.
It's a requirement, that xwiki is fully configured after it's bootstrapped.
So our clients get working system right after deploy. That's why why setup
permissions in code.
Edward.

2016年8月22日(月) 14:51 Vincent Massol :

> Hi,
>
> > On 19 Aug 2016, at 05:21, Edward Knyshov  wrote:
> >
> > Hi. I'm trying to customize permissions in xwiki
> > using ApplicationReadyEventListener.
> > I override some permission in XWikiPreferences XWikiGlobalRights page to
> > get page deletion work by default for all users.
> >
> > https://gist.github.com/edvorg/4e2771ac02c4c64b705127964bc53c64
> >
> > I set up permissions in these functions.
> >
> > https://gist.github.com/edvorg/da7f8e64a46b7bbbf16f953e3fcc0e30
>
> I’m curious to know why you need to write code to set permissions for all
> users? Why don’t you use the UI?
>
> Thanks
> -Vincent
>
> >
> > This solutions works fine. But I got a problem with fresh xwiki
> bootstrap.
> > Sometimes I get fully broken xwiki - all macros shows error. And I have
> > something about admin user not having permission to edit some page:
> >
> > https://gist.github.com/edvorg/1bdec91e5483307696bc68841d2cb1d8
> >
> > I tried to debug all this code but it doesn't make much sense to me. I
> only
> > found that this CacheChecker thing somehow affects the issue. Could
> someone
> > point me to possible issues in my solution and maybe describe how this
> > CacheChecker should be used? I would appreciate any help, as we can not
> get
> > rid of xwiki integration bugs for a long time. Thank you!
>
> ___
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] A problem with xwiki macros

2016-08-18 Thread Edward Knyshov
Hi. I'm trying to customize permissions in xwiki
using ApplicationReadyEventListener.
I override some permission in XWikiPreferences XWikiGlobalRights page to
get page deletion work by default for all users.

https://gist.github.com/edvorg/4e2771ac02c4c64b705127964bc53c64

I set up permissions in these functions.

https://gist.github.com/edvorg/da7f8e64a46b7bbbf16f953e3fcc0e30

This solutions works fine. But I got a problem with fresh xwiki bootstrap.
Sometimes I get fully broken xwiki - all macros shows error. And I have
something about admin user not having permission to edit some page:

https://gist.github.com/edvorg/1bdec91e5483307696bc68841d2cb1d8

I tried to debug all this code but it doesn't make much sense to me. I only
found that this CacheChecker thing somehow affects the issue. Could someone
point me to possible issues in my solution and maybe describe how this
CacheChecker should be used? I would appreciate any help, as we can not get
rid of xwiki integration bugs for a long time. Thank you!
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users