Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-03-06 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
Hi Guillaume, Guillaume Lerouge wrote: if it works let's use it ;-) Following Vicent advise in another thread I have realized that Panels.IncludedDocuments could help me to avoid a problem: if I included Panels.BulletinBoardList in a given column and an user has no access to any bulletin

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-03-06 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
[Ricardo Rodriguez] Your EPEC Network ICT Team wrote: Hi Guillaume, Guillaume Lerouge wrote: if it works let's use it ;-) Following Vicent advise in another thread I have realized that Panels.IncludedDocuments could help me to avoid a problem: if I included

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-25 Thread Sergiu Dumitriu
[Ricardo Rodriguez] Your EPEC Network ICT Team wrote: Sergiu Dumitriu wrote: Simple. $xwiki.getDocument returns null if you can't access that document. #set($var = null) will leave $var to its previous value (velocity feature, can be configured to allow setting null, but it is not allowed

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-25 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
Nope, just my years of experience with Velocity. Thanks! I do hope I manage to get such an experience... Best, -- Ricardo Rodríguez Your EPEC Network ICT Team ___ users mailing list users@xwiki.org

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-21 Thread Guillaume Lerouge
It makes sense, discussions àla Wikipedia if I'm right ;-) The quickest way to do this is to create a specific skin with a new displayer for comments. In fact, that's what was done for http://wikipeople.elle.fr, see for instance http://wikipeople.elle.fr/xwiki/bin/view/People/DrewBarrymore . As

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-21 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
Hi Guillaume! Guillaume Lerouge wrote: It makes sense, discussions àla Wikipedia if I'm right ;-) I am not sure this is a good comparison. I must recognize that the last MediaWiki release I've installed and used is a bit old (1.9.3), but as far as I see the possibilities open by the XWiki

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-21 Thread Guillaume Lerouge
Hi there, The last version of the Bulletin Board Application is now available for download at http://code.xwiki.org/xwiki/bin/view/Applications/BulletinBoardApplicationDownloads . Description of the application available here :

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-21 Thread [Ricardo Rodriguez]
Hi! Guillaume Lerouge wrote: This version adds a few layout changes and introduces a new panel that lists the bulletin boards an user has access to in a given wiki, available at [ Panels.BulletinBoardList] Hope you will like it, Guillaume I do! At least for us, this is a longly

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-21 Thread [Ricardo Rodriguez]
Hi! Sorry for posting this message again, but I've done something wrong in my previous post and it is hard to read it. Guillaume Lerouge wrote: This version adds a few layout changes and introduces a new panel that lists the bulletin boards an user has access to in a given wiki, available

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-21 Thread Guillaume Lerouge
There's a problem indeed... Here is the code : #set ($sql = , BaseObject as obj where obj.name=doc.fullName and obj.className='BBCode.BBClass' and obj.name'BBCode.BBClassTemplate' order by doc.date desc) #set($bbs = $xwiki.searchDocuments($sql)) #foreach ($item in $bbs) #set ($bbdoc =

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-21 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
Guillaume Lerouge wrote: - the check on rights is done before the moment each Bulletin Board is displayed, so it may have something to do with the rights configuration... Do you explicitely deny the view right to your user ? (Locally when I deny view right to an user he cannot see the

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-20 Thread Guillaume Lerouge
Hi, the problem you encountered has now been corrected. The Bulletin Board application has also been upgraded, adding some administration features as well as the possibility to quote other messages. Full description here : http://code.xwiki.org/xwiki/bin/view/Applications/BulletinBoardApplication

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-20 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
Guillaume Lerouge wrote: Hi, the problem you encountered has now been corrected. The Bulletin Board application has also been upgraded, adding some administration features as well as the possibility to quote other messages. Full description here :

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-20 Thread Guillaume Lerouge
Hi Ricardo, I'm not quite sure about what's the best way to handle this issue at the level of categories. However, please note that using the latest version of the application you can create new bulletin boards, giving each one its own space. This way protecting Topics and categories becomes much

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-20 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
Guillaume Lerouge wrote: Hi Ricardo, I'm not quite sure about what's the best way to handle this issue at the level of categories. However, please note that using the latest version of the application you can create new bulletin boards, giving each one its own space. This way protecting

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-19 Thread Guillaume Lerouge
Hi, I tried to reproduce your problem but didn't manage to... Can you provide more information about the steps you're following ? - is your user logged-in when he creates the topic ? - has you done anything special with your rights setup ? - has the page been saved once before you create the

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-19 Thread Ngo Thi Hong Nga
http://rapidshare.com/files/93105012/XwikiBulletionBoard.avi.html You can download my screen recorder to see what I have done. The category name, category description, topic title and topic first post all empty. ___ users mailing list users@xwiki.org

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-19 Thread Ngo Thi Hong Nga
I use XE 1.1.2 ___ users mailing list users@xwiki.org http://lists.xwiki.org/mailman/listinfo/users

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-19 Thread Ngo Thi Hong Nga
I use Windows Media Player 11 with K-lite Codec Pack to view this avi. You can download K-lite Codec Pack here: http://rapidshare.com/files/93178779/klcodec362f.exe.html ;) ___ users mailing list users@xwiki.org

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-19 Thread Guillaume Lerouge
Ok, I found the problem with the help of a handful of helpful people :-) I'll update the XAR in the evening. Thanks for your patience and your help ! Guillaume On 19/02/2008, Ngo Thi Hong Nga [EMAIL PROTECTED] wrote: I found the problem: when using IE 7.0.5730.11 the problem occurs, but when

[xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-18 Thread Ngo Thi Hong Nga
I use Bulletin Board application with XE 1.1.2. I import the xar file, I add a new topic, enter title and first post, then make some reply. Every thing is displayed properly (author, post reply,..), except for the topic title and topic first post always be the empty string , although they are not

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-18 Thread Ngo Thi Hong Nga
The screenshot is here: http://farm3.static.flickr.com/2411/2274127483_df5296912f_o.jpg In the left is view mode and the right is edit mode. I check the contents of the TopicClass object in my topic page, both the properties title and post is empty, when I enter something in these 2 properties,

Re: [xwiki-users] Bulletin Board cannot display topic title and first post !?

2008-02-18 Thread Ngo Thi Hong Nga
I have already entered a title and the first post for the new topic, then click Save and View and the result is what you see in the left of the screenshot. That's the reason why I post this problem here. ___ users mailing list users@xwiki.org