[xwiki-users] WysiWyg Editor compile error

2010-10-08 Thread Ramon Gomes Brandão - SERINT
Hi, 

I had until today success compiling the wysiwyg modules. So I've updated my 
local checked-out code to the last head version of wysiwyg editor (both client 
and server modules), but now the server module fails to compile with the 
following error:


[ERROR] Failed to execute goal 
org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile (default-compile) 
on project xwiki-web-gwt-wysiwyg-server: Compilation failure: Compilation 
failure: 
/workspace/xwiki-gwt-wysiwyg-server/src/main/java/com/xpn/xwiki/wysiwyg/server/internal/wiki/DefaultLinkService.java:[33,33]
 cannot find symbol
symbol  : class LinkParser
location: package org.xwiki.rendering.parser
/workspace/xwiki-gwt-wysiwyg-server/src/main/java/com/xpn/xwiki/wysiwyg/server/internal/wiki/DefaultLinkService.java:[91,12]
 cannot find symbol
symbol  : class LinkParser
location: class com.xpn.xwiki.wysiwyg.server.internal.wiki.DefaultLinkService

I'm using the XE 2.4. How can  I correct this error? Should I use another 
branch/version/revision of server module? The client module worked well with 
the latest from HEAD. 

Regards, 
Ramon
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] WysiWyg Editor compile error

2010-10-08 Thread Marius Dumitru Florea
Hi Ramon,

On 10/08/2010 10:22 AM, Ramon Gomes Brandão - SERINT wrote:
 Hi,

 I had until today success compiling the wysiwyg modules. So I've updated my 
 local checked-out code to the last head version of wysiwyg editor (both 
 client and server modules), but now the server module fails to compile with 
 the following error:


 [ERROR] Failed to execute goal 
 org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile 
 (default-compile) on project xwiki-web-gwt-wysiwyg-server: Compilation 
 failure: Compilation failure:
 /workspace/xwiki-gwt-wysiwyg-server/src/main/java/com/xpn/xwiki/wysiwyg/server/internal/wiki/DefaultLinkService.java:[33,33]
  cannot find symbol
 symbol  : class LinkParser
 location: package org.xwiki.rendering.parser
 /workspace/xwiki-gwt-wysiwyg-server/src/main/java/com/xpn/xwiki/wysiwyg/server/internal/wiki/DefaultLinkService.java:[91,12]
  cannot find symbol
 symbol  : class LinkParser
 location: class com.xpn.xwiki.wysiwyg.server.internal.wiki.DefaultLinkService

Should be fine now (it was a mistake on our side). Update your sources. 
Note that the WYSIWYG server side (2.5-SNAPSHOT) has some changes that 
are compatible with XE 2.4. The client side might work well though.

Hope this helps,
Marius


 I'm using the XE 2.4. How can  I correct this error? Should I use another 
 branch/version/revision of server module? The client module worked well with 
 the latest from HEAD.

 Regards,
 Ramon
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users