Re: [xwiki-users] XWiki going out of resources

2011-03-23 Thread Andreas Hahn
This problem seems to strike back on me.
Whenever I open the users page .../XWiki/aha
it sends the garbage collector to infinity - restarting Tomcat is the only
help.
However its an older wiki: XWiki Enterprise 2.3-milestone-1.27899

This is the .xar:

https://docs.google.com/leaf?id=0B05JH-hYx5XINjkyNzBlNjAtODkyYy00MWUxLTlkNWQtODcwMTljMGNlOTY3hl=de

Thanks for your support

Andreas

--
View this message in context: 
http://xwiki.475771.n2.nabble.com/XWiki-going-out-of-resources-tp5885402p6199454.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki going out of resources

2011-03-23 Thread Vincent Massol
Hi Andreas,

On Mar 23, 2011, at 10:05 AM, Andreas Hahn wrote:

 This problem seems to strike back on me.
 Whenever I open the users page .../XWiki/aha
 it sends the garbage collector to infinity - restarting Tomcat is the only
 help.
 However its an older wiki: XWiki Enterprise 2.3-milestone-1.27899
 
 This is the .xar:
 
 https://docs.google.com/leaf?id=0B05JH-hYx5XINjkyNzBlNjAtODkyYy00MWUxLTlkNWQtODcwMTljMGNlOTY3hl=de
 
 Thanks for your support

I don't know what the problem is but do you have the same issue with XE 2.7.1 
or XE 3.0M3? (would be good to know if there's something to fix)

Thanks
-Vincent

PS: Note that the strategy for xwiki developers is to support only the last 2 
versions (ie 2.7.x and 3.0 as of now).
See http://www.xwiki.org/xwiki/bin/view/Main/Support (I've just added the info 
box)
That said, you may be lucky and find someone to help you with your specific 
problem on a 2.3M1 release.

 Andreas
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki going out of resources

2011-03-23 Thread Andreas Hahn
Am 23.03.2011 10:31, schrieb Vincent Massol:
 Hi Andreas,

 On Mar 23, 2011, at 10:05 AM, Andreas Hahn wrote:

 This problem seems to strike back on me.
 Whenever I open the users page .../XWiki/aha
 it sends the garbage collector to infinity - restarting Tomcat is the only
 help.
 However its an older wiki: XWiki Enterprise 2.3-milestone-1.27899

 This is the .xar:

 https://docs.google.com/leaf?id=0B05JH-hYx5XINjkyNzBlNjAtODkyYy00MWUxLTlkNWQtODcwMTljMGNlOTY3hl=de

 Thanks for your support
 I don't know what the problem is but do you have the same issue with XE 2.7.1 
 or XE 3.0M3? (would be good to know if there's something to fix)

 Thanks
 -Vincent

 PS: Note that the strategy for xwiki developers is to support only the last 2 
 versions (ie 2.7.x and 3.0 as of now).
 See http://www.xwiki.org/xwiki/bin/view/Main/Support (I've just added the 
 info box)
 That said, you may be lucky and find someone to help you with your specific 
 problem on a 2.3M1 release.

I understand that. However in that instance I did some changes to the 
*.cfg and thus I hoped to avoid trouble by postponing the migration ...

thanks
Andreas
 Andreas
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users


___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] XWiki going out of resources

2011-01-03 Thread Andreas Hahn
Hi XWiki users,

fwiw I just want to share my experiences and observations with XWiki 
instance running out of memory.

I was having a hard time to track this down but in the end I could 
successfully isolate the problem.
For quite some time my XWiki instance was getting unresponsive to 
requests sooner or later.

The Wiki was hosted on a VirtualBox VM and in most cases the VM guest 
was just freezing and needed to be restarted leaving no usable traces in 
the logs. In some cases I even found JVM crash reports so I first 
checked different JVMs and VirtualBox versions (PUEL and OSE licences).

I had no success with this approach and so I moved the XWiki directly to 
a host environment (Ubuntu 10.10). I added Server instrumentation 
(VisualVM) but still the wiki got down after a while. Surprisingly the 
system was hanging although in many cases there was even enough memory 
available (I checked different VM settings up to 4GB).
Finally a VisualVM thread dump showed what happened:
When the robots came visiting my service they query a large number of 
pages and among them was one user-url:
.../XWiki/someUser which ran into an infinite looping condition when 
rendering the page.
I don't know how this could happen but as a result the whole memory was 
consumed and partly released afterwards so it seemed that there is still 
enough space available. Once this happened however the Webserver needed 
to be restarted because it wasn't responsive any more.
Since I have deleted this user account everything is running ok for a 
couple of days now - I still have to move the service back into the 
VirtualBox guest VM.

What puzzles me finally that its possible that one single request can 
kill the service by going into an infinte rendering loop.
I would have thought that at some level there is a depth limit to 
prevent such conditions.

Hope these observations help someone though 

enjoy
Andreas

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki going out of resources

2011-01-03 Thread Sergiu Dumitriu
On 01/03/2011 12:38 PM, Andreas Hahn wrote:
 Hi XWiki users,

 fwiw I just want to share my experiences and observations with XWiki
 instance running out of memory.

 I was having a hard time to track this down but in the end I could
 successfully isolate the problem.
 For quite some time my XWiki instance was getting unresponsive to
 requests sooner or later.

 The Wiki was hosted on a VirtualBox VM and in most cases the VM guest
 was just freezing and needed to be restarted leaving no usable traces in
 the logs. In some cases I even found JVM crash reports so I first
 checked different JVMs and VirtualBox versions (PUEL and OSE licences).

 I had no success with this approach and so I moved the XWiki directly to
 a host environment (Ubuntu 10.10). I added Server instrumentation
 (VisualVM) but still the wiki got down after a while. Surprisingly the
 system was hanging although in many cases there was even enough memory
 available (I checked different VM settings up to 4GB).
 Finally a VisualVM thread dump showed what happened:
 When the robots came visiting my service they query a large number of
 pages and among them was one user-url:
 .../XWiki/someUser which ran into an infinite looping condition when
 rendering the page.
 I don't know how this could happen but as a result the whole memory was
 consumed and partly released afterwards so it seemed that there is still
 enough space available. Once this happened however the Webserver needed
 to be restarted because it wasn't responsive any more.
 Since I have deleted this user account everything is running ok for a
 couple of days now - I still have to move the service back into the
 VirtualBox guest VM.

 What puzzles me finally that its possible that one single request can
 kill the service by going into an infinte rendering loop.
 I would have thought that at some level there is a depth limit to
 prevent such conditions.

Normally, there are recursion checks in different places, like velocity 
macros can be nested to at most 20 levels (100 in 3.0). What would help 
is exporting the user profile as XAR and uploading it somewhere so that 
we can see what's causing this specific problem.

 Hope these observations help someone though 


-- 
Sergiu Dumitriu
http://purl.org/net/sergiu/
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki going out of resources

2011-01-03 Thread Andreas Hahn
Am 03.01.2011 13:21, schrieb Sergiu Dumitriu:
 On 01/03/2011 12:38 PM, Andreas Hahn wrote:
 Hi XWiki users,

 fwiw I just want to share my experiences and observations with XWiki
 instance running out of memory.

 I was having a hard time to track this down but in the end I could
 successfully isolate the problem.
 For quite some time my XWiki instance was getting unresponsive to
 requests sooner or later.

 The Wiki was hosted on a VirtualBox VM and in most cases the VM guest
 was just freezing and needed to be restarted leaving no usable traces in
 the logs. In some cases I even found JVM crash reports so I first
 checked different JVMs and VirtualBox versions (PUEL and OSE licences).

 I had no success with this approach and so I moved the XWiki directly to
 a host environment (Ubuntu 10.10). I added Server instrumentation
 (VisualVM) but still the wiki got down after a while. Surprisingly the
 system was hanging although in many cases there was even enough memory
 available (I checked different VM settings up to 4GB).
 Finally a VisualVM thread dump showed what happened:
 When the robots came visiting my service they query a large number of
 pages and among them was one user-url:
 .../XWiki/someUser which ran into an infinite looping condition when
 rendering the page.
 I don't know how this could happen but as a result the whole memory was
 consumed and partly released afterwards so it seemed that there is still
 enough space available. Once this happened however the Webserver needed
 to be restarted because it wasn't responsive any more.
 Since I have deleted this user account everything is running ok for a
 couple of days now - I still have to move the service back into the
 VirtualBox guest VM.

 What puzzles me finally that its possible that one single request can
 kill the service by going into an infinte rendering loop.
 I would have thought that at some level there is a depth limit to
 prevent such conditions.
 Normally, there are recursion checks in different places, like velocity
 macros can be nested to at most 20 levels (100 in 3.0). What would help
 is exporting the user profile as XAR and uploading it somewhere so that
 we can see what's causing this specific problem.

 Ok, thanks for your support offer. I'll see if I can restore the old user 
 profile. I've created a new one with the same name in the meantime.
 Hope these observations help someone though 


___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users