Re: Unexpected compilation error with 2.4.14

2018-03-06 Thread Jochen Theodorou
On 06.03.2018 13:23, Andres Almiray wrote: Hello everyone, I'm in the process of updating the Griffon build to use Groovy 2.4.14 and encountered a weird problem in one of the tests

Re: Unexpected compilation error with 2.4.14

2018-03-06 Thread Paul King
I used 1.8.0_161 but so far have only pasted the problematic line into Groovy Console and run it. Jochen, your change did seem to be missing on 2_5_X but was on the other branches. I just cherry picked it onto 2_5_X. I think we need to close off GROOVY-8338 and clone a new issue with a new

Re: Unexpected compilation error with 2.4.14

2018-03-06 Thread Paul King
Okay, I can reproduce now on 2.4.14 and latest 2_4_X using 1.8.0_161. No problem on that JVM version with 2.5.0-beta-3 or 2_5_X with the cherry-picked change or 2.6.0-alpha-3 or master. Cheers, Paul. On Wed, Mar 7, 2018 at 10:13 AM, Paul King wrote: > I used 1.8.0_161 but

Re: Unexpected compilation error with 2.4.14

2018-03-06 Thread Paul King
I created https://issues.apache.org/jira/browse/GROOVY-8494 to track this. Cheers, Paul. On Wed, Mar 7, 2018 at 10:34 AM, Paul King wrote: > Okay, I can reproduce now on 2.4.14 and latest 2_4_X using 1.8.0_161. > No problem on that JVM version with 2.5.0-beta-3 or 2_5_X

Re: Unexpected compilation error with 2.4.14

2018-03-06 Thread Paul King
Looks weird. We should never get a VerifyError, so worth raising a bug. That line by itself seems to work okay in a script. I won't get time until tomorrow to replicate properly. Someone else might jump in in the meantime. Cheers, Paul. On Tue, Mar 6, 2018 at 10:23 PM, Andres Almiray

Unexpected compilation error with 2.4.14

2018-03-06 Thread Andres Almiray
Hello everyone, I'm in the process of updating the Griffon build to use Groovy 2.4.14 and encountered a weird problem in one of the tests