Re: [FFP] DHCP-Requests werden nicht weitergeleitet

2018-04-10 Diskussionsfäden Sven R.
Nur der Vollständigkeit halber hier mal das Doku-Stück zu der Gateway
Geschichte:

https://www.open-mesh.org/projects/batman-adv/wiki/Gateways

demnach werden DHCP Broadcasts von batman in ein unicast umgewandelt,
und nur zu einem ausgewählten node, der als 'gw server' konfiguriert
ist, weitergeleitet.


Sven


Am 09.04.2018 um 15:46 schrieb Johannes Rohr:
> Am Montag, 9. April 2018, 14:52:49 CEST schrieb Sven R.:
>
>>> Da ich das mittlerweile auf mehreren Routern sehe, seit ich die Uplinks
>>> auf
>>> Hedy mit no-tunnel aktualisiert habe und es anscheinend nichts hilft, die
>>> Router ohne eigenen Uplink auf Hedy zu aktualisiere (ja, mit Reset und
>>> Neukonfiguration), glaube ich nicht, dass das Problem beim einzelnen
>>> Router
>>> liegt. Irgendwas lässt die DHCP-Pakete in diesem Roaming-Netz nicht durch.
>>> Irgendein Problem mit B.A.T.M.A.N?
>> batman macht eigentlich ein layer2 netz, das sollte sich eigentlich
>> nicht dafür interessieren, ob ein packet dhcp oder irgendwas anderes ist.
> Habe den Fehler mittlerweile gefunden. Habe bei der Einrichtung der Uplinks 
> mit Hedy die Befehle für die /etc/rc.local offenbar gedankenlos aus der 
> Sektion für die Clients kopiert. Daher stand bei den Uplinks batctl gw client 
> anstelle von gw server. Und das hatte offenbar diesen Nebeneffekt.
>
> Ciao,
>
> Johannes
>
>
>
>>> Gibt es anderswo in der Potsdamer community ein Roaming-Netz, dass nach
>>> der
>>> Umstellung auf Hedy vernünftig funktioniert?
>> bei mir läuft ein hedy 1.1.0 ausm buildbot als uplink und teilweise hedy
>> und alte kathleen 0.1.2 als roaming clients.
>> allerdings alles via kabelkopplung verbunden
>>
>>> Hat jemand einen Tipp für mich, wie ich feststellen kann, wo die
>>> DHCP-Pakete hängenbleiben?
>> wie gesagt, auf jedem router noch ne extra ssid und dann systematisch
>> durchchecken, vll geht es von einem und vom anderen nicht.
>>
>> der erste dhcp-request ist in der regel broadcast, vll stimmen da
>> irgendwo die netzmasken nicht auf den roaming-interfaces mit dhcp
>>
>>> Achja, auf https://wiki.freifunk-potsdam.de/Roaming steht, bei Clients
>>> solle man die Schnittstelle ROAM_IP keiner Firewallzone zuordnen, auf den
>>> Uplinks aber zu "Freifunk". Gilt das noch? Ich nehme an, dass in einem
>>> Roaming- Netzwerk die DHCP-Pakete über die ROAM_AP-Schnittstelle laufen.
>> das gilt noch.
>> die firewall gruppen beeinflussen das routing auf layer3, batman baut
>> aber ein großes layer2 netz auf,
>> daher werden die pakete von batman auf layer2 geroutet.
>> erst auf dem uplink werden die pakete dann auf layer3 geroutet, daher
>> muss dort das interface in der firewallgruppe freifunk sein.
>>
>>> Ciao,
>>>
>>> Johannes
>> funktioniert denn wirklich nur dhcp nicht?
>> das häufigste problem mit batman ist, dass irgendwo das bat0 nicht auf
>> der br-ROAM_AP liegt,
>> dann geht aber in der regel gar nichts an dem betreffoffenem router.
>>
>> weißt du denn von welchem router aus das nicht geht, macht es einen
>> unterschied, ob der router über kabelkopplung oder luft mit dem uplink
>> verbunden ist?
>>
>> Sven
>>
 Sven

 Am 09.04.2018 um 11:48 schrieb Johannes Rohr:
> Am Montag, 9. April 2018, 06:46:56 CEST schrieb Carsten N:
>> Hallo Johannes,
>> solch komisches Verhalten stellte ich öfters bei Kathleen 0.3.0 fest.
>> Hier empfehle ich, mal auf irgend eine andere Kathleen oder Hedy zu
>> wechsel und zu probien.
> Hat leider bisher nichts gebracht.
>
> Johannes
>
>> Viele Grüße
>> Carsten
>>
>> Am 08.04.2018 22:12, schrieb Johannes Rohr:
>>> Im Uferwerk haben wir ja ein Roaming-Netzwerk nach
>>> https://wiki.freifunk-potsdam.de/Roaming Seit ich die Uplinks auf Hedy
>>> mit No-Tunnel aktualisiert
>>> habe stelle ich fest, dass einige der Clients auf denen noch Kathleen
>>> läuft,
>>> keine DHCP-Requests mehr weiterleiten. Wenn ein client schon eine
>>> IP-Adresse
>>> bevor er zu dem fraglichen Knoten wechselt geht's. Aber wenn er über
>>> den
>>> betroffenen Knoten ein DHCP-Request rausschickt, kommt keine Antwort.
>>>
>>> Bevor ich die Uplinks auf Hedy umgestellt war alles in Ordnung.
>>>
>>> Kann sich da jemand einen Reim drauf machen?
>>>
>>> Johannes
>> ___
>> Users mailing list
>> Users@lists.freifunk-potsdam.de
>> https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users
>
>
>

___
Users mailing list
Users@lists.freifunk-potsdam.de
https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users

Re: [FFP] DHCP-Requests werden nicht weitergeleitet

2018-04-09 Diskussionsfäden Johannes Rohr
Am Montag, 9. April 2018, 14:52:49 CEST schrieb Sven R.:

> > Da ich das mittlerweile auf mehreren Routern sehe, seit ich die Uplinks
> > auf
> > Hedy mit no-tunnel aktualisiert habe und es anscheinend nichts hilft, die
> > Router ohne eigenen Uplink auf Hedy zu aktualisiere (ja, mit Reset und
> > Neukonfiguration), glaube ich nicht, dass das Problem beim einzelnen
> > Router
> > liegt. Irgendwas lässt die DHCP-Pakete in diesem Roaming-Netz nicht durch.
> > Irgendein Problem mit B.A.T.M.A.N?
> 
> batman macht eigentlich ein layer2 netz, das sollte sich eigentlich
> nicht dafür interessieren, ob ein packet dhcp oder irgendwas anderes ist.

Habe den Fehler mittlerweile gefunden. Habe bei der Einrichtung der Uplinks 
mit Hedy die Befehle für die /etc/rc.local offenbar gedankenlos aus der 
Sektion für die Clients kopiert. Daher stand bei den Uplinks batctl gw client 
anstelle von gw server. Und das hatte offenbar diesen Nebeneffekt.

Ciao,

Johannes



> 
> > Gibt es anderswo in der Potsdamer community ein Roaming-Netz, dass nach
> > der
> > Umstellung auf Hedy vernünftig funktioniert?
> 
> bei mir läuft ein hedy 1.1.0 ausm buildbot als uplink und teilweise hedy
> und alte kathleen 0.1.2 als roaming clients.
> allerdings alles via kabelkopplung verbunden
> 
> > Hat jemand einen Tipp für mich, wie ich feststellen kann, wo die
> > DHCP-Pakete hängenbleiben?
> 
> wie gesagt, auf jedem router noch ne extra ssid und dann systematisch
> durchchecken, vll geht es von einem und vom anderen nicht.
> 
> der erste dhcp-request ist in der regel broadcast, vll stimmen da
> irgendwo die netzmasken nicht auf den roaming-interfaces mit dhcp
> 
> > Achja, auf https://wiki.freifunk-potsdam.de/Roaming steht, bei Clients
> > solle man die Schnittstelle ROAM_IP keiner Firewallzone zuordnen, auf den
> > Uplinks aber zu "Freifunk". Gilt das noch? Ich nehme an, dass in einem
> > Roaming- Netzwerk die DHCP-Pakete über die ROAM_AP-Schnittstelle laufen.
> 
> das gilt noch.
> die firewall gruppen beeinflussen das routing auf layer3, batman baut
> aber ein großes layer2 netz auf,
> daher werden die pakete von batman auf layer2 geroutet.
> erst auf dem uplink werden die pakete dann auf layer3 geroutet, daher
> muss dort das interface in der firewallgruppe freifunk sein.
> 
> > Ciao,
> > 
> > Johannes
> 
> funktioniert denn wirklich nur dhcp nicht?
> das häufigste problem mit batman ist, dass irgendwo das bat0 nicht auf
> der br-ROAM_AP liegt,
> dann geht aber in der regel gar nichts an dem betreffoffenem router.
> 
> weißt du denn von welchem router aus das nicht geht, macht es einen
> unterschied, ob der router über kabelkopplung oder luft mit dem uplink
> verbunden ist?
> 
> Sven
> 
> >> Sven
> >> 
> >> Am 09.04.2018 um 11:48 schrieb Johannes Rohr:
> >>> Am Montag, 9. April 2018, 06:46:56 CEST schrieb Carsten N:
>  Hallo Johannes,
>  solch komisches Verhalten stellte ich öfters bei Kathleen 0.3.0 fest.
>  Hier empfehle ich, mal auf irgend eine andere Kathleen oder Hedy zu
>  wechsel und zu probien.
> >>> 
> >>> Hat leider bisher nichts gebracht.
> >>> 
> >>> Johannes
> >>> 
>  Viele Grüße
>  Carsten
>  
>  Am 08.04.2018 22:12, schrieb Johannes Rohr:
> > Im Uferwerk haben wir ja ein Roaming-Netzwerk nach
> > https://wiki.freifunk-potsdam.de/Roaming Seit ich die Uplinks auf Hedy
> > mit No-Tunnel aktualisiert
> > habe stelle ich fest, dass einige der Clients auf denen noch Kathleen
> > läuft,
> > keine DHCP-Requests mehr weiterleiten. Wenn ein client schon eine
> > IP-Adresse
> > bevor er zu dem fraglichen Knoten wechselt geht's. Aber wenn er über
> > den
> > betroffenen Knoten ein DHCP-Request rausschickt, kommt keine Antwort.
> > 
> > Bevor ich die Uplinks auf Hedy umgestellt war alles in Ordnung.
> > 
> > Kann sich da jemand einen Reim drauf machen?
> > 
> > Johannes
> 
> ___
> Users mailing list
> Users@lists.freifunk-potsdam.de
> https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users




___
Users mailing list
Users@lists.freifunk-potsdam.de
https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users

Re: [FFP] DHCP-Requests werden nicht weitergeleitet

2018-04-09 Diskussionsfäden Sven R.
Am 09.04.2018 um 14:28 schrieb Johannes Rohr:
> Am Montag, 9. April 2018, 12:02:11 CEST schrieb Sven R.:
>> um sowas besser zu debuggen, hab ich bei mir pro router noch eine extra
>> ssid mit verschlüsseltem netz drauf,
>> da kann man das dann auf einen router eingrenzen.
> Da ich das mittlerweile auf mehreren Routern sehe, seit ich die Uplinks auf 
> Hedy mit no-tunnel aktualisiert habe und es anscheinend nichts hilft, die 
> Router ohne eigenen Uplink auf Hedy zu aktualisiere (ja, mit Reset und 
> Neukonfiguration), glaube ich nicht, dass das Problem beim einzelnen Router 
> liegt. Irgendwas lässt die DHCP-Pakete in diesem Roaming-Netz nicht durch. 
> Irgendein Problem mit B.A.T.M.A.N? 
batman macht eigentlich ein layer2 netz, das sollte sich eigentlich
nicht dafür interessieren, ob ein packet dhcp oder irgendwas anderes ist.
>
> Gibt es anderswo in der Potsdamer community ein Roaming-Netz, dass nach der 
> Umstellung auf Hedy vernünftig funktioniert? 
bei mir läuft ein hedy 1.1.0 ausm buildbot als uplink und teilweise hedy
und alte kathleen 0.1.2 als roaming clients.
allerdings alles via kabelkopplung verbunden
>
> Hat jemand einen Tipp für mich, wie ich feststellen kann, wo die DHCP-Pakete 
> hängenbleiben?
wie gesagt, auf jedem router noch ne extra ssid und dann systematisch
durchchecken, vll geht es von einem und vom anderen nicht.

der erste dhcp-request ist in der regel broadcast, vll stimmen da
irgendwo die netzmasken nicht auf den roaming-interfaces mit dhcp
>
> Achja, auf https://wiki.freifunk-potsdam.de/Roaming steht, bei Clients solle 
> man die Schnittstelle ROAM_IP keiner Firewallzone zuordnen, auf den Uplinks 
> aber zu "Freifunk". Gilt das noch? Ich nehme an, dass in einem Roaming-
> Netzwerk die DHCP-Pakete über die ROAM_AP-Schnittstelle laufen.
das gilt noch.
die firewall gruppen beeinflussen das routing auf layer3, batman baut
aber ein großes layer2 netz auf,
daher werden die pakete von batman auf layer2 geroutet.
erst auf dem uplink werden die pakete dann auf layer3 geroutet, daher
muss dort das interface in der firewallgruppe freifunk sein.
> Ciao,
>
> Johannes
funktioniert denn wirklich nur dhcp nicht?
das häufigste problem mit batman ist, dass irgendwo das bat0 nicht auf
der br-ROAM_AP liegt,
dann geht aber in der regel gar nichts an dem betreffoffenem router.

weißt du denn von welchem router aus das nicht geht, macht es einen
unterschied, ob der router über kabelkopplung oder luft mit dem uplink
verbunden ist?

Sven
>
>> Sven
>>
>> Am 09.04.2018 um 11:48 schrieb Johannes Rohr:
>>> Am Montag, 9. April 2018, 06:46:56 CEST schrieb Carsten N:
 Hallo Johannes,
 solch komisches Verhalten stellte ich öfters bei Kathleen 0.3.0 fest.
 Hier empfehle ich, mal auf irgend eine andere Kathleen oder Hedy zu
 wechsel und zu probien.
>>> Hat leider bisher nichts gebracht.
>>>
>>> Johannes
>>>
 Viele Grüße
 Carsten

 Am 08.04.2018 22:12, schrieb Johannes Rohr:
> Im Uferwerk haben wir ja ein Roaming-Netzwerk nach
> https://wiki.freifunk-potsdam.de/Roaming Seit ich die Uplinks auf Hedy
> mit No-Tunnel aktualisiert
> habe stelle ich fest, dass einige der Clients auf denen noch Kathleen
> läuft,
> keine DHCP-Requests mehr weiterleiten. Wenn ein client schon eine
> IP-Adresse
> bevor er zu dem fraglichen Knoten wechselt geht's. Aber wenn er über
> den
> betroffenen Knoten ein DHCP-Request rausschickt, kommt keine Antwort.
>
> Bevor ich die Uplinks auf Hedy umgestellt war alles in Ordnung.
>
> Kann sich da jemand einen Reim drauf machen?
>
> Johannes
>

___
Users mailing list
Users@lists.freifunk-potsdam.de
https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users

Re: [FFP] DHCP-Requests werden nicht weitergeleitet

2018-04-09 Diskussionsfäden Johannes Rohr
Am Montag, 9. April 2018, 12:02:11 CEST schrieb Sven R.:
> um sowas besser zu debuggen, hab ich bei mir pro router noch eine extra
> ssid mit verschlüsseltem netz drauf,
> da kann man das dann auf einen router eingrenzen.

Da ich das mittlerweile auf mehreren Routern sehe, seit ich die Uplinks auf 
Hedy mit no-tunnel aktualisiert habe und es anscheinend nichts hilft, die 
Router ohne eigenen Uplink auf Hedy zu aktualisiere (ja, mit Reset und 
Neukonfiguration), glaube ich nicht, dass das Problem beim einzelnen Router 
liegt. Irgendwas lässt die DHCP-Pakete in diesem Roaming-Netz nicht durch. 
Irgendein Problem mit B.A.T.M.A.N? 

Gibt es anderswo in der Potsdamer community ein Roaming-Netz, dass nach der 
Umstellung auf Hedy vernünftig funktioniert? 

Hat jemand einen Tipp für mich, wie ich feststellen kann, wo die DHCP-Pakete 
hängenbleiben?

Achja, auf https://wiki.freifunk-potsdam.de/Roaming steht, bei Clients solle 
man die Schnittstelle ROAM_IP keiner Firewallzone zuordnen, auf den Uplinks 
aber zu "Freifunk". Gilt das noch? Ich nehme an, dass in einem Roaming-
Netzwerk die DHCP-Pakete über die ROAM_AP-Schnittstelle laufen.

Ciao,

Johannes


> 
> Sven
> 
> Am 09.04.2018 um 11:48 schrieb Johannes Rohr:
> > Am Montag, 9. April 2018, 06:46:56 CEST schrieb Carsten N:
> >> Hallo Johannes,
> >> solch komisches Verhalten stellte ich öfters bei Kathleen 0.3.0 fest.
> >> Hier empfehle ich, mal auf irgend eine andere Kathleen oder Hedy zu
> >> wechsel und zu probien.
> > 
> > Hat leider bisher nichts gebracht.
> > 
> > Johannes
> > 
> >> Viele Grüße
> >> Carsten
> >> 
> >> Am 08.04.2018 22:12, schrieb Johannes Rohr:
> >>> Im Uferwerk haben wir ja ein Roaming-Netzwerk nach
> >>> https://wiki.freifunk-potsdam.de/Roaming Seit ich die Uplinks auf Hedy
> >>> mit No-Tunnel aktualisiert
> >>> habe stelle ich fest, dass einige der Clients auf denen noch Kathleen
> >>> läuft,
> >>> keine DHCP-Requests mehr weiterleiten. Wenn ein client schon eine
> >>> IP-Adresse
> >>> bevor er zu dem fraglichen Knoten wechselt geht's. Aber wenn er über
> >>> den
> >>> betroffenen Knoten ein DHCP-Request rausschickt, kommt keine Antwort.
> >>> 
> >>> Bevor ich die Uplinks auf Hedy umgestellt war alles in Ordnung.
> >>> 
> >>> Kann sich da jemand einen Reim drauf machen?
> >>> 
> >>> Johannes
> 
> ___
> Users mailing list
> Users@lists.freifunk-potsdam.de
> https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users




___
Users mailing list
Users@lists.freifunk-potsdam.de
https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users

Re: [FFP] DHCP-Requests werden nicht weitergeleitet

2018-04-09 Diskussionsfäden Sven R.
um sowas besser zu debuggen, hab ich bei mir pro router noch eine extra
ssid mit verschlüsseltem netz drauf,
da kann man das dann auf einen router eingrenzen.

Sven

Am 09.04.2018 um 11:48 schrieb Johannes Rohr:
> Am Montag, 9. April 2018, 06:46:56 CEST schrieb Carsten N:
>> Hallo Johannes,
>> solch komisches Verhalten stellte ich öfters bei Kathleen 0.3.0 fest.
>> Hier empfehle ich, mal auf irgend eine andere Kathleen oder Hedy zu
>> wechsel und zu probien.
> Hat leider bisher nichts gebracht. 
>
> Johannes
>
>> Viele Grüße
>> Carsten
>>
>> Am 08.04.2018 22:12, schrieb Johannes Rohr:
>>> Im Uferwerk haben wir ja ein Roaming-Netzwerk nach
>>> https://wiki.freifunk-potsdam.de/Roaming Seit ich die Uplinks auf Hedy
>>> mit No-Tunnel aktualisiert
>>> habe stelle ich fest, dass einige der Clients auf denen noch Kathleen
>>> läuft,
>>> keine DHCP-Requests mehr weiterleiten. Wenn ein client schon eine
>>> IP-Adresse
>>> bevor er zu dem fraglichen Knoten wechselt geht's. Aber wenn er über
>>> den
>>> betroffenen Knoten ein DHCP-Request rausschickt, kommt keine Antwort.
>>>
>>> Bevor ich die Uplinks auf Hedy umgestellt war alles in Ordnung.
>>>
>>> Kann sich da jemand einen Reim drauf machen?
>>>
>>> Johannes
___
Users mailing list
Users@lists.freifunk-potsdam.de
https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users

Re: [FFP] DHCP-Requests werden nicht weitergeleitet

2018-04-09 Diskussionsfäden Johannes Rohr
Am Montag, 9. April 2018, 06:46:56 CEST schrieb Carsten N:
> Hallo Johannes,
> solch komisches Verhalten stellte ich öfters bei Kathleen 0.3.0 fest.
> Hier empfehle ich, mal auf irgend eine andere Kathleen oder Hedy zu
> wechsel und zu probien.

Hat leider bisher nichts gebracht. 

Johannes

> 
> Viele Grüße
> Carsten
> 
> Am 08.04.2018 22:12, schrieb Johannes Rohr:
> > Im Uferwerk haben wir ja ein Roaming-Netzwerk nach
> > https://wiki.freifunk-potsdam.de/Roaming Seit ich die Uplinks auf Hedy
> > mit No-Tunnel aktualisiert
> > habe stelle ich fest, dass einige der Clients auf denen noch Kathleen
> > läuft,
> > keine DHCP-Requests mehr weiterleiten. Wenn ein client schon eine
> > IP-Adresse
> > bevor er zu dem fraglichen Knoten wechselt geht's. Aber wenn er über
> > den
> > betroffenen Knoten ein DHCP-Request rausschickt, kommt keine Antwort.
> > 
> > Bevor ich die Uplinks auf Hedy umgestellt war alles in Ordnung.
> > 
> > Kann sich da jemand einen Reim drauf machen?
> > 
> > Johannes
> > 
> > 
> > ___
> > Users mailing list
> > Users@lists.freifunk-potsdam.de
> > https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users
> 
> ___
> Users mailing list
> Users@lists.freifunk-potsdam.de
> https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users




___
Users mailing list
Users@lists.freifunk-potsdam.de
https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users

Re: [FFP] DHCP-Requests werden nicht weitergeleitet

2018-04-08 Diskussionsfäden Carsten N

Hallo Johannes,
solch komisches Verhalten stellte ich öfters bei Kathleen 0.3.0 fest. 
Hier empfehle ich, mal auf irgend eine andere Kathleen oder Hedy zu 
wechsel und zu probien.


Viele Grüße
Carsten

Am 08.04.2018 22:12, schrieb Johannes Rohr:

Im Uferwerk haben wir ja ein Roaming-Netzwerk nach
https://wiki.freifunk-potsdam.de/Roaming Seit ich die Uplinks auf Hedy
mit No-Tunnel aktualisiert
habe stelle ich fest, dass einige der Clients auf denen noch Kathleen 
läuft,
keine DHCP-Requests mehr weiterleiten. Wenn ein client schon eine 
IP-Adresse
bevor er zu dem fraglichen Knoten wechselt geht's. Aber wenn er über 
den

betroffenen Knoten ein DHCP-Request rausschickt, kommt keine Antwort.

Bevor ich die Uplinks auf Hedy umgestellt war alles in Ordnung.

Kann sich da jemand einen Reim drauf machen?

Johannes


___
Users mailing list
Users@lists.freifunk-potsdam.de
https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users

___
Users mailing list
Users@lists.freifunk-potsdam.de
https://lists.freifunk-potsdam.de/cgi-bin/mailman/listinfo/users