Re: [OMPI users] OMPI was not built with SLURM's PMI support

2019-08-08 Thread Jing Gong via users
Hi Gilles, > You need to > configure --with-pmi ... Originally I specified the flag "--with-pmi" but looked at the output of slurm ... version 16.05 or later: you can use SLURM's PMIx support. This requires that you configure and build SLURM --with-pmix. .. I recompiled with flag

Re: [OMPI users] OMPI was not built with SLURM's PMI support

2019-08-08 Thread Gilles GOUAILLARDET via users
Hi, You need to configure --with-pmi ... Cheers, Gilles On August 8, 2019, at 11:28 PM, Jing Gong via users wrote: Hi, Recently our Slurm system has been upgraded to 19.0.5. I tried to recompile openmpi v3.0 due to the bug reported in https://bugs.schedmd.com/show_bug.cgi?id=6993

Re: [OMPI users] OMPI was not built with SLURM's PMI support

2019-08-08 Thread Ralph Castain via users
Did you configure Slurm to use PMIx? If so, then you simply need to set the "--mpi=pmix" or "--mpi=pmix_v2" (depending on which version of PMIx you used) flag on your srun cmd line so it knows to use it. If not (and you can't fix it), then you have to explicitly configure OMPI to use Slurm's

[OMPI users] OMPI was not built with SLURM's PMI support

2019-08-08 Thread Jing Gong via users
Hi, Recently our Slurm system has been upgraded to 19.0.5. I tried to recompile openmpi v3.0 due to the bug reported in https://bugs.schedmd.com/show_bug.cgi?id=6993 The configure flags are: $./configure --enable-shared --enable-static --with-slurm --with-pmix and the output of