[OMPI users] OpenMPI non blocking I_Allreduce segfaults when using custom function..

2015-12-16 Thread Udayanga Wickramasinghe
Hi all, I have a custom MPI_Op function which I use within a non blocking version of all_reduce(). When executing the mpi program I am seeing a segfault thrown from libNBC. It seems like this is a known issue in openMPI atleast [1]. Is this somehow fixed in a later release version of openmpi ? I

Re: [OMPI users] OpenMPI non blocking I_Allreduce segfaults when using custom function..

2015-12-17 Thread Udayanga Wickramasinghe
the 1.8 series so you will need to update to 1.10 to get the > fix. > > -Nathan > > On Wed, Dec 16, 2015 at 02:48:45PM -0500, Udayanga Wickramasinghe wrote: > >Hi all, > >I have a custom MPI_Op function which I use within a non blocking > version > >o

[OMPI users] Using OpenMPI Thread Multiple mode

2016-01-19 Thread Udayanga Wickramasinghe
Hi devs, I am using THREAD_MULTIPLE in openmpi version 1.8.4. However I occasionally see following warning and my application gets hanged up intermittently. Does this mean thread multiple mode is not supported in 1.8.4 ? Or does openmpi has a version that fully supports this ?

Re: [OMPI users] Increasing OpenMPI RMA win attach region count.

2019-01-08 Thread Udayanga Wickramasinghe
Sorry should be corrected as MPI3.0 spec [1] [1] https://www.mpi-forum.org/docs/mpi-3.0/mpi30-report.pdf ; page=443 Best Regards, Udayanga On Tue, Jan 8, 2019 at 11:36 PM Udayanga Wickramasinghe wrote: > Hi, > I am running into an issue in open-mpi where it crashes abruptly &g

[OMPI users] Increasing OpenMPI RMA win attach region count.

2019-01-08 Thread Udayanga Wickramasinghe
Hi, I am running into an issue in open-mpi where it crashes abruptly during MPI_WIN_ATTACH. [nid00307:25463] *** An error occurred in MPI_Win_attach [nid00307:25463] *** reported by process [140736284524545,140728898420736] [nid00307:25463] *** on win rdma window 3 [nid00307:25463] ***

Re: [OMPI users] Increasing OpenMPI RMA win attach region count.

2019-01-10 Thread Udayanga Wickramasinghe
ble either by setting: >> >> Environment: >> >> OMPI_MCA_osc_rdma_max_attach >> >> >> mpirun command line: >> >> —mca osc_rdma_max_attach >> >> >> Keep in mind that each attachment may use an underlying hardware resource >> th

Re: [OMPI users] A strange warning on Cray XC with Opemmpi-4.00

2019-01-07 Thread Udayanga Wickramasinghe
;https://www.facebook.com/LebaneseAmericanUniversity> > > in <https://www.linkedin.com/edu/school?id=14810> > > t <https://twitter.com/lebamuniv> > > ig <https://instagram.com/lebamericanuni> > -- > > > > *From:*

[OMPI users] A strange warning on Cray XC with Opemmpi-4.00

2019-01-07 Thread Udayanga Wickramasinghe
Hi, I upgraded my open-mpi version to 4.00 on a Cray Aries cluster (GNI/uGNI). Every time I run mpi, I get the following warning. Is there any way to suppress this message? I am not seeing this in 3.1.3 version of open-mpi. Any idea why openfabrics device is getting initialized when cray GNI

Re: [OMPI users] A strange warning on Cray XC with Opemmpi-4.00

2019-01-07 Thread Udayanga Wickramasinghe
; > > > On Mon, Jan 7, 2019 at 8:16 AM Udayanga Wickramasinghe > wrote: > > > > Hi Salim, > > Thank you. Yeah, I noticed warnings would vanish by turning on > btl_openib_allow_ib -- but since this is quite annoying I am wondering if > there is any other wa

[OMPI users] A strange warning on Cray XC with Opemmpi-4.00

2019-01-07 Thread Udayanga Wickramasinghe
Hi, I upgraded my open-mpi version to 4.00 on a Cray Aries cluster (GNI/uGNI). Every time I run mpi, I get the following warning. Is there any way to suppress this message? I am not seeing this in 3.1.3 version of open-mpi. Any idea why openfabrics device is getting initialized when cray GNI

Re: [OMPI users] Increasing OpenMPI RMA win attach region count.

2019-01-09 Thread Udayanga Wickramasinghe
imit). It is > recommended to keep the total number as small as possible. > > -Nathan > > > On Jan 8, 2019, at 9:36 PM, Udayanga Wickramasinghe > wrote: > > > > Hi, > > I am running into an issue in open-mpi where it crashes abruptly during > MPI

Re: [OMPI users] Increasing OpenMPI RMA win attach region count.

2019-01-09 Thread Udayanga Wickramasinghe
ting-mca-params > > > > > On Jan 9, 2019, at 1:18 PM, Udayanga Wickramasinghe > wrote: > > > > Thanks. Yes, I am aware of that however, I currently have a requirement > to increase the default. > > > > Best, > > Udayanga > > > > On Wed, Jan