Re: [ovirt-users] ovirt 4.1 : Can't install guest tools for Zentyal 5.0 (based on ubuntu 16.04 xenial)

2017-08-07 Thread yayo (j)
>
>
>
> Better workaround is to download newer python-apt from here [1] and
> install it manually with dpkg. The guest agent seems to work OK with it.
> There's much less chance of breaking something else, also newer
> python-apt will be picked-up automatically on upgrades.
>
> Tomas
>
>
> [1] https://packages.ubuntu.com/yakkety/python-apt
>
>

Thank you, this is fix the problem!


root@vmdczen01:~# dpkg -i python-apt_1.1.0~beta5_amd64.deb
Selecting previously unselected package python-apt.
(Reading database ... 155994 files and directories currently installed.)
Preparing to unpack python-apt_1.1.0~beta5_amd64.deb ...
Unpacking python-apt (1.1.0~beta5) ...
dpkg: dependency problems prevent configuration of python-apt:
 python-apt depends on dirmngr | gnupg (<< 2); however:
  Package dirmngr is not installed.
  Version of gnupg on system is 2.1.15-1ubuntu6.

dpkg: error processing package python-apt (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-apt

root@vmdczen01:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer
required:
  linux-headers-4.4.0-83 linux-headers-4.4.0-83-generic
linux-image-4.4.0-83-generic linux-image-extra-4.4.0-83-generic
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  dirmngr
The following NEW packages will be installed:
  dirmngr
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
Need to get 235 kB of archives.
After this operation, 644 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://it.archive.ubuntu.com/ubuntu xenial/main amd64 dirmngr amd64
2.1.11-6ubuntu2 [235 kB]
Fetched 235 kB in 0s (775 kB/s)
Selecting previously unselected package dirmngr.
(Reading database ... 156021 files and directories currently installed.)
Preparing to unpack .../dirmngr_2.1.11-6ubuntu2_amd64.deb ...
Unpacking dirmngr (2.1.11-6ubuntu2) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up dirmngr (2.1.11-6ubuntu2) ...
Setting up python-apt (1.1.0~beta5) ...

root@vmdczen01:~# apt-get install ovirt-guest-agent
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer
required:
  linux-headers-4.4.0-83 linux-headers-4.4.0-83-generic
linux-image-4.4.0-83-generic linux-image-extra-4.4.0-83-generic
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libnl-route-3-200 python-dbus python-ethtool qemu-guest-agent
Suggested packages:
  python-dbus-doc python-dbus-dbg
Recommended packages:
  python-gi | python-qt4-dbus
The following NEW packages will be installed:
  libnl-route-3-200 ovirt-guest-agent python-dbus python-ethtool
qemu-guest-agent
0 upgraded, 5 newly installed, 0 to remove and 2 not upgraded.
Need to get 383 kB of archives.
After this operation, 1,574 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64
libnl-route-3-200 amd64 3.2.27-1ubuntu0.16.04.1 [124 kB]
Get:2 http://it.archive.ubuntu.com/ubuntu xenial/main amd64 python-dbus
amd64 1.2.0-3 [83.5 kB]
Get:3 http://it.archive.ubuntu.com/ubuntu xenial/universe amd64
python-ethtool amd64 0.11-3 [18.0 kB]
Get:4 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe amd64
qemu-guest-agent amd64 1:2.5+dfsg-5ubuntu10.14 [135 kB]
Get:5 http://it.archive.ubuntu.com/ubuntu xenial/universe amd64
ovirt-guest-agent all 1.0.11.2.dfsg-1 [23.4 kB]
Fetched 383 kB in 0s (993 kB/s)
Selecting previously unselected package libnl-route-3-200:amd64.
(Reading database ... 156038 files and directories currently installed.)
Preparing to unpack .../libnl-route-3-200_3.2.27-1ubuntu0.16.04.1_amd64.deb
...
Unpacking libnl-route-3-200:amd64 (3.2.27-1ubuntu0.16.04.1) ...
Selecting previously unselected package python-dbus.
Preparing to unpack .../python-dbus_1.2.0-3_amd64.deb ...
Unpacking python-dbus (1.2.0-3) ...
Selecting previously unselected package python-ethtool.
Preparing to unpack .../python-ethtool_0.11-3_amd64.deb ...
Unpacking python-ethtool (0.11-3) ...
Selecting previously unselected package qemu-guest-agent.
Preparing to unpack
.../qemu-guest-agent_1%3a2.5+dfsg-5ubuntu10.14_amd64.deb ...
Unpacking qemu-guest-agent (1:2.5+dfsg-5ubuntu10.14) ...
Selecting previously unselected package ovirt-guest-agent.
Preparing to unpack .../ovirt-guest-agent_1.0.11.2.dfsg-1_all.deb ...
Unpacking ovirt-guest-agent (1.0.11.2.dfsg-1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for systemd (229-4ubuntu19) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for dbus (1.10.6-1ubuntu3.3) ...

Re: [ovirt-users] ovirt 4.1 : Can't install guest tools for Zentyal 5.0 (based on ubuntu 16.04 xenial)

2017-08-07 Thread Tomáš Golembiovský
On Mon, 7 Aug 2017 16:08:00 +0200
"yayo (j)"  wrote:

> >
> > This is the problem!
> >
> > I looked at the packages for conflict and figured the issue is in gnpug.
> > Zentyal repository contains gnupg version 2.1.15-1ubuntu6 which breaks
> > python-apt <= 1.1.0~beta4.
> >
> >  
> Ok, thank you! Any workaround (something like packege pinning?) to fix this
> problem?

Package pinning is probably not a good idea. I've noticed that there are
some libraries that require gnupg >= 2.x and you would not be able to
install those. They came from Zentyal repo so I assume they might be
essential for some features.

Better workaround is to download newer python-apt from here [1] and
install it manually with dpkg. The guest agent seems to work OK with it.
There's much less chance of breaking something else, also newer
python-apt will be picked-up automatically on upgrades.

Tomas


[1] https://packages.ubuntu.com/yakkety/python-apt

-- 
Tomáš Golembiovský 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] ovirt 4.1 : Can't install guest tools for Zentyal 5.0 (based on ubuntu 16.04 xenial)

2017-08-07 Thread yayo (j)
>
> Agreed.
>>
>> Open a bug with Zentyal. They broke the packages from Ubuntu and should
>> fix it themselves. They have to backport newer version of python-apt.
>> The one from yakkety (1.1.0~beta5) should be good enough to fix the
>> problem.
>>
>> In the bug report note that the ovirt-guest-agent from Ubuntu repository
>> cannot be installed. It is not only related to the package from the
>> private repo.
>
>
>
> Ok, Thank you!
>


Done: https://tracker.zentyal.org/issues/5279

Thank you Again
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] ovirt 4.1 : Can't install guest tools for Zentyal 5.0 (based on ubuntu 16.04 xenial)

2017-08-07 Thread yayo (j)
>
> This is the problem!
>
> I looked at the packages for conflict and figured the issue is in gnpug.
> Zentyal repository contains gnupg version 2.1.15-1ubuntu6 which breaks
> python-apt <= 1.1.0~beta4.
>
>
Ok, thank you! Any workaround (something like packege pinning?) to fix this
problem?


>
> > And this is a BIG problem ... Can I open a bug ? Where?
>
> Agreed.
>
> Open a bug with Zentyal. They broke the packages from Ubuntu and should
> fix it themselves. They have to backport newer version of python-apt.
> The one from yakkety (1.1.0~beta5) should be good enough to fix the
> problem.
>
> In the bug report note that the ovirt-guest-agent from Ubuntu repository
> cannot be installed. It is not only related to the package from the
> private repo.



Ok, Thank you!
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] ovirt 4.1 : Can't install guest tools for Zentyal 5.0 (based on ubuntu 16.04 xenial)

2017-08-07 Thread Tomáš Golembiovský
On Mon, 7 Aug 2017 10:18:35 +0200
"yayo (j)"  wrote:

> Hi,
> 
> 
> I just tried that with development version of Zentyal and it works for
> > me. Well, there are some caveats, see below.
> >
> >  
> Please provide steps not just "works for me" ... Thank you
> 
> 
> 
> > > Just wanted to add my input.  I just recently noticed the same thing.
> > > Luckily i was just testing Zentyal, but when I installed python-apt after
> > > reading the error message, apt seemed to completely break.  I would be
> > > curious on a workaround/fix for this as well.  
> >
> > Could you be more specific? What was the problem? Was it problem with
> > python-apt per-se or with ovirt-guest-agent using python-apt?
> >
> >  
> In the past with Zentyal 5 Dev Edition I had the same error: Added
> suggested repository that want install "python-apt" and remove "apt-get"
> (because conflicts)
> 
> 
> 
> >  
> > >
> > >
> > > On Fri, Aug 4, 2017 at 9:28 AM, yayo (j)  wrote:
> > >  
> > > > Hi all,
> > > >
> > > > I have this problem: I'm tring to install the guest tools following  
> > this  
> > > > guide: https://www.ovirt.org/documentation/how-to/guest-
> > > > agent/install-the-guest-agent-in-ubuntu/#for-ubuntu-1604  
> >
> > I've noticed that the ovirt-guest-agent package available in the
> > repository mentioned on the oVirt site is missing dependency on
> > qemu-guest-agent. You have to install it additionally for oVirt to work
> > properly.
> >  
> 
> 
> *Steps with repository:*
> http://download.opensuse.org/repositories/home:/evilissimo:/ubuntu:/16.04/xUbuntu_16.04/
> 
> *Update:*
> 
> 
> root@vmdczen01:~# apt-get update
> Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
> Hit:2 http://it.archive.ubuntu.com/ubuntu xenial InRelease
> Get:3 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
> Get:4 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease [102
> kB]
> Hit:5 http://archive.zentyal.org/zentyal 5.0 InRelease
> Ign:6
> http://download.opensuse.org/repositories/home:/evilissimo:/ubuntu:/16.04/xUbuntu_16.04
> InRelease
> Hit:7
> http://download.opensuse.org/repositories/home:/evilissimo:/ubuntu:/16.04/xUbuntu_16.04
> Release
> Fetched 306 kB in 0s (325 kB/s)
> Reading package lists... Done
> 
> 
> 
> *Tring to install:*
> 
> 
> root@vmdczen01:~# apt-get install ovirt-guest-agent
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  ovirt-guest-agent : Depends: python-apt but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
> 
> 
> *Zentyal version is: *5.0.8
> 
> So, this repository is *totally broken*
> 
> 
> 
> >
> > If you, however, instal the ovirt-guest-agent from official Ubuntu
> > repository there is different issue. There is this unresolved bug:
> >
> > https://bugs.launchpad.net/ubuntu/+source/ovirt-guest-agent/+bug/1609130
> >
> > You have to fix permissions on /var/log/ovirt-guest-agent as mentioned
> > in the bug report.
> >
> >  
> 
> The problem is the same, if you remove the extra repisotory and then try to
> use the "main" repository, you have the problem with python-apt
> 
> 
> Extra tests:
> 
> I have tried to install "python-apt" directly and I can reproduce the
> problem mentioned by Stewart:
> 
> 
> Update (Check that extra repository is commented out):
> 
> 
> root@vmdczen01:~# apt-get update
> Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
> Get:2 http://archive.zentyal.org/zentyal 5.0 InRelease [4,887 B]
> Get:3 http://it.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
> Get:4 http://archive.zentyal.org/zentyal 5.0/main amd64 Packages [28.1 kB]
> Get:5 http://archive.zentyal.org/zentyal 5.0/main i386 Packages [6,218 B]
> Get:6 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
> [325 kB]
> Get:7 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
> Get:8 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease [102
> kB]
> Get:9 http://it.archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1,201
> kB]
> Get:10 http://it.archive.ubuntu.com/ubuntu xenial/main i386 Packages [1,196
> kB]
> Get:11 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
> [306 kB]
> Get:12 http://it.archive.ubuntu.com/ubuntu xenial/main Translation-en [568
> kB]
> Get:13 http://it.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
> [7,532 kB]
> Get:14 http://it.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
> [7,512 kB]
> Get:15 http://it.archive.ubuntu.com/ubuntu xenial/universe 

Re: [ovirt-users] ovirt 4.1 : Can't install guest tools for Zentyal 5.0 (based on ubuntu 16.04 xenial)

2017-08-07 Thread yayo (j)
Hi,


I just tried that with development version of Zentyal and it works for
> me. Well, there are some caveats, see below.
>
>
Please provide steps not just "works for me" ... Thank you



> > Just wanted to add my input.  I just recently noticed the same thing.
> > Luckily i was just testing Zentyal, but when I installed python-apt after
> > reading the error message, apt seemed to completely break.  I would be
> > curious on a workaround/fix for this as well.
>
> Could you be more specific? What was the problem? Was it problem with
> python-apt per-se or with ovirt-guest-agent using python-apt?
>
>
In the past with Zentyal 5 Dev Edition I had the same error: Added
suggested repository that want install "python-apt" and remove "apt-get"
(because conflicts)



>
> >
> >
> > On Fri, Aug 4, 2017 at 9:28 AM, yayo (j)  wrote:
> >
> > > Hi all,
> > >
> > > I have this problem: I'm tring to install the guest tools following
> this
> > > guide: https://www.ovirt.org/documentation/how-to/guest-
> > > agent/install-the-guest-agent-in-ubuntu/#for-ubuntu-1604
>
> I've noticed that the ovirt-guest-agent package available in the
> repository mentioned on the oVirt site is missing dependency on
> qemu-guest-agent. You have to install it additionally for oVirt to work
> properly.
>


*Steps with repository:*
http://download.opensuse.org/repositories/home:/evilissimo:/ubuntu:/16.04/xUbuntu_16.04/

*Update:*


root@vmdczen01:~# apt-get update
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Hit:2 http://it.archive.ubuntu.com/ubuntu xenial InRelease
Get:3 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:4 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease [102
kB]
Hit:5 http://archive.zentyal.org/zentyal 5.0 InRelease
Ign:6
http://download.opensuse.org/repositories/home:/evilissimo:/ubuntu:/16.04/xUbuntu_16.04
InRelease
Hit:7
http://download.opensuse.org/repositories/home:/evilissimo:/ubuntu:/16.04/xUbuntu_16.04
Release
Fetched 306 kB in 0s (325 kB/s)
Reading package lists... Done



*Tring to install:*


root@vmdczen01:~# apt-get install ovirt-guest-agent
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ovirt-guest-agent : Depends: python-apt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


*Zentyal version is: *5.0.8

So, this repository is *totally broken*



>
> If you, however, instal the ovirt-guest-agent from official Ubuntu
> repository there is different issue. There is this unresolved bug:
>
> https://bugs.launchpad.net/ubuntu/+source/ovirt-guest-agent/+bug/1609130
>
> You have to fix permissions on /var/log/ovirt-guest-agent as mentioned
> in the bug report.
>
>

The problem is the same, if you remove the extra repisotory and then try to
use the "main" repository, you have the problem with python-apt


Extra tests:

I have tried to install "python-apt" directly and I can reproduce the
problem mentioned by Stewart:


Update (Check that extra repository is commented out):


root@vmdczen01:~# apt-get update
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Get:2 http://archive.zentyal.org/zentyal 5.0 InRelease [4,887 B]
Get:3 http://it.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Get:4 http://archive.zentyal.org/zentyal 5.0/main amd64 Packages [28.1 kB]
Get:5 http://archive.zentyal.org/zentyal 5.0/main i386 Packages [6,218 B]
Get:6 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
[325 kB]
Get:7 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:8 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease [102
kB]
Get:9 http://it.archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1,201
kB]
Get:10 http://it.archive.ubuntu.com/ubuntu xenial/main i386 Packages [1,196
kB]
Get:11 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
[306 kB]
Get:12 http://it.archive.ubuntu.com/ubuntu xenial/main Translation-en [568
kB]
Get:13 http://it.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
[7,532 kB]
Get:14 http://it.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
[7,512 kB]
Get:15 http://it.archive.ubuntu.com/ubuntu xenial/universe Translation-en
[4,354 kB]
Get:16 http://it.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages
[144 kB]
Get:17 http://it.archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages
[140 kB]
Get:18 http://it.archive.ubuntu.com/ubuntu xenial/multiverse Translation-en
[106 kB]
Get:19 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64
Packages [599 kB]
Get:20 

Re: [ovirt-users] ovirt 4.1 : Can't install guest tools for Zentyal 5.0 (based on ubuntu 16.04 xenial)

2017-08-06 Thread Tomáš Golembiovský
Hi,

I just tried that with development version of Zentyal and it works for
me. Well, there are some caveats, see below.


On Fri, 4 Aug 2017 09:31:22 -0400
Wesley Stewart  wrote:

> Just wanted to add my input.  I just recently noticed the same thing.
> Luckily i was just testing Zentyal, but when I installed python-apt after
> reading the error message, apt seemed to completely break.  I would be
> curious on a workaround/fix for this as well.

Could you be more specific? What was the problem? Was it problem with
python-apt per-se or with ovirt-guest-agent using python-apt?


> 
> 
> On Fri, Aug 4, 2017 at 9:28 AM, yayo (j)  wrote:
> 
> > Hi all,
> >
> > I have this problem: I'm tring to install the guest tools following this
> > guide: https://www.ovirt.org/documentation/how-to/guest-
> > agent/install-the-guest-agent-in-ubuntu/#for-ubuntu-1604

I've noticed that the ovirt-guest-agent package available in the
repository mentioned on the oVirt site is missing dependency on
qemu-guest-agent. You have to install it additionally for oVirt to work
properly.

If you, however, instal the ovirt-guest-agent from official Ubuntu
repository there is different issue. There is this unresolved bug:

https://bugs.launchpad.net/ubuntu/+source/ovirt-guest-agent/+bug/1609130

You have to fix permissions on /var/log/ovirt-guest-agent as mentioned
in the bug report.


> >
> > This is the sources:
> >
> > deb http://it.archive.ubuntu.com/ubuntu/ xenial main restricted
> > deb http://it.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
> > deb http://it.archive.ubuntu.com/ubuntu/ xenial universe
> > deb http://it.archive.ubuntu.com/ubuntu/ xenial-updates universe
> > deb http://it.archive.ubuntu.com/ubuntu/ xenial multiverse
> > deb http://it.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
> > deb http://it.archive.ubuntu.com/ubuntu/ xenial-backports main restricted
> > universe multiverse
> >
> > deb http://archive.zentyal.org/zentyal 5.0 main extra
> >
> > deb http://security.ubuntu.com/ubuntu xenial-security main restricted
> > deb http://security.ubuntu.com/ubuntu xenial-security universe
> > deb http://security.ubuntu.com/ubuntu xenial-security multiverse
> >
> >
> > But when I try to install, I have this error:
> >
> >
> > root@vmdczen01:~# apt-get install ovirt-guest-agent
> > Reading package lists... Done
> > Building dependency tree
> > Reading state information... Done
> > Some packages could not be installed. This may mean that you have
> > requested an impossible situation or if you are using the unstable
> > distribution that some required packages have not yet been created
> > or been moved out of Incoming.
> > The following information may help to resolve the situation:
> >
> > The following packages have unmet dependencies:
> >  ovirt-guest-agent : Depends: python-apt but it is not going to be
> > installed
> > E: Unable to correct problems, you have held broken packages.
> >
> >
> > I've found that python-apt is in "main" repo:
> >
> >
> > https://packages.ubuntu.com/xenial/amd64/python-apt/download
> >
> >
> > So, what's the problem?

Did you run 'apt-get update' to synchronize the repository content?


Tomas

> >
> >
> > Can you help me?
> > Thank you
> >
> >
> > ___
> > Users mailing list
> > Users@ovirt.org
> > http://lists.ovirt.org/mailman/listinfo/users
> >
> >  


-- 
Tomáš Golembiovský 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] ovirt 4.1 : Can't install guest tools for Zentyal 5.0 (based on ubuntu 16.04 xenial)

2017-08-04 Thread Wesley Stewart
Just wanted to add my input.  I just recently noticed the same thing.
Luckily i was just testing Zentyal, but when I installed python-apt after
reading the error message, apt seemed to completely break.  I would be
curious on a workaround/fix for this as well.


On Fri, Aug 4, 2017 at 9:28 AM, yayo (j)  wrote:

> Hi all,
>
> I have this problem: I'm tring to install the guest tools following this
> guide: https://www.ovirt.org/documentation/how-to/guest-
> agent/install-the-guest-agent-in-ubuntu/#for-ubuntu-1604
>
> This is the sources:
>
> deb http://it.archive.ubuntu.com/ubuntu/ xenial main restricted
> deb http://it.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
> deb http://it.archive.ubuntu.com/ubuntu/ xenial universe
> deb http://it.archive.ubuntu.com/ubuntu/ xenial-updates universe
> deb http://it.archive.ubuntu.com/ubuntu/ xenial multiverse
> deb http://it.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
> deb http://it.archive.ubuntu.com/ubuntu/ xenial-backports main restricted
> universe multiverse
>
> deb http://archive.zentyal.org/zentyal 5.0 main extra
>
> deb http://security.ubuntu.com/ubuntu xenial-security main restricted
> deb http://security.ubuntu.com/ubuntu xenial-security universe
> deb http://security.ubuntu.com/ubuntu xenial-security multiverse
>
>
> But when I try to install, I have this error:
>
>
> root@vmdczen01:~# apt-get install ovirt-guest-agent
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  ovirt-guest-agent : Depends: python-apt but it is not going to be
> installed
> E: Unable to correct problems, you have held broken packages.
>
>
> I've found that python-apt is in "main" repo:
>
>
> https://packages.ubuntu.com/xenial/amd64/python-apt/download
>
>
> So, what's the problem?
>
>
> Can you help me?
> Thank you
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users