Re: [Users] bonding setup with python sdk

2013-02-14 Thread Michael Pasternak
new example for the setupnetworks action is available here [1], thanks Moti. [1] http://www.ovirt.org/Testing/PythonApi#Networking On 02/13/2013 01:54 PM, Louis Coilliot wrote: Hello, thanks for your feedback. The version is : rhevm-sdk-3.1.0.16-1.el6ev.noarch and latest from RHN.

Re: [Users] How do Networks and Vlan-tagging work in oVirt ?

2013-02-14 Thread Pavel Zhukov
Looks like that vdsm parses null value in the gateway=null as True and raise Exception. Can you raise a bugreport? -- Best regards, Pavel Zhukov mailto:pzhu...@redhat.com On Wed, 13 Feb 2013, Matt . wrote: | Thanks indeed, I'm with Nicolas, also working on a nice setup with this |

Re: [Users] How do Networks and Vlan-tagging work in oVirt ?

2013-02-14 Thread Gianluca Cecchi
On Tue, Feb 12, 2013 at 10:27 PM, Moti Asayag wrote: You should follow the next steps: 1. Create a new logical network from the networks main tab: define its data-center and set its vlan-id to 50 (the VM network checkbox should be checked) 2. Click on the created network in the networks

Re: [Users] Power Users cannot add Network Interfaces

2013-02-14 Thread Moti Asayag
On 02/14/2013 12:47 AM, Eli Mesika wrote: - Original Message - From: Dead Horse deadhorseconsult...@gmail.com To: users@ovirt.org users@ovirt.org Sent: Thursday, February 14, 2013 12:16:58 AM Subject: [Users] Power Users cannot add Network Interfaces Power Users seems to no

Re: [Users] How do Networks and Vlan-tagging work in oVirt ?

2013-02-14 Thread Mike Kolesnik
- Original Message - On Tue, Feb 12, 2013 at 10:27 PM, Moti Asayag wrote: You should follow the next steps: 1. Create a new logical network from the networks main tab: define its data-center and set its vlan-id to 50 (the VM network checkbox should be checked) 2.

[Users] oVirt 3.2 beta: Usb redirection and low level usb access

2013-02-14 Thread Gianluca Cecchi
Hello, I'm testing a WIndows XP vm with native usb redirection and oVirt 3.2 beta Currently I'm using a Fedora 17 client with Firefox 18 Some questions: - when setting native usb redirection I still get the warning at bottom: Migration is NOT currently supported using SPICE Native USB

Re: [Users] How do Networks and Vlan-tagging work in oVirt ?

2013-02-14 Thread Gianluca Cecchi
On Thu, Feb 14, 2013 at 10:37 AM, Mike Kolesnik wrote: client will have ip of the form 10.10.10.x/24 with gw 10.10.10.1 and eventually I would like to give an ip address to the created bond itself. Can I? You can specify IP Netmask statically on the interface that you attach the network

Re: [Users] How do Networks and Vlan-tagging work in oVirt ?

2013-02-14 Thread Mike Kolesnik
- Original Message - Thanks indeed, I'm with Nicolas, also working on a nice setup with this information! Here is some more logging: Thanks for the log. Unfortunately I can't tell much from it, can you please send a log of the setup networks command from VDSM log, where it is

[Users] full screen and different resolutions with spice

2013-02-14 Thread Gianluca Cecchi
Let me know if I had better to post to spice-devel I'm testing oVirt 3.2 beta user portal. One client boots from a usb stick running SLAX 32bit in persistent mode with kernel 3.6.9. It is a derivative from slackware 14 where I compiled and persistently installed spice-protocol-0.12.2-noarch-1

Re: [Users] full screen and different resolutions with spice

2013-02-14 Thread Itamar Heim
On 14/02/2013 13:22, Gianluca Cecchi wrote: Let me know if I had better to post to spice-devel yes... adding them I'm testing oVirt 3.2 beta user portal. One client boots from a usb stick running SLAX 32bit in persistent mode with kernel 3.6.9. It is a derivative from slackware 14 where

Re: [Users] NFS Advanced Parameters Greyed out on Existing Storage Domains

2013-02-14 Thread Greg Padgett
On 02/14/2013 12:45 AM, Chris Noffsinger wrote: Thank you for the speedy clarification. No problem. So as I understand this BZ for the errata, the nfs_mount_options were being ignored in vdsm.conf and then after the errata, they are no longer ignored?

[Users] Discussion... work appears to be needed in areas of recovery and cleanup

2013-02-14 Thread Rick Beldin
Hi... I've been working with both RHEV and Ovirt and can see distinct changes and improvements with regards to how Ovirt is emerging and changing. One area that still disturbs me is in the area of recovery and cleanup, specifically around the ovirt-engine (rhevm) node. I've observed a few

Re: [Users] Discussion... work appears to be needed in areas of recovery and cleanup

2013-02-14 Thread Sandro Bonazzola
Il 14/02/2013 14:35, Rick Beldin ha scritto: Hi Rick, - engine-cleanup (rhevm-cleanup) doesn't always cleanup Can you provide more information about this? Have you opened a bug? -- Sandro ___ Users mailing list Users@ovirt.org

Re: [Users] Move single vmdk (or else) disk into oVirt/RHEV

2013-02-14 Thread Richard W.M. Jones
On Mon, Feb 11, 2013 at 04:14:38PM +0100, Nicolas Ecarnot wrote: Hi, I find it hard to find any information about the way I have to follow to convert/import a vmdk/qcow/raw/etc... single disk into an oVirt disks list. I know how to use virt-v2v to import complete VMs (disk AND config),

Re: [Users] Move single vmdk (or else) disk into oVirt/RHEV

2013-02-14 Thread Nicolas Ecarnot
Le 14/02/2013 15:05, Richard W.M. Jones a écrit : On Mon, Feb 11, 2013 at 04:14:38PM +0100, Nicolas Ecarnot wrote: Hi, I find it hard to find any information about the way I have to follow to convert/import a vmdk/qcow/raw/etc... single disk into an oVirt disks list. I know how to use

[Users] Fwd: Internet Explorer with latest master

2013-02-14 Thread Alona Kaplan
Hi, The webadmin and userportal works pretty fine for me on ie8 and ie9. Can you please be more specific about what doesn't work for you? Maybe attaching a screen shot. Maybe you've compiled the application with -Dgwt.userAgent flag for a specific browser? You should compile without any

Re: [Users] Move single vmdk (or else) disk into oVirt/RHEV

2013-02-14 Thread Itamar Heim
On 14/02/2013 16:56, Nicolas Ecarnot wrote: Le 14/02/2013 15:05, Richard W.M. Jones a écrit : On Mon, Feb 11, 2013 at 04:14:38PM +0100, Nicolas Ecarnot wrote: Hi, I find it hard to find any information about the way I have to follow to convert/import a vmdk/qcow/raw/etc... single disk into an

[Users] oVirt 3.2 and Solaris 10 guests

2013-02-14 Thread Koch (ovido)
Hi, I've a strange network issue with Solaris 10 x86 guests on oVirt 3.2 (beta) with an CentOS 6.3 hypervisor (using dreyou's repository for VDSM packages). My host configuration is the following: Operating system: Other Network interface type: rtl8139 Network Name: ovirtmgmt Disk interface: IDE

Re: [Users] oVirt 3.2 and Solaris 10 guests

2013-02-14 Thread Jean-Francois Saucier
I can confirm the same issue with Solaris 11 and oVirt 3.1. Everything seems OK, my network card is configured correctly (static IP) but cannot communicate with anyone. On Thu, Feb 14, 2013 at 10:46 AM, René Koch (ovido) r.k...@ovido.at wrote: Hi, I've a strange network issue with Solaris 10

Re: [Users] Move single vmdk (or else) disk into oVirt/RHEV

2013-02-14 Thread Nicolas Ecarnot
Le 14/02/2013 16:43, Itamar Heim a écrit : That is exactly the case : it is indeed a pure data disk with an ext3 filesystem (no LVM, no nothing). I intend to attach it to some existing VM. I know how to convert it into qcow2 or whatever. I know how to create an additionnal disk in oVirt. I know

Re: [Users] Internet Explorer with latest master

2013-02-14 Thread Vojtech Szocs
Hi, the patch you've mentioned removes X-UA-Compatible meta-tag [1] from WebAdmin and UserPortal HTML page: !-- Directs IE to display the webpage in IE9 standards mode -- meta http-equiv=X-UA-Compatible content=IE=9/ The purpose of this meta-tag was to future-proof the application with regard

Re: [Users] Fwd: Internet Explorer with latest master

2013-02-14 Thread Vojtech Szocs
Hi, Maybe you've compiled the application with -Dgwt.userAgent flag for a specific browser? this is a good point, please make sure to compile UserPortal for all browsers, e.g. instead of: $ mvn clean install -Pdep,gwt-user -Dgwt.userAgent=specificBrowser you should just do: $ mvn

Re: [Users] Fwd: Internet Explorer with latest master

2013-02-14 Thread Dead Horse
When I compile the engine I do the following: (FC17 build host) -- git clone http://gerrit.ovirt.org/ovirt-engine.git -- cd ovirt-engine -- make rpm Thus I assume the master build does not default to compiling for all browsers? The GWT compliation seems to go through quite a few permuatations

Re: [Users] oVirt 3.2 and Solaris 10 guests

2013-02-14 Thread Jiri Belka
On Thu, 14 Feb 2013 10:49:13 -0500 Jean-Francois Saucier jsauc...@gmail.com wrote: oVirt 3.2: -netdev tap,fd=25,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:1a:4a:00:64:9e,bus=pci.0,addr=0x3,bootindex=3 ^^^ - realtek, really? Try e1000 which is usually much more

Re: [Users] oVirt 3.2 and Solaris 10 guests

2013-02-14 Thread Jean-Francois Saucier
On Thu, Feb 14, 2013 at 11:21 AM, Jiri Belka jbe...@redhat.com wrote: On Thu, 14 Feb 2013 10:49:13 -0500 Jean-Francois Saucier jsauc...@gmail.com wrote: oVirt 3.2: -netdev tap,fd=25,id=hostnet0 -device

Re: [Users] oVirt 3.2 and Solaris 10 guests

2013-02-14 Thread Koch (ovido)
On Thu, 2013-02-14 at 11:22 -0500, Jean-Francois Saucier wrote: On Thu, Feb 14, 2013 at 11:21 AM, Jiri Belka jbe...@redhat.com wrote: On Thu, 14 Feb 2013 10:49:13 -0500 Jean-Francois Saucier jsauc...@gmail.com wrote: oVirt 3.2: -netdev

Re: [Users] Fwd: Internet Explorer with latest master

2013-02-14 Thread Alona Kaplan
Hi, Instead of doing make rpm please compile manually using the following command: mvn clean install -Dgwt.userAgent=ie8,ie9,gecko1_8,safari,opera -Pgwt-admin,gwt-user,dep Alona. - Original Message - From: Dead Horse deadhorseconsult...@gmail.com To: Vojtech Szocs vsz...@redhat.com

[Users] ovirt-shell: Disabling autopage

2013-02-14 Thread Adam Litke
Hi, Currently the ovirt-shell displays command results using a pager. It does this even when running non-interactively (ie. input via pipe) which is broken. As a workaround, I discovered the option 'cli:autopage = False' should be placed in my .ovirtshellrc file. This works great the first

Re: [Users] Fwd: Internet Explorer with latest master

2013-02-14 Thread Dead Horse
I remember there being a GWT configuration file somewhere where those could be set? - DHC On Thu, Feb 14, 2013 at 10:44 AM, Alona Kaplan alkap...@redhat.com wrote: Hi, Instead of doing make rpm please compile manually using the following command: mvn clean install

Re: [Users] Fwd: Internet Explorer with latest master

2013-02-14 Thread Dead Horse
NVM got it -- BUILD_FLAGS=-Dgwt.userAgent=ie8,ie9,gecko1_8,safari,opera -Pgwt-admin,gwt-user,dep Building now. - DHC On Thu, Feb 14, 2013 at 12:23 PM, Dead Horse deadhorseconsult...@gmail.comwrote: I remember there being a GWT configuration file somewhere where those could be set? - DHC

Re: [Users] ovirt-shell: Disabling autopage

2013-02-14 Thread Michael Pasternak
Hi Adam, On 02/14/2013 07:04 PM, Adam Litke wrote: Hi, Currently the ovirt-shell displays command results using a pager. It does this even when running non-interactively (ie. input via pipe) which is broken. Not sure what do you mean by 'broken', - i didn't hear any complaints on pipe

[Users] oVirt 3.2 -- Now Available

2013-02-14 Thread Mike Burns
The oVirt Team is pleased to announce that oVirt 3.2 is now available. There are a number of exciting new features in 3.2 [1]. Some of the highlights include: * UI Plugins * Port Mirroring * Networks as a top level Configuration * Japanese Localization * Storage Live Migration * Improved

Re: [Users] ovirt-shell: Disabling autopage

2013-02-14 Thread Adam Litke
On Thu, Feb 14, 2013 at 09:27:11PM +0200, Michael Pasternak wrote: Hi Adam, On 02/14/2013 07:04 PM, Adam Litke wrote: Hi, Currently the ovirt-shell displays command results using a pager. It does this even when running non-interactively (ie. input via pipe) which is broken.

Re: [Users] Power Users cannot add Network Interfaces

2013-02-14 Thread Moti Asayag
On 02/14/2013 06:13 PM, Dead Horse wrote: The dialog is graying the ok button, screenshot attached. Also attached is the engine log, although I don't see anything in it that jumps out at me. - DHC Is your management network a non-vm network ? The described symptom looks a like [1]. [1]

Re: [Users] Power Users cannot add Network Interfaces

2013-02-14 Thread Dead Horse
It is still marked and recognized as Management Network and a VM Network. SuperUsers can still add VNIC's this is only affecting non-superusers EG: PowerUserRole - DHC On Thu, Feb 14, 2013 at 3:30 PM, Moti Asayag masa...@redhat.com wrote: On 02/14/2013 06:13 PM, Dead Horse wrote: The

Re: [Users] oVirt 3.2 -- Now Available

2013-02-14 Thread Jeff Bailey
There seems to be an awful lot of open bugs left in https://bugzilla.redhat.com/show_bug.cgi?id=881006 :) The real reason for this message though is conflicts between the ovirt-engine-cli and ovirt-engine-sdk packages in the F18 repo. Plus, I don't see an ovirt-engine-sdk in the 3.2 stable

Re: [Users] oVirt 3.2 -- Now Available

2013-02-14 Thread Mike Burns
On 02/14/2013 06:00 PM, Jeff Bailey wrote: There seems to be an awful lot of open bugs left in https://bugzilla.redhat.com/show_bug.cgi?id=881006 :) Yes, we need to go through and clean that up. I think they all got in, but in the effort to get it out -- well, i wasn't very diligent in

Re: [Users] oVirt 3.2 -- Now Available

2013-02-14 Thread Jeff Bailey
On 2/14/2013 6:00 PM, Jeff Bailey wrote: There seems to be an awful lot of open bugs left in https://bugzilla.redhat.com/show_bug.cgi?id=881006 :) The real reason for this message though is conflicts between the ovirt-engine-cli and ovirt-engine-sdk packages in the F18 repo. Plus, I don't

Re: [Users] oVirt 3.2 -- Now Available

2013-02-14 Thread Jeff Bailey
On 2/14/2013 6:21 PM, Mike Burns wrote: On 02/14/2013 06:00 PM, Jeff Bailey wrote: There seems to be an awful lot of open bugs left in https://bugzilla.redhat.com/show_bug.cgi?id=881006 :) Yes, we need to go through and clean that up. I think they all got in, but in the effort to get it out

[Users] Engine location best practice?

2013-02-14 Thread Lance A. Brown
I'm setting up an oVirt environment at $WORK and trying to decide where to locate the ovirt-engine. Is it better practice to put it on a separate computer from the nodes? If I co-locate it on a node machine, then I have to worry about it being unavailable if that node is down. How much of an

Re: [Users] ovirt-shell: Disabling autopage

2013-02-14 Thread Michael Pasternak
On 02/14/2013 09:44 PM, Adam Litke wrote: On Thu, Feb 14, 2013 at 09:27:11PM +0200, Michael Pasternak wrote: Hi Adam, On 02/14/2013 07:04 PM, Adam Litke wrote: Hi, Currently the ovirt-shell displays command results using a pager. It does this even when running non-interactively (ie.

Re: [Users] Engine location best practice?

2013-02-14 Thread Itamar Heim
On 15/02/2013 04:46, Lance A. Brown wrote: I'm setting up an oVirt environment at $WORK and trying to decide where to locate the ovirt-engine. Is it better practice to put it on a separate computer from the nodes? If I co-locate it on a node machine, then I have to worry about it being

Re: [Users] oVirt 3.2 -- Now Available

2013-02-14 Thread Itamar Heim
On 15/02/2013 01:00, Jeff Bailey wrote: There seems to be an awful lot of open bugs left in https://bugzilla.redhat.com/show_bug.cgi?id=881006 :) The real reason for this message though is conflicts between the ovirt-engine-cli and ovirt-engine-sdk packages in the F18 repo. Plus, I don't see an

Re: [Users] Add NIC directly to VM (Dedicated)

2013-02-14 Thread Itamar Heim
On 10/02/2013 18:07, Matt . wrote: Here: http://www.mail-archive.com/users@ovirt.org/msg06261.html 2013/2/10 Shahar Havivi shah...@redhat.com mailto:shah...@redhat.com On 10.02.13 16:36, Matt . wrote: Hi, I'm thinking about the way how I did that with the dedicated NIC