[ovirt-users] stalls during live Merge Centos 7 / qemu 2.3

2016-04-11 Thread Markus Stockhausen
Hi there, I'm getting slowly mad about our new Centos 7 cluster. Whenever I start a live merge the machine completely freezes. It seems to be independent of the Guest OS (tried SLES 11 SP3, SLES11 SP4 and SLES12). I already opened BZ1319400 because I'm clueless. Doing the same in our Fedora 20

Re: [ovirt-users] Cannot create local ISO storage domain from UI.

2016-04-11 Thread Barak Korren
On 11 April 2016 at 11:51, knarra wrote: > Hi, > > I am trying to set up Hosted Engine. I wanted to deploy windows virtual > machines in this environment and as part of that i am creating ISO Domain to > upload my windows image. But for some reason, while i create ISO

Re: [ovirt-users] Ovirt + OpenVSwitch

2016-04-11 Thread Sverker Abrahamsson
Hi My usecase is that I am setting up a lab to emulate a customers production environment which has multiple vlans. As this is done in a hosting environment where I don't have any control over the switches, I've created virtual switches with OpenVSwitch which connects together a couple of

[ovirt-users] Cleanup Ovirt Node

2016-04-11 Thread Marcelo Leandro
Good Morning , how do I clear the configurations of oVirt node? Thanks, Marcelo Leandro ___ Users mailing list Users@ovirt.org http://lists.ovirt.org/mailman/listinfo/users

Re: [ovirt-users] Cannot create local ISO storage domain from UI.

2016-04-11 Thread knarra
On 04/11/2016 04:39 PM, Barak Korren wrote: On 11 April 2016 at 11:51, knarra wrote: Hi, I am trying to set up Hosted Engine. I wanted to deploy windows virtual machines in this environment and as part of that i am creating ISO Domain to upload my windows image. But

[ovirt-users] How reliable does network netween hypervisor / storage and engine has to be?

2016-04-11 Thread Christophe TREFOIS
Dear all, We are considering moving 2 hypervisors and 1 iSCSI storage to a different physical data centre. Does the engine have certain requirements in terms of network connectivity to achieve this? The network should be quite stable, but is not able to sustain heavy data transfer for long

Re: [ovirt-users] can I use ovirt webmin UI create glusterfs volume and not use ovirtmgmt ip

2016-04-11 Thread Sahina Bose
On 04/06/2016 03:05 PM, 胡茂荣 wrote: My problem is : my environment : [root@node44 bin]# cat /etc/hosts 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 192.168.8.93

[ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Frank Thommen
Dear all, I'm currently lost at finding any documentation about the Python SDK (http://www.ovirt.org/develop/release-management/features/infra/python-sdk/) like provided classes, functions etc.. There are some examples on the mentioned page, but I cannot find a complete documentation. Our

[ovirt-users] Single VM Down After Attempted Snapshot

2016-04-11 Thread Clint Boggio
Greetings users; I've got a single VM in a 3.6 environment that is in a down state after and attempt at creating a snapshot via script, and exporting said snapshot to the export domain. I see some indications of what could possibly be wrong in the filtered engine.log, and i'm at a loss on how to

[ovirt-users] Upgrade path/possibility from 3.3?

2016-04-11 Thread William Kwan
Hi all, I have a couple of oVirt cluster running 3.3.3-2.el6.  I would like to upgrade them to the latest version. I sort of remember upgrading from 3.3 to 3.5 required an step to upgrade to 3.4 as an extra step.  With the new 3.6, will it be fine to upgrade straight from 3.3.3 to 3.6? or I

[ovirt-users] Keyboard mapping VNC

2016-04-11 Thread Jonas Israelsson
Greetings. We are under the impression the the keyboard layout for the VNC-server is missing from a vm's xml definition, hence the same default layout is always used. We therefore (just to test) created a small host hook adding a static keyboard layout, and with the hook, it seem to work as

Re: [ovirt-users] ovirt with glusterfs - big test - unwanted results

2016-04-11 Thread Sahina Bose
So I looked at the vdsm logs and since there were multiple tests done it was difficult to isolate which error to track down. You mentioned test between 14:00-14:30 CET - but the gluster logs that were attached ended at 11.29 UTC Tracking down the errors when the master domain (gluster volume

Re: [ovirt-users] Install oVirt with directly-attached SCSI devices

2016-04-11 Thread Paolo Smiraglia
Thank you Nir and Rik for your hints! I'll check them soon. Bests, Paolo On 04/09/2016 09:03 PM, Rik Theys wrote: > Hi Paolo, > > If your storage is detected by multipathd as a multipath capable device > (it should, even if connected through only one connection), oVirt will > detect it as

Re: [ovirt-users] ovirt node 3.6 stable

2016-04-11 Thread Johan Kooijman
Doesn't exist yet, you can use 3.5 node stable or the nightly builds: http://jenkins.ovirt.org/job/ovirt-node_ovirt-3.6_create-iso-el7_merged/ On Fri, Apr 8, 2016 at 11:04 PM, Marcelo Leandro wrote: > Yes, but i cant see the ovirt node 3.6 > > Thanks. > Em 08/04/2016

Re: [ovirt-users] Hosted engine on gluster problem

2016-04-11 Thread Richard Neuboeck
Hi Darryl, I'm still experimenting with my oVirt installation so I tried to recreate the problems you've described. My setup has three HA hosts for virtualization and three machines for the gluster replica 3 setup. I manually migrated the Engine from the initial install host (one) to host

Re: [ovirt-users] ovirt node 3.6 stable

2016-04-11 Thread Sandro Bonazzola
On Mon, Apr 11, 2016 at 9:07 AM, Johan Kooijman wrote: > Doesn't exist yet, you can use 3.5 node stable or the nightly builds: > http://jenkins.ovirt.org/job/ovirt-node_ovirt-3.6_create-iso-el7_merged/ > > On Fri, Apr 8, 2016 at 11:04 PM, Marcelo Leandro

Re: [ovirt-users] Creating templates in a blocking fashion from Python SDK

2016-04-11 Thread Juan Hernández
On 04/10/2016 12:16 PM, Yaniv Kaul wrote: > > > On Sun, Apr 10, 2016 at 11:02 AM, Yedidyah Bar David > wrote: > > On Sun, Apr 10, 2016 at 10:43 AM, Barak Korren > wrote: > > Hi there, I use

Re: [ovirt-users] HA agent fails to start

2016-04-11 Thread Sandro Bonazzola
On Mon, Apr 11, 2016 at 8:11 AM, Richard Neuboeck wrote: > Hi oVirt Group, > > in my attempts to get all aspects of oVirt 3.6 up and running I > stumbled upon something I'm not sure how to fix: > > Initially I installed a hosted engine setup. After that I added > another

Re: [ovirt-users] Hosted engine on gluster problem

2016-04-11 Thread Richard Neuboeck
On 04/11/2016 11:11 AM, Sandro Bonazzola wrote: > On Mon, Apr 11, 2016 at 9:37 AM, Richard Neuboeck > > wrote: > > Hi Darryl, > > I'm still experimenting with my oVirt installation so I tried to > recreate the problems you've

[ovirt-users] python sdk and params

2016-04-11 Thread Fabrice Bacchella
I'm playing with the python sdk. When I want to delete a VM, I see that it takes a action with settings : [@param action.force: boolean] [@param action.vm.disks.detach_only: boolean] [@param action.async: boolean] [@param action.grace_period.expiry: long] [@param correlation_id: any string] But

Re: [ovirt-users] Hosted engine on gluster problem

2016-04-11 Thread Sandro Bonazzola
On Mon, Apr 11, 2016 at 9:37 AM, Richard Neuboeck wrote: > Hi Darryl, > > I'm still experimenting with my oVirt installation so I tried to > recreate the problems you've described. > > My setup has three HA hosts for virtualization and three machines > for the gluster

Re: [ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Frank Thommen
On 11.04.16 20:17, Brett I. Holcomb wrote: On Mon, 2016-04-11 at 14:38 -0300, Amador Pahim wrote: On 04/11/2016 02:07 PM, Brett I. Holcomb wrote: On Mon, 2016-04-11 at 17:27 +0200, Frank Thommen wrote: Dear all, I'm currently lost at finding any documentation about the Python SDK

Re: [ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Brett I. Holcomb
On Mon, 2016-04-11 at 17:27 +0200, Frank Thommen wrote: > Dear all, > > I'm currently lost at finding any documentation about the Python SDK  > (http://www.ovirt.org/develop/release-management/features/infra/pytho > n-sdk/)  > like provided classes, functions etc..  There are some examples on >

Re: [ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Amador Pahim
On 04/11/2016 02:07 PM, Brett I. Holcomb wrote: On Mon, 2016-04-11 at 17:27 +0200, Frank Thommen wrote: Dear all, I'm currently lost at finding any documentation about the Python SDK (http://www.ovirt.org/develop/release-management/features/infra/python-sdk/) like provided classes, functions

Re: [ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Brett I. Holcomb
On Mon, 2016-04-11 at 14:38 -0300, Amador Pahim wrote: > On 04/11/2016 02:07 PM, Brett I. Holcomb wrote: > On Mon, 2016-04-11 at 17:27 +0200, Frank Thommen wrote: > > Dear all, > > > > I'm currently lost at finding any documentation about the Python > > SDK  > >

Re: [ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Jamie Lawrence
> On Apr 11, 2016, at 11:41 AM, Frank Thommen > wrote: > > Thanks to all who answered. Brett brings it to the point: All sent links so > far are indeed helpful - thanks a lot - but not the reference I expected. >

Re: [ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Raz Tamir
Try this http://old.ovirt.org/Python-sdk Thanks, Raz Tamir Red Hat Israel On Mon, Apr 11, 2016 at 10:57 PM, Jamie Lawrence wrote: > > > On Apr 11, 2016, at 11:41 AM, Frank Thommen < > f.thom...@dkfz-heidelberg.de> wrote: > > > > > Thanks to all who answered. Brett

Re: [ovirt-users] python sdk and params

2016-04-11 Thread Juan Hernández
On 04/11/2016 11:51 AM, Fabrice Bacchella wrote: > I'm playing with the python sdk. > > When I want to delete a VM, I see that it takes a action with settings : > > [@param action.force: boolean] > [@param action.vm.disks.detach_only: boolean] > [@param action.async: boolean] > [@param

Re: [ovirt-users] python sdk and params

2016-04-11 Thread Fabrice Bacchella
> Le 11 avr. 2016 à 12:20, Juan Hernández a écrit : > > On 04/11/2016 11:51 AM, Fabrice Bacchella wrote: >> I'm playing with the python sdk. >> >> When I want to delete a VM, I see that it takes a action with settings : >> >> [@param action.force: boolean] >> [@param

[ovirt-users] debuging Python SDK

2016-04-11 Thread Fabrice Bacchella
I writting code to generate a VM. But I'm getting : Traceback (most recent call last): ... newvm = self.api.vms.add(params.VM(**kwargs)) File "build/bdist.macosx-10.10-x86_64/egg/ovirtsdk/infrastructure/brokers.py", line 35195, in add File

Re: [ovirt-users] debuging Python SDK

2016-04-11 Thread Fabrice Bacchella
>> >> It should be better if the given attribute name was given, it will save >> me time. >> > > Unfortunately we can't improve that area of the code, because that > "params.py" file is automatically generated using the generateDS.py > tool, and those are the errors it generates. > > In

Re: [ovirt-users] Looking for Python-SDK documentation

2016-04-11 Thread Brett I. Holcomb
On Mon, 2016-04-11 at 20:41 +0200, Frank Thommen wrote: > On 11.04.16 20:17, Brett I. Holcomb wrote: > > > > On Mon, 2016-04-11 at 14:38 -0300, Amador Pahim wrote: > > > > > > > > > On 04/11/2016 02:07 PM, Brett I. Holcomb wrote: > > > > > > > > On Mon, 2016-04-11 at 17:27 +0200, Frank Thommen

Re: [ovirt-users] Hosted engine on gluster problem

2016-04-11 Thread Bond, Darryl
My setup is hyperconverged. I have placed my test results in https://bugzilla.redhat.com/show_bug.cgi?id=1298693 Short description of setup: 3 hosts with 2 disks each set up with gluster replica 3 across the 6 disks volume name hosted-engine. Hostname hosted-storage configured in /etc//hosts

Re: [ovirt-users] Fwd: Re: ***UNCHECKED*** Re: kvm vcpu0 unhandled rdmsr

2016-04-11 Thread Yaniv Kaul
On Sun, Apr 10, 2016 at 11:22 PM, Yaniv Kaul wrote: > On Sun, Apr 10, 2016 at 6:05 PM, gregor wrote: > >> Hi, >> >> has anybody a last tip. Now the third installed Windows Server 2012 R2 >> VM is damaged and I will move tomorrow my host back to VMWare

[ovirt-users] HA agent fails to start

2016-04-11 Thread Richard Neuboeck
Hi oVirt Group, in my attempts to get all aspects of oVirt 3.6 up and running I stumbled upon something I'm not sure how to fix: Initially I installed a hosted engine setup. After that I added another HA host (with hosted-engine --deploy). The host was registered in the Engine correctly and HA

Re: [ovirt-users] Creating templates in a blocking fashion from Python SDK

2016-04-11 Thread Barak Korren
Is there a way to block on the template creation task and not return to the code until it finishes? >>> >>> >>> I don't think so, but you can loop waiting, see e.g.: >>> >>> http://www.ovirt.org/develop/api/pythonapi/#create-a-template-from-vm >>> [2] >> >> >> I wish we could have