Re: [ovirt-users] Users Digest, Vol 55, Issue 155

2016-04-20 Thread Nir Soffer
n the oVirt node and set >> > the "sap_agent" custom property for the vm as you may see on >> > the >> > screenshot. >> > >> > sap_agent >> > >> > Ars?ne >> > >> > On 04/15/2016 12:15 PM, Simon Barret

Re: [ovirt-users] Users Digest, Vol 55, Issue 155

2016-04-20 Thread Clint Boggio
> > the > > /dev/shm/vhostmd0 on the ovirt node. > > > > The part I?m stuck on is: ?This disk image is exported > > read-only to guests. Guests can read the disk image to see > > metrics? from > > http://www.ovirt.org

Re: [ovirt-users] Unable to add hosts in ovirt-engine 3.6

2016-04-20 Thread Yedidyah Bar David
On Wed, Apr 20, 2016 at 4:10 AM, Sandvik Agustin wrote: > Hi Users, > > Good day, i'm having problem on adding hosts/hypervisor in ovirt-engine 3.6, > a month ago i have successfully added 2 hypervisor when the engine is still > version 3.5, then a week ago, i manage to

Re: [ovirt-users] Delete Failed to update OVF disks, OVF data isn't updated on those OVF stores (Data Center Default, Storage Domain hostedengine_nfs).

2016-04-20 Thread Paul Groeneweg | Pazion
Hi Roy, What do you mean with a RFE , submit a bug ticket? Here is what I did: I removed the OVF disks as explained from the hosted engine/storage. I started another server, tried several things like putting to maintenance and reinstalling, but I keep getting: Apr 20 00:18:00 geisha-3

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread วีร์ ศรีทิพโพธิ์
I'll try to clean to storage then report back. This is what I got from "hosted-engine --vm-status" in host01: [root@host01 ~]# hosted-engine --vm-status Traceback (most recent call last): File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main "__main__", fname, loader,

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Yedidyah Bar David
On Wed, Apr 20, 2016 at 7:15 AM, Wee Sritippho wrote: > Hi, > > I used CentOS-7-x86_64-Minimal-1511.iso to install the hosts and the engine. > > The 1st host and the hosted-engine were installed successfully, but the 2nd > host failed with this error message: > > "Failed to

[ovirt-users] Windows BSOD with virtio serial driver

2016-04-20 Thread Kevin C
Hi list, I imported two windows boxes from Proxmox to oVirt. I want to install ovirt-guest-agent and drivers, but I had BSOD when installing virtio-serial. How can I have some debug info, and need I this driver ? smime.p7s Description: S/MIME cryptographic signature

Re: [ovirt-users] several questions about serial console

2016-04-20 Thread Nathanaël Blanchet
thank you, it works, exactly what I need. Le 20/04/2016 09:12, Milan Zamazal a écrit : Nathanaël Blanchet writes: * how to get out of a selectionned vm where we are on the login prompt (why not backing up to the vm menu) rather than killing the ssh process or closing the

[ovirt-users] Fw: job queue

2016-04-20 Thread Dominique Taffin
Hello! I was hoping someone could give some insight details... I have a question regarding the internal operations of ovirt- engine. It seems the internal queue only processes up to 10 requests / jobs simultanious. E.g. 7 Power_ON and 3 LiveMigrations. All remaining jobs (e.g. 50 more Power_On

[ovirt-users] ovirt-guest-agent not starting on Windows 2008 R2

2016-04-20 Thread Kevin C
Hi list, On a Windows 2008 R2, oVirt guest agent is not starting. The following information was included with the event:  Traceback (most recent call last):   File "win32serviceutil.pyc", line 835, in SvcRun   File "OVirtGuestService.pyc", line 89, in SvcDoRun   File "GuestAgentWin32.pyc", line

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Yedidyah Bar David
On Wed, Apr 20, 2016 at 11:40 AM, Martin Sivak wrote: >> Doesn't cleaning sanlock lockspace require also to stop sanlock itself? >> I guess it's supposed to be able to handle this, but perhaps users want >> to clean the lockspace because dirt there causes also problems with >>

[ovirt-users] Issue while importing the existing storage domain

2016-04-20 Thread SATHEESARAN
Hi All, I was testing the gluster geo-replication on RHEV storage domain backed by gluster volume. In this case, storage domain ( data domain ) was created with gluster replica 3 volume. The VMs additional disks are carved out from this storage domain. Now I have geo-replicated[1] the

Re: [ovirt-users] ovirt-guest-agent not starting on Windows 2008 R2

2016-04-20 Thread Yaniv Kaul
On Wed, Apr 20, 2016 at 11:37 AM, Kevin C wrote: > Hi list, > > On a Windows 2008 R2, oVirt guest agent is not starting. The following > information was included with the event: > > Traceback (most recent call last): > File "win32serviceutil.pyc", line 835, in SvcRun >

Re: [ovirt-users] Delete Failed to update OVF disks, OVF data isn't updated on those OVF stores (Data Center Default, Storage Domain hostedengine_nfs).

2016-04-20 Thread Roy Golan
On Wed, Apr 20, 2016 at 9:05 AM, Paul Groeneweg | Pazion wrote: > Hi Roy, > > What do you mean with a RFE , submit a bug ticket? > > Yes please. https://*bugzilla*.redhat.com/enter_bug.cgi?product= *oVirt* > Here is what I did: > > I removed the OVF disks as explained from the

[ovirt-users] Issue while importing the existing storage domain

2016-04-20 Thread SATHEESARAN
Hi All, I was testing the gluster geo-replication on RHEV storage domain backed by gluster volume. In this case, storage domain ( data domain ) was created with gluster replica 3 volume. The VMs additional disks are carved out from this storage domain. Now I have geo-replicated[1] the

Re: [ovirt-users] Delete Failed to update OVF disks, OVF data isn't updated on those OVF stores (Data Center Default, Storage Domain hostedengine_nfs).

2016-04-20 Thread Paul Groeneweg | Pazion
Yes I removed them also from the web interface. Cen I recreate these or how can I restore? Op wo 20 apr. 2016 om 09:01 schreef Roy Golan : > On Wed, Apr 20, 2016 at 9:05 AM, Paul Groeneweg | Pazion > wrote: > >> Hi Roy, >> >> What do you mean with a RFE ,

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Martin Sivak
> Assuming you never deployed a host with ID 52, this is likely a result of a > corruption or dirt or something like that. > I see that you use FC storage. In previous versions, we did not clean such > storage, so you might have dirt left. This is the exact reason for an error like yours. Using

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Martin Sivak
> Doesn't cleaning sanlock lockspace require also to stop sanlock itself? > I guess it's supposed to be able to handle this, but perhaps users want > to clean the lockspace because dirt there causes also problems with > sanlock, no? Sanlock can be up, but the lockspace has to be unused. > So the

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Martin Sivak
> And we also do not clean on upgrades... Perhaps we can? Should? Optionally? > We can't. We do not execute any setup tool during upgrade and the clean procedure requires that all hosted engine tooling is shut down. Martin On Wed, Apr 20, 2016 at 11:40 AM, Yedidyah Bar David

Re: [ovirt-users] Windows BSOD with virtio serial driver

2016-04-20 Thread Yaniv Kaul
On Wed, Apr 20, 2016 at 11:53 AM, Kevin C wrote: > Hi list, > > > I imported two windows boxes from Proxmox to oVirt. I want to install > ovirt-guest-agent and drivers, but I had BSOD when installing virtio-serial. > > How can I have some debug info, and need I this

Re: [ovirt-users] several questions about serial console

2016-04-20 Thread Milan Zamazal
Nathanaël Blanchet writes: > * how to get out of a selectionned vm where we are on the login prompt > (why not backing up to the vm menu) rather than killing the ssh > process or closing the terminal? Usual "^] " doesn't work there. You must use ssh escape sequences with ssh,

Re: [ovirt-users] ldap servers configuration can be misleading with AD

2016-04-20 Thread Fabrice Bacchella
> Le 20 avr. 2016 à 10:16, Ondra Machacek a écrit : > > On 04/19/2016 07:46 PM, Fabrice Bacchella wrote: >> >>> Le 19 avr. 2016 à 17:35, Ondra Machacek a écrit : >>> >>> On 04/19/2016 04:37 PM, Fabrice Bacchella wrote: I tried to plug ovirt

Re: [ovirt-users] Delete Failed to update OVF disks, OVF data isn't updated on those OVF stores (Data Center Default, Storage Domain hostedengine_nfs).

2016-04-20 Thread Paul Groeneweg | Pazion
I have added a ticket: https://bugzilla.redhat.com/show_bug.cgi?id=1328718 Looking forward to solve! ( trying to providing as much info as required ). For the short term, wwhat do I need to restore/rollback to get the OVF_STORE back in the Web GUI? is this all db? Op wo 20 apr. 2016 om 09:04

Re: [ovirt-users] ldap servers configuration can be misleading with AD

2016-04-20 Thread Ondra Machacek
On 04/19/2016 07:46 PM, Fabrice Bacchella wrote: Le 19 avr. 2016 à 17:35, Ondra Machacek a écrit : On 04/19/2016 04:37 PM, Fabrice Bacchella wrote: I tried to plug ovirt using my company AD. But I have a problem, the DNS srv records are not well managed and I can't use

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Yedidyah Bar David
On Wed, Apr 20, 2016 at 11:11 AM, Martin Sivak wrote: >> Assuming you never deployed a host with ID 52, this is likely a result of a >> corruption or dirt or something like that. > >> I see that you use FC storage. In previous versions, we did not clean such >> storage, so you

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Martin Sivak
> after moving to global maintenance. Good point. > Martin - any advantage of this over '–reinitialize-lockspace'? Besides > that it works also in older versions? Care to add this to the howto page? Reinitialize lockspace clears the sanlock lockspace, not the metadata file. Those are two

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Yedidyah Bar David
On Wed, Apr 20, 2016 at 11:20 AM, Martin Sivak wrote: >> after moving to global maintenance. > > Good point. > >> Martin - any advantage of this over '–reinitialize-lockspace'? Besides >> that it works also in older versions? Care to add this to the howto page? > > Reinitialize

Re: [ovirt-users] ldap servers configuration can be misleading with AD

2016-04-20 Thread Ondra Machacek
On 04/20/2016 10:33 AM, Fabrice Bacchella wrote: Le 20 avr. 2016 à 10:16, Ondra Machacek a écrit : On 04/19/2016 07:46 PM, Fabrice Bacchella wrote: Le 19 avr. 2016 à 17:35, Ondra Machacek a écrit : On 04/19/2016 04:37 PM, Fabrice Bacchella

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Wee Sritippho
Hi Didi & Martin, I followed your instructions and are able to add the 2nd host. Thank you :) This is what I've done: [root@host01 ~]# hosted-engine --set-maintenance --mode=global [root@host01 ~]# systemctl stop ovirt-ha-agent [root@host01 ~]# systemctl stop ovirt-ha-broker [root@host01

[ovirt-users] hosted-engine install stalls

2016-04-20 Thread Johan Vermeulen
Hello All, my setup of a hosted engine on Centos7.2 hangs on : [ INFO ] Connecting Storage Pool In the log file I see a lot of items with "ok": *2016-04-20 13:04:01 DEBUG otopi.plugins.ovirt_hosted_engine_setup.storage.storage storage._activateStorageDomain:1067

Re: [ovirt-users] several questions about serial console

2016-04-20 Thread Nathanaël Blanchet
Le 19/04/2016 09:50, Michal Skrivanek a écrit : On 17 Apr 2016, at 11:53, Yedidyah Bar David wrote: On Fri, Apr 15, 2016 at 7:18 PM, Nathanaël Blanchet wrote: Le 15/04/2016 17:27, Nathanaël Blanchet a écrit : Hi all, About serial console: how to get

Re: [ovirt-users] Fwd: hosted-engine install stalls

2016-04-20 Thread Johan Vermeulen
Simone, the install has continuedI can now install the os on the vm... Many thanks. greetz, J. 2016-04-20 14:54 GMT+02:00 Simone Tiraboschi : > On Wed, Apr 20, 2016 at 2:18 PM, Johan Vermeulen > wrote: > > I should sent this to the list, my

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Yedidyah Bar David
On Wed, Apr 20, 2016 at 1:42 PM, Wee Sritippho wrote: > Hi Didi & Martin, > > I followed your instructions and are able to add the 2nd host. Thank you :) > > This is what I've done: > > [root@host01 ~]# hosted-engine --set-maintenance --mode=global > > [root@host01 ~]#

Re: [ovirt-users] hosted-engine install stalls

2016-04-20 Thread Simone Tiraboschi
Hi, can you please attach the whole logs? On Wed, Apr 20, 2016 at 1:15 PM, Johan Vermeulen wrote: > Hello All, > > my setup of a hosted engine on Centos7.2 hangs on : [ INFO ] Connecting > Storage Pool > In the log file I see a lot of items with "ok": > > 2016-04-20

Re: [ovirt-users] ovirt-guest-agent not starting on Windows 2008 R2

2016-04-20 Thread Kevin COUSIN
>> > > Is the virtio-serial driver installed and working correctly? Please check > in the device manager. > Y. > > I have BSOD when I try to install virtio-serial on Windows (I sent to the list, I didn't know my errors are dependent). So I need to fix my BSOD on virtio-serial driver to fix

Re: [ovirt-users] oVirt 3.5 and SSLv3

2016-04-20 Thread Alexander Wels
On Wednesday, April 20, 2016 08:39:14 AM Robert Story wrote: > Yesterday I had to re-install a host node in my 3.5.6 cluster. After a fresh > install of CentOS 7.2, attempts to re-install failed, as did removing and > re-adding the node. Here is a log excerpt from the engine: > > > 2016-04-19

[ovirt-users] VM status

2016-04-20 Thread Kevin C
Hi, I have exclamation mark on some VM. But I can't have more informations when I hover my mouse over my VM (I only and "Up/Down" status or "Server/Desktop") How can I know where is the problem ? Thanks a lot smime.p7s Description: S/MIME cryptographic signature

Re: [ovirt-users] VM status

2016-04-20 Thread Alexander Wels
On Wednesday, April 20, 2016 02:30:01 PM Kevin C wrote: > Hi, > > I have exclamation mark on some VM. But I can't have more informations when > I hover my mouse over my VM (I only and "Up/Down" status or > "Server/Desktop") > > How can I know where is the problem ? > > Thanks a lot There

Re: [ovirt-users] Fwd: hosted-engine install stalls

2016-04-20 Thread Simone Tiraboschi
On Wed, Apr 20, 2016 at 2:18 PM, Johan Vermeulen wrote: > I should sent this to the list, my apologies > > 2016-04-20 14:14 GMT+02:00 Johan Vermeulen : >> >> Hello, >> >> many thanks for helping me out. >> This is the whole log: We call createVolume

[ovirt-users] hosted-engine install stalls

2016-04-20 Thread Johan Vermeulen
Hello All, my setup of a hosted engine on Centos7.2 hangs on : [ INFO ] Connecting Storage Pool In the log file I see a lot of items with "ok": *2016-04-20 13:04:01 DEBUG otopi.plugins.ovirt_hosted_engine_setup.storage.storage storage._activateStorageDomain:1067

Re: [ovirt-users] Windows BSOD with virtio serial driver

2016-04-20 Thread Kevin COUSIN
> > You need this driver for the guest agent to report information and > generally work well in Windows. This is the communication channel for the > agent. > While this is a qemu and/or driver issues, we'll need a lot more > information to able to help you, beginning with the version of Windows,

Re: [ovirt-users] Delete Failed to update OVF disks, OVF data isn't updated on those OVF stores (Data Center Default, Storage Domain hostedengine_nfs).

2016-04-20 Thread Paul Groeneweg | Pazion
Looks like the system does try recreate the OVF :-) Too bad this failed again... http://screencast.com/t/RlYCR1rk8T http://screencast.com/t/CpcQuoKg Failed to create OVF store disk for Storage Domain hostedengine_nfs. The Disk with the id b6f34661-8701-4f82-a07c-ed7faab4a1b8 might be removed

[ovirt-users] oVirt 3.5 and SSLv3

2016-04-20 Thread Robert Story
Yesterday I had to re-install a host node in my 3.5.6 cluster. After a fresh install of CentOS 7.2, attempts to re-install failed, as did removing and re-adding the node. Here is a log excerpt from the engine: 2016-04-19 18:22:01,100 INFO

[ovirt-users] Using oVirt Python SDK in Avocado Testing Framework

2016-04-20 Thread Amador Pahim
Hi guys, I would like to share this post on using oVirt Python SDK to write tests in Avocado Testing Framework: https://virtstuff.wordpress.com/2016/04/10/ovirt-functional-tests-using-avocado/ This post was born from an issue report, but after we get rid of the issue, I wonder if someone

Re: [ovirt-users] oVirt 3.5 and SSLv3

2016-04-20 Thread Robert Story
On Wed, 20 Apr 2016 08:52:49 -0400 Alexander wrote: AW> On Wednesday, April 20, 2016 08:39:14 AM Robert Story wrote: AW> > Yesterday I had to re-install a host node in my 3.5.6 cluster. After a fresh AW> > install of CentOS 7.2, attempts to re-install failed, as did removing and AW> > re-adding

Re: [ovirt-users] [hosted-engine] Metadata too new error when adding 2nd host

2016-04-20 Thread Martin Sivak
Hi everybody, I added the procedure to the wiki, it you would be so kind to review it. https://github.com/oVirt/ovirt-site/pull/188 Thanks Martin On Wed, Apr 20, 2016 at 1:29 PM, Yedidyah Bar David wrote: > On Wed, Apr 20, 2016 at 1:42 PM, Wee Sritippho

Re: [ovirt-users] Delete Failed to update OVF disks, OVF data isn't updated on those OVF stores (Data Center Default, Storage Domain hostedengine_nfs).

2016-04-20 Thread Paul Groeneweg | Pazion
The logs are not from the machine where the hosted engine is running on, but from the SPM. Op wo 20 apr. 2016 om 17:19 schreef Paul Groeneweg | Pazion : > Hereby the logs. > > > Op wo 20 apr. 2016 om 17:11 schreef Maor Lipchuk : > >> Hi Paul, >> >> Can u

Re: [ovirt-users] Disks Illegal State

2016-04-20 Thread Clint Boggio
In my case Markus, the backing disks are MIA and show only as bright red broken symbolic links. Using the postgres commands to set them as OK would be folly, and likley cause more trouble. if the snapshot disks are truly gone, (and they are), what procedure would i use to inform the database and

Re: [ovirt-users] Disks Illegal State

2016-04-20 Thread Clint Boggio
The "vdsm-tool dump-volume-chains" command on the iSCSI storage domain shows one disk in "ILLEGAL" state while the gui shows 8 disk images in the same state. ### # BEGIN COMMAND OUTPUT ### [root@KVM01 ~]# vdsm-tool

Re: [ovirt-users] Fwd: hosted-engine install stalls

2016-04-20 Thread Simone Tiraboschi
On Wed, Apr 20, 2016 at 3:29 PM, Johan Vermeulen wrote: > Simone, > > the install has continuedI can now install the os on the vm... > Many thanks. It shouldn't take that much: normally it's a matter of seconds. > greetz, J. > > 2016-04-20 14:54 GMT+02:00 Simone

Re: [ovirt-users] Disks Illegal State

2016-04-20 Thread Nir Soffer
On Wed, Apr 20, 2016 at 5:34 PM, Clint Boggio wrote: > The "vdsm-tool dump-volume-chains" command on the iSCSI storage domain > shows one disk in "ILLEGAL" state while the gui shows 8 disk images in > the same state. Interesting - it would be useful to find the missing

Re: [ovirt-users] vhostmd vdsm-hook

2016-04-20 Thread Arsène Gschwind
I've never tried with 2 disks but I will assume that the next free available disk will be used by the vdsm hook and the vm-dump-metrics cmd will check the kind of disk. Let me know if you give a try thanks, Arsène On 04/19/2016 02:43 PM, Simon Barrett wrote: Thanks again but how does

Re: [ovirt-users] Unable to add hosts in ovirt-engine 3.6

2016-04-20 Thread Sandvik Agustin
Hi, Thanks for the quick reply, my ovirt-engine is running on CentOS 6.7 and my hypervisor is also CentOS 6.7. engine.log ]# tail /var/log/ovirt-engine/engine.log at java.util.concurrent.FutureTask.run(FutureTask.java:262) [rt.jar:1.7.0_95] at

[ovirt-users] Consult actual size the disk vm

2016-04-20 Thread Marcelo Leandro
Hello, i am try automate an task, i am try consult the actual size the disk of vm, but not have success, i try in database in table imagens, i try with python-api with command: vm = api.vms.get(vmname) disk = vm.disks.get(diskname) disk.get_actual_size() but the informations not is equal with

Re: [ovirt-users] Users Digest, Vol 55, Issue 155

2016-04-20 Thread Nir Soffer
entry in the qemu-kvm output: >>>>> >>>>>drive >>>>>file=/dev/shm/vhostmd0,if=none,id=drive-virtio- >>>>> disk701,readonly=on,format=raw >>>>>-device >>>>>virtio-blk-pci,scsi=off,bus=pci.0,addr=0x8,drive=drive

Re: [ovirt-users] Users Digest, Vol 55, Issue 155

2016-04-20 Thread Clint Boggio
, which is great news and very >>>> useful. >>>> >>>>Thanks for your help. >>>> >>>>Simon >>>> >>>>*From:*users-boun...@ovirt.org <mailto:users-boun...@ovirt.org> >>>>[mailto:use

Re: [ovirt-users] Issue while importing the existing storage domain

2016-04-20 Thread Idan Shaby
Hi Satheesaran, Please file a BZ and attach all the relevant logs so we can investigate it properly. Regards, Idan On Wed, Apr 20, 2016 at 12:42 PM, SATHEESARAN wrote: > Hi All, > > I was testing the gluster geo-replication on RHEV storage domain backed by > gluster