Re: [ovirt-users] ovirt 4.0 hosted engine deploy

2016-07-04 Thread qinglong.d...@horebdata.cn
Yes, I am running 7.2. Here are the vdsm logs when I excuted "hosted-engine --deploy" Reactor thread::INFO::2016-07-04 17:51:49,584::protocoldetector::72::ProtocolDetector.AcceptorImpl::(handle_accept) Accepting connection from ::1:45014 Reactor thread::DEBUG::2016-07-04

Re: [ovirt-users] [oVirt 4.0] Is it possible to access oVirt through a reverse proxy

2016-07-04 Thread Colin Coe
Hi all I've logged case 01662585 with GSS. I see that RHEV 4.0 beta is in the customer support portal, I'm going to see if we can upgrade our current DEV RHEV environment to 4.0 BETA so we can start testing early. Thanks On Mon, Jul 4, 2016 at 5:39 PM, Martin Perina

Re: [ovirt-users] Cannot add Hosted Engine Host because of missing answersfile

2016-07-04 Thread Matt .
Hi, I did a new installer re-imported my old engine and it's all fine again. I think, or it should be nice that the hosted engine install checks don't rely on dns only. It fails at the end even when you are using /etc/hosts which should work fine. It's known that when DNS doesn't work well the

Re: [ovirt-users] disk not bootable

2016-07-04 Thread Fernando Fuentes
Nir, That's exactly how I did it Nir. I will test tomorrow with a new Windows VM and report back. Regards, -- Fernando Fuentes ffuen...@txweather.org http://www.txweather.org On Mon, Jul 4, 2016, at 10:48 AM, Nir Soffer wrote: > On Mon, Jul 4, 2016 at 6:43 PM, Francesco Romani

Re: [ovirt-users] Cannot add Hosted Engine Host because of missing answersfile

2016-07-04 Thread Simone Tiraboschi
On Mon, Jul 4, 2016 at 3:54 PM, Matt . wrote: > Indeed, that is what I thought, but does this mean I need to reinstall > that whole VM ? Yes, unfortunately the best option, since you installation never completed, is to clean the hosted-engine storage domain and restart

Re: [ovirt-users] VM convert Windows2012R2 to Ovirt

2016-07-04 Thread Pavel Gashev
Vinzenz, I just tried libguestfs-RHEL-7.3-preview. I have converted a Windows2012R2 VM with no issues, except it doesn't boot – see attached screenshot. Thanks On 21/06/16 14:14, "users-boun...@ovirt.org on behalf of Vinzenz Feenstra"

Re: [ovirt-users] disk not bootable

2016-07-04 Thread Francesco Romani
- Original Message - > From: "Nir Soffer" > To: "Fernando Fuentes" > Cc: "Francesco Romani" , "users" > Sent: Saturday, July 2, 2016 11:18:01 AM > Subject: Re: [ovirt-users] disk not bootable > > On Sat, Jul

Re: [ovirt-users] disk not bootable

2016-07-04 Thread Nir Soffer
On Mon, Jul 4, 2016 at 6:43 PM, Francesco Romani wrote: > - Original Message - >> From: "Nir Soffer" >> To: "Fernando Fuentes" >> Cc: "Francesco Romani" , "users" >> Sent: Saturday, July

Re: [ovirt-users] Cannot add Hosted Engine Host because of missing answersfile

2016-07-04 Thread Matt .
Indeed, that is what I thought, but does this mean I need to reinstall that whole VM ? And what about the hosted_storare and such ? 2016-07-04 12:36 GMT+02:00 Simone Tiraboschi : > On Mon, Jul 4, 2016 at 10:48 AM, Matt . wrote: >> Hi, >> >> Yes, the

Re: [ovirt-users] Ovirt Node NG 4.0.0 wants to bridge my infiniband link

2016-07-04 Thread Giorgio Biacchi
As I said, Infiniband is not ethernet so it cannot be L2 bridged. This is normal and I understand why it can't be done. I'd like to know if there's a way to configure host networking for infiniband link without bridging because is not necessary to have a bridge there. In addition to this, 3.6

Re: [ovirt-users] Ovirt Node NG 4.0.0 wants to bridge my infiniband link

2016-07-04 Thread Arman Khalatyan
As I remember the IBoIP is not fully implemented Ethernet protocol, it does not support bridging. *** Dr. Arman Khalatyan eScience -SuperComputing Leibniz-Institut für Astrophysik Potsdam (AIP) An der Sternwarte 16, 14482 Potsdam,

[ovirt-users] ldap and multiple profiles

2016-07-04 Thread Fabrice Bacchella
I want to setup two LDAP base profile. One is backed using an active directory (for real users) One is backed using an openldap (for service account). I have to problem with this setup. One it's that in the log I see many "Creating LDAP pool 'authz'" and "Creating LDAP pool 'authn'". If I have

Re: [ovirt-users] Ovirt Node NG 4.0.0 wants to bridge my infiniband link

2016-07-04 Thread Yevgeny Zaspitsky
Infiniband should not be bridged. Ovirt tries to build a bridge over a NIC if the network is a VM one. Please verify that it isn't. On Mon, Jul 4, 2016 at 5:10 PM, Giorgio Biacchi wrote: > As I said, Infiniband is not ethernet so it cannot be L2 bridged. This is > normal >

Re: [ovirt-users] Ovirt Node NG 4.0.0 wants to bridge my infiniband link

2016-07-04 Thread Giorgio Biacchi
Thanks, setting the link as non VM networks let me configure the interface as needed. Regards On 07/04/2016 04:16 PM, Yevgeny Zaspitsky wrote: > Infiniband should not be bridged. > Ovirt tries to build a bridge over a NIC if the network is a VM one. Please > verify that it isn't. > > On Mon,

Re: [ovirt-users] disk not bootable

2016-07-04 Thread Fernando Fuentes
Nir, I will try and get you a working xml. Any updates on your question from the team? TIA! -- Fernando Fuentes ffuen...@txweather.org http://www.txweather.org On Sat, Jul 2, 2016, at 04:18 AM, Nir Soffer wrote: > On Sat, Jul 2, 2016 at 1:33 AM, Fernando Fuentes >

Re: [ovirt-users] Unable to set up oVirt 4.0 HE using glusterfs storage

2016-07-04 Thread Kevin Hung
On 7/4/2016 4:38 AM, Simone Tiraboschi wrote: On Sun, Jul 3, 2016 at 5:57 AM, Kevin Hung wrote: 4. Using cloud-init with default values to customize the engine appliance can fail on the line "Creating/refreshing DWH database schema" if it takes longer than 600 seconds to

[ovirt-users] ovirt 4.0 hosted engine deploy

2016-07-04 Thread qinglong.d...@horebdata.cn
Hi, all I got an error when I excuted "hosted-engine --deploy" on centos 7.0. [root@node ~]# hosted-engine --deploy [ INFO ] Stage: Initializing [ INFO ] Generating a temporary VNC password. [ INFO ] Stage: Environment setup During customization use CTRL-D to abort.

Re: [ovirt-users] ovirt 4.0 hosted engine deploy

2016-07-04 Thread Roy Golan
On Mon, Jul 4, 2016 at 12:23 PM, qinglong.d...@horebdata.cn < qinglong.d...@horebdata.cn> wrote: > Hi, all > I got an error when I excuted "hosted-engine --deploy" on centos > 7.0 > We don't support 7.0 you need Centos 7.2 If you are running 7.2 look at /var/log/vdsm/vdsm.log to see why

[ovirt-users] Is it possible to disable qxl video?

2016-07-04 Thread Arman Khalatyan
Hi, I am doing PCI Passthrough for GPUs. Is it possible somehow to disable/remove default video qxl? thanks, Arman,. *** Dr. Arman Khalatyan eScience -SuperComputing Leibniz-Institut für Astrophysik Potsdam (AIP) An der Sternwarte 16,

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-07-04 Thread Arman Khalatyan
Hi, I am also interested to upgrade my system from centos 7 ovirt 3.6.7 to ovirt4, are there any preferable order to upgrade? Host then engine? or engine then host? thanks, Arman. *** Dr. Arman Khalatyan eScience -SuperComputing

Re: [ovirt-users] Cannot add Hosted Engine Host because of missing answersfile

2016-07-04 Thread Simone Tiraboschi
On Mon, Jul 4, 2016 at 10:48 AM, Matt . wrote: > Hi, > > Yes, the issue is that I don't have that info on the shared storage > indeed. I was wondering if I just can create it manually. It's not that easy and not that safe. It will be much easier and quicker to simply

[ovirt-users] Ovirt Node NG 4.0.0 wants to bridge my infiniband link

2016-07-04 Thread Giorgio Biacchi
Hi list, I'm trying a test installation of the new Ovirt Node Image and engine before upgrading my 3.6 installation. In my current environment every hypervisor access the NFS shared data domain via infiniband. With a couple of vdsm hooks I was able to set the infiniband link in connected mode and

Re: [ovirt-users] Migrate to python-ovirt-engine-sdk4

2016-07-04 Thread Juan Hernández
On 07/03/2016 12:37 PM, gregor wrote: > Hi, > > today I will migrate my backup tool [1] from oVirt version 3 to 4. > Is there anywhere a documentation to the new SDK? I downloaded the > source and read in the meantime through the code. It seems it will be a > lot of work :-( > > cheers > gregor

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-07-04 Thread Arman Khalatyan
about a n hour ago I just tested to setup ovirt 3.6, then upgrade it, 2 nodes: host and ovirt on separated machines. very smoothly upgraded, first engine upgrade then host upgrade. The only trouble on hosts is that some pacages are still reffering to ovirt-3.6 repository even ovirt-4.0 is there.

[ovirt-users] 'Image does not exist in domain' while moving disks

2016-07-04 Thread Dael Maselli
Hi, I'm trying to move disks between storage domain but I get this error: "VDSM command failed: Image does not exist in domain: u'image=6bf41b4e-3184-40c1-9db0-e304b39f34d0, domain=ae2ab96e-c2bf-44bb-beba-6c4d7cb9f5cc'" I tried live and shutting down the vms. I also can't make snapshot of

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-07-04 Thread nicola.gentile.to
alse I am interested. Nicola Il 04/07/2016 11:25, Arman Khalatyan ha scritto: Hi, I am also interested to upgrade my system from centos 7 ovirt 3.6.7 to ovirt4, are there any preferable order to upgrade? Host then engine? or engine then host? thanks, Arman.

[ovirt-users] Do vm's on host start up after crash if the Engine is down

2016-07-04 Thread Jonas Kirk Pedersen
Hello I am curious to what happens if ovirt and our hosts goes down due to power failure and the ovirt-engine will not start up. Does the vm's that was on the hosts before the crash start up again when the host is online or does the hosts need the engine for starting the vm's Is there some kind of

Re: [ovirt-users] [oVirt 4.0] Is it possible to access oVirt through a reverse proxy

2016-07-04 Thread Martin Perina
Hi, first let me explain more thoroughly how things works in 4.0. Here's a bit simplified login flow: 1. Let's assume that ovirt.example.com was set as FQDN during engine-setup 2. User tries to access http://ovirt.example.com/ovirt-engine/webadmin 3. SSO authentication filters checks if user is

Re: [ovirt-users] Importing *.ova appliance

2016-07-04 Thread Arik Hadas
Hi Anantha, Yes, it is supported but only for OVA appliances that are generated by vSphere 5.5 and above. What kind of OVA did you try to import from? (how it was generated?) Regards, Arik - Original Message - > Hi, > > How do we import a *.ova appliance in oVirt? Starting 3.6.6, we

Re: [ovirt-users] Communicating with ovirt agent

2016-07-04 Thread Yaniv Kaul
On Mon, Jul 4, 2016 at 12:05 PM, Tadas wrote: > Yes, and it works fine. Though we went for a simplier solution. > Also, one of problems is that oVirt is very distribution-oriented. To > use it on distributions different than Redhat requires lots of tuning. > Indeed, it is EL

Re: [ovirt-users] Networking issues with oVirt Guest VM.

2016-07-04 Thread Yevgeny Zaspitsky
Adding mailing list back... On Mon, Jul 4, 2016 at 3:38 PM, Yevgeny Zaspitsky wrote: > Clint, > > Sorry, I missed that you already tried that. > > Here are my thoughts (some more shooting in the dark) after reading your > description again: > >- You have quite

Re: [ovirt-users] Communicating with ovirt agent

2016-07-04 Thread Tadas
We are mostly using Debian based distros (Debian, Ubuntu). And since this is a massive project it takes much time to adopt it to different distro and also maintain it. On the other hand our project is in production at the moment and the only thing that was still unfinished was SSO part. With

Re: [ovirt-users] Ovirt Node NG 4.0.0 wants to bridge my infiniband link

2016-07-04 Thread Yevgeny Zaspitsky
Hello, What's "couple of vdsm hooks"? Could you provide the source code of those? Regards, Yevgeny On Mon, Jul 4, 2016 at 1:43 PM, Giorgio Biacchi wrote: > Hi list, > I'm trying a test installation of the new Ovirt Node Image and engine > before > upgrading my 3.6

Re: [ovirt-users] Ovirt Node NG 4.0.0 wants to bridge my infiniband link

2016-07-04 Thread Giorgio Biacchi
Hi, hooks are only needed to set connected mode and the correct MTU on the infiniband link. The problem is bound to the host networking setup procedure. Here's the hooks: cat /usr/libexec/vdsm/hooks/before_vdsm_start/10_set_ib0_connected_mode #!/bin/sh echo Setting IB connected mode echo

Re: [ovirt-users] Cannot add Hosted Engine Host because of missing answersfile

2016-07-04 Thread Simone Tiraboschi
On Mon, Jul 4, 2016 at 6:31 AM, Matt . wrote: > Hi! > > Apperently there has been something gone wrong with the hosted engine > install which I can perfectly start but cannot add any Host to the HA > setup. > > I'm missing an answers.conf on my host where I did the

Re: [ovirt-users] Communicating with ovirt agent

2016-07-04 Thread Tadas
Got everything working now. Thank you for your help. For any users, whom it may be useful, heres the code for external (SSO) logins from hypervisor. http://paste.ubuntu.com/18435531/ On Fri, 2016-07-01 at 13:53 +0200, Vinzenz Feenstra wrote: > > > On Jul 1, 2016, at 12:05 PM, Tadas

Re: [ovirt-users] Communicating with ovirt agent

2016-07-04 Thread Yaniv Kaul
On Mon, Jul 4, 2016 at 9:16 AM, Tadas wrote: > Got everything working now. > Great to hear. What is your use case? Y. > Thank you for your help. > For any users, whom it may be useful, heres the code for external (SSO) > logins from hypervisor. > >

Re: [ovirt-users] [oVirt 4.0] Is it possible to access oVirt through a reverse proxy

2016-07-04 Thread Yaniv Dary
RFE is the correct ticket type. Yaniv Dary Technical Product Manager Red Hat Israel Ltd. 34 Jerusalem Road Building A, 4th floor Ra'anana, Israel 4350109 Tel : +972 (9) 7692306 8272306 Email: yd...@redhat.com IRC : ydary On Jul 4, 2016 02:36, "Colin Coe" wrote: >

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-07-04 Thread Yaniv Dary
Yes, this is correct. Yaniv Dary Technical Product Manager Red Hat Israel Ltd. 34 Jerusalem Road Building A, 4th floor Ra'anana, Israel 4350109 Tel : +972 (9) 7692306 8272306 Email: yd...@redhat.com IRC : ydary On Jul 4, 2016 08:15, wrote: > Hi, > > in my setup I have

Re: [ovirt-users] Cannot add Hosted Engine Host because of missing answersfile

2016-07-04 Thread Matt .
Hi Sure I can, I will attach them today. The install failed at the end as the installer/deploy didn't like my hostfile on the vdsm host where I was doing the install. The install of the engine went fine. I don't think it's a bug, it could be tackled when such thing happens but still, it was a

Re: [ovirt-users] Unable to set up oVirt 4.0 HE using glusterfs storage

2016-07-04 Thread Simone Tiraboschi
On Sun, Jul 3, 2016 at 5:57 AM, Kevin Hung wrote: > Looks like there still needs to be some work done on oVirt 4.0 Node and > ovirt-hosted-engine-setup before it's ready for general consumption. I have > spent days trying to get this to work, and only got it running (on one

Re: [ovirt-users] Cannot add Hosted Engine Host because of missing answersfile

2016-07-04 Thread Simone Tiraboschi
On Mon, Jul 4, 2016 at 10:25 AM, Matt . wrote: > Hi Sure I can, I will attach them today. > > The install failed at the end as the installer/deploy didn't like my > hostfile on the vdsm host where I was doing the install. The install > of the engine went fine. Do you mean

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-07-04 Thread ovirt
Thank you for the quick answer. Best regards Christoph Am 04.07.2016 um 09:12 schrieb Yaniv Dary: Yes, this is correct. Yaniv Dary Technical Product Manager Red Hat Israel Ltd. 34 Jerusalem Road Building A, 4th floor Ra'anana, Israel 4350109 Tel : +972 (9) 7692306 8272306 Email:

Re: [ovirt-users] Cannot add Hosted Engine Host because of missing answersfile

2016-07-04 Thread Matt .
Hi, Yes, the issue is that I don't have that info on the shared storage indeed. I was wondering if I just can create it manually. I would like to add some to the documentation there if it's possible. Logs will be posted :) 2016-07-04 10:44 GMT+02:00 Simone Tiraboschi : >

Re: [ovirt-users] Ovirt 3.6.x upgrade to 4.0: HE VM not shutdownable - hyperkonverged r3a1 setup

2016-07-04 Thread Roy Golan
On Thu, Jun 30, 2016 at 12:33 PM, Roy Golan wrote: > > > On Wed, Jun 29, 2016 at 10:25 AM, wrote: > >> Hello all, >> >> yesterday I upgraded my 3.6.x to 4.0 and got stuck with obviously not >> being able to shutdown HE VM itself ("shutdown all VMs" required

Re: [ovirt-users] Ovirt 3.6.x upgrade to 4.0: HE VM not shutdownable - hyperkonverged r3a1 setup

2016-07-04 Thread Roy Golan
reformatting cause the command I gave you is missing quotes ```bash su - postgres psql engine -c "update vm_static set cluster_id = (select cluster_id from cluster where name = 'NEWCLUSTERNAME') where vm_name = 'HostedEngine'; " ``` On Mon, Jul 4, 2016 at 12:02 PM, Roy Golan

Re: [ovirt-users] Communicating with ovirt agent

2016-07-04 Thread Tadas
Yes, and it works fine. Though we went for a simplier solution. Also, one of problems is that oVirt is very distribution-oriented. To use it on distributions different than Redhat requires lots of tuning. On Mon, 2016-07-04 at 11:11 +0300, Yaniv Kaul wrote: > > > On Mon, Jul 4, 2016 at 10:25 AM,

Re: [ovirt-users] Upgrade from 3.6 to 4.0

2016-07-04 Thread Gianluca Cecchi
Il 04/Lug/2016 09:12, "Yaniv Dary" ha scritto: > > Yes, this is correct. > > Yaniv Dary > Technical Product Manager > Red Hat Israel Ltd. > 34 Jerusalem Road > Building A, 4th floor > Ra'anana, Israel 4350109 > > Tel : +972 (9) 7692306 > 8272306 > Email: yd...@redhat.com