Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread aleksey . maksimov
https://bugzilla.redhat.com/show_bug.cgi?id=1377069 18.09.2016, 10:09, "Roy Golan" : > On 18 September 2016 at 09:48, wrote: >> Thanks Roy >> >> But if I'm going to redirect the output of the hosted-engine command to >> /dev/null, I can not identify

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Nir Soffer
On Sun, Sep 18, 2016 at 2:03 PM, Roy Golan wrote: > Thanks Nir. He is using hosted engine which already uses vdscli > Right, this issue effects any program importing vdscli. Fixed in https://gerrit.ovirt.org/64100 > > On 18 September 2016 at 13:55, Nir Soffer

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
On 18 September 2016 at 10:09, Roy Golan wrote: > > > On 18 September 2016 at 09:48, wrote: > >> Thanks Roy >> >> >> But if I'm going to redirect the output of the hosted-engine command to >> /dev/null, I can not identify the possible problem of the

Re: [ovirt-users] Support on oVirt

2016-09-18 Thread Yedidyah Bar David
On Fri, Sep 16, 2016 at 11:30 AM, Johann van der Westhuizen < joh...@sharenet.co.za> wrote: > Hi, > > > > And for VNC? > Remote-viewer handles both spice and vnc. For vnc, you have other options - most vnc viewers will work, check the console.vv file for connection details if you want. Best,

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread aleksey . maksimov
Thanks Roy But if I'm going to redirect the output of the hosted-engine command to /dev/null, I can not identify the possible problem of the command :( It may be possible exclude DeprecationWarning from the code in next version 4.0.4 :) ? 18.09.2016, 09:27, "Roy Golan" : >

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Nir Soffer
On Sun, Sep 18, 2016 at 10:51 AM, Roy Golan wrote: > Alexsey thank you. > > Irit, Danken please have a look at https://bugzilla.redhat.com/sh > ow_bug.cgi?id=1377069 > This is unfortunate regression in 4.0, should be fixed soon. In meantime this can be fixed by removing

Re: [ovirt-users] Ask for functionalities

2016-09-18 Thread Yaniv Dary
Yaniv Dary Technical Product Manager Red Hat Israel Ltd. 34 Jerusalem Road Building A, 4th floor Ra'anana, Israel 4350109 Tel : +972 (9) 7692306 8272306 Email: yd...@redhat.com IRC : ydary On Sun, Sep 18, 2016 at 10:23 AM, Barak Korren wrote: > > I am not sure if

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
On 18 September 2016 at 09:48, wrote: > Thanks Roy > > > But if I'm going to redirect the output of the hosted-engine command to > /dev/null, I can not identify the possible problem of the command :( > That's only stderror. You should still see the standard input and

Re: [ovirt-users] can't import vm from KVM host

2016-09-18 Thread Shahar Havivi
On 16.09.16 10:14, Nelson Lameiras wrote: > I upgraded to oVirt 4.0.4 RC1 to test this issue (engine and hosts) and I > still have the same problem. > > Migration GUI still shows zero disks when the source VM had block disk > devices. Yes... I was verify and merged to 4.0.4 Is your source and

Re: [ovirt-users] Ask for functionalities

2016-09-18 Thread Barak Korren
> I am not sure if it is the wright place do to this. The right place would be to open an RFE in bugzilla. > - Is it possible to add a column in the hosts tab to show if a particular > host is part of the hosted-engine group. > - Is it possible to add for testing purpose when using nested-kvm, a

Re: [ovirt-users] Replace one engine host

2016-09-18 Thread Roy Golan
vm03 is missing here from the status. Can you reinstall it from UI (if you added the host vm03 then just go to Management menu and click reinstall, choose 'Deploy' Option) - After its done, when the host is activated you'll need to manually switch the host out of maintenence (we have a bug on it -

[ovirt-users] Replace one engine host

2016-09-18 Thread Davide Ferrari
Hello Still playing a bit with oVirt, my cluster is ovirt+gluster with a replica 3 glusterfs for the engine (on vm01, vm02 and vm03) and 4 hosts for the data glusterfs and running virtual machines (vm01, vm02, vm03 and vm04). Now, by mistake, I deployed hosted-engine on vm04 but I don't want to

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
Alexsey thank you. Irit, Danken please have a look at https://bugzilla.redhat.com/ show_bug.cgi?id=1377069 On 18 September 2016 at 10:49, wrote: > https://bugzilla.redhat.com/show_bug.cgi?id=1377069 > > 18.09.2016, 10:09, "Roy Golan" : > > On 18

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
Thanks Nir. He is using hosted engine which already uses vdscli On 18 September 2016 at 13:55, Nir Soffer wrote: > On Sun, Sep 18, 2016 at 10:51 AM, Roy Golan wrote: > >> Alexsey thank you. >> >> Irit, Danken please have a look at

Re: [ovirt-users] Replace one engine host

2016-09-18 Thread Davide Ferrari
Hello Roy, I forgot to mention that I already reinstalled (several times) vm03 from the gui with the deploy option checked, but there's no way it appears there. For the record vm04 was the first host deployed (from cli) after the initial vm01 installation, then vm02 and then 03. On Sep 18, 2016

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
Try to point stderr to /dev/null. For example this should work: ```bash vdsClient -s 0 list table 2> /dev/null ``` On 18 September 2016 at 08:59, wrote: > Hello oVirt guru`s ! > > Every time I call the commands: > > * hosted-engine --set-maintenance --mode=global > *

Re: [ovirt-users] Fail to upgrade to 4.1 from 4.0

2016-09-18 Thread Yedidyah Bar David
On Fri, Sep 16, 2016 at 2:53 PM, Martin Perina wrote: > Hi, > > I'm glad that you new attempt to upgrade 3.6 to 4.0 were successfull and 4.0 > is now working OK for you. > > More answers to questions inline: > > On Thu, Sep 15, 2016 at 9:50 PM, Marcin M. Jessa

Re: [ovirt-users] Replace one engine host

2016-09-18 Thread Roy Golan
Can you share the deploy logs of vm03? /var/log/ovirt-engine/host-deploy/ Is there an /etc/ovirt-hosted-engine/hosted-engine.conf at all? On 18 September 2016 at 17:28, Davide Ferrari wrote: > Hello Roy, I forgot to mention that I already reinstalled (several times) > vm03

Re: [ovirt-users] Replace one engine host

2016-09-18 Thread Davide Ferrari
Oh, thanks! You put me on the right way! Now it works: Steps that I did: - reinstall + deploy vm03 - manually set from maintenance to none on vm03 - reinstall + undeploy vm04 (I left it deployed again last time, trying to remove it) Then I found the problem: vm03 hosted-engine conf