Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
Googling on the message about br-int suggested adding that bridge to ovs: ovs-vsctl add-br br-int Then the VM is able to boot, but it fails to get network connectivity. Output in /var/log/messages: Dec 28 23:31:35 h2 ovs-vsctl: ovs|1|vsctl|INFO|Called as ovs-vsctl --timeout=5 --

[ovirt-users] New oVirt user

2016-12-28 Thread Jim Kusznir
Hello: I've been involved in virtualization from its very early days, and been running linux virtualization solutions off and on for a decade. Previously, I was always frustrated with the long feature list offered by many linux virtualization systems but with no reasonable way to manage that. It

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
From /usr/libexec/vdsm/hooks/before_device_create/ovirt_provider_ovn_hook (installed by ovirt-provider-ovn-driver rpm): BRIDGE_NAME = 'br-int' Den 2016-12-28 kl. 23:56, skrev Sverker Abrahamsson: Googling on the message about br-int suggested adding that bridge to ovs: ovs-vsctl add-br

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Edward Haas
Guys, In oVirt, when a host is added to the cluster it must have a NIC/Bond for management. Currently, it does not support anything else, unless one uses hooks to fake things (but I do not recommend it, it will just make things complex and may collide with other options). I am not sure if such a

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread TranceWorldLogic .
Hi All, I am also facing same issue (unable to change ovirtmgmt to OVS type). On git repository, I saw some commit in which added support to switch network type in host. but there is red cross across those changes. Would I get to know will this issue get solve in 4.1 release ? I tried modifying

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
I have tried various variants to create an interface with the dummy driver, currently I have an interface dummy0 which is assigned to a legacy bridge ovirtmgmt but ovirt-engine doesn't see those neither. /Sverker Den 2016-12-28 kl. 12:06, skrev Marcin Mirecki: I have an internal OVS bridge

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Marcin Mirecki
Sverker, Can you try adding a vnic named veth_* or dummy_*, (or alternatively add the name of the vnic to vdsm.config fake_nics), and setup the management network using this vnic? I suppose adding the vnic you use for connecting to the engine to fake_nics should make it visible to the engine,

Re: [ovirt-users] [ANN] oVirt 4.1.0 Second Beta Release is now available for testing

2016-12-28 Thread Nathanaël Blanchet
Hello, On my 4.1 Second Beta test platform, I meet this issue on the three hosts : VDSM gaua3 command failed: 'exceptions.AttributeError'>:'NoneType' object has no attribute 'statistics'"> Le 21/12/2016 à 16:12, Sandro Bonazzola a écrit : The oVirt Project is pleased to announce the

Re: [ovirt-users] [ANN] oVirt 4.1.0 Second Beta Release is now available for testing

2016-12-28 Thread Yaniv Bronheim
On Wed, Dec 28, 2016 at 3:43 PM, Nathanaël Blanchet wrote: > Hello, > > On my 4.1 Second Beta test platform, I meet this issue on the three hosts > : VDSM gaua3 command failed: 'exceptions.AttributeError'>:'NoneType' > object has no attribute 'statistics'"> > Hi Nathanael,

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
Hi Marcin Yes, that is my issue. I don't want to let ovirt/vdsm see eth0 nor ovsbridge0 since as soon as it sees them it messes up the network config so that the host will be unreachable. I have an internal OVS bridge called ovirtbridge which has a port with IP address, but in the host

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Marcin Mirecki
> I have an internal OVS bridge called ovirtbridge which has a port with > IP address, but in the host network settings that port is not visible. I just verified and unfortunately the virtual ports are not visible in engine to assign a network to :( I'm afraid that the engine is not ready for

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Yaniv Dary
Did you install the host side VIF driver? Yaniv Dary Technical Product Manager Red Hat Israel Ltd. 34 Jerusalem Road Building A, 4th floor Ra'anana, Israel 4350109 Tel : +972 (9) 7692306 8272306 Email: yd...@redhat.com IRC : ydary On Wed, Dec 28, 2016 at 1:39 AM, Sverker Abrahamsson <

Re: [ovirt-users] [HEADS UP] CentOS 7.3 is rolling out, need qemu-kvm-ev 2.6

2016-12-28 Thread Gianluca Cecchi
On Tue, Dec 27, 2016 at 5:58 PM, Christophe TREFOIS < christophe.tref...@uni.lu> wrote: > Hi, > > > > The package starts with q, yet you pasted only ovirt and vdsm from yum > update. > > > > Can you paste complete output of yum update? > > > > Also, the qemu package should be there when you go to

Re: [ovirt-users] problem to start vm after disk resizing

2016-12-28 Thread Fred Rolland
Hi, What version are you using? The LV should not have been changed, Were there any steps done directly on the storage not via the engine ? Please perform a getDeviceList and check the output on each of the hosts and see that the device that has been increased is reported with the right size on

Re: [ovirt-users] How to setup OVS using python SDK ?

2016-12-28 Thread Yaniv Dary
You should not use the OVS hook or native implementation. We don't feel this feature is ready and we stopped its development recently. You should look at the OVN implementation, there is a deep dive planned for this soon, please look it up. Feature Page:

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
Hi Yaniv I have installed ovirt-provider-ovn-1.0-1.fc24.noarch.rpm and ovirt-provider-ovn-driver-1.0-1.fc24.noarch.rpm /Sverker Den 2016-12-28 kl. 09:24, skrev Yaniv Dary: Did you install the host side VIF driver? Yaniv Dary Technical Product Manager Red Hat Israel Ltd. 34 Jerusalem Road

[ovirt-users] hosted_storage locked

2016-12-28 Thread Gary Pedretty
Just setup a new hosted-engine Data Center. With 3 hosts and gluster based storage domains. Used the latest installers. Everything went well, until I got the engine deployed and each host setup and went to the web interface for the first time. After adding the master storage domain, the

Re: [ovirt-users] hosted_storage locked

2016-12-28 Thread Evgenia Tokar
Hi! Can you attach the engine log from the hosted engine vm? Thanks, Jenny On Wed, Dec 28, 2016 at 10:56 AM, Gary Pedretty wrote: > Just setup a new hosted-engine Data Center. With 3 hosts and gluster > based storage domains. Used the latest installers. Everything

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Marcin Mirecki
Hi Sverker, The management network is mandatory on each host. It's used by the engine to communicate with the host. Looking at your description and the exception it looks like it is missing. The error is caused by not having any network for the host (network list retrieved in

Re: [ovirt-users] I wrote an oVirt thing

2016-12-28 Thread Juan Hernández
On 12/28/2016 06:47 PM, Nathanaël Blanchet wrote: > Hi, > > I understand that ovirt-shell is deprecated, but I need it for the moment. > > I've just done a pip install upgrade ovirt-engine-sdk-python on my > ubuntu laptop and now ovirt-shell is totally broken, saying : > ImportError: No module

Re: [ovirt-users] I wrote an oVirt thing

2016-12-28 Thread Nathanaël Blanchet
Hi, I understand that ovirt-shell is deprecated, but I need it for the moment. I've just done a pip install upgrade ovirt-engine-sdk-python on my ubuntu laptop and now ovirt-shell is totally broken, saying : ImportError: No module named ovirtsdk.xml. Can I go back to the previous SDK? How

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
Hi I first tried to set device name to dummy_0, but then ifup did not succeed in creating the device unless I first did 'ip link add dummy_0 type dummy' but then it would not suceed to establish the if on reboot. Setting fake_nics = dummy0 would not work neither, but this works: fake_nics =

Re: [ovirt-users] Issue with OVN/OVS and mandatory ovirtmgmt network

2016-12-28 Thread Sverker Abrahamsson
In addition I had to add an alias to modprobe: [root@h2 modprobe.d]# cat dummy.conf alias dummy0 dummy Den 2016-12-28 kl. 23:03, skrev Sverker Abrahamsson: Hi I first tried to set device name to dummy_0, but then ifup did not succeed in creating the device unless I first did 'ip link add