Re: [ovirt-users] Cannot Remove Disk

2018-02-08 Thread Andrej Krejcir
Do the operations work in the UI? If not, then the DB has to be changed manually: $ psql engine UPDATE image_storage_domain_map sd_map SET quota_id = NULL FROM images WHERE sd_map.image_id = images.image_guid AND images.image_group_id = 'ID_OF_THE_DISK'; On 8 February 2018 at 17:06, Donny

Re: [ovirt-users] Cannot Remove Disk

2018-02-08 Thread Donny Davis
Disabling the quota for that DC did the trick. The funny part is it was never enabled. I put it in audit mode, tried a delete, got the error... and then disabled it. Worked, I am a happy camper... Thanks guys. On Thu, Feb 8, 2018 at 11:51 AM, Andrej Krejcir wrote: > Or, it

Re: [ovirt-users] Cannot Remove Disk

2018-02-08 Thread Andrej Krejcir
Or, it should be enough to disable the quota in the data center, then change it for the disk and reenable it again. On 8 February 2018 at 17:42, Andrej Krejcir wrote: > Do the operations work in the UI? > If not, then the DB has to be changed manually: > > $ psql engine > >

Re: [ovirt-users] Cannot Remove Disk

2018-02-08 Thread Donny Davis
Any operation on the disk throws this error, to include changing the quota. On Thu, Feb 8, 2018 at 11:03 AM, Andrej Krejcir wrote: > The error message means that the data center (storage pool) where the > quota is defined is different from the data center where the disk is.

Re: [ovirt-users] Power management - oVirt 4,2

2018-02-08 Thread Martin Perina
Hi Terry, from the error message below I'd say that you are either not using correct IP address of iLO5 interface or you haven't enabled remote access to your iLO5 interface. According to [1] iLO5 should fully IPMI compatible. So are you sure that you enabled the remote access to your iLO5

Re: [ovirt-users] oVirt DR: ansible with 4.1, only a subset of storage domain replicated

2018-02-08 Thread Luca 'remix_tj' Lorenzetto
On Tue, Feb 6, 2018 at 9:33 PM, Maor Lipchuk wrote: [cut] >> What i need is that informations about vms is replicated to the remote >> site with disk. >> In an older test i had the issue that disks were replicated to remote >> site, but vm configuration not! >> I've found

Re: [ovirt-users] Maximum time node can be offline.

2018-02-08 Thread Thomas Letherby
Thanks, that answers my follow up question! :) My concern is that I could have a host off-line for a month say, is that going to cause any issues? Thanks, Thomas On Thu, Feb 8, 2018 at 3:12 AM Staniforth, Paul < p.stanifo...@leedsbeckett.ac.uk> wrote: > Hello, > >you should be

Re: [ovirt-users] Cannot Remove Disk

2018-02-08 Thread Donny Davis
So now when I create a new disk on the same domain with quota disabled, I get - Cannot edit Virtual Disk. Quota is not valid. This is a new machine, created after the above issue was solved On Thu, Feb 8, 2018 at 11:56 AM, Donny Davis wrote: > Disabling the quota for

Re: [ovirt-users] After realizing HA migration, the virtual machine can still get the virtual machine information by using the "vdsm-client host getVMList" instruction on the host before the migration

2018-02-08 Thread Petr Kotas
Hi Pym, the feature is know in testing. I am not sure when it will be released, but I hope for sooner date. Petr On Tue, Feb 6, 2018 at 12:36 PM, Pym wrote: > Thank you very much for your help, so is this patch released now? Where > can I get this patch? > > > > > > > At

Re: [ovirt-users] Clear name_server table entries

2018-02-08 Thread Carlos Rodrigues
Hi, Many thanks. Cheers On Thu, 2018-02-08 at 10:54 +0200, Michael Burman wrote: > Hi > > Yes you may delete the entries, make sure you are not deleting > name_server of hosts that already running in your engine(if you have > such). > Deleting the multiple entries in the DB + removing the

[ovirt-users] Engine AAA LDAP startTLS Protocol Issue

2018-02-08 Thread Alan Griffiths
Hi, Trying to configure Engine to authenticate against OpenLDAP and I seem to be hitting a protocol bug. Attempts to test the login during the setup fail with 2018-02-07 12:27:37,872Z WARNING Exception: The connection reader was unable to successfully complete TLS negotiation:

Re: [ovirt-users] Network configuration validation error

2018-02-08 Thread Michael Burman
Thanks, I'm not so familiar with the hosted-engine --upgrade-appliance flow, can someone from the list that is familiar with such flow assist? On Thu, Feb 8, 2018 at 12:10 PM, wrote: > Hi, > > I installed my nodes with the latest packages available in repositories. > Then

Re: [ovirt-users] oVirt CLI Question

2018-02-08 Thread Ondra Machacek
On 02/07/2018 11:28 PM, Andrei V wrote: Hi, How to force power off, and then launch (after timeout e.g. 20sec) particular VM from bash or Python script? Please check the following Python script: https://github.com/oVirt/ovirt-engine-sdk/blob/master/sdk/examples/stop_vm.py It stops the VM

[ovirt-users] ovn problem - Failed to communicate with the external provider, see log for additional details.

2018-02-08 Thread George Sitov
Hello! I have a problem wiith configure external provider. Edit config file - ovirt-provider-ovn.conf, set ssl parameters. systemctl start ovirt-provider-ovn start without problem. In external proveder in web gui i set: Provider URL: https://ovirt.mydomain.com:9696 Username: admin@internal

Re: [ovirt-users] Power management - oVirt 4,2

2018-02-08 Thread Terry hey
Dear Martin, Thank you for helping me. To answer your question, 1. Does the Test in Edit fence agent dialog work​? Ans: it shows that "Test failed: Internal JSON-RPC error" Regardless the fail result, i press "OK" to enable power management. There are four event log appear in "Events"

[ovirt-users] Spice Newb

2018-02-08 Thread Marshall Mitchell
I'm attempting to get my first install of oVirt going in full swing. I have all the hosts installed and an engine running. All is smooth. I'm not trying to connect to the Spice console with my Remote Viewer and I have no clue how to figure out what port I should be connecting too. I've been

Re: [ovirt-users] Maximum time node can be offline.

2018-02-08 Thread Staniforth, Paul
Hello, you should be able to use the power saving cluster scheduling policy. https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.2-beta/html/administration_guide/sect-Scheduling_Policies Regards, Paul S. From:

Re: [ovirt-users] Clear name_server table entries

2018-02-08 Thread Michael Burman
Hi Yes you may delete the entries, make sure you are not deleting name_server of hosts that already running in your engine(if you have such). Deleting the multiple entries in the DB + removing the duplicated name servers in /etc/resolv.conf should work around this bug, which was decided to close

Re: [ovirt-users] Network configuration validation error

2018-02-08 Thread Michael Burman
Not sure i understand from which version you trying to upgrade and what is the exact upgrade flow, if i got it correctly, it is seems that you upgraded the hosts to 4.2, but engine still 4.1? What exactly the upgrade steps, please explain the flow., what have you done after upgrading the hosts? to

Re: [ovirt-users] Spice Newb

2018-02-08 Thread Gianluca Cecchi
On Wed, Feb 7, 2018 at 4:16 AM, Marshall Mitchell < marsh...@marshallholdingco.com> wrote: > I’m attempting to get my first install of oVirt going in full swing. I > have all the hosts installed and an engine running. All is smooth. I’m not > trying to connect to the Spice console with my Remote

Re: [ovirt-users] Network configuration validation error

2018-02-08 Thread spfma . tech
Hi, I installed my nodes with the latest packages available in repositories. Then I installed the self-hosted engine on one of them, created the cluster and added the second node. When I encountered these network config problems and saw your answer, I thougt it was time to update some

Re: [ovirt-users] Network configuration validation error

2018-02-08 Thread spfma . tech
In fact I don't know what flow should be followed. I have found several documentations, but most deal with older version so I am not sure I am doing right. Is there a working documented procedure somewhere ? Le 08-Feb-2018 11:17:06 +0100, mbur...@redhat.com a crit: Thanks, I'm not so

Re: [ovirt-users] Maximum time node can be offline.

2018-02-08 Thread Gianluca Cecchi
On Fri, Feb 9, 2018 at 2:30 AM, Thomas Letherby wrote: > Thanks, that answers my follow up question! :) > > My concern is that I could have a host off-line for a month say, is that > going to cause any issues? > > Thanks, > > Thomas > > I think that if in the mean time you

Re: [ovirt-users] Cannot Remove Disk

2018-02-08 Thread Andrej Krejcir
The error message means that the data center (storage pool) where the quota is defined is different from the data center where the disk is. It seems like a bug, as it should not be possible to assign a quota to a disk from a different data center. To fix it, try setting the quota of the disk to

Re: [ovirt-users] Cannot Remove Disk

2018-02-08 Thread Donny Davis
Again, any operation on the disk throws the error. The UI, API both throw the exception On Thu, Feb 8, 2018 at 11:42 AM, Andrej Krejcir wrote: > Do the operations work in the UI? > If not, then the DB has to be changed manually: > > $ psql engine > > UPDATE

[ovirt-users] IndexError python-sdk

2018-02-08 Thread David David
Hi all. python-ovirt-engine-sdk4-4.2.2-2.el7.centos.x86_64 Issue is that I cant upload a snapshot I get IndexError when do upload_disk_snapshots.py https://github.com/oVirt/ovirt-engine-sdk/blob/master/sdk/examples/upload_disk_snapshots.py Output: Traceback (most recent call last): File

Re: [ovirt-users] Engine AAA LDAP startTLS Protocol Issue

2018-02-08 Thread Alan Griffiths
That works. Thanks. On 8 February 2018 at 12:56, Ondra Machacek wrote: > On 02/08/2018 11:04 AM, Alan Griffiths wrote: >> >> Hi, >> >> Trying to configure Engine to authenticate against OpenLDAP and I seem >> to be hitting a protocol bug. >> >> Attempts to test the login

Re: [ovirt-users] qcow2 images corruption

2018-02-08 Thread Nicolas Ecarnot
Le 08/02/2018 à 13:59, Yaniv Kaul a écrit : On Feb 7, 2018 7:08 PM, "Nicolas Ecarnot" > wrote: Hello, TL; DR : qcow2 images keep getting corrupted. Any workaround? Long version: This discussion has already been launched by

Re: [ovirt-users] Issue with 4.2.1 RC and SSL

2018-02-08 Thread Yedidyah Bar David
On Thu, Feb 8, 2018 at 2:42 PM, Petr Kotas wrote: > Hi Stack, > > have you tried it on other linux distributions? Scientific is not officially > supported. > > My guess based on your log is there are somewhere missing certificates, > maybe different path?. > You can check the

Re: [ovirt-users] Importing Libvirt Kvm Vms to oVirt Status: Released in oVirt 4.2 using ssh - Failed to communicate with the external provider

2018-02-08 Thread maoz zadok
Using the command line on the engine machine (as root) works fine. I don't use ssh key from the agent GUI but the authentication section (with root user and password), I think that it's a bug, I manage to migrate with TCP but I just want to let you know. is it possible to use ssh-key from the

Re: [ovirt-users] Importing Libvirt Kvm Vms to oVirt Status: Released in oVirt 4.2 using ssh - Failed to communicate with the external provider

2018-02-08 Thread Petr Kotas
You can generate one :). There are different guides for different platforms. The link I sent is the good start on where to put the keys and how to set it up. Petr On Thu, Feb 8, 2018 at 3:09 PM, maoz zadok wrote: > Using the command line on the engine machine (as root) works

Re: [ovirt-users] oVirt DR: ansible with 4.1, only a subset of storage domain replicated

2018-02-08 Thread Maor Lipchuk
On Thu, Feb 8, 2018 at 10:34 AM, Luca 'remix_tj' Lorenzetto < lorenzetto.l...@gmail.com> wrote: > On Tue, Feb 6, 2018 at 9:33 PM, Maor Lipchuk wrote: > [cut] > >> What i need is that informations about vms is replicated to the remote > >> site with disk. > >> In an older

Re: [ovirt-users] Importing Libvirt Kvm Vms to oVirt Status: Released in oVirt 4.2 using ssh - Failed to communicate with the external provider

2018-02-08 Thread Petr Kotas
Hi Maoz, it looks like cannot connect due to wrong setup of ssh keys. Which linux are you using? The guide for setting the ssh connection to libvirt is here: https://wiki.libvirt.org/page/SSHSetup May it helps? Petr On Wed, Feb 7, 2018 at 10:53 PM, maoz zadok wrote: >

Re: [ovirt-users] ovn problem - Failed to communicate with the external provider, see log for additional details.

2018-02-08 Thread Ilya Fedotov
Hello, Georgy Maybe, the problem have the different domain name and name your node name(local domain), and certificate note valid. with br, Ilya 2018-02-05 22:36 GMT+03:00 George Sitov : > Hello! > > I have a problem wiith configure external provider. > > Edit config

Re: [ovirt-users] Issue with 4.2.1 RC and SSL

2018-02-08 Thread Petr Kotas
Hi Stack, have you tried it on other linux distributions? Scientific is not officially supported. My guess based on your log is there are somewhere missing certificates, maybe different path?. You can check the paths by the documentation:

Re: [ovirt-users] Engine AAA LDAP startTLS Protocol Issue

2018-02-08 Thread Ondra Machacek
On 02/08/2018 11:04 AM, Alan Griffiths wrote: Hi, Trying to configure Engine to authenticate against OpenLDAP and I seem to be hitting a protocol bug. Attempts to test the login during the setup fail with 2018-02-07 12:27:37,872Z WARNING Exception: The connection reader was unable to

[ovirt-users] effectiveness of "discard=unmap"

2018-02-08 Thread Matthias Leopold
Hi, i'm sorry to bother you again with my ignorance of the DISCARD feature for block devices in general. after finding several ways to enable "discard=unmap" for oVirt disks (via standard GUI option for iSCSI disks or via "diskunmap" custom property for Cinder disks) i wanted to check in

Re: [ovirt-users] qcow2 images corruption

2018-02-08 Thread Yaniv Kaul
On Feb 7, 2018 7:08 PM, "Nicolas Ecarnot" wrote: Hello, TL; DR : qcow2 images keep getting corrupted. Any workaround? Long version: This discussion has already been launched by me on the oVirt and on qemu-block mailing list, under similar circumstances but I learned

Re: [ovirt-users] ovn problem - Failed to communicate with the external provider, see log for additional details.

2018-02-08 Thread Marcin Mirecki
Hello George, Probably your engine and provider certs do not match. The engine pki should be in: /etc/pki/ovirt-engine/certs/ The provider keys are defined in the SSL section of the config file (/etc/ovirt-provider-ovn/conf.d/...): [SSL] https-enabled=true ssl-key-file=...

[ovirt-users] Info about exporting from vSphere

2018-02-08 Thread Gianluca Cecchi
Hello, I have this ind of situation. Source env: It is vSphere 6.5 (both vCenter Server appliance and ESXi hosts) where I have an admin account to connect to, but currently only to vCenter and not to the ESXi hosts The VM to be migrated is Windows 2008 R2 SP1 with virtual hw version 8 (ESXi 5.0

Re: [ovirt-users] vdsmd fails after upgrade 4.1 -> 4.2

2018-02-08 Thread Frank Rothenstein
Thanks Thomas, it seems you were right. I followed the instructions to enable hugepages via kernel command line and after reboot vdsmd starts correctly. (I went back to 4.1.9 in between, added the kernel command line and upgraded to 4.2) The docs/release notes should mention it - or did I miss

[ovirt-users] Cannot Remove Disk

2018-02-08 Thread Donny Davis
Ovirt 4.2 has been humming away quite nicely for me in the last few months, and now I am hitting an issue when try to touch any api call that has to do with a specific disk. This disk resides on a hyperconverged DC, and none of the other disks seem to be affected. Here is the error thrown.

Re: [ovirt-users] Info about exporting from vSphere

2018-02-08 Thread Gianluca Cecchi
On Thu, Feb 8, 2018 at 4:28 PM, Luca 'remix_tj' Lorenzetto < lorenzetto.l...@gmail.com> wrote: > On Thu, Feb 8, 2018 at 4:20 PM, Gianluca Cecchi > wrote: > > Hello, > > I have this ind of situation. > [cut] > > I see in my oVirt 4.1.9 that I can import from: > > > > 1)

Re: [ovirt-users] Cannot Remove Disk

2018-02-08 Thread Martin Sivak
Andrej, this might be related to the recent fixes of yours in that area. Can you take a look please? Best regards Martin Sivak On Thu, Feb 8, 2018 at 4:18 PM, Donny Davis wrote: > Ovirt 4.2 has been humming away quite nicely for me in the last few months, > and now I am

Re: [ovirt-users] Info about exporting from vSphere

2018-02-08 Thread Luca 'remix_tj' Lorenzetto
On Thu, Feb 8, 2018 at 4:34 PM, Gianluca Cecchi wrote: > > Thanks Luca. > I asked because I see this inside the gui. > https://drive.google.com/file/d/12vI9RUq9t4J--jlkqSxvG2jqylGfD2sP/view?usp=sharing > > Probably you do it via api and you don't need to provide ESXi