[ovirt-users] VMs stuck in migrating state

2018-02-26 Thread nicolas
Hi, We're running 4.1.9 and during the weekend we had a storage issue that seemed to leave some hosts in an strange state. One of the hosts has almost all VMs migrating (although it seems to not actually being migrating them) and the migration state cannot be cancelled. When clicking on one

Re: [ovirt-users] Power Management - Supermicro SuperBlade

2018-02-26 Thread Martin Perina
On Sun, Feb 25, 2018 at 7:53 AM, Scott Harvanek wrote: > Hoping someone can help here, I've looked and can't find any examples on > this. > > I've got some SuperBlade chassis and the blades are managed via the > chassis controller. What is the proper way to configure

Re: [ovirt-users] Power management - oVirt 4,2

2018-02-26 Thread Martin Perina
On Fri, Feb 23, 2018 at 11:34 AM, Terry hey wrote: > Dear Martin, > I am very sorry that i reply you so late. > Do you mean that 4.2 can support ilo5 by selecting the option "ilo4" in > power management? > ​Yes ​ > "from the error message below I'd say that you are

Re: [ovirt-users] Hosted Engine VM not imported

2018-02-26 Thread Alessandro De Salvo
Hi, after checking the engine.log I see a bunch of error like this too: 2018-02-26 03:22:06,806+01 INFO [org.ovirt.engine.core.vdsbroker.vdsbroker.GetVolumeInfoVDSCommand] (EE-ManagedThreadFactory-engine-Thread-97153) [796a8bc5] HostName = atlas-svc-18 2018-02-26 03:22:06,806+01 ERROR

Re: [ovirt-users] Hosted Engine VM not imported

2018-02-26 Thread Simone Tiraboschi
On Sat, Feb 24, 2018 at 2:32 PM, Alessandro De Salvo < alessandro.desa...@roma1.infn.it> wrote: > Hi, > > I have just migrated my dev cluster to the latest master, reinstalling the > engine VM and reimporting from a previous backup. I'm trying with >

Re: [ovirt-users] Hosted Engine VM not imported

2018-02-26 Thread Alessandro De Salvo
Ciao Simone, many thanks. So, how are we supposed to use those hooks? Should we just create a file /usr/share/ovirt-hosted-engine-setup/ansible/hooks/enginevm_before_engine_setup/enginevm_before_engine_setup.yml with the instructions to restore? Do you have an example for doing that? For

[ovirt-users] Start VM automatically

2018-02-26 Thread Fabrice SOLER
Hello, My node (IP ovirtmgmt) is behind a routeur that is running on the hypervisor (the node itself). So, I need that the VM (routeur) start automatically after the node start. The ovirt engine is running on another infrastructure and the version is 4.2.0. The node is also in this version.

Re: [ovirt-users] API endpoint for a VM to fetch metadata about itself

2018-02-26 Thread Geoff Sweet
OK, that's a great place for me to start. However the problem is that all my post-install tooling is now running on a VM that knows nothing about itself (having been installed via pxe and kickstart) like it's {vm_id}. Can the API be used to query for a VM and it's attributes based on something

Re: [ovirt-users] Start VM automatically

2018-02-26 Thread Fabrice SOLER
Hi Hanson, Thank you for your answer, but the routeur is a VM. So I need that this VM start without the engine. It has to start when the node start (after a power failure). Only when the routeur will be up, I will be able to manage the node and the VMs. Do you think there a solution ?

Re: [ovirt-users] Start VM automatically

2018-02-26 Thread Christopher Cox
On 02/26/2018 05:33 PM, Fabrice SOLER wrote: Hi Hanson, Thank you for your answer, but the routeur is a VM. So I need that this VM start without the engine. It has to start when the node start (after a power failure). Only when the routeur will be up, I will be able to manage the node and

[ovirt-users] Q: VM disk speed penalty NFS vs Local data center storage

2018-02-26 Thread Andrei Verovski
Hi, Since oVirt doesn’t support more then 1 host in data center with local storage domain as described here: http://lists.ovirt.org/pipermail/users/2018-January/086118.html I have to setup NFS server on node with VMs (on same

Re: [ovirt-users] Can't move/copy VM disks between Data Centers

2018-02-26 Thread Andrei Verovski
Hi, Thanks for clarification. I’m using 4.2. Anyway, I have to define another data center with shared storage domain (since data center with local storage domain can have only 1 host), and the do what you have described. Is it possible to copy VM disks from 1 data center #1 local storage

Re: [ovirt-users] Q: VM disk speed penalty NFS vs Local data center storage

2018-02-26 Thread Yaniv Kaul
On Mon, Feb 26, 2018 at 1:30 PM, Andrei Verovski wrote: > Hi, > > Since oVirt doesn’t support more then 1 host in data center with local > storage domain as described here: > http://lists.ovirt.org/pipermail/users/2018-January/086118.html > > I have to setup NFS server on

Re: [ovirt-users] VMs with multiple vdisks don't migrate

2018-02-26 Thread fsoyer
Hi, I don't beleive that this is relatd to a host, tests have been done from victor source to ginger dest and ginger to victor. I don't see problems on storage (gluster 3.12 native managed by ovirt), when VMs with a uniq disk from 20 to 250G migrate without error in some seconds and with no

Re: [ovirt-users] Can't move/copy VM disks between Data Centers

2018-02-26 Thread Fred Rolland
Hi, Which version are you using? in 4.1 , the support of adding shared storage to local DC was added [1]. You can copy/move disks to the shared storage domain, then detach the SD and attach to another DC. In any case, you wont be able to live migrate VMs from the local DC, it is not supported.

[ovirt-users] Before migrating to Ovirt

2018-02-26 Thread Tal Bar-Or
Hello Ovirt users, Currently we haveing 4 Xen pools in our organization each pool have 8 servers. Due to new 7.3 version change ,we plan to migrate our upcoming 5th pool to Ovirt, the decision to do POC migration to Ovirt is from lots of Xen users that suggested Ovirt migration better and mature

Re: [ovirt-users] VM is locked, servlet , and SpiceVersion.txt problem

2018-02-26 Thread Terry hey
Thank for your reply. OK, then do you know how to delete the lock virtual machine? Because i cannot find the locked VM by using "./unlock_entity.sh". I cannot do anything on it. Thank you. 2018-02-23 20:36 GMT+08:00 Tomas Jelinek : > > > On Fri, Feb 23, 2018 at 11:31 AM,

Re: [ovirt-users] oVirt 4.2 WebUI Plugin API Docs?

2018-02-26 Thread Zip
Thanks Alexander, This works: api.addMainTab('oVirtTab', 'ovirt-tab', ‘http://www.something.com', {priority: 5}); Can you advise how to get the api.addSubTab to work? api.addSubTab('ovirt-tab', 'Test 123', 'test-123', '#’); I tried the above and many other combinations, no errors, just doesnt

Re: [ovirt-users] oVirt 4.2 WebUI Plugin API Docs?

2018-02-26 Thread Alexander Wels
On Monday, February 26, 2018 9:50:37 AM EST Zip wrote: > Thanks Alexander, > > This works: > > api.addMainTab('oVirtTab', 'ovirt-tab', ‘http://www.something.com', > {priority: 5}); > > Can you advise how to get the api.addSubTab to work? > > api.addSubTab('ovirt-tab', 'Test 123', 'test-123',

Re: [ovirt-users] Before migrating to Ovirt

2018-02-26 Thread Dan Yasny
On Fri, Feb 23, 2018 at 11:33 AM, Tal Bar-Or wrote: > Hello Ovirt users, > > Currently we haveing 4 Xen pools in our organization each pool have 8 > servers. > Due to new 7.3 version change ,we plan to migrate our upcoming 5th pool to > Ovirt, the decision to do POC migration

Re: [ovirt-users] Before migrating to Ovirt

2018-02-26 Thread Yedidyah Bar David
On Fri, Feb 23, 2018 at 6:33 PM, Tal Bar-Or wrote: > Hello Ovirt users, > > Currently we haveing 4 Xen pools in our organization each pool have 8 > servers. > Due to new 7.3 version change ,we plan to migrate our upcoming 5th pool to > Ovirt, the decision to do POC migration to

Re: [ovirt-users] Network and disk inactive after 4.2.1 upgrade

2018-02-26 Thread Francesco Romani
On 02/13/2018 04:05 PM, Chris Adams wrote: > I upgraded my dev cluster from 4.2.0 to 4.2.1 yesterday, and I noticed > that all my VMs show the network interfaces unplugged and disks inactive > (despite the VMs being up and running just fine). This includes the > hosted engine. > > I had not

Re: [ovirt-users] Hosts firewall custom setup

2018-02-26 Thread Martin Perina
On Mon, Feb 26, 2018 at 2:49 PM, Nicolas Ecarnot wrote: > Le 26/02/2018 à 14:03, Yedidyah Bar David a écrit : > >> On Mon, Feb 26, 2018 at 2:01 PM, Nicolas Ecarnot >> wrote: >> >>> Hello, >>> >>> On oVirt 4.2.1.7, I'm trying to setup custom iptables

Re: [ovirt-users] Ghost Snapshot Disk

2018-02-26 Thread Lionel Caignec
Ok so i reply myself, Version is 4.1.7.6-1 I just delete manually a snapshot previously created. But this is an io intensive vm, whit big disk (2,5To, and 5To). For the log, i cannot paste all my log on public list security reason, i will send you full in private. Here is an extract relevant

Re: [ovirt-users] Hosts firewall custom setup

2018-02-26 Thread Nicolas Ecarnot
Le 26/02/2018 à 14:03, Yedidyah Bar David a écrit : On Mon, Feb 26, 2018 at 2:01 PM, Nicolas Ecarnot wrote: Hello, On oVirt 4.2.1.7, I'm trying to setup custom iptables rules as I'm doing since years with engine-config --set IPTablesConfigSiteCustom="blah blah blah". On

Re: [ovirt-users] Hosts firewall custom setup

2018-02-26 Thread Yedidyah Bar David
On Mon, Feb 26, 2018 at 3:49 PM, Nicolas Ecarnot wrote: > Le 26/02/2018 à 14:03, Yedidyah Bar David a écrit : >> >> On Mon, Feb 26, 2018 at 2:01 PM, Nicolas Ecarnot >> wrote: >>> >>> Hello, >>> >>> On oVirt 4.2.1.7, I'm trying to setup custom iptables

Re: [ovirt-users] oVirt 4.2 WebUI Plugin API Docs?

2018-02-26 Thread Alexander Wels
On Sunday, February 25, 2018 1:11:08 AM EST Zip wrote: > Hi Alexander, > > If I try the following: > > > > > > var api = parent.pluginApi('HelloWorld'); > api.register({ > UiInit: function () { > api.addMainTab('FooTab','xtab123','

Re: [ovirt-users] VMs with multiple vdisks don't migrate

2018-02-26 Thread Milan Zamazal
"fsoyer" writes: > I don't beleive that this is relatd to a host, tests have been done from > victor > source to ginger dest and ginger to victor. I don't see problems on storage > (gluster 3.12 native managed by ovirt), when VMs with a uniq disk from 20 to > 250G migrate

[ovirt-users] Hosts firewall custom setup

2018-02-26 Thread Nicolas Ecarnot
Hello, On oVirt 4.2.1.7, I'm trying to setup custom iptables rules as I'm doing since years with engine-config --set IPTablesConfigSiteCustom="blah blah blah". On my hosts, I can see in my hosts that /etc/sysconfig/iptables does contain the correct custom rules I added, but when manually

Re: [ovirt-users] Network and disk inactive after 4.2.1 upgrade

2018-02-26 Thread Chris Adams
Once upon a time, Arsène Gschwind said: > After upgrading from 4.1.9 to 4.2.1 I had the same problem. > Had to reactivate network and disk on all VMs. Do you use the hosted engine? If so, how did you fix it? -- Chris Adams

Re: [ovirt-users] Ghost Snapshot Disk

2018-02-26 Thread Shani Leviim
Hi Lionel, The error message you've mentioned sounds like a UI error. Can you please attach your ui log? Also, on the data from 'images' table you've uploaded, can you describe which line is the relevant disk? Finally (for now), in case the snapshot was deleted, can you please validate it by

Re: [ovirt-users] Ghost Snapshot Disk

2018-02-26 Thread Lionel Caignec
Hi 1) this is error message from ui.log 2018-02-26 13:44:10,001+01 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-3) [] Permutation name: 8C01181C3B121D0AAE1312275CC96415 2018-02-26 13:44:10,001+01 ERROR

Re: [ovirt-users] Ghost Snapshot Disk

2018-02-26 Thread Shani Leviim
Hi, What is your engine version, please? I'm trying to reproduce your steps, for understanding better was is the cause for that error. Therefore, a full engine log is needed. Can you please attach it? Thanks, *Shani Leviim* On Mon, Feb 26, 2018 at 2:48 PM, Lionel Caignec

Re: [ovirt-users] Hosts firewall custom setup

2018-02-26 Thread Yedidyah Bar David
On Mon, Feb 26, 2018 at 2:01 PM, Nicolas Ecarnot wrote: > Hello, > > On oVirt 4.2.1.7, I'm trying to setup custom iptables rules as I'm doing > since years with engine-config --set IPTablesConfigSiteCustom="blah blah > blah". > > On my hosts, I can see in my hosts that

[ovirt-users] ovirt 4.1 - skylake - no avx512 support in virtual machines

2018-02-26 Thread Marco Lorenzo Crociani
Hi, I can't access avx512* instruction set from virtual machines. I have made a one server compute cluster to test new hardware: oVirt 4.1.9 CentOS 7 Cluster CPU Type: Intel Skylake Family Compatibility Version: 4.1 HOST: CPU Model Name:Intel(R) Xeon(R) Platinum 8180 CPU @ 2.50GHz Family: