Re: [ovirt-users] vdsm hook noipspoof on interface level

2018-04-13 Thread Eitan Raviv
You might find the following useful: https://ovirt.org/develop/release-management/features/network/networkfilterparameters/ HTH On Thu, Apr 12, 2018, 14:52 Peter Hudec wrote: > Hi, > > I would like to restrict of usage IP address on VMs. Thos could be > achied by usinf

[ovirt-users] Snapshots from User Portal in ovirt 4.2?

2018-04-13 Thread Brian Chow
After upgrading from 4.1 to 4.2, we can no longer find the snapshot functionality in the User Portal -- the documentation is still referencing the 4.1 UI. Was this removed from the user portal? Moved to a different area? Are the required permissions different from 4.1? Thanks for the help!

Re: [ovirt-users] ?= vdsClient is removed and replaced by vdsm-clien

2018-04-13 Thread Arik Hadas
On Fri, Apr 13, 2018 at 6:54 PM, fsoyer wrote: > Hi, > This task is listed (since 2 days) in the GUI / up right "tasks" icon. It > is visibly freezed as no OVA file has been created, but no errors in GUI, > just... it runs. Or : it loops :) > This (test) vm is one on which I

[ovirt-users] Add nodes to single-node hyperconverged cluster

2018-04-13 Thread Joe DiTommasso
Hi, I'm currently running an out-of-date (3.6) 3-node oVirt cluster, using NFS storage. I'd like to upgrade to the latest release and move to a hyperconverged setup, but I've only got the three hosts to play with. I'm currently thinking of pulling one node from my current cluster, rebuilding it to

Re: [ovirt-users] How to recreate lease file for hosted engine

2018-04-13 Thread Ling Ho
This is what I ended up doing and got my hosted-engine VM to come back up: sanlock direct init -r

Re: [ovirt-users] I broke my ovirt real good....

2018-04-13 Thread ~Stack~
On 04/13/2018 07:16 AM, Alexander Wels wrote: > On Thursday, April 12, 2018 6:26:07 PM EDT ~Stack~ wrote: >> Greetings, >> >> So I did a over-confident-admin-makes-rookie-mistake. I changed a bunch >> of things all back-to-back and thus don't actually know what broke. :-D >> >> The only two real

Re: [ovirt-users] [ANN] oVirt 4.2.3 First Release Candidate is now available

2018-04-13 Thread Michal Skrivanek
> On 12 Apr 2018, at 16:21, Lev Veyde wrote: > > The oVirt Project is pleased to announce the availability of the oVirt 4.2.3 > First Release Candidate, as of April 12th, 2018 > > This update is a release candidate of the third in a series of stabilization > updates to

Re: [ovirt-users] I broke my ovirt real good....

2018-04-13 Thread Michael Mortensen (MCMR)
Hi Stack, Do you use FQDN? Did you perhaps hit this one https://www.ovirt.org/blog/2016/05/modify-ifcfg-files/ ? The discussion in this bug report may be of assistance in that case: https://bugzilla.redhat.com/show_bug.cgi?id=1252534 If you've stored the VM disks and templates and whatnot on

Re: [ovirt-users] ?==?utf-8?q? vdsClient is removed and replaced by vdsm-client

2018-04-13 Thread fsoyer
Hi all, I can't find any exhaustive doc for new vdsm-client. My problem actually is a task (export a vm to OVA) blocked. I found that I can interact with vdsm-client Task getInfo taskID=, and replace getInfo by "stop", BUT : how can I find this UUID ??? Old "vdsClient -s 0 getAllTasksStatuses"

Re: [ovirt-users] Recovering oVirt-Engine with a backup before upgrading to 4.2

2018-04-13 Thread Sven Achtelik
Hi All, I got my stuff up and running again. I works like described in the manual and I used some extra hardware to jumpstart this. I'm now back on my hosted Engine 4.1.9 with 3 Hosts running it. The Engine is running on the appliance that is pulled by the deployment tool and after having

[ovirt-users] Hosted Engine won't start, how to debug?

2018-04-13 Thread Thomas Klute
Dear oVirt Team, after trying to reboot a hosted engine setup on oVirt 4.2 the VM won't come up anymore. The qemu-kvm process is there but we're unable to access the VM using - the serial console (simply does not show anything, does not react to characters typed) - VNC / Spice because the hosted

Re: [ovirt-users] OVN between two different datacenters with different networks

2018-04-13 Thread Vasily Lamykin
Very big thanks, In your solution I want fix only one... " tunneling-IP is IP-of-host-of-engine-2" For me - works variant is IP of host2 , which can provides access to engine1 Василий Ламыкин Старший инженер по эксплуатации сетевых сервисов Центра управления сетью Столица Единый Центр управления

Re: [ovirt-users] I broke my ovirt real good....

2018-04-13 Thread ~Stack~
On 04/13/2018 03:02 AM, Michael Mortensen (MCMR) wrote: > Hi Stack, > > Do you use FQDN? Did you perhaps hit this one > https://www.ovirt.org/blog/2016/05/modify-ifcfg-files/ ? The discussion in > this bug report may be of assistance in that case: >

Re: [ovirt-users] Engine reports

2018-04-13 Thread Peter Hudec
thanks, problem was with the selinux. I applied the permission on the /var/lib/elasticsearch once again. Deployment is done ;) Right now mi browser is complaining about certificate on SSO. When I try to reach https://kibana. I'm redirected to SSO https:// :8443/oauth/authorize?... An error

Re: [ovirt-users] Hosted Engine won't start, how to debug?

2018-04-13 Thread Thomas Klute
Dear Martin, yes, that worked. Thank you so much!! We were able to see that the latest kernel update failed and did not create the initramfs file and thus the boot process failed with a kernel panic. Debugging this problem took us many hours... It felt so complicated to connect a vnc to this vm

Re: [ovirt-users] Hosted Engine won't start, how to debug?

2018-04-13 Thread Martin Sivak
Hi, the serial console will show output if the kernel knows to use it. The VNC approach is also possible and I believe we already have a graphical device present. What you are looking for is probably this (VNC method is described there):

Re: [ovirt-users] Hosted Engine won't start, how to debug?

2018-04-13 Thread Thomas Klute
Dear Martin, thanks for the feedback. We already read this and tried it. It seems to me that the graphics device was removed from the hosted engine by some ovirt release. If I try to set a console password I see this message: hosted-engine --add-console-password Enter password: no graphics

Re: [ovirt-users] ?==?utf-8?q? vdsClient is removed and replaced by vdsm-client

2018-04-13 Thread Michal Skrivanek
> On 13 Apr 2018, at 10:14, fsoyer wrote: > > Hi all, > I can't find any exhaustive doc for new vdsm-client. My problem actually is a > task (export a vm to OVA) blocked. if you want to interact with that action it would always be best to start with engine’s REST API

Re: [ovirt-users] I broke my ovirt real good....

2018-04-13 Thread Alexander Wels
On Thursday, April 12, 2018 6:26:07 PM EDT ~Stack~ wrote: > Greetings, > > So I did a over-confident-admin-makes-rookie-mistake. I changed a bunch > of things all back-to-back and thus don't actually know what broke. :-D > > The only two real "big" changes were: > * Upgrade from 4.2.1 to 4.2.2 >

Re: [ovirt-users] WARN VdsBroker

2018-04-13 Thread Roy Golan
Every VDSM(host) reports the application list per installed vm, every time the engine asks for the vm statistics. The list probably contains an illegal value or we fail to convert it , anyhow it doesn't interfere with the rest of the monitoring process. Please share the output of this command

[ovirt-users] WARN VdsBroker

2018-04-13 Thread Vrgotic, Marko
Hi oVirt community, I have just upgraded from 4.2.0 to 4.2.2 version. I noticed a ton of : 2018-04-13 11:13:48,857+02 WARN [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (EE-ManagedThreadFactory-engineScheduled-Thread-84) [] Failed to convert app:

Re: [ovirt-users] Hosted Engine won't start, how to debug?

2018-04-13 Thread Martin Sivak
You need to be in global maintenance, but I think you already know that. Then try updating the vm.conf like you already did and add this line: devices={device:vnc,type:graphics,deviceId:f1d0394e-b077-4ea6-99e5-b9b6b8fe073c,address:None} Then restart the VM using hosted-engine commands and try

Re: [ovirt-users] ?==?utf-8?q? vdsClient is removed and replaced by vdsm-client

2018-04-13 Thread Arik Hadas
On Fri, Apr 13, 2018 at 11:14 AM, fsoyer wrote: > Hi all, > I can't find any exhaustive doc for new vdsm-client. My problem actually > is a task (export a vm to OVA) blocked. > I'm afraid you won't find any task in VDSM for 'export a VM to OVA'. Expoting a VM to OVA is

Re: [ovirt-users] Engine reports

2018-04-13 Thread Rich Megginson
On 04/13/2018 05:12 AM, Peter Hudec wrote: thanks, problem was with the selinux. I applied the permission on the /var/lib/elasticsearch once again. Deployment is done ;) Excellent Right now mi browser is complaining about certificate on SSO. When I try to reach https://kibana. I'm

[ovirt-users] oVirt changing IPs of hosts and engine

2018-04-13 Thread Alex K
Hi all! I wanted to check from your experience what would be the best approach to change the IP addresses of the engine and hosts on the management network. I have a 3 node cluster (in production) on ovirt 4.1 with engine and hosts resolving through /etc/hosts files on hosts and engine. The hosts

Re: [ovirt-users] ?==?utf-8?q? ?==?utf-8?q? ?= vdsClient is removed and replaced by vdsm-clien

2018-04-13 Thread fsoyer
Ok I see, thank you.  vdsm-client Host getAllTasksStatuses works on the SPM. But vdsm-client Task getInfo TaskID=TaskID=55cbec7f-e7dc-4431-bce9-8ec1d61a7feb returns : vdsm-client: Command Task.getInfo with args {'TaskID': '55cbec7f-e7dc-4431-bce9-8ec1d61a7feb'} failed: (code=-32603,

Re: [ovirt-users] ?==?utf-8?q? ?==?utf-8?q? ?= vdsClient is removed and replaced by vdsm-clien

2018-04-13 Thread fsoyer
Hi, This task is listed (since 2 days) in the GUI / up right "tasks" icon. It is visibly freezed as no OVA file has been created, but no errors in GUI, just... it runs. Or : it loops :) This (test) vm is one on which I have extended the disk (50 -> 100G). Before being stopped and trying to

[ovirt-users] How to recreate lease file for hosted engine

2018-04-13 Thread Ling Ho
Hello, I upgraded ovirt-engine to 4.2.2 yesterday, and tried moving hosted engine disk to a different domain. I thought the move was sucessful and went and shut down my old domain NFS server. After that my hosted engine stopped. Now all NFS is back up, I find that my hosted engine storage