[ovirt-users] Re: External ceph storage

2018-05-29 Thread Jeff Bailey
While it's certainly not ideal, of the available options I prefer cephfs. You get full functionality unlike going through cinder and I wouldn't trust the new iscsi gateway functionality for any kind of redundant gateway usage yet. Direct native rbd access would certainly be preferred but

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Jim Kusznir
I see in messages on ovirt3 (my 3rd machine, the one upgraded to 4.2): May 29 11:54:41 ovirt3 ovs-vsctl: ovs|1|db_ctl_base|ERR|unix:/var/run/openvswitch/db.sock: database connection failed (No such file or directory) May 29 11:54:51 ovirt3 ovs-vsctl:

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Jim Kusznir
On one ovirt server, I'm now seeing these messages: [56474.239725] blk_update_request: 63 callbacks suppressed [56474.239732] blk_update_request: I/O error, dev dm-2, sector 0 [56474.240602] blk_update_request: I/O error, dev dm-2, sector 3905945472 [56474.241346] blk_update_request: I/O error,

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Sahina Bose
Do you see errors reported in the mount logs for the volume? If so, could you attach the logs? Any issues with your underlying disks. Can you also attach output of volume profiling? On Wed, May 30, 2018 at 12:13 AM, Jim Kusznir wrote: > Ok, things have gotten MUCH worse this morning. I'm

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Jim Kusznir
Ok, things have gotten MUCH worse this morning. I'm getting random errors from VMs, right now, about a third of my VMs have been paused due to storage issues, and most of the remaining VMs are not performing well. At this point, I am in full EMERGENCY mode, as my production services are now

[ovirt-users] Re: [Qemu-block] Libvirt ERROR cannot access backing file after importing VM from OpenStack

2018-05-29 Thread Eric Blake
On 05/28/2018 05:27 AM, Arik Hadas wrote: [Answering before reading the entire thread; apologies if I'm repeating things, or if I have to chime in again at other spots] Let me demonstrate briefly the flow for OVA: Let's say that we have a VM that is based on a template and has one disk and

[ovirt-users] Unable to login after upgrade

2018-05-29 Thread Michael Watters
I recently upgraded one of our ovirt engines from 4.1 to the 4.2.3 release and the admin account is no longer able to login.  After entering the user name and password I receive a message that states "The user admin@internal is not authorized to perform login". Is there a way to resolve this? 

[ovirt-users] Re: Fwd: FreeBSD after 10.3 could not boot (Freeze)

2018-05-29 Thread Karli Sjöberg
On Wed, 2018-05-30 at 01:09 +0800, Paul.LKW wrote: > Hi Alexandr Krivulya: > Tried all configuration combination also could not boot still hang on > the screen captured ! I just tried it as well, works fine, no problemo. My VM has: 1 vCPU 1GB vRAM 8GB vHDD In a Nehalem cluster.

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Jim Kusznir
Thank you for your response. I have 4 gluster volumes. 3 are replica 2 + arbitrator. replica bricks are on ovirt1 and ovirt2, arbitrator on ovirt3. The 4th volume is replica 3, with a brick on all three ovirt machines. The first 3 volumes are on an SSD disk; the 4th is on a Seagate SSHD (same

[ovirt-users] Re: Unable to login after upgrade

2018-05-29 Thread Alex K
Are you using engine IP to login? Perhaps the sso default file was overwritten? Alex On Tue, May 29, 2018, 20:32 Michael Watters wrote: > I recently upgraded one of our ovirt engines from 4.1 to the 4.2.3 > release and the admin account is no longer able to login. After > entering the user

[ovirt-users] Re: Libvirt ERROR cannot access backing file after importing VM from OpenStack

2018-05-29 Thread Nir Soffer
On Mon, May 28, 2018 at 2:38 PM Kevin Wolf wrote: > Am 28.05.2018 um 12:27 hat Arik Hadas geschrieben: > > On Mon, May 28, 2018 at 11:25 AM, Kevin Wolf wrote: > > > > > [ Adding qemu-block ] > > > > > > Am 27.05.2018 um 10:36 hat Arik Hadas geschrieben: > > > > On Thu, May 24, 2018 at 6:13 PM,

[ovirt-users] Re: [Qemu-block] Libvirt ERROR cannot access backing file after importing VM from OpenStack

2018-05-29 Thread Nir Soffer
On Tue, May 29, 2018 at 10:43 PM Eric Blake wrote: > On 05/28/2018 05:27 AM, Arik Hadas wrote: > ... > > Few months ago people from the oVirt-storage team checked the qemu > toolset > > and replied that this capability is not yet provided, therefore we > > implemented the workaround described

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Jim Kusznir
I think this is the profile information for one of the volumes that lives on the SSDs and is fully operational with no down/problem disks: [root@ovirt2 yum.repos.d]# gluster volume profile data info Brick: ovirt2.nwfiber.com:/gluster/brick2/data --

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Alex K
I would check disks status and accessibility of mount points where your gluster volumes reside. On Tue, May 29, 2018, 22:28 Jim Kusznir wrote: > On one ovirt server, I'm now seeing these messages: > [56474.239725] blk_update_request: 63 callbacks suppressed > [56474.239732] blk_update_request:

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Jim Kusznir
Due to the cluster spiraling downward and increasing customer complaints, I went ahead and finished the upgrade of the nodes to ovirt 4.2 and gluster 3.12. It didn't seem to help at all. I DO have one brick down on ONE of my 4 gluster filesystems/exports/whatever. The other 3 are fully

[ovirt-users] Re: [Qemu-block] Libvirt ERROR cannot access backing file after importing VM from OpenStack

2018-05-29 Thread Eric Blake
On 05/29/2018 04:11 PM, Nir Soffer wrote: I think real streaming is unlikely to happen because most image formats that QEMU supports aren't made that way. If there is a compelling reason, we can consider it, but it would work only with very few target formats and as such would have to be

[ovirt-users] Re: Gluster quorum

2018-05-29 Thread Jim Kusznir
I had the same problem when I upgraded to 4.2. I found that if I went to the brick in the UI and selected it, there was a "start" button in the upper-right of the gui. clicking that resolved this problem a few minutes later. I had to repeat for each volume that showed a brick down for which

[ovirt-users] Re: Ovirt 4.2.4 - Trouble installing additional self hosted engine hosts

2018-05-29 Thread Simone Tiraboschi
On Tue, May 29, 2018 at 9:32 AM, Maton, Brett wrote: > Hi Ido, > > It appears that I have the latest packages installed, any more logs that > might be useful ? > A quick workaround requires you to rename /etc/yum/pluginconf.d/vdsm.conf /usr/share/yum-plugins/vdsm.py* to

[ovirt-users] Re: Ovirt 4.2.4 - Trouble installing additional self hosted engine hosts

2018-05-29 Thread Maton, Brett
Hi Ido, It appears that I have the latest packages installed, any more logs that might be useful ? All physical hosts: yum clean all yum upgrade No packages marked for update rpm -qf /usr/share/yum-plugins/vdsm.pyc vdsm-4.20.28-1.el7.x86_64 HE: yum clean all yum upgrade No packages

[ovirt-users] Ovirt 4.2.4 - Trouble installing additional self hosted engine hosts

2018-05-29 Thread Maton, Brett
Adding regular, non SHE hosts works fine, however I can't seem to add Self Hosted Engine to additional physical hosts. I think this is the problem, but I don't know what the solution is: 2018-05-29 08:00:52,502+0100 ERROR otopi.context context._executeMethod:152 Failed to execute stage 'Misc

[ovirt-users] Re: Ovirt 4.2.4 - Trouble installing additional self hosted engine hosts

2018-05-29 Thread Ido Rosenzwig
Dear Brett, The Issue was fixed yesterday. check the bug page: https://bugzilla.redhat.com/show_bug.cgi?id=1583045 Try to do 'yum update' on the engine and on the additional hosts. Best regards, Ido Rosenzwig On Tue, May 29, 2018 at 10:10 AM, Maton, Brett wrote: > Adding regular, non SHE

[ovirt-users] Re: [ovirt-announce] CVE-2018-3639 - Important - oVirt - Speculative Store Bypass

2018-05-29 Thread Nathanaël Blanchet
I'm not able to do such a thing but it is quite good to know it is feasible! Was nice to meet you at San Francisco summit :) Le 28/05/2018 à 19:56, Yaniv Kaul a écrit : On Mon, May 28, 2018 at 3:40 PM, Nathanaël Blanchet > wrote: XP has reached is end of life

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Jim Kusznir
I also finally found the following in my system log on one server: [10679.524491] INFO: task glusterclogro:14933 blocked for more than 120 seconds. [10679.525826] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message. [10679.527144] glusterclogro D 97209832bf40 0

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Jim Kusznir
Well, things went from bad to very, very bad It appears that during one of the 2 minute lockups, the fencing agents decided that another node in the cluster was down. As a result, 2 of the 3 nodes were simultaneously reset with fencing agent reboot. After the nodes came back up, the engine

[ovirt-users] Does ovirt engine itself support high scalability (such as Load Balancing)?

2018-05-29 Thread simiam
Hi, Does ovirt engine itself support high scalability (such as Load Balancing)? It means that i can add one or many engine servers to balance the load easily. Thanks. ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to

[ovirt-users] Re: Does ovirt engine itself support high scalability (such as Load Balancing)?

2018-05-29 Thread simiam
If it supports, how can i enable the feature? Thanks. ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement: https://www.ovirt.org/site/privacy-policy/ oVirt Code of Conduct:

[ovirt-users] Re: Fwd: FreeBSD after 10.3 could not boot (Freeze)

2018-05-29 Thread Karli Sjöberg
Paul, "reply all" next timeDen 30 maj 2018 05:32 skrev "Paul.LKW" :Hi  Karli Sjöberg/  Alexandr Krivulya So the image says the virtual hardware is about the same, except for Cluster type. I've had issues before getting FreeBSD running in oVirt with Opteron. Since i then had two clusters: one

[ovirt-users] Re: Gluster problems, cluster performance issues

2018-05-29 Thread Krutika Dhananjay
Adding Ravi to look into the heal issue. As for the fsync hang and subsequent IO errors, it seems a lot like https://bugzilla.redhat.com/show_bug.cgi?id=1497156 and Paolo Bonzini from qemu had pointed out that this would be fixed by the following commit: commit

[ovirt-users] Re: Libvirt ERROR cannot access backing file after importing VM from OpenStack

2018-05-29 Thread Kevin Wolf
Am 29.05.2018 um 11:27 hat Richard W.M. Jones geschrieben: > On Mon, May 28, 2018 at 01:27:21PM +0300, Arik Hadas wrote: > > Let me demonstrate briefly the flow for OVA: > > Let's say that we have a VM that is based on a template and has one disk > > and one snapshot, so its volume-chain would be:

[ovirt-users] Re: Ovirt 4.2.4 - Trouble installing additional self hosted engine hosts

2018-05-29 Thread Maton, Brett
Thanks for the tip Simone, all working now. Best regards, Brett On 29 May 2018 at 09:24, Simone Tiraboschi wrote: > > > On Tue, May 29, 2018 at 9:32 AM, Maton, Brett > wrote: > >> Hi Ido, >> >> It appears that I have the latest packages installed, any more logs >> that might be useful ? >>

[ovirt-users] Re: LDAP Authentication issues

2018-05-29 Thread Ondra Machacek
What's you LDAP and what profile did you choose? This looks like you have chosen incorect profile during setup. Are you sure you arent using posix group and using non-posix aaa profile? Sharing a debug log of ovirt-engine-extensions-tool would be helpfull. On Fri, May 25, 2018, 10:04 AM Callum

[ovirt-users] Re: oVirt Node on CentOS 7.5 and AMD EPYC Support

2018-05-29 Thread Michal Skrivanek
> On 25 May 2018, at 18:25, Sandro Bonazzola wrote: > > > > 2018-05-25 18:17 GMT+02:00 Tobias Scheinert >: > Hi, > > for any of you who wants AMD EPYC support right now (its a hack, not proper > tested!): > > Michal, can we backport

[ovirt-users] Re: Libvirt ERROR cannot access backing file after importing VM from OpenStack

2018-05-29 Thread Richard W.M. Jones
On Mon, May 28, 2018 at 01:27:21PM +0300, Arik Hadas wrote: > Let me demonstrate briefly the flow for OVA: > Let's say that we have a VM that is based on a template and has one disk > and one snapshot, so its volume-chain would be: > T -> S -> V > (V is the volume the VM writes to, S is the

[ovirt-users] Cannot see ipaddr of new VM

2018-05-29 Thread 03ce007
I have got a self-hosted-engine (4.2) running on centos (7.4). I am trying to create new vanilla vm with static ip using cloud-init to test ssh connectivity. I have below playbook - - name: Add vanilla vm ovirt_vms: auth: "{{ ovirt_auth }}" name: test01 cluster:

[ovirt-users] Updated ovirt-engine packages were released for oVirt 4.2

2018-05-29 Thread Lev Veyde
Hi, We have added an updated oVirt engine (4.2.3.8) to the oVirt 4.2 stable yum repo. It fixes BZ#1582483 [1]. [1] https://bugzilla.redhat.com/1582483 Thanks in advance, -- Lev Veyde Software Engineer, RHCE | RHCVA | MCITP Red Hat Israel l...@redhat.com |

[ovirt-users] start vm without engine

2018-05-29 Thread David David
hi. How to start VM directly in hypervisor? ovirt-engine was crashed. VM's id is known. vdsclient VM, hasn't argumets for starting vm. Thanks. ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy

[ovirt-users] Re: start vm without engine

2018-05-29 Thread Jayme
Try using the virsh command On Tue, May 29, 2018 at 11:08 AM, David David wrote: > hi. > > How to start VM directly in hypervisor? ovirt-engine was crashed. > > VM's id is known. > > vdsclient VM, hasn't argumets for starting vm. > > Thanks. > > ___ >

[ovirt-users] Re: start vm without engine

2018-05-29 Thread Michal Skrivanek
> On 29 May 2018, at 16:08, David David wrote: > > hi. > > How to start VM directly in hypervisor? ovirt-engine was crashed. that is not supported yet > > VM's id is known. > > vdsclient VM, hasn't argumets for starting vm. it does, but you need to connect storage and then supply the

[ovirt-users] Re: Fwd: FreeBSD after 10.3 could not boot (Freeze)

2018-05-29 Thread Alexandr Krivulya
Hi! I procced with default instalation of 10.4-amd64 from ISO and it boots just fine. Can you provide some more info about VM configuration? 26.05.2018 20:59, Paul.LKW пишет: HI All: Any one have tried to boot up FreeBSD 10.4 successful? I tried 10.3 is all working fine but no lucky in 10.4

[ovirt-users] Re: oVirt: single host install

2018-05-29 Thread Sahina Bose
On Tue, May 22, 2018 at 12:17 AM, Justin Zygmont wrote: > > > -Original Message- > From: Derek Atkins [mailto:warl...@mit.edu] > Sent: Monday, May 21, 2018 8:33 AM > To: Simone Tiraboschi > Cc: users ; ov...@fateknollogee.com > Subject: [ovirt-users] Re: oVirt: single host install > >

[ovirt-users] Re: ovirt-node: freshly installed node: network interfaces not visible

2018-05-29 Thread Ales Musil
On Mon, May 28, 2018 at 3:50 PM, wrote: > Hello, > > I'm deploying a test cluster to get used to the ovirt product. > My ovirt ( 4.2.2) engine is deployed in a vmware virtual machine. > > I'm busy deploying 5 hosts using the ovirt-node iso. > > I have issue with the additional physical network

[ovirt-users] Re: ovirt-node: freshly installed node: network interfaces not visible

2018-05-29 Thread etienne . charlier
Hello Ales, Thanks for the answer ! I tried multiple time to refresh capabilities... without success For the record, the tab named "Host Devices" is also empty Have a nice Day Etienne ___ Users mailing list -- users@ovirt.org To unsubscribe send an

[ovirt-users] Non-responsive vm's due to crashed host and hosted vm liveliness check fails

2018-05-29 Thread clam2718
Dear Community: The local drive on a host running ovirt-node-ng-4.1.9 in a three node cluster failed. I have production JIRA and Postres running on it at the time, not in HA, just simple vm's. Storage is via NFS on a Synology NAS. Hosted Engine was on a different host, but JIRA and Postgres

[ovirt-users] Re: Fwd: FreeBSD after 10.3 could not boot (Freeze)

2018-05-29 Thread Paul.LKW
Hi Alexandr Krivulya: Tried all configuration combination also could not boot still hang on the screen captured ! Alexandr Krivulya 於 29/5/2018 22:57 寫道: Hi! I procced with default instalation of 10.4-amd64 from ISO and it boots just fine. Can you provide some more info about VM