[ovirt-users] Re: Can't add a pre-existing (storage-only) gluster member as a compute-also node using self-hosted hyper-convergent engine

2019-08-16 Thread thomas
I did rebuild, but that didn't resolve the problem or answer the real question, moved to a new topic: https://lists.ovirt.org/archives/list/users@ovirt.org/thread/X3UBQT3ZKAX64TWKZQSBJ2ZUCPYNOXH7/ ___ Users mailing list -- users@ovirt.org To

[ovirt-users] Custum driver in oVirt node image?

2019-08-19 Thread thomas
Using 3 Mini-ITX Atoms J5005 boards to build a three node HC test environment (actually there is a fourth to simulate a remote DC) These boards have a RealTek 8169 Gbit controller, which for hardware/firmware or driver reasons comes up just fine on cold boots, but struggles on warm-boots or

[ovirt-users] Can't add a pre-existing (storage-only) gluster member as a compute-also node using self-hosted hyper-convergent engine

2019-08-12 Thread thomas
Intro: Trying to add oVirt self-hosted engine to a pre-existing set of system already using Gluster storage seems to fail, because ‘hosted engine wizard’ seems to create its own peer pool for managed hosts, instead of joining the one given for storage. Context: I am testing on a set of four

[ovirt-users] Re: Can't add a pre-existing (storage-only) gluster member as a compute-also node using self-hosted hyper-convergent engine

2019-08-12 Thread thomas
Oops, sorry for the noise: The problem could have been me... The host that I used to create the hosted appliance might have been running a local gluster at the time the wizard ran (leftover from a single node install). And that might explain why the wizard would then expand that pool with new

[ovirt-users] Re: Hyperconverged setup ovirt 4.3.x using ansible?

2019-08-19 Thread thomas
I cannot really answer your question, but I have a similar one and some observations. I also wanted to split the three node HC setup into the Gluster part and the HC magic engine injection. I have been using Glusters in combination with a non-hosted or local engine with success and I thought

[ovirt-users] Re: ovirt node install

2019-08-19 Thread thomas
I concur with Paul, I got the same from fresh installs of the oVirt node image created August 5th on all instances. ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement:

[ovirt-users] Procedure to replace out out of three hyperconverged nodes

2019-08-19 Thread thomas
On my silent Atom based three node Hyperconverged journey I hit upon a snag: Evidently they are too slow for Ansible. The Gluster storage part went all great and perfect on fresh oVirt node images that I had configured to leave an empty partition instead of the standard /dev/sdb, but the

[ovirt-users] Re: Hyperconverged setup ovirt 4.3.x using ansible?

2019-08-19 Thread thomas
Looks like a bull's eye at first glance: Thank you very much! ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement: https://www.ovirt.org/site/privacy-policy/ oVirt Code of Conduct:

[ovirt-users] Re: ovirt node install

2019-08-20 Thread thomas
same result on 4.3.6-rc1, and the manual update to ovirt-node-ng-nodectl noarch 4.4.0-0.20190820.0.el7 fixes it there. Didn't try it on the 'production' 4.3.5 variant, but would assume it works there, too. ___ Users mailing list -- users@ovirt.org To

[ovirt-users] Hyperconverged on a self-made Gluster: Considered normal or 'way-off'?

2019-08-16 Thread thomas
I use three very low power target nodes (J5005 Intel Atoms, 24GB RAM, 250GB SSD) to experiment with hyperconverged oVirt, and some bigger machines to act as pure compute nodes, preferably CentOS based, potentially oVirt Node image based. I've used both CentOS7 and oVirt Node image bases (all

[ovirt-users] Health Warning: Cinnamon toxic when adding EL7 nodes as oVirt hosts

2019-08-22 Thread thomas
Of course a desktop on a virtualization host isn't really recommended, but actually, managing highly or even high-available supports services as VMs on a set of fat workstations under the control of oVirt can be rather useful... And I prefer Cinnamon so much over the other desktops, it gets

[ovirt-users] Re: Health Warning: Cinnamon toxic when adding EL7 nodes as oVirt hosts

2019-08-22 Thread thomas
Hi Didi, thanks for the attention! I created a clean slate test using four identical (Atom J5005 32GB RAM, 1TB SSD) boxes and virgin SSDs. Three-node hosted-engine using oVirt node 4.3.5 (August 5th) image. Tested adding an n+1 compute node with the same current oVirt image, which worked fine

[ovirt-users] Re: Custum driver in oVirt node image?

2019-08-22 Thread thomas
Thanks Paul, what a life-saver: I never expected something like that would exist, so I didn't even look for it. In the mean-time I went for option three using the 2.5Gbit NIC, because I managed to find out why my CentOS nodes failed: Adding Cinnamon breaks oVirt for some very strange reason.

[ovirt-users] Re: Health Warning: Cinnamon toxic when adding EL7 nodes as oVirt hosts

2019-08-26 Thread thomas
> Hi, > > On Thu, Aug 22, 2019 at 3:29 PM > I assume this was successful. Did you check what packages were > actually installed? Especially which were updated? > I went for minimal user actions, so things would be easy to repeat. But while "yum groupinstall cinnamon" is only a single

[ovirt-users] Re: Health Warning: Cinnamon toxic when adding EL7 nodes as oVirt hosts

2019-09-04 Thread thomas
> On Mon, Aug 26, 2019 at 2:13 PM > rpmUtils is part of yum itself, in the yum libraries. miniyum is part of > otopi. > > > It was: > > https://bugzilla.redhat.com/show_bug.cgi?id=1724056 > > But only for 4.4 (the next version). > Otopi seems to generate a tarball on the host that runs the

[ovirt-users] Re: Procedure to replace out out of three hyperconverged nodes

2019-09-04 Thread thomas
I was eventually able to solve that problem by using net.ifnames=0 on the kernel boot command line during the installation of CentOS or the oVirt Node image, to avoid injecting non-portable machine specific network names and configurations in the overlay network. Unfortunately this won't work

[ovirt-users] hyperconverged single node with SSD cache fails gluster creation

2019-09-04 Thread thomas
I am seeing more success than failures at creating single and triple node hyperconverged setups after some weeks of experimentation so I am branching out to additional features: In this case the ability to use SSDs as cache media for hard disks. I tried first with a single node that combined

[ovirt-users] Re: Any real experiences with nested virtualisation?

2019-09-04 Thread thomas
First, it's a scenario the oVirt team seem to actually embrace themselves. I believe I have seen that type of deployment mentioned either in one of the forward looking blog posts or Red Hat summit videos. And then it simply makes a lot of sense to have those crucial management VMs that control

[ovirt-users] Re: Health Warning: Cinnamon toxic when adding EL7 nodes as oVirt hosts

2019-09-11 Thread thomas
he source code helped and then the fact that the otopi scipt could be executed stand-alone. I will file a bug report and perhaps the documentation could be updated to include a Python3 warning. Thanks for your support, Thomas ___ Users mailing list -- user

[ovirt-users] Re: Health Warning: Cinnamon toxic when adding EL7 nodes as oVirt hosts

2019-09-12 Thread thomas
> On Wed, Sep 11, 2019 at 8:34 PM > Thanks for the report! > > I'll try to handle it soon. Probably something trivial like changing > the order in that line should be enough. We already did that a few > times in the past :-( I don't know if RHEL/CentOS 8 is completely "python2" clean. If not,

[ovirt-users] Re: hyperconverged single node with SSD cache fails gluster creation

2019-09-09 Thread thomas
Thanks a ton! On one hand I'm glad it's a bug now known and fixed, on the other hand I am more scared than ever, that oVirt is too raw to upgrade without intensive QA. I'll try both the manual approach and the new ansible scripts once I've overcome a new problem, that keeps me busy (that will

[ovirt-users] Re: Beginning oVirt / Hyperconverged

2019-11-11 Thread thomas
I guess this is a little late now... but: I wanted to do the same, especially because the additional servers (beyond 3) would lower the relative storage cost overhead when using erasure coding, but it's 'off the trodden path' and I cannot recommend it, after seeing just how fragile the whole

[ovirt-users] Re: SSBD issues on live cluster

2019-11-15 Thread thomas
I have a somewhat similar issue because I use J5005 based Atom boxes for oVirt in the home-lab, but these fail strangely during installation and are just hair-tairingly slow during installation. So I move to a Kaby-Lake desktop for the installation and then need to downgrade all the way to

[ovirt-users] Re: SSBD issues on live cluster

2019-11-15 Thread thomas
At least you're not alone: https://bugzilla.redhat.com/show_bug.cgi?id=1745181 Now since that Epyc is useless: Do you want to swap for a J5005? (tschuldigung... konnte mich wieder nicht bremsen) All that code is Python somewhere, so you can find who adds that tag and suppress it until they

[ovirt-users] Re: SSBD issues on live cluster

2019-11-15 Thread thomas
Hi Christian, I'd say that the CPUs aren't perfectly uniform in terms of capabilities and microcode patches. "ssbd" is a speculative store bypass, as far as I know and if your host doesn't have the µ-code patches installed but your cluster definition has them (based typically on the machine

[ovirt-users] Re: SSBD issues on live cluster

2019-11-15 Thread thomas
After re-reading... The primary host determines the CPU base requirements. But in this case the base may be newer than what the canned hosted image for the hosted-engine supports initially (before you update it). So by deactivating the mitigations temporarily via a boot flag on the host, you

[ovirt-users] Re: 3node HCI fails when HostedEngineLocal is trying to add additional Gluster members

2019-12-04 Thread thomas
After spending another couple of hours trying to track down the problem, I have found that the "lost connection" seems due to KVM shutting down, because it cannot find the certificates for the Spice and VNC connections in /etc/pki/vdsm/*, where 'ovirt-hosted-engine-cleanup' deleted them. So

[ovirt-users] Re: 3node HCI fails when HostedEngineLocal is trying to add additional Gluster members

2019-12-04 Thread thomas
Thanks Strahil, for your suggestions. Actually, I was far beyond the pick-up point you describe, as the Gluster had all been prepared and was operable, even the local VM was already running and accessible via the GUI. But I picked up your hint to try to continue with the scripted variant, and

[ovirt-users] Did a change in Ansible 2.9 in the ovirt_vm_facts module break the hosted-engine-setup?

2019-12-04 Thread thomas
I am having problems installing a 3-node HCI cluster on machines that used to work fine and on a fresh set of servers, too. After a series of setbacks on a set of machines with failed installations and potentially failed clean-ups, I am ssing a fresh set of servers that had never run oVirt

[ovirt-users] Re: Did a change in Ansible 2.9 in the ovirt_vm_facts module break the hosted-engine-setup?

2019-12-12 Thread thomas
This seems to be a much bigger generic issue with Ansible 2.9. Here is an excerpt from the release notes: "Renaming from _facts to _info Ansible 2.9 renamed a lot of modules from _facts to _info, because the modules do not return Ansible facts. Ansible facts relate to a specific host. For

[ovirt-users] Re: Did a change in Ansible 2.9 in the ovirt_vm_facts module break the hosted-engine-setup?

2019-12-12 Thread thomas
What got me derailed was the "ERROR" tag and the fact that it was the last thing to happen on the outside ("waiting for engine to be up"), while the HostedEngineLocal on the inside was looking for Gluster members it couldn't find... ___ Users mailing

[ovirt-users] Re: Did a change in Ansible 2.9 in the ovirt_vm_facts module break the hosted-engine-setup?

2019-12-12 Thread thomas
Thanks Martin, that actually helps a lot, because I was afraid of the implications. So the error must really be elsewhere. I am having another look at the logs from the HostedEngineLocal and it seems to complain that no Gluster members are up, not even the initial one. I also saw no entries

[ovirt-users] Re: HCL: 4.3.7: Hosted engine fails

2019-12-12 Thread thomas
You may just be able to use the username and password already created during the installation: vdsm@ovirt/shibboleth. ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement:

[ovirt-users] Re: Gluster set up fails - Nearly there I think...

2019-12-11 Thread thomas
The error message "/dev/sdXX has been excluded by a filter" is potentially very misleading, because it catches all sorts of conditions. Basically any known storage signature on the storage you may recycle (perhaps from a previous attempt) will trigger this. The functionality is more of a

[ovirt-users] Re: Issue deploying self hosted engine on new install

2019-12-11 Thread thomas
Yes, I have had the same and posted about it here somewhere: I believe it's an incompatible Ansible change. Here is the critical part if the message below: "The 'ovirt_host_facts' module has been renamed to 'ovirt_host_info', and the renamed one no longer returns ansible_facts" and that

[ovirt-users] Re: 3node HCI fails when HostedEngineLocal is trying to add additional Gluster members

2019-12-11 Thread thomas
Hi Strahil, first of all, thanks for following up on this... I think I'll put that list of yours on the wall: It's a key piece of documentation that I found missing: Perhaps you could reconstruct it from systemd dependencies, but... I may not have rebooted... it takes a long time on these

[ovirt-users] Mixing compute and storage without (initial) HCI

2019-12-11 Thread thomas
Some documentation, especially on older RHEV versions seems to indicate that Gluster storage roles and compute server roles in an oVirt cluster or actually exclusive. Yet HCI is all about doing both, which is slightly confusing when you try to overcome HCI issues simply by running the

[ovirt-users] Re: Issue deploying self hosted engine on new install

2019-12-11 Thread thomas
This is the reference https://lists.ovirt.org/archives/list/users@ovirt.org/thread/YWAPIHYM7RMJIWFBC5WCAAWG3EQIGTRZ/ ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement:

[ovirt-users] Re: CPU Type compatibility matrix

2019-12-11 Thread thomas
Actually oVirt simply makes the node you initially install the HostedEngine on the baseline, which is why it says in the docs that you should run it from your "oldest" machine to ensure it doesn't fall over in case an even older host wins the contest for running the management engine VM after

[ovirt-users] 3node HCI fails when HostedEngineLocal is trying to add additional Gluster members

2019-12-01 Thread thomas
Three Gen8 HP360 recalled from retirement with single 1TB TLC SATA SSD for boot and oVirt /engine and 7x4TB HDD RAID6 for /vmstore and /data, 10Gbit NICs and network. All CentOS 7.7 updated daily. These machines may not be used exclusively for oVirt so I don't want to re-install the OS, when

[ovirt-users] Re: hyperconverged single node with SSD cache fails gluster creation

2019-11-28 Thread thomas
rough caching with 550GB size (note that it fails to apply that value beyond the first node). Has anyone else tried a hyperconverged 3-node with SSD caching with success recently? Thanks for your feedback and help so far, Thomas ___ Users mailing list -- us

[ovirt-users] Re: Inconsisten datacenter [urgent]

2019-10-05 Thread thomas
I'm reluctant to give any advice in a situation as fragile as that, but I believe VDSM doesn't want you to mess with virsh in oVirt: You're supposed to make things happen with hosted-engine and potentially vdsm-tool. Try to see if you can get the management VM down with hosted-engine

[ovirt-users] Re: [ANN] oVirt 4.3.6 is now generally available

2019-10-05 Thread thomas
I got a three-node and a single-node HCI that I upgraded from 4.3.5 on CentOS 7.6 to 4.3.6 on CentOS 7.7. The three-node update worked like a charm, mostly just using the GUI: VMs got properly migrated but the SPM wasn't, I'm afraid, causing a re-election and some Gluster healing wobbles I had

[ovirt-users] Re: multiple subnets on hosts for vm's

2020-04-12 Thread thomas
I'd basically like to second the "request" or question: I started on an /28 allocation, because that was the only available at the time. In the mean-time I managed to get hold of a full class C net, which I'd like to use for the VMs on a 3-node HCI with a couple of extra compute and gluster

[ovirt-users] oVirt thrashes Docker network during installation

2020-04-12 Thread thomas
I want to run containers and VMs side by side and not necessarily nested. The main reason for that is GPUs, Voltas mostly, used for CUDA machine learning not for VDI, which is what most of the VM orchestrators like oVirt or vSphere seem to focus on. And CUDA drivers are notorious for refusing

[ovirt-users] Re: oVirt thrashes Docker network during installation

2020-04-12 Thread thomas
The general idea was, that with oVirt I'd get a little more automation and benefits than with just using VirtualBox as a GUI for KVMs. Boy did I underestimate the amount of intellectual investment for the first value return. Turned out quite a bit bigger than vSphere, but much more intriguing,

[ovirt-users] Re: oVirt thrashes Docker network during installation

2020-04-12 Thread thomas
Hi Strahil, color me surprised, too, especially considering where things are supposed to go in terms of roadmap. Yet again, both oVIrt and Docker could be excused to think that they "own the hardware" they are running on, because it's a rather natural assumption, even if there are good

[ovirt-users] Re: oVirt 4.4.0 Release is now generally available

2020-05-20 Thread thomas
My enthusiasm for CentOS8 is limited. My enthusiasm for a hard migration even more so. So how much time do I have before 4.3 becomes inoperable? ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy

[ovirt-users] Re: Non storage nodes erronously included in quota calculations for HCI?

2020-05-20 Thread thomas
OK ;-) 3 node HCI 2+1 data/arbiter added 3 compute-only nodes via host install without HE support which add no storage to the gluster (install still adds them as peers). With 2 compute-only nodes inactive/down I updated the third compute node (no contributing bricks) and saw all VMs pausing

[ovirt-users] Non storage nodes erronously included in quota calculations for HCI?

2020-05-19 Thread thomas
For my home-lab I operate a 3 node HCI cluster on 100% passive Atoms, mostly to run light infrastructure services such as LDAP and NextCloud. I then add workstations or even laptops as pure compute hosts to the cluster for bigger but temporary things, that might actually run a different OS most

[ovirt-users] Re: Upgrade Memory of oVirt Nodes

2020-05-19 Thread thomas
Just like Strahil, I would expect this to work just fine. RAM differences are actually the smallest concern, unless you run out of it in the mean-time. And there you may want to be careful and perhaps move VMs around manually with such a small HCI setup. oVirt will properly optimize the VMs

[ovirt-users] Re: deprecating export domain?

2020-08-30 Thread thomas
While I am trying to prepare a migration from 4.3 to 4.4 with the base OS switch, I am exploring all variants of moving VMs. OVA export/import and export domains have issues and failures so now I am trying backup domains and fail to understand how they are to be used and the sparse

[ovirt-users] Re: How can Gluster be a HCI default, when it's hardly ever working?

2020-09-02 Thread thomas
In this specific case Ieven used virgin hardware originally. Once I managed to kill the hosted-engine by downgrading the datacenter cluster to legacy, I re-installed all gluster storage from the VDO level up. No traces of a file system should be left with LVM and XFS on top, even if I didn't

[ovirt-users] Re: How can you avoid breaking 4.3.11 legacy VMs imported in 4.4.1 during a migration?

2020-08-31 Thread thomas
Thanks for the suggestion, I tried that, but I didn't get very far on a single node HCI cluster... And I'm afraid it won't be much better on HCI in general, which is really the use case I am most interested in. Silently converting VMs is something rather unexpected from a hypervisor, doing it

[ovirt-users] How can Gluster be a HCI default, when it's hardly ever working?

2020-08-31 Thread thomas
I've just tried to verify what you said here. As a base line I started with the 1nHCI Gluster setup. From four VMs, two legacy, two Q35 on the single node Gluster, one survived the import, one failed silently with an empty disk, two failed somewhere in the middle of qemu-img trying to write

[ovirt-users] Posts not updating on lists.ovirt.org web site since September 10th?

2020-09-15 Thread thomas
I can see new posts coming in via e-mail, but updates on the web sites have stopped and posts don't disappear? ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to users-le...@ovirt.org Privacy Statement:

[ovirt-users] Gluster quorum issue on 3-node HCI with extra 5-nodes as compute and storage nodes

2020-09-14 Thread thomas
Yes, I've also posted this on the Gluster Slack. But I am using Gluster mostly because it's part of oVirt HCI, so don't just send me away, please! Problem: GlusterD refusing to start due to quorum issues for volumes where it isn’t contributing any brick (I've had this before on a different

[ovirt-users]oVirt HCI issue: GlusterD refusing to start due to quorum issues for volumes where it isn’t contributing any brick

2020-09-14 Thread thomas
Sorry if it's a duplicate: I go an error on post... And yes I posted it on the Gluster slack first, but I am using Gluster only because the marketing on oVirt HCI worked so well... I got 3 recycled servers for an oVirt test environment first and set those up as 3-node HCI using defaults

[ovirt-users] Re: How to Backup a VM

2020-09-03 Thread thomas
> On Sun, Aug 30, 2020 at 7:13 PM > Using export domain is not a single click, but it is not that complicated. > But this is good feedback anyway. > > > I think the issue is gluster, not qemu-img. > > > How did you try? transfer via the UI is completely different than > transfer using the

[ovirt-users] How can you avoid breaking 4.3.11 legacy VMs imported in 4.4.1 during a migration?

2020-08-31 Thread thomas
Testing the 4.3 to 4.4 migration... what I describe here is facts is mostly observations and conjecture, could be wrong, just makes writing easier... While 4.3 seems to maintain a default emulated machine type (pc-i440fx-rhel7.6.0 by default), it doesn't actually allow setting it in the

[ovirt-users] Re: How can you avoid breaking 4.3.11 legacy VMs imported in 4.4.1 during a migration?

2020-08-31 Thread thomas
I might have found one: You can set the emulated machine to 'legacy' before the first launch. No idea yet, if it will actually work, because the boot disk was copied empty... ___ Users mailing list -- users@ovirt.org To unsubscribe send an email to

[ovirt-users] can't mount an export domain with 4K block size (VDO) as PosixFS (xfs)

2020-08-31 Thread thomas
After this (https://devconfcz2020a.sched.com/event/YOtG/ovirt-4k-teaching-an-old-dog-new-tricks) I sure do not expect this (log below): Actually I am trying to evaluate just how portable oVirt storage is and this case I had prepared a USB3 HDD with VDO, which I could literally move between

[ovirt-users] Re: How can you avoid breaking 4.3.11 legacy VMs imported in 4.4.1 during a migration?

2020-08-31 Thread thomas
On a machine that survived the import, that worked as expected. May want to add that to a check list, that the original machine type for legacy isn't carried over after an import but needs to be set explicitly. ___ Users mailing list -- users@ovirt.org

[ovirt-users] Re: can't mount an export domain with 4K block size (VDO) as PosixFS (xfs)

2020-08-31 Thread thomas
I like playing with shiny new toys and VDO is one :-) Actually with that it shouldn't matter if whatever is put on top actually has spare allocation in the file format or just blocks with zeros, which makes for a reusable HDD in case I am working with imageio images that are raw. Good to know

[ovirt-users] Re: Promiscuous Mode

2020-08-31 Thread thomas
Not sure it will actually do that, but if you create a new network profile, you can select a 'port mirroring' option: It is my understanding that is what you need. You may also want to deselect the filtering rules in the same place. ___ Users mailing

[ovirt-users] Re: ovirt-engine and host certification is expired in ovirt4.0

2020-10-04 Thread thomas
From what I observed (but it's not something I try often), if you try to enable maintenance on a host and have VMs on it, it will try migrating the VMs first, which is a copy-first, state-transfer-afterwards process. So if there is no migration target available or if the copying and

[ovirt-users] Re: CEPH - Opinions and ROI

2020-10-04 Thread thomas
Thank you very much for your story! It has very much confirmed a few suspicions that have been gathering over the last... O my God! Has it two years already? 1. Don't expect plug-and-play, unless you're on SAN or NFS (even HCI doesn't seem to be in the heart of the oVirt team) 2. Don't expect

[ovirt-users] Re: CEPH - Opinions and ROI

2020-10-04 Thread thomas
Thanks a lot for this feed back! I've never had any practical experience with Ceph, MooseFS, BeeGFS or Lustre: GlusterFS to me mostly had the charme of running on 1/2/3 nodes and then anything beyond at a balanced benefits in terms of resilience vs. performance... in theory, of course. And on

[ovirt-users] Re: Is the Hosted Engine setup finished + Can't connect vdsm storage

2020-08-27 Thread thomas
It would be interesting to know, how the previous team got to six nodes: I don't remember seeing any documentation how to do that easily... However, this state of affairs also seems to be quite normal, whenever I reboot a single node HCI setup: I've seen that with two systems now, one running

[ovirt-users] Re: TroubleshootingoVirt Node deploy FQDN not reachable

2020-08-27 Thread thomas
Just fresh from a single node HCI setup (CentOS 8 + oVirt 4.4.1) I did yesterday on an Intel i7-8559U NUC with a single 1TB NVMe storage stick and 64GB of RAM: The HCI wizard pretty much assumes a "second disk", but a partition will actually do. And it doesn't even have to be in /dev/mapper,

[ovirt-users] Re: Error exporting into ova

2020-08-27 Thread thomas
I am testing the migration from CentOS7/oVirt 4.3 to CentOS8/oVirt 4.4. Exporting all VMs to OVAs, and re-importing them on a new cluster built from scratch seems the safest and best method, because in the step-by-step migration, there is simply far too many things that can go wrong and no easy

[ovirt-users] Re: Gluster Volume Type Distributed

2020-08-27 Thread thomas
Replicated is pretty much hard coded into all the Ansible scripts for the HCI setup. So you can't do anything but replicated and only choose between arbiter or full replica there. Distributed give you anything with three nodes, but with five, seven, nine or really high numbers, it becomes quite

[ovirt-users] Re: Hosted Engine stuck in Firmware

2020-08-30 Thread thomas
Thanks for diving into that mess first, because it allowed me to understand what I had done as well... In my case the issue was a VM moved from 4.3 to 4.4 seemed to be silently upgraded from "default" (whatever was default on 4.3) to "Q35", which seems to be the new default of 4.4. But that

[ovirt-users] Re: How to Backup a VM

2020-08-30 Thread thomas
I found OVA export/import to be rather tricky. On the final 4.3 release there still remains a bug, which can lead to the OVA files containing nothing but zeros for the disks, a single line fix that only made it into 4.4 https://bugzilla.redhat.com/show_bug.cgi?id=1813028 Once I fixed that on

[ovirt-users] Re: How to Backup a VM

2020-08-30 Thread thomas
Struggling with bugs and issues on OVA export/import (my clear favorite otherwise, especially when moving VMs between different types of hypervisors), I've tried pretty much everything else, too. Export domains are deprecated and require quite a bit of manual handling. Unfortunately the

[ovirt-users] Re: Error exporting into ova

2020-08-30 Thread thomas
> On Fri, Aug 28, 2020 at 2:31 AM > You should really try the attach/detach storage domain, this is the > recommended way to move > vms from one ovirt system to another. > > You could detach the entire domain with all vms from the old system, > and connect it to the new > system, without

[ovirt-users] Re: Error exporting into ova

2020-08-30 Thread thomas
BTW: This is the message I get on the import: VDSM nucvirt command HSMGetAllTasksStatusesVDS failed: value=low level Image copy failed: ("Command ['/usr/bin/qemu-img', 'convert', '-p', '-t', 'none', '-T', 'none', '-f', 'qcow2',

[ovirt-users] Re: Node upgrade to 4.4

2020-09-24 Thread thomas
I am hoping for a miracle like that, too. In the mean-time I am trying to make sure that all variants of exports and imports from *.ova to re-attachable NFS domains work properly, in case I have to start from scratch. HCI upgrades don't get the special love you'd expect after RHV's proud

[ovirt-users] Re: Node upgrade to 4.4

2020-09-26 Thread thomas
I was looking forward to that presentation for exactly that reason: But it completely bypassed the HCI scenario, was very light on details and of course assumed that everything would just work, because there is no easy fail-back and you're probably better off taking down the complete farm

[ovirt-users] Single Node HCI upgrade procedure from CentOS7/oVirt 4.3 to CentOS8/oVirt 4.4?

2020-09-26 Thread thomas
I can hear you saying: "You did understand that single node HCI is just a toy, right?" For me the primary use of a single node HCI is adding some disaster resilience in small server edge type scenarios, where a three node HCI provides the fault tolerance: 3+1 with a bit of distance, warm or

[ovirt-users] Re: Problem with Cluster-wise BIOS Settings in oVirt 4.4

2020-10-01 Thread thomas
Que yo sepa, no existe alternativa al reinstalarlo... La maquina de manejamiento hereda su configuracion del cluster y en este caso, cuando lo tengas cambiado, le falta la hardware virtualizada para arrancar, y como no tienes GUI tampoco lo puedes cambiar... ¡No eres el primero quien haya

[ovirt-users] OVA exported from oVirt cannot be imported in oVirt

2020-07-29 Thread thomas
I have successfully imported OVA files which came from VirtualBox before, something I'd consider the slightly greater hurdle. Exporting a VM to an OVA file and then importing it on another platform can obviously create compatibility issues, but oVirt <-> oVirt exports and imports with the same

[ovirt-users] Re: Management Engine IP change

2020-07-29 Thread thomas
I honestly don't know, because I have not tried myself, so you might just want to stop reading right here. But from what I understand about the design philosophy of oVirt, it should be ok to change it, while nobody probably ever tested it and everybody would tell you it's a bad idea to do so,

[ovirt-users] Re: Hosted Engine Deployement

2020-07-29 Thread thomas
I might have run into similar issues at one point... And it might be where the network configuration on the installation host has already been partially changed to include the bridge that's used to communicate with HostedEngineLocal. The installation is not able to pick up cleanly from every

[ovirt-users] Re: Ovirt hypervisor as an DRBD node

2020-07-29 Thread thomas
I believe the oVirt team thought it easier to implement on GlusterFS, which AFAIK does pretty much what you want to do, but comes supported as part of the product as an (almost-)ready-to-use HCI. ___ Users mailing list -- users@ovirt.org To unsubscribe

[ovirt-users] Re: Problem with paused VMs in ovirt 4.3.10.

2020-07-29 Thread thomas
Hi Damien, I'm afraid nobody will be able to help you here. What made the CPU jump into a sea of "FF FF FF FF..." can't be diagnosed remotely, but it's KVM that stopped, because that's not legal x86-64 code, nothing oVirt can do about it. Salut Damien, j'ai bien peur que personne ne puisse

[ovirt-users] Re: where is error log for OVA import

2020-07-29 Thread thomas
From what I have observed, OVA import seems to have two modes: If the OVA is a 'foreign' format, the ova file needs to be converted and that conversion effort is then logged into /var/log/vdsm/import on the oVirt node where in import runs. Import failures are then mostly an issue with the

[ovirt-users] Re: oVirt 4.4.1 HCI single server deployment failed nested-kvm

2020-07-29 Thread thomas
I tried using nested virtualization, too, a couple of weeks ago. I was using a 3 node HCI CentOS 7.8 cluster and I got pretty far. Configuring KVM to work with nested page tables isn't all that well documented but I got there, I even installed some host extensions, that seem requried. Even the

[ovirt-users] Re: OVA import does not upload disks

2020-07-29 Thread thomas
I have the same issue, it seems, but AFAIK the problem is on the export side: While the OVA logical file size matches the size of the VM's disk, the actual storage usage on the VDO compressed and deduplicated NFS I use as export target per 'du -h *.ova' is a mere 28KB, while 'strings .ova'

[ovirt-users] Re: OVA export creates empty and unusable images

2020-08-01 Thread thomas
I confirm, I get "qemu-img: /dev/loop0: error while converting qcow2: Could not open device: Permission denied", too. You've nailed it and Nir has pasted your log into the bug report 1862115. ___ Users mailing list -- users@ovirt.org To unsubscribe

[ovirt-users] Re: OVA export creates empty and unusable images

2020-08-01 Thread thomas
Unfortunately that means OVA export/import doesn't seem to be a QA test case for oVirt releases... which would make me want to drop it like a hot potato, if there was any alternative at this point. I guess my biggest mistake was to assume that oVirt was like CentOS.

[ovirt-users] Has anyone ever had success importing an OVA VM exported from oVirt to VirtualBox or VMware? On Windows?

2020-08-06 Thread thomas
After applying the OVA export patch, that ensured disk content was actually written ino the OVA image, I have been able to transfer *.ova VMs between two oVirt clusters. There are still problems that I will report once I have fully tested what's going on, but in the mean-time for all those, who

[ovirt-users] Re: Has anyone ever had success importing an OVA VM exported from oVirt to VirtualBox or VMware? On Windows?

2020-08-07 Thread thomas
Not yet, because I was fighting a nasty outage, evidently created from importing, starting and deleting images too quickly for my Atoms + Xeon-D based test farm... But it's on the list :-) Ciao, Thomas ___ Users mailing list -- users@ovirt.org

[ovirt-users] Why OVA imports failed (the other reason...)

2020-08-07 Thread thomas
Empty disks from exports that went wrong didn't help. But that's fixed now, even if I can't fully validate the OVA exports on VMware and VirtualBox. The export/import target for the *.ova files is an SSD hosted xfs file system on a pure compute Xeon D oVirt node, exported and automounted to the

[ovirt-users] Re: Why OVA imports failed (the other reason...)

2020-08-07 Thread thomas
Here is the explanation, I think: root 12319 12313 15 16:59 pts/000:00:56 qemu-img convert -O qcow2 /dev/loop0 /rhev/data-center/mnt/glusterSD/192.168.0.91:_vmstore/9d1b8774-c5dc-46a8-bfa2-6a6db5851195/images/3be7c1bb-377c-4d5e-b4f6-1a6574b8a52b/845cdd93-def8-4d84-9a08-f8c991f89fe3 This

[ovirt-users] Re: OVA export creates empty and unusable images

2020-08-10 Thread thomas
ven't seen the need when moving VMs between VB/VMware/Hyper-V. And with Windows VMs, starting with W7/W2012 it's become almost a no-op, just pop it in and it will adjust with little more than a reboot, unless you want those virtio drivers for speed. > > Thanks Thomas, this is very useful fee

[ovirt-users] Re: Request for feedback about "Overview of Networking in oVirt"

2020-08-11 Thread thomas
Thanks for putting in the effort! I learned a lot of new things. I also learned that I need to learn a few more now. The table could use some alternating background or a grid: Too easy to get lost. Environments change over time, e.g. you find you really should have split the management,

[ovirt-users] Is the udev settling issue more wide spread? Getting failed 'qemu-img -convert' also while copying disks between data and vmstore domains

2020-08-11 Thread thomas
While trying to diagnose an issue with a set of VMs that get stopped for I/O problems at startup, I try to deal with the fact that their boot disks cause this issue, no matter where I connect them. They might have been the first disks I ever tried to sparsify and I was afraid that might have

[ovirt-users] Re: Hosted Engine Deployment stuck at 3. Prepare VM

2020-08-11 Thread thomas
I came across this in an environment where the proxy was very slow. The downloaded image for the appliance gets deleted every so often (and perhaps also via the cleanup script), so when it needs to be reloaded from the internet, it can take its time, because its quite large (>1GB). Another

[ovirt-users] Re: Is the udev settling issue more wide spread? Getting failed 'qemu-img -convert' also while copying disks between data and vmstore domains

2020-08-11 Thread thomas
Hi Strahil, no updates, especially since I am stuck on 4.3.11 and they tell us it's final. Glusterfs is 6.9-1.el7. Apart from those three VMs and the inability to copy disks the whole farm runs fine so far. Where would I configure the verbosity of logging? Can't find an obvious config option.

  1   2   3   >