Re: [ovirt-users] Unable to connect to console in user portal

2017-01-05 Thread Shalabh Goel
This is the rpm installed in my server.



*ovirt-release40-4.0.5-2.noarch*Looks like I have ovirt 4.0.5 installed.
How to upgrade to 4.0.6?

@Pavel, yes disabling Single sign-on worked.

Thanks a lot everyone.

Shalabh Goel


On Thu, Jan 5, 2017 at 2:46 PM, Tomas Jelinek  wrote:

> It looks like you are hitting this bug: https://bugzilla.redhat.
> com/show_bug.cgi?id=1391146
>
> It should have been fixed in 4.0.6. What exact version of ovirt-engine do
> you have?
>
> On Thu, Jan 5, 2017 at 8:16 AM, Pavel Gashev  wrote:
>
>> Shalabh,
>>
>>
>>
>> Does it help to disable SSO on that VM?
>>
>>
>>
>>
>>
>> *From: * on behalf of Shalabh Goel <
>> shalabhgoe...@gmail.com>
>> *Date: *Wednesday 4 January 2017 at 14:55
>> *To: *users 
>> *Subject: *[ovirt-users] Unable to connect to console in user portal
>>
>>
>>
>> Hi,
>>
>> I have created two VMs on a node. Then I created a user and gave
>> permission to the user for both as UserRole from the web console. Now when
>> I login as the user to the user portal, I can see both the VMs. But when I
>> click connect or double-click on a particular VM, I get an error message
>> "Error while executing action VmLogon: Internal Engine Error".
>>
>> The ovirt engine and node version is 4.0.
>>
>>
>>
>> Please help
>>
>>
>>
>> Thank You
>>
>> Shalabh Goel
>>
>> ___
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>>
>>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Unable to connect to console in user portal

2017-01-05 Thread Tomas Jelinek
It looks like you are hitting this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1391146

It should have been fixed in 4.0.6. What exact version of ovirt-engine do
you have?

On Thu, Jan 5, 2017 at 8:16 AM, Pavel Gashev  wrote:

> Shalabh,
>
>
>
> Does it help to disable SSO on that VM?
>
>
>
>
>
> *From: * on behalf of Shalabh Goel <
> shalabhgoe...@gmail.com>
> *Date: *Wednesday 4 January 2017 at 14:55
> *To: *users 
> *Subject: *[ovirt-users] Unable to connect to console in user portal
>
>
>
> Hi,
>
> I have created two VMs on a node. Then I created a user and gave
> permission to the user for both as UserRole from the web console. Now when
> I login as the user to the user portal, I can see both the VMs. But when I
> click connect or double-click on a particular VM, I get an error message
> "Error while executing action VmLogon: Internal Engine Error".
>
> The ovirt engine and node version is 4.0.
>
>
>
> Please help
>
>
>
> Thank You
>
> Shalabh Goel
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Unable to connect to console in user portal

2017-01-04 Thread Shalabh Goel
I have copied the engine.log file below:

2017-01-05 16:35:00,820 WARN
 [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData]
(DefaultQuartzScheduler6) [] Domain
'f04c189e-c3a8-414d-822a-5846488773b3:iso-win10host' report isn't an actual
report
2017-01-05 16:35:00,821 WARN
 [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData]
(DefaultQuartzScheduler6) [] Domain
'2f039ab5-6f76-4461-bb19-5a0272ce5520:vmdata-hostwin10' report isn't an
actual report
2017-01-05 16:35:15,942 WARN
 [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData]
(DefaultQuartzScheduler8) [47ff0909] Domain
'f04c189e-c3a8-414d-822a-5846488773b3:iso-win10host' report isn't an actual
report
2017-01-05 16:35:15,942 WARN
 [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData]
(DefaultQuartzScheduler8) [47ff0909] Domain
'2f039ab5-6f76-4461-bb19-5a0272ce5520:vmdata-hostwin10' report isn't an
actual report
2017-01-05 16:35:31,758 WARN
 [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData]
(DefaultQuartzScheduler10) [] Domain
'f04c189e-c3a8-414d-822a-5846488773b3:iso-win10host' report isn't an actual
report
2017-01-05 16:35:31,759 WARN
 [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData]
(DefaultQuartzScheduler10) [] Domain
'2f039ab5-6f76-4461-bb19-5a0272ce5520:vmdata-hostwin10' report isn't an
actual report
2017-01-05 16:35:46,938 INFO
 [org.ovirt.engine.extension.aaa.jdbc.core.Tasks] (default task-90) []
(house keeping) deleting failed logins prior to 2016-12-29 11:05:46Z.
2017-01-05 16:35:46,947 WARN
 [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData]
(DefaultQuartzScheduler5) [] Domain
'f04c189e-c3a8-414d-822a-5846488773b3:iso-win10host' report isn't an actual
report
2017-01-05 16:35:46,947 WARN
 [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData]
(DefaultQuartzScheduler5) [] Domain
'2f039ab5-6f76-4461-bb19-5a0272ce5520:vmdata-hostwin10' report isn't an
actual report
2017-01-05 16:35:47,022 INFO
 [org.ovirt.engine.extension.aaa.jdbc.core.Tasks] (default task-90) []
(house keeping) deleting failed logins prior to 2016-12-29 11:05:47Z.
2017-01-05 16:35:49,315 INFO
 [org.ovirt.engine.core.sso.utils.AuthenticationUtils] (default task-90) []
User user1@internal successfully logged in with scopes: ovirt-app-admin
ovirt-app-api ovirt-app-portal ovirt-ext=auth:sequence-priority=~
ovirt-ext=revoke:revoke-all ovirt-ext=token-info:authz-search
ovirt-ext=token-info:public-authz-search ovirt-ext=token-info:validate
ovirt-ext=token:password-access
2017-01-05 16:35:49,561 INFO
 [org.ovirt.engine.core.bll.aaa.CreateUserSessionCommand] (default task-92)
[5dc1a4fc] Running command: CreateUserSessionCommand internal: false.
2017-01-05 16:35:50,937 INFO
 [org.ovirt.engine.docs.utils.servlet.ContextSensitiveHelpMappingServlet]
(default task-101) [] Context-sensitive help is not installed. Manual
directory doesn't exist: /usr/share/ovirt-engine/manual
2017-01-05 16:35:54,302 INFO  [org.ovirt.engine.core.bll.VmLogonCommand]
(default task-121) [29e83352] Running command: VmLogonCommand internal:
false. Entities affected :  ID: 99b499b1-86a6-4e98-bdb1-5344933e2599 Type:
VMAction group CONNECT_TO_VM with role type USER
2017-01-05 16:35:54,354 INFO
 [org.ovirt.engine.core.vdsbroker.vdsbroker.VmLogonVDSCommand] (default
task-121) [29e83352] START, VmLogonVDSCommand(HostName = win10-host,
VmLogonVDSCommandParameters:{runAsync='true',
hostId='118d80be-a7e0-48fe-a740-107153076090',
vmId='99b499b1-86a6-4e98-bdb1-5344933e2599', domain='internal-authz',
password='***', userName='user1@internal-authz'}), log id: 24f3041c
2017-01-05 16:35:55,360 ERROR
[org.ovirt.engine.core.vdsbroker.vdsbroker.VmLogonVDSCommand] (default
task-121) [29e83352] Failed in 'VmLogonVDS' method
2017-01-05 16:35:55,368 ERROR
[org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector]
(default task-121) [29e83352] Correlation ID: null, Call Stack: null,
Custom Event ID: -1, Message: VDSM win10-host command failed: Guest agent
non-responsive
2017-01-05 16:35:55,368 INFO
 [org.ovirt.engine.core.vdsbroker.vdsbroker.VmLogonVDSCommand] (default
task-121) [29e83352] Command
'org.ovirt.engine.core.vdsbroker.vdsbroker.VmLogonVDSCommand' return value
'StatusOnlyReturnForXmlRpc [status=StatusForXmlRpc [code=19, message=Guest
agent non-responsive]]'
2017-01-05 16:35:55,368 INFO
 [org.ovirt.engine.core.vdsbroker.vdsbroker.VmLogonVDSCommand] (default
task-121) [29e83352] HostName = win10-host
2017-01-05 16:35:55,368 ERROR
[org.ovirt.engine.core.vdsbroker.vdsbroker.VmLogonVDSCommand] (default
task-121) [29e83352] Command 'VmLogonVDSCommand(HostName = win10-host,
VmLogonVDSCommandParameters:{runAsync='true',
hostId='118d80be-a7e0-48fe-a740-107153076090',
vmId='99b499b1-86a6-4e98-bdb1-5344933e2599', domain='internal-authz',
password='***', userName='user1@internal-authz'})' execution failed:
VDSGenericException: VDSErrorException: Failed to VmLogonVDS, error = Guest
agent non-responsive, code = 19
2017-01-05 16:35:55,368 INFO
 

Re: [ovirt-users] Unable to connect to console in user portal

2017-01-04 Thread Alexander Wels
On Wednesday, January 4, 2017 5:25:56 PM EST Shalabh Goel wrote:
> Hi,
> 
> I have created two VMs on a node. Then I created a user and gave permission
> to the user for both as UserRole from the web console. Now when I login as
> the user to the user portal, I can see both the VMs. But when I click
> connect or double-click on a particular VM, I get an error message "Error
> while executing action VmLogon: Internal Engine Error".
> 

Can you provide us with the engine logs. The engine is giving an internal 
server error which is bad and shouldn't happen, but obviously it did and its 
highly likely there is a stack trace in the logs that will give us some idea 
what is going on.

> The ovirt engine and node version is 4.0.
> 
> Please help
> 
> Thank You
> 
> Shalabh Goel


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Unable to connect to console in user portal

2017-01-04 Thread Shalabh Goel
Hi,

I have created two VMs on a node. Then I created a user and gave permission
to the user for both as UserRole from the web console. Now when I login as
the user to the user portal, I can see both the VMs. But when I click
connect or double-click on a particular VM, I get an error message "Error
while executing action VmLogon: Internal Engine Error".

The ovirt engine and node version is 4.0.

Please help

Thank You

Shalabh Goel
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users