Re: [ovirt-users] Upgrade to 4.2 Postgresql Error

2017-12-22 Thread Gabriel Stein
Well, that's the problem! I interrupted the yum process and that destroyed
my yum. I tried to fix it and I ended with a beautiful kernel panic. But
I'm guilty, not ovirt.

I will install on another hosts, but first I will need to recover the host
with kernel panic. I will open another thread with this problem.

All the best!

Gabriel

Gabriel Stein
--
Gabriel Ferraz Stein
Tel.: +49 (0)  170 2881531

2017-12-22 11:35 GMT+01:00 Yaniv Kaul :

>
>
> On Dec 22, 2017 11:56 AM, "Gabriel Stein"  wrote:
>
> Well, it worked, I could upgrade the hosted-engine changing the
> /etc/locale to en-US-UTF8. I deactivated puppet too, if someone are using
> puppet for provisioning.
>
> Now I'm having problems to update the host, but it's just this annoying
> bug from vsdm(you need to restart it)
>
>
> Can you share more information?
> And the log, if possible.
> Y.
>
>
> Thanks a lot!
>
> Best Regards,
>
> Gabriel
> PS: Looking forward for the resolution in Bugzilla.
>
> Gabriel Stein
> --
> Gabriel Ferraz Stein
> Tel.: +49 (0)  170 2881531
>
> 2017-12-21 17:15 GMT+01:00 Simone Tiraboschi :
>
>>
>>
>> On Thu, Dec 21, 2017 at 4:30 PM, Simone Tiraboschi 
>> wrote:
>>
>>>
>>>
>>> On Thu, Dec 21, 2017 at 8:41 AM, Sandro Bonazzola 
>>> wrote:
>>>


 2017-12-20 16:07 GMT+01:00 Gabriel Stein :

> Hi!
>
> well, I'm a update fever and I decided to update my ovirt to 4.2.0.
>

 Thanks for this valuable feedback! Simone has already replied and will
 check your setup logs.




>
> How I'm doingi it?
>
> I'm following the rules!
>
> 1 - Global Maintenance Mode
> 2 - Yum Install ovirt-release-4.2
> 3- yum update ovirt-setup*.
>
> But, by the engine-setup I have a conflict with the system collation
> and postgresql. Unfortunatelly I changed via puppet to the german
> collation(de_DE-UTF8) of ovirt-engine hosted vm(because it's a standard 
> for
> us) but this was after the engine-setup and the DB Configuration from
> Postgresql.
>

 Adding also Didi


>
> I think that I can easily change the system collation to us-US-UFT8
> but I'm afraid that I can "destroy" my hosted-engine VM with that change,
> is hosted-engine so sensible?
>
> How I know that error?  The logs are saying that(and the error in on
> postgresql upgrade part of setup)!
>
> *Performing Consistency Checks*
> *-*
> *Checking cluster versions   ok*
> *Checking database user is the install user  ok*
> *Checking database connection settings   ok*
> *Checking for prepared transactions  ok*
> *Checking for reg* system OID user data typesok*
> *Checking for contrib/isn with bigint-passing mismatch   ok*
> *Checking for invalid "line" user columnsok*
> *Creating dump of global objects ok*
> *Creating dump of database schemas*
> *  engine*
> *  ovirt_engine_history*
> *  postgres*
> *  template1*
> *ok*
>
> *lc_collate values for database "postgres" do not match:  old
> "en_US.UTF-8", new "de_DE.UTF-8"*
> *Failure, exiting*
>
> I would be thankful if someone could give me some hint about that!
>

>>> OK, reproduced.
>>> The issue happens if and only if you changed system wide locales after
>>> having installed ovirt-engine but before upgrading it to 4.2.
>>> I'm going to open a bug to track it.
>>>
>>
>> https://bugzilla.redhat.com/show_bug.cgi?id=1528371
>>
>>
>>>
>>> In engine-setup we are explicitly setting en_US.UTF-8 as the locale of
>>> the engine DB but we are not touching at all the locale of postgres own DB
>>> which match the system wide locale and your issue is indeed on the postgres
>>> DB, not on the engine one.
>>> pg_upgrade cannot change it on the fly on upgrades.
>>>
>>> I tried to find a working fix with env variables but unfortunately
>>> nothing I tired worked.
>>> The only workaround I was able to find is to temporary set the locale
>>> you had at first successful engine-setup execution time (en_US.UTF-8 in
>>> your case but it varies) under /etc/locale.conf and only then execute
>>> engine-setup to upgrade it to 4.2.
>>> After that you could safely switch back /etc/locale.conf to whatever you
>>> need.
>>> All the env variable I tried seams absolutely not relevant for this
>>> specific issue.
>>>
>>>
>>>
>>>

> Best Regards,
>
> Gabriel
> PS: If I go to devconf in Brno I will pay a lot of beers to the
> developer of the engine-setup rollback! 

Re: [ovirt-users] Upgrade to 4.2 Postgresql Error

2017-12-22 Thread Yaniv Kaul
On Dec 22, 2017 11:56 AM, "Gabriel Stein"  wrote:

Well, it worked, I could upgrade the hosted-engine changing the /etc/locale
to en-US-UTF8. I deactivated puppet too, if someone are using puppet for
provisioning.

Now I'm having problems to update the host, but it's just this annoying bug
from vsdm(you need to restart it)


Can you share more information?
And the log, if possible.
Y.


Thanks a lot!

Best Regards,

Gabriel
PS: Looking forward for the resolution in Bugzilla.

Gabriel Stein
--
Gabriel Ferraz Stein
Tel.: +49 (0)  170 2881531

2017-12-21 17:15 GMT+01:00 Simone Tiraboschi :

>
>
> On Thu, Dec 21, 2017 at 4:30 PM, Simone Tiraboschi 
> wrote:
>
>>
>>
>> On Thu, Dec 21, 2017 at 8:41 AM, Sandro Bonazzola 
>> wrote:
>>
>>>
>>>
>>> 2017-12-20 16:07 GMT+01:00 Gabriel Stein :
>>>
 Hi!

 well, I'm a update fever and I decided to update my ovirt to 4.2.0.

>>>
>>> Thanks for this valuable feedback! Simone has already replied and will
>>> check your setup logs.
>>>
>>>
>>>
>>>

 How I'm doingi it?

 I'm following the rules!

 1 - Global Maintenance Mode
 2 - Yum Install ovirt-release-4.2
 3- yum update ovirt-setup*.

 But, by the engine-setup I have a conflict with the system collation
 and postgresql. Unfortunatelly I changed via puppet to the german
 collation(de_DE-UTF8) of ovirt-engine hosted vm(because it's a standard for
 us) but this was after the engine-setup and the DB Configuration from
 Postgresql.

>>>
>>> Adding also Didi
>>>
>>>

 I think that I can easily change the system collation to us-US-UFT8 but
 I'm afraid that I can "destroy" my hosted-engine VM with that change, is
 hosted-engine so sensible?

 How I know that error?  The logs are saying that(and the error in on
 postgresql upgrade part of setup)!

 *Performing Consistency Checks*
 *-*
 *Checking cluster versions   ok*
 *Checking database user is the install user  ok*
 *Checking database connection settings   ok*
 *Checking for prepared transactions  ok*
 *Checking for reg* system OID user data typesok*
 *Checking for contrib/isn with bigint-passing mismatch   ok*
 *Checking for invalid "line" user columnsok*
 *Creating dump of global objects ok*
 *Creating dump of database schemas*
 *  engine*
 *  ovirt_engine_history*
 *  postgres*
 *  template1*
 *ok*

 *lc_collate values for database "postgres" do not match:  old
 "en_US.UTF-8", new "de_DE.UTF-8"*
 *Failure, exiting*

 I would be thankful if someone could give me some hint about that!

>>>
>> OK, reproduced.
>> The issue happens if and only if you changed system wide locales after
>> having installed ovirt-engine but before upgrading it to 4.2.
>> I'm going to open a bug to track it.
>>
>
> https://bugzilla.redhat.com/show_bug.cgi?id=1528371
>
>
>>
>> In engine-setup we are explicitly setting en_US.UTF-8 as the locale of
>> the engine DB but we are not touching at all the locale of postgres own DB
>> which match the system wide locale and your issue is indeed on the postgres
>> DB, not on the engine one.
>> pg_upgrade cannot change it on the fly on upgrades.
>>
>> I tried to find a working fix with env variables but unfortunately
>> nothing I tired worked.
>> The only workaround I was able to find is to temporary set the locale you
>> had at first successful engine-setup execution time (en_US.UTF-8 in your
>> case but it varies) under /etc/locale.conf and only then execute
>> engine-setup to upgrade it to 4.2.
>> After that you could safely switch back /etc/locale.conf to whatever you
>> need.
>> All the env variable I tried seams absolutely not relevant for this
>> specific issue.
>>
>>
>>
>>
>>>
 Best Regards,

 Gabriel
 PS: If I go to devconf in Brno I will pay a lot of beers to the
 developer of the engine-setup rollback! Saved my life!

>>>
>>> The specific developer won't be there, but you're welcome to reach oVirt
>>> people there and share some beer :-)
>>>
>>>
>>>






 Gabriel Stein
 --
 Gabriel Ferraz Stein
 Tel.: +49 (0)  170 2881531

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users


>>>
>>>
>>> --
>>>
>>> SANDRO BONAZZOLA
>>>
>>> ASSOCIATE MANAGER, SOFTWARE ENGINEERING, EMEA ENG VIRTUALIZATION R
>>>
>>> Red Hat EMEA 
>>> 
>>> TRIED. 

Re: [ovirt-users] Upgrade to 4.2 Postgresql Error

2017-12-21 Thread Simone Tiraboschi
On Thu, Dec 21, 2017 at 4:30 PM, Simone Tiraboschi 
wrote:

>
>
> On Thu, Dec 21, 2017 at 8:41 AM, Sandro Bonazzola 
> wrote:
>
>>
>>
>> 2017-12-20 16:07 GMT+01:00 Gabriel Stein :
>>
>>> Hi!
>>>
>>> well, I'm a update fever and I decided to update my ovirt to 4.2.0.
>>>
>>
>> Thanks for this valuable feedback! Simone has already replied and will
>> check your setup logs.
>>
>>
>>
>>
>>>
>>> How I'm doingi it?
>>>
>>> I'm following the rules!
>>>
>>> 1 - Global Maintenance Mode
>>> 2 - Yum Install ovirt-release-4.2
>>> 3- yum update ovirt-setup*.
>>>
>>> But, by the engine-setup I have a conflict with the system collation and
>>> postgresql. Unfortunatelly I changed via puppet to the german
>>> collation(de_DE-UTF8) of ovirt-engine hosted vm(because it's a standard for
>>> us) but this was after the engine-setup and the DB Configuration from
>>> Postgresql.
>>>
>>
>> Adding also Didi
>>
>>
>>>
>>> I think that I can easily change the system collation to us-US-UFT8 but
>>> I'm afraid that I can "destroy" my hosted-engine VM with that change, is
>>> hosted-engine so sensible?
>>>
>>> How I know that error?  The logs are saying that(and the error in on
>>> postgresql upgrade part of setup)!
>>>
>>> *Performing Consistency Checks*
>>> *-*
>>> *Checking cluster versions   ok*
>>> *Checking database user is the install user  ok*
>>> *Checking database connection settings   ok*
>>> *Checking for prepared transactions  ok*
>>> *Checking for reg* system OID user data typesok*
>>> *Checking for contrib/isn with bigint-passing mismatch   ok*
>>> *Checking for invalid "line" user columnsok*
>>> *Creating dump of global objects ok*
>>> *Creating dump of database schemas*
>>> *  engine*
>>> *  ovirt_engine_history*
>>> *  postgres*
>>> *  template1*
>>> *ok*
>>>
>>> *lc_collate values for database "postgres" do not match:  old
>>> "en_US.UTF-8", new "de_DE.UTF-8"*
>>> *Failure, exiting*
>>>
>>> I would be thankful if someone could give me some hint about that!
>>>
>>
> OK, reproduced.
> The issue happens if and only if you changed system wide locales after
> having installed ovirt-engine but before upgrading it to 4.2.
> I'm going to open a bug to track it.
>

https://bugzilla.redhat.com/show_bug.cgi?id=1528371


>
> In engine-setup we are explicitly setting en_US.UTF-8 as the locale of the
> engine DB but we are not touching at all the locale of postgres own DB
> which match the system wide locale and your issue is indeed on the postgres
> DB, not on the engine one.
> pg_upgrade cannot change it on the fly on upgrades.
>
> I tried to find a working fix with env variables but unfortunately nothing
> I tired worked.
> The only workaround I was able to find is to temporary set the locale you
> had at first successful engine-setup execution time (en_US.UTF-8 in your
> case but it varies) under /etc/locale.conf and only then execute
> engine-setup to upgrade it to 4.2.
> After that you could safely switch back /etc/locale.conf to whatever you
> need.
> All the env variable I tried seams absolutely not relevant for this
> specific issue.
>
>
>
>
>>
>>> Best Regards,
>>>
>>> Gabriel
>>> PS: If I go to devconf in Brno I will pay a lot of beers to the
>>> developer of the engine-setup rollback! Saved my life!
>>>
>>
>> The specific developer won't be there, but you're welcome to reach oVirt
>> people there and share some beer :-)
>>
>>
>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> Gabriel Stein
>>> --
>>> Gabriel Ferraz Stein
>>> Tel.: +49 (0)  170 2881531
>>>
>>> ___
>>> Users mailing list
>>> Users@ovirt.org
>>> http://lists.ovirt.org/mailman/listinfo/users
>>>
>>>
>>
>>
>> --
>>
>> SANDRO BONAZZOLA
>>
>> ASSOCIATE MANAGER, SOFTWARE ENGINEERING, EMEA ENG VIRTUALIZATION R
>>
>> Red Hat EMEA 
>> 
>> TRIED. TESTED. TRUSTED. 
>>
>>
>> ___
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>>
>>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 4.2 Postgresql Error

2017-12-21 Thread Simone Tiraboschi
On Thu, Dec 21, 2017 at 8:41 AM, Sandro Bonazzola 
wrote:

>
>
> 2017-12-20 16:07 GMT+01:00 Gabriel Stein :
>
>> Hi!
>>
>> well, I'm a update fever and I decided to update my ovirt to 4.2.0.
>>
>
> Thanks for this valuable feedback! Simone has already replied and will
> check your setup logs.
>
>
>
>
>>
>> How I'm doingi it?
>>
>> I'm following the rules!
>>
>> 1 - Global Maintenance Mode
>> 2 - Yum Install ovirt-release-4.2
>> 3- yum update ovirt-setup*.
>>
>> But, by the engine-setup I have a conflict with the system collation and
>> postgresql. Unfortunatelly I changed via puppet to the german
>> collation(de_DE-UTF8) of ovirt-engine hosted vm(because it's a standard for
>> us) but this was after the engine-setup and the DB Configuration from
>> Postgresql.
>>
>
> Adding also Didi
>
>
>>
>> I think that I can easily change the system collation to us-US-UFT8 but
>> I'm afraid that I can "destroy" my hosted-engine VM with that change, is
>> hosted-engine so sensible?
>>
>> How I know that error?  The logs are saying that(and the error in on
>> postgresql upgrade part of setup)!
>>
>> *Performing Consistency Checks*
>> *-*
>> *Checking cluster versions   ok*
>> *Checking database user is the install user  ok*
>> *Checking database connection settings   ok*
>> *Checking for prepared transactions  ok*
>> *Checking for reg* system OID user data typesok*
>> *Checking for contrib/isn with bigint-passing mismatch   ok*
>> *Checking for invalid "line" user columnsok*
>> *Creating dump of global objects ok*
>> *Creating dump of database schemas*
>> *  engine*
>> *  ovirt_engine_history*
>> *  postgres*
>> *  template1*
>> *ok*
>>
>> *lc_collate values for database "postgres" do not match:  old
>> "en_US.UTF-8", new "de_DE.UTF-8"*
>> *Failure, exiting*
>>
>> I would be thankful if someone could give me some hint about that!
>>
>
OK, reproduced.
The issue happens if and only if you changed system wide locales after
having installed ovirt-engine but before upgrading it to 4.2.
I'm going to open a bug to track it.

In engine-setup we are explicitly setting en_US.UTF-8 as the locale of the
engine DB but we are not touching at all the locale of postgres own DB
which match the system wide locale and your issue is indeed on the postgres
DB, not on the engine one.
pg_upgrade cannot change it on the fly on upgrades.

I tried to find a working fix with env variables but unfortunately nothing
I tired worked.
The only workaround I was able to find is to temporary set the locale you
had at first successful engine-setup execution time (en_US.UTF-8 in your
case but it varies) under /etc/locale.conf and only then execute
engine-setup to upgrade it to 4.2.
After that you could safely switch back /etc/locale.conf to whatever you
need.
All the env variable I tried seams absolutely not relevant for this
specific issue.




>
>> Best Regards,
>>
>> Gabriel
>> PS: If I go to devconf in Brno I will pay a lot of beers to the developer
>> of the engine-setup rollback! Saved my life!
>>
>
> The specific developer won't be there, but you're welcome to reach oVirt
> people there and share some beer :-)
>
>
>
>>
>>
>>
>>
>>
>>
>> Gabriel Stein
>> --
>> Gabriel Ferraz Stein
>> Tel.: +49 (0)  170 2881531
>>
>> ___
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>>
>>
>
>
> --
>
> SANDRO BONAZZOLA
>
> ASSOCIATE MANAGER, SOFTWARE ENGINEERING, EMEA ENG VIRTUALIZATION R
>
> Red Hat EMEA 
> 
> TRIED. TESTED. TRUSTED. 
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 4.2 Postgresql Error

2017-12-20 Thread Sandro Bonazzola
2017-12-20 16:07 GMT+01:00 Gabriel Stein :

> Hi!
>
> well, I'm a update fever and I decided to update my ovirt to 4.2.0.
>

Thanks for this valuable feedback! Simone has already replied and will
check your setup logs.




>
> How I'm doingi it?
>
> I'm following the rules!
>
> 1 - Global Maintenance Mode
> 2 - Yum Install ovirt-release-4.2
> 3- yum update ovirt-setup*.
>
> But, by the engine-setup I have a conflict with the system collation and
> postgresql. Unfortunatelly I changed via puppet to the german
> collation(de_DE-UTF8) of ovirt-engine hosted vm(because it's a standard for
> us) but this was after the engine-setup and the DB Configuration from
> Postgresql.
>

Adding also Didi


>
> I think that I can easily change the system collation to us-US-UFT8 but
> I'm afraid that I can "destroy" my hosted-engine VM with that change, is
> hosted-engine so sensible?
>
> How I know that error?  The logs are saying that(and the error in on
> postgresql upgrade part of setup)!
>
> *Performing Consistency Checks*
> *-*
> *Checking cluster versions   ok*
> *Checking database user is the install user  ok*
> *Checking database connection settings   ok*
> *Checking for prepared transactions  ok*
> *Checking for reg* system OID user data typesok*
> *Checking for contrib/isn with bigint-passing mismatch   ok*
> *Checking for invalid "line" user columnsok*
> *Creating dump of global objects ok*
> *Creating dump of database schemas*
> *  engine*
> *  ovirt_engine_history*
> *  postgres*
> *  template1*
> *ok*
>
> *lc_collate values for database "postgres" do not match:  old
> "en_US.UTF-8", new "de_DE.UTF-8"*
> *Failure, exiting*
>
> I would be thankful if someone could give me some hint about that!
>
> Best Regards,
>
> Gabriel
> PS: If I go to devconf in Brno I will pay a lot of beers to the developer
> of the engine-setup rollback! Saved my life!
>

The specific developer won't be there, but you're welcome to reach oVirt
people there and share some beer :-)



>
>
>
>
>
>
> Gabriel Stein
> --
> Gabriel Ferraz Stein
> Tel.: +49 (0)  170 2881531
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>


-- 

SANDRO BONAZZOLA

ASSOCIATE MANAGER, SOFTWARE ENGINEERING, EMEA ENG VIRTUALIZATION R

Red Hat EMEA 

TRIED. TESTED. TRUSTED. 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 4.2 Postgresql Error

2017-12-20 Thread Simone Tiraboschi
On Wed, Dec 20, 2017 at 4:07 PM, Gabriel Stein 
wrote:

> Hi!
>
> well, I'm a update fever and I decided to update my ovirt to 4.2.0.
>
> How I'm doingi it?
>
> I'm following the rules!
>
> 1 - Global Maintenance Mode
> 2 - Yum Install ovirt-release-4.2
> 3- yum update ovirt-setup*.
>
> But, by the engine-setup I have a conflict with the system collation and
> postgresql. Unfortunatelly I changed via puppet to the german
> collation(de_DE-UTF8) of ovirt-engine hosted vm(because it's a standard for
> us) but this was after the engine-setup and the DB Configuration from
> Postgresql.
>
> I think that I can easily change the system collation to us-US-UFT8 but
> I'm afraid that I can "destroy" my hosted-engine VM with that change, is
> hosted-engine so sensible?
>
> How I know that error?  The logs are saying that(and the error in on
> postgresql upgrade part of setup)!
>
> *Performing Consistency Checks*
> *-*
> *Checking cluster versions   ok*
> *Checking database user is the install user  ok*
> *Checking database connection settings   ok*
> *Checking for prepared transactions  ok*
> *Checking for reg* system OID user data typesok*
> *Checking for contrib/isn with bigint-passing mismatch   ok*
> *Checking for invalid "line" user columnsok*
> *Creating dump of global objects ok*
> *Creating dump of database schemas*
> *  engine*
> *  ovirt_engine_history*
> *  postgres*
> *  template1*
> *ok*
>
> *lc_collate values for database "postgres" do not match:  old
> "en_US.UTF-8", new "de_DE.UTF-8"*
> *Failure, exiting*
>
> I would be thankful if someone could give me some hint about that!
>

Could you please attach the whole engine-setup log file?



>
> Best Regards,
>
> Gabriel
> PS: If I go to devconf in Brno I will pay a lot of beers to the developer
> of the engine-setup rollback! Saved my life!
>
>
>
>
>
>
> Gabriel Stein
> --
> Gabriel Ferraz Stein
> Tel.: +49 (0)  170 2881531
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 4.2 Postgresql Error

2017-12-20 Thread Gabriel Stein
BTW: I already tried to change the
postgresql-setup(/opt/rh/rh-postgresql95/root/usr/bin/postgresql-setup) as
I found in a postgresql forum:

export LANG=en_US.UTF-8
export LANGUAGE="en_US.UTF-8"
export LANG="en_US.UTF-8"
export LC_ALL="en_US.UTF-8"

Didn't help.

Thanks!




Gabriel Stein
--
Gabriel Ferraz Stein
Tel.: +49 (0)  170 2881531

2017-12-20 16:07 GMT+01:00 Gabriel Stein :

> Hi!
>
> well, I'm a update fever and I decided to update my ovirt to 4.2.0.
>
> How I'm doingi it?
>
> I'm following the rules!
>
> 1 - Global Maintenance Mode
> 2 - Yum Install ovirt-release-4.2
> 3- yum update ovirt-setup*.
>
> But, by the engine-setup I have a conflict with the system collation and
> postgresql. Unfortunatelly I changed via puppet to the german
> collation(de_DE-UTF8) of ovirt-engine hosted vm(because it's a standard for
> us) but this was after the engine-setup and the DB Configuration from
> Postgresql.
>
> I think that I can easily change the system collation to us-US-UFT8 but
> I'm afraid that I can "destroy" my hosted-engine VM with that change, is
> hosted-engine so sensible?
>
> How I know that error?  The logs are saying that(and the error in on
> postgresql upgrade part of setup)!
>
> *Performing Consistency Checks*
> *-*
> *Checking cluster versions   ok*
> *Checking database user is the install user  ok*
> *Checking database connection settings   ok*
> *Checking for prepared transactions  ok*
> *Checking for reg* system OID user data typesok*
> *Checking for contrib/isn with bigint-passing mismatch   ok*
> *Checking for invalid "line" user columnsok*
> *Creating dump of global objects ok*
> *Creating dump of database schemas*
> *  engine*
> *  ovirt_engine_history*
> *  postgres*
> *  template1*
> *ok*
>
> *lc_collate values for database "postgres" do not match:  old
> "en_US.UTF-8", new "de_DE.UTF-8"*
> *Failure, exiting*
>
> I would be thankful if someone could give me some hint about that!
>
> Best Regards,
>
> Gabriel
> PS: If I go to devconf in Brno I will pay a lot of beers to the developer
> of the engine-setup rollback! Saved my life!
>
>
>
>
>
>
> Gabriel Stein
> --
> Gabriel Ferraz Stein
> Tel.: +49 (0)  170 2881531
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Upgrade to 4.2 Postgresql Error

2017-12-20 Thread Gabriel Stein
Hi!

well, I'm a update fever and I decided to update my ovirt to 4.2.0.

How I'm doingi it?

I'm following the rules!

1 - Global Maintenance Mode
2 - Yum Install ovirt-release-4.2
3- yum update ovirt-setup*.

But, by the engine-setup I have a conflict with the system collation and
postgresql. Unfortunatelly I changed via puppet to the german
collation(de_DE-UTF8) of ovirt-engine hosted vm(because it's a standard for
us) but this was after the engine-setup and the DB Configuration from
Postgresql.

I think that I can easily change the system collation to us-US-UFT8 but I'm
afraid that I can "destroy" my hosted-engine VM with that change, is
hosted-engine so sensible?

How I know that error?  The logs are saying that(and the error in on
postgresql upgrade part of setup)!

*Performing Consistency Checks*
*-*
*Checking cluster versions   ok*
*Checking database user is the install user  ok*
*Checking database connection settings   ok*
*Checking for prepared transactions  ok*
*Checking for reg* system OID user data typesok*
*Checking for contrib/isn with bigint-passing mismatch   ok*
*Checking for invalid "line" user columnsok*
*Creating dump of global objects ok*
*Creating dump of database schemas*
*  engine*
*  ovirt_engine_history*
*  postgres*
*  template1*
*ok*

*lc_collate values for database "postgres" do not match:  old
"en_US.UTF-8", new "de_DE.UTF-8"*
*Failure, exiting*

I would be thankful if someone could give me some hint about that!

Best Regards,

Gabriel
PS: If I go to devconf in Brno I will pay a lot of beers to the developer
of the engine-setup rollback! Saved my life!






Gabriel Stein
--
Gabriel Ferraz Stein
Tel.: +49 (0)  170 2881531
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users